Subject: [Tools-discuss] Spurious YANG warnings

From: Eric Rescorla <[email-masked]>
Date: Sat, 17 Jun 2017 11:25:36 -0700

The YANG checker seems to be overreacting to documents which
have code examples but no YANG.

See, for instance:
https://datatracker.ietf.org/doc/draft-ietf-kitten-rfc5653bis/

-Ekr

---

From: Henrik Levkowetz <[email-masked]>
Date: Sat, 17 Jun 2017 22:41:19 +0200

Hi Ekr,

> https://datatracker.ietf.org/doc/draft-ietf-kitten-rfc5653bis/

Good point.

Working on a fix.

Thanks :-) , and regards,

	Henrik

---

From: "Eggert, Lars" <[email-masked]>
Date: Mon, 19 Jun 2017 06:22:42 +0000

Don't all IDs have to have YANG these days? ;-)

--
Sent from a mobile device; please excuse typos.
+49 151 120 55791

On Jun 17, 2017, at 20:26, Eric Rescorla <[email-masked]<mailto:[email-masked]>> wrote:

See, for instance:

-Ekr

--
Tools-discuss mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tools-discuss

Please report datatracker.ietf.org<http://datatracker.ietf.org> bugs at http://tools.ietf.org/tools/ietfdb
or send email to [email-masked]<mailto:[email-masked]>

Please report tools.ietf.org<http://tools.ietf.org> bugs at http://tools.ietf.org/tools/issues or
send email to [email-masked]<mailto:[email-masked]>

---

From: Eric Rescorla <[email-masked]>
Date: Mon, 19 Jun 2017 04:15:52 -0700

> Don't all IDs have to have YANG these days? ;-)

Oh but in that case we need different warnings! "This document is missing a
YANG section!!!"

-Ekr

> +49 151 120 55791 <+49%201511%202055791>
>
> On Jun 17, 2017, at 20:26, Eric Rescorla <[email-masked]> wrote:
>
> [email-masked]
> Please report datatracker.ietf.org bugs at http://tools.ietf.org/tools/
> ietfdb
> or send email to [email-masked]
>
> Please report tools.ietf.org bugs at http://tools.ietf.org/tools/issues or
> send email to [email-masked]
>
>