Subject: [Tools-discuss] Making online or Windows kramdown-rfc2629 work

From: Mike Jones <[email-masked]>
Date: Thu, 13 Apr 2017 15:54:43 +0000

I've been trying to find a way to run kramdown-rfc2629 from my Windows laptop and failing.  This is what I got when I tried to compile a .md file that Yaron Sheffer wrote using the kramdown input option at https://xml2rfc.tools.ietf.org/experimental.html.
Unable to Validate File
WARNING: Parsing Error: no element found
ERROR: Unable to parse the XML document: INPUT
INPUT: Line 1: Document is empty
INPUT: Line 1: Start tag expected, '<' not found
Using XML_LIBRARY=/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml2:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml3:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml4:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml5:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml6:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml7:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml8
Parsing file INPUT
________________________________
Apache/2.2.22 (Debian) Server at xml2rfc.tools.ietf.org Port 443

durif

Is there a trick I'm missing here?  I'd really prefer to compile the .md online than have to do local tool installations on all my machines.

I then tried to use a local Ruby installation.  I installed 64-bit Ruby 2.3.3.  I did the "gem install kramdown-rfc2629".  I then ran "kramdown-rfc2629 \mbj\tmp\draft-sheffer-oauth-jwt-bcp.md > \mbj\tmp\draft-sheffer-oauth-jwt-bcp.xml", which resulted in a zero-length .xml file and the following log output.  Any suggestions on next steps?

.refcache/reference.RFC.2119.xml: fetching
C:/Ruby23-x64/lib/ruby/2.3.0/net/http.rb:933:in `connect_nonblock': SSL_connect returned=1 errno=0 state=error: certificate verify failed (OpenSSL::SSL::SSLError)
        from C:/Ruby23-x64/lib/ruby/2.3.0/net/http.rb:933:in `connect'
        from C:/Ruby23-x64/lib/ruby/2.3.0/net/http.rb:863:in `do_start'
        from C:/Ruby23-x64/lib/ruby/2.3.0/net/http.rb:852:in `start'
        from C:/Ruby23-x64/lib/ruby/2.3.0/open-uri.rb:319:in `open_http'
        from C:/Ruby23-x64/lib/ruby/2.3.0/open-uri.rb:737:in `buffer_open'
        from C:/Ruby23-x64/lib/ruby/2.3.0/open-uri.rb:212:in `block in open_loop'
        from C:/Ruby23-x64/lib/ruby/2.3.0/open-uri.rb:210:in `catch'
        from C:/Ruby23-x64/lib/ruby/2.3.0/open-uri.rb:210:in `open_loop'
        from C:/Ruby23-x64/lib/ruby/2.3.0/open-uri.rb:151:in `open_uri'
        from C:/Ruby23-x64/lib/ruby/2.3.0/open-uri.rb:717:in `open'
        from C:/Ruby23-x64/lib/ruby/2.3.0/open-uri.rb:35:in `open'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/kramdown-rfc2629-1.1.1/lib/kramdown-rfc2629.rb:447:in `block in get_and_cache_resource'
        from C:/Ruby23-x64/lib/ruby/2.3.0/timeout.rb:91:in `block in timeout'
        from C:/Ruby23-x64/lib/ruby/2.3.0/timeout.rb:33:in `block in catch'
        from C:/Ruby23-x64/lib/ruby/2.3.0/timeout.rb:33:in `catch'
        from C:/Ruby23-x64/lib/ruby/2.3.0/timeout.rb:33:in `catch'
        from C:/Ruby23-x64/lib/ruby/2.3.0/timeout.rb:106:in `timeout'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/kramdown-rfc2629-1.1.1/lib/kramdown-rfc2629.rb:442:in `get_and_cache_resource'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/kramdown-rfc2629-1.1.1/lib/kramdown-rfc2629.rb:518:in `block in convert_img'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/kramdown-rfc2629-1.1.1/lib/kramdown-rfc2629.rb:512:in `scan'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/kramdown-rfc2629-1.1.1/lib/kramdown-rfc2629.rb:512:in `convert_img'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/kramdown-rfc2629-1.1.1/lib/kramdown-rfc2629.rb:125:in `block in inner_a'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/kramdown-rfc2629-1.1.1/lib/kramdown-rfc2629.rb:123:in `map'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/kramdown-rfc2629-1.1.1/lib/kramdown-rfc2629.rb:123:in `inner_a'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/kramdown-rfc2629-1.1.1/lib/kramdown-rfc2629.rb:130:in `inner'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/kramdown-rfc2629-1.1.1/lib/kramdown-rfc2629.rb:143:in `convert_p'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/kramdown-rfc2629-1.1.1/lib/kramdown-rfc2629.rb:125:in `block in inner_a'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/kramdown-rfc2629-1.1.1/lib/kramdown-rfc2629.rb:123:in `map'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/kramdown-rfc2629-1.1.1/lib/kramdown-rfc2629.rb:123:in `inner_a'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/kramdown-rfc2629-1.1.1/lib/kramdown-rfc2629.rb:130:in `inner'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/kramdown-rfc2629-1.1.1/lib/kramdown-rfc2629.rb:652:in `convert_root'        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/kramdown-rfc2629-1.1.1/lib/kramdown-rfc2629.rb:118:in `convert1'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/kramdown-rfc2629-1.1.1/lib/kramdown-rfc2629.rb:113:in `convert'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/kramdown-1.13.2/lib/kramdown/converter/base.rb:105:in `convert'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/kramdown-1.13.2/lib/kramdown/document.rb:120:in `method_missing'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/kramdown-rfc2629-1.1.1/bin/kramdown-rfc2629:279:in `<top (required)>'
        from C:/Ruby23-x64/bin/kramdown-rfc2629:22:in `load'
        from C:/Ruby23-x64/bin/kramdown-rfc2629:22:in `<main>'

Has anyone gotten this to work online or on Windows?

                                                                -- Mike

---

From: Yaron Sheffer <[email-masked]>
Date: Thu, 13 Apr 2017 19:04:16 +0300

And for the record, the document 
(https://raw.githubusercontent.com/yaronf/I-D/master/jwt-bcp/draft-sheffer-oauth-jwt-bcp.md) 
works just fine with kramdown-rfc2629 (v1.1.1) running native on Linux.

Thanks,
	Yaron

On 13/04/17 18:54, Mike Jones wrote:
> I’ve been trying to find a way to run kramdown-rfc2629 from my Windows
> laptop and failing.  This is what I got when I tried to compile a .md
> file that Yaron Sheffer wrote using the kramdown input option at
> https://xml2rfc.tools.ietf.org/experimental.html.
>
> *Unable to Validate File*
>
> Using
> XML_LIBRARY=/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml2:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml3:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml4:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml5:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml6:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml7:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml8
>
> Parsing file INPUT
>
> ------------------------------------------------------------------------
>
> /Apache/2.2.22 (Debian) Server at xml2rfc.tools.ietf.org Port 443/
>
> durif
>
>
>
> Is there a trick I’m missing here?  I’d really prefer to compile the .md
> online than have to do local tool installations on all my machines.
>
>
>
> I then tried to use a local Ruby installation.  I installed 64-bit Ruby
> 2.3.3.  I did the “gem install kramdown-rfc2629”.  I then ran
> “kramdown-rfc2629 \mbj\tmp\draft-sheffer-oauth-jwt-bcp.md >
> \mbj\tmp\draft-sheffer-oauth-jwt-bcp.xml”, which resulted in a
> zero-length .xml file and the following log output.  Any suggestions on
> next steps?
>
>
>
> C:/Ruby23-x64/lib/ruby/2.3.0/net/http.rb:933:in `connect_nonblock':
> SSL_connect returned=1 errno=0 state=error: certificate verify failed
> (OpenSSL::SSL::SSLError)
>
>         from
> C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/kramdown-rfc2629-1.1.1/lib/kramdown-rfc2629.rb:447:in
> `block in get_and_cache_resource'
>
>         from
> C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/kramdown-rfc2629-1.1.1/lib/kramdown-rfc2629.rb:442:in
> `get_and_cache_resource'
>
>         from
> C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/kramdown-rfc2629-1.1.1/lib/kramdown-rfc2629.rb:518:in
> `block in convert_img'
>
>         from
> C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/kramdown-rfc2629-1.1.1/lib/kramdown-rfc2629.rb:512:in
> `scan'
>
>         from
> C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/kramdown-rfc2629-1.1.1/lib/kramdown-rfc2629.rb:512:in
> `convert_img'
>
>         from
> C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/kramdown-rfc2629-1.1.1/lib/kramdown-rfc2629.rb:125:in
> `block in inner_a'
>
>         from
> C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/kramdown-rfc2629-1.1.1/lib/kramdown-rfc2629.rb:123:in
> `map'
>
>         from
> C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/kramdown-rfc2629-1.1.1/lib/kramdown-rfc2629.rb:123:in
> `inner_a'
>
>         from
> C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/kramdown-rfc2629-1.1.1/lib/kramdown-rfc2629.rb:130:in
> `inner'
>
>         from
> C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/kramdown-rfc2629-1.1.1/lib/kramdown-rfc2629.rb:143:in
> `convert_p'
>
>         from
> C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/kramdown-rfc2629-1.1.1/lib/kramdown-rfc2629.rb:125:in
> `block in inner_a'
>
>         from
> C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/kramdown-rfc2629-1.1.1/lib/kramdown-rfc2629.rb:123:in
> `map'
>
>         from
> C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/kramdown-rfc2629-1.1.1/lib/kramdown-rfc2629.rb:123:in
> `inner_a'
>
>         from
> C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/kramdown-rfc2629-1.1.1/lib/kramdown-rfc2629.rb:130:in
> `inner'
>
>         from
> C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/kramdown-rfc2629-1.1.1/lib/kramdown-rfc2629.rb:652:in
> `convert_root'        from
> C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/kramdown-rfc2629-1.1.1/lib/kramdown-rfc2629.rb:118:in
> `convert1'
>
>         from
> C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/kramdown-rfc2629-1.1.1/lib/kramdown-rfc2629.rb:113:in
> `convert'
>
>         from
> C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/kramdown-1.13.2/lib/kramdown/converter/base.rb:105:in
> `convert'
>
>         from
> C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/kramdown-1.13.2/lib/kramdown/document.rb:120:in
> `method_missing'
>
>         from
> C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/kramdown-rfc2629-1.1.1/bin/kramdown-rfc2629:279:in
> `<top (required)>'
>

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 13 Apr 2017 18:39:31 +0200

There is a workaround for the openssl windows cert problem in https://github.com/cabo/kramdown-rfc2629/issues/30 (yes, I know...).

I don't know what is wrong with the web service, though. 

Sent from mobile

> On 13. Apr 2017, at 17:54, Mike Jones <[email-masked]> wrote:
> 
> I’ve been trying to find a way to run kramdown-rfc2629 from my Windows laptop and failing.  This is what I got when I tried to compile a .md file that Yaron Sheffer wrote using the kramdown input option at https://xml2rfc.tools.ietf.org/experimental.html.
> Unable to Validate File
> Is there a trick I’m missing here?  I’d really prefer to compile the .md online than have to do local tool installations on all my machines.
>  
> I then tried to use a local Ruby installation.  I installed 64-bit Ruby 2.3.3.  I did the “gem install kramdown-rfc2629”.  I then ran “kramdown-rfc2629 \mbj\tmp\draft-sheffer-oauth-jwt-bcp.md > \mbj\tmp\draft-sheffer-oauth-jwt-bcp.xml”, which resulted in a zero-length .xml file and the following log output.  Any suggestions on next steps?
>  
> -- 
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please report datatracker.ietf.org bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
> 
> Please report tools.ietf.org bugs at http://tools.ietf.org/tools/issues or
> send email to [email-masked]

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Thu, 13 Apr 2017 17:08:12 +0000

Thanks for the error report.

Kramdown-rfc2629 was throwing an error:

/usr/local/bin/kramdown-rfc2629:23:in `load': /var/lib/gems/1.9.1/gems/kramdown-rfc2629-1.1.0/bin/kramdown-rfc2629:210: multiple assignment in conditional (SyntaxError)
                from /usr/local/bin/kramdown-rfc2629:23:in `<main>'

There must have been a fix put into kramdown-rfc2629 at some point, because doing a gem update fixed the problem.

Please try it again.

                Tony Hansen

PS. The error message wasn’t showing up anywhere; it wasn’t even in the apache logs. I’ll have to investigate why.

From: Tools-discuss <[email-masked]> on behalf of Carsten Bormann <[email-masked]>
Date: Thursday, April 13, 2017 at 12:39 PM
To: Mike Jones <[email-masked]>
Cc: Tools-discuss <[email-masked]>, Dick Hardt <[email-masked]>
Subject: Re: [Tools-discuss] Making online or Windows kramdown-rfc2629 work

There is a workaround for the openssl windows cert problem in https://github.com/cabo/kramdown-rfc2629/issues/30<https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_cabo_kramdown-2Drfc2629_issues_30&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=GMwQIeRVQJg_oGi4TolqsXlxHS2-FluXhD8RYljyfR0&s=6YsbdsKggNHFNYDGW3Q532lqGYBVVsIoIJ7XG_CShSQ&e=> (yes, I know...).

Sent from mobile

On 13. Apr 2017, at 17:54, Mike Jones <[email-masked]<mailto:[email-masked]>> wrote:

I’ve been trying to find a way to run kramdown-rfc2629 from my Windows laptop and failing.  This is what I got when I tried to compile a .md file that Yaron Sheffer wrote using the kramdown input option at https://xml2rfc.tools.ietf.org/experimental.html<https://urldefense.proofpoint.com/v2/url?u=https-3A__xml2rfc.tools.ietf.org_experimental.html&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=GMwQIeRVQJg_oGi4TolqsXlxHS2-FluXhD8RYljyfR0&s=gpPYfkCb61fNgJDS3bGlaJiO57tyemC9wzoMluiE08Q&e=>.
Unable to Validate File
WARNING: Parsing Error: no element found
ERROR: Unable to parse the XML document: INPUT
INPUT: Line 1: Document is empty
INPUT: Line 1: Start tag expected, '<' not found
Using XML_LIBRARY=/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml2:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml3:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml4:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml5:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml6:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml7:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml8<https://urldefense.proofpoint.com/v2/url?u=http-3A__tools.ietf.org_tools_xml2rfc_web_public_rfc_bibxml-3A_home_www_tools.ietf.org_tools_xml2rfc_web_public_rfc_bibxml2-3A_home_www_tools.ietf.org_tools_xml2rfc_web_public_rfc_bibxml3-3A_home_www_tools.ietf.org_tools_xml2rfc_web_public_rfc_bibxml4-3A_home_www_tools.ietf.org_tools_xml2rfc_web_public_rfc_bibxml5-3A_home_www_tools.ietf.org_tools_xml2rfc_web_public_rfc_bibxml6-3A_home_www_tools.ietf.org_tools_xml2rfc_web_public_rfc_bibxml7-3A_home_www_tools.ietf.org_tools_xml2rfc_web_public_rfc_bibxml8&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=GMwQIeRVQJg_oGi4TolqsXlxHS2-FluXhD8RYljyfR0&s=tFjkJ7_cqQhNM0gdzYkZcHZZv3mP8e7oZDxcf2Kp-wE&e=>
Parsing file INPUT
________________________________
Apache/2.2.22 (Debian) Server at xml2rfc.tools.ietf.org<https://urldefense.proofpoint.com/v2/url?u=http-3A__xml2rfc.tools.ietf.org&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=GMwQIeRVQJg_oGi4TolqsXlxHS2-FluXhD8RYljyfR0&s=L8PWOLGM_7wXYnsbKES-AbwGjmqV4IC0WI9m6RSG0ew&e=> Port 443

durif

                                                                -- Mike

--
Tools-discuss mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tools-discuss<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_tools-2Ddiscuss&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=GMwQIeRVQJg_oGi4TolqsXlxHS2-FluXhD8RYljyfR0&s=1TrzavQLO_hCgJQJz08q7viNSL2SffV6dN2UI6oa-L4&e=>

Please report datatracker.ietf.org<https://urldefense.proofpoint.com/v2/url?u=http-3A__datatracker.ietf.org&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=GMwQIeRVQJg_oGi4TolqsXlxHS2-FluXhD8RYljyfR0&s=TtQIQEtt-16GfjvmXYm5rvLlahKg72Dk-fDZ_ZGU8MU&e=> bugs at http://tools.ietf.org/tools/ietfdb<https://urldefense.proofpoint.com/v2/url?u=http-3A__tools.ietf.org_tools_ietfdb&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=GMwQIeRVQJg_oGi4TolqsXlxHS2-FluXhD8RYljyfR0&s=Nemm1JpXctopkZbK7NvKUPlHsyL-8hbuXo42ZTvqYWQ&e=>
or send email to [email-masked]<mailto:[email-masked]>

Please report tools.ietf.org<https://urldefense.proofpoint.com/v2/url?u=http-3A__tools.ietf.org&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=GMwQIeRVQJg_oGi4TolqsXlxHS2-FluXhD8RYljyfR0&s=QXizYxDmoRe350ceRy2GpgFMoQC4kQqXsNh6Azz9c1A&e=> bugs at http://tools.ietf.org/tools/issues<https://urldefense.proofpoint.com/v2/url?u=http-3A__tools.ietf.org_tools_issues&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=GMwQIeRVQJg_oGi4TolqsXlxHS2-FluXhD8RYljyfR0&s=sw3swpCuyEXeHOjEz6TTBy4gzMab5oSce-YAjDi98ls&e=> or
send email to [email-masked]<mailto:[email-masked]>

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Thu, 13 Apr 2017 17:30:42 +0000

Hmmm, there’s still a problem, but it’s evidently a permissions problem somewhere.

Tracking it down now.

                Tony

From: Tools-discuss <[email-masked]> on behalf of "HANSEN, TONY L" <[email-masked]>
Date: Thursday, April 13, 2017 at 1:08 PM
To: Carsten Bormann <[email-masked]>, Mike Jones <[email-masked]>
Cc: Tools-discuss <[email-masked]>, Dick Hardt <[email-masked]>
Subject: Re: [Tools-discuss] Making online or Windows kramdown-rfc2629 work

***Security Advisory: This Message Originated Outside of AT&T ***
Reference http://cso.att.com/EmailSecurity/IDSP.html for more information.
Thanks for the error report.

Please try it again.

                Tony Hansen

Sent from mobile

durif

                                                                -- Mike

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Thu, 13 Apr 2017 17:58:15 +0000

The latest kramdown-rfc2629 doesn’t handle not being able to create a $PWD/.refcache directory well -- the older versions apparently continued on.

I’ve worked around this issue now, and successfully run Mike’s md file through the web interface.

Enjoy!

                Tony

Date: Thursday, April 13, 2017 at 1:30 PM

Tracking it down now.

                Tony

Please try it again.

                Tony Hansen

Sent from mobile

durif

                                                                -- Mike

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 13 Apr 2017 20:24:26 +0200

Interesting, as it can't really do anything with bib refs without that directory (or a replacement that you can specify via environment). Anyway, thanks for fixing this!

Sent from mobile

> On 13. Apr 2017, at 19:58, HANSEN, TONY L <[email-masked]> wrote:
> 
> $PWD/.refcache

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Thu, 13 Apr 2017 18:27:53 +0000

Note: I’ve found .refcache directories sprinkled around various places. :-)

I worked around it by using the new $KRAMDOWN_REFCACHEDIR environment variable to force a location whose permissions I could control.

                Tony

From: Carsten Bormann <[email-masked]>
Date: Thursday, April 13, 2017 at 2:24 PM
To: "HANSEN, TONY L" <[email-masked]>
Cc: Mike Jones <[email-masked]>, Tools-discuss <[email-masked]>, Dick Hardt <[email-masked]>
Subject: Re: [Tools-discuss] Making online or Windows kramdown-rfc2629 work

Sent from mobile

On 13. Apr 2017, at 19:58, HANSEN, TONY L <[email-masked]<mailto:[email-masked]>> wrote:
$PWD/.refcache

---

From: Yaron Sheffer <[email-masked]>
Date: Thu, 13 Apr 2017 21:43:53 +0300

Thank you Tony!

---

From: Mike Jones <[email-masked]>
Date: Thu, 13 Apr 2017 20:58:21 +0000

OK - this is working for me now.  Thanks, Tony and Carsten.

				-- Mike

-----Original Message-----
From: Tools-discuss [mailto:[email-masked]] On Behalf Of Yaron Sheffer
Sent: Thursday, April 13, 2017 11:44 AM
To: HANSEN, TONY L <[email-masked]>; Carsten Bormann <[email-masked]>
Cc: [email-masked]; Dick Hardt <[email-masked]>
Subject: Re: [Tools-discuss] Making online or Windows kramdown-rfc2629 work

Thank you Tony!

Please report tools.ietf.org bugs at http://tools.ietf.org/tools/issues or send email to [email-masked]

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 15 Apr 2017 10:26:44 +0200

Mike,

Kramdown-rfc2629 version 1.1.2 has an automatically activated workaround for the Windows OpenSSL cert store issue.   I don’t have a good way to test this on various Windows platforms.  Can you do me a favor and update your kramdown-rfc2629 gem:

	gem update

and then check whether kramdown-rfc2629 now works locally?

(It will still output a warning.  And the hacked-in cert-store is stale; use the `certified-update` command to get a slightly less stale version.)

Grüße, Carsten

> On Apr 13, 2017, at 22:58, Mike Jones <[email-masked]> wrote:
>