Subject: [Tools-discuss] datatracker rewrapping lines in WG minutes?

From: John G.Scudder <[email-masked]>
Date: Wed, 19 Apr 2017 17:04:01 -0400

I don't know if this is a new behavior but I've never noticed it before -- datatracker seems to be "helping" by rewrapping the lines of my .txt file, that I had already wrapped the way I wanted them, the outcome being predictably horrible. But trying to reverse-engineer the behavior is not straightforward. If I try the obvious and hand it completely unwrapped text so that it can have its own way with it, the resulting wrap is a bit clownish, e.g.:

Source:
John: You have seen the note well many times but this is a reminder on the contribution definition in the IETF. All things you say and present here are covered. It is a boring but important stuff.

(oh as a bonus maybe my MUA or yours will wrap the above. It is a single line with no breaks.)

Result:
John: You have seen the note well
many times but this is a reminder on the contribution definition in the IETF.
All things you say and present here are covered. It is a boring but important
stuff.

(why on earth did it wrap after 'well'?)

To make matters more interesting some heuristics already seem to be in place to keep it from "helping" sometimes. I sorted things out by hard-wrapping to 72, but what I really want is an option to just upload my .txt and have it go unmolested. 

:-(

--John

---

From: Robert Sparks <[email-masked]>
Date: Wed, 19 Apr 2017 17:01:56 -0500

Hi John -

This is something that crops up in lots of places (reviews, discusses 
and comments, shepherd writeups for example), and finding the right 
balance hasn't been easy. We have found a technique that's been working 
better for most folks, but haven't applied it to all the possible places 
we might be able to yet.

What view are you looking at that is doing the less-than-optimal 
wrapping? (There's more than one way to look at the minutes).

RjS