Subject: Re: [Tools-discuss] tools.ietf.org/html/rfc-index ?

From: =JeffH <[email-masked]>
Date: Tue, 10 Jan 2012 12:01:59 -0800

Julian replied..
 > On 2012-01-10 20:39, =JeffH wrote:
 >> Is there html-ified rfc-index, a la the tools.ietf.org/html regime,
 >> whose links are to tools.ietf.org/html RFCs ?
 >>
 >> If not, as seems the case (tools.ietf.org/html/rfc-index 404's), it'd be
 >> pretty useful. There could be a link to it from
 >> <https://tools.ietf.org/html/>, plus the "New RFCs" rfc-index blurbs
 >> that are listed on the latter view could be more fully html-ified.
 >>
 >> thanks,
 >> ...
 >
 > That's very easy to do with XSLT based on the XML version of the RFC
 > index;

ah, good idea.

 >  do you want to give it a try if I start with a simple (ugly)
 > version for you to complete?

don't have cycles to hack on xslt at the moment unfortunately

thanks,

=JeffH

---

From: =JeffH <[email-masked]>
Date: Thu, 26 Jan 2012 16:56:53 -0800

> On 2012-01-25 23:30 =JeffH said:
 > ...
 >>  >  I just
 >>  > put up a new page too, http://tools.ietf.org/html/rfcs, which is more in the
 >>  > style of http://tools.ietf.org/html/
 >>
 >> but both of those lack links for obsoletes, obsoleted by, updates -- thus the
 >> former meets my particular needs better (fwiw).
 >
 > Fixed.

cool, thx.

 >>  >> If not, as seems the case (tools.ietf.org/html/rfc-index 404's), it'd 
be pretty
 >>  >> useful. There could be a link to it from<https://tools.ietf.org/html/>, 
plus
 >>  >> the "New RFCs" rfc-index blurbs that are listed on the latter view could be
 >>  >> more fully html-ified.
 >>  >
 >>  > I'll look at fixing that next.
 >
 > Done.

thx again :)

Some comments..

on https://tools.ietf.org/html/ :

"(Full index pages to htmlized RFCs are available, too: plain, mini, 2-column.)"

should perhaps be..

"(hypertext RFC indexes: traditional, mini, 2-column.)"

Also, the page title for https://tools.ietf.org/rfc/ (i.e. traditional) is "RFC 
Mini-Index" -- perhaps it should be something else?

HTH,

=JeffH