Subject: [TOOLS-DEVELOPMENT] Tools call Tuesday 9 Feb at 1900 UTC

From: Robert Sparks <[email-masked]>
Date: Thu, 4 Feb 2021 13:49:05 -0600

We have a tools call next Tuesday.

Coordinates and an outline of the agenda are available at

<https://codimd.ietf.org/tools-team-20210209#>

*Given the confusion on start time at the last couple of sessions, 
please carefully check the stated time and make sure your calendars agree *

The calendar is at 
https://calendar.google.com/calendar/ical/ietf.org_g4f732f5cdhl2to81jis83ch9s%40group.calendar.google.com/public/basic.ics

Please bash the agenda  - feel free to add topics if needed.

I will be adding detail tomorrow. If you have content to share, adding 
it earlier is better than later.

RjS

---

From: Russ Housley <[email-masked]>
Date: Thu, 4 Feb 2021 15:10:15 -0500

The agenda includes: Moving essential services from tools.ietf.org

I am glad to see this.  We used to talk about moving "mission critical" tools from tools.ietf.org to Secretariat operation.  Is this subtle change is wording intended to convey a difference?

Years ago, the IAOC Tools Management Committee was the group that determine whether a particular tool was "mission critical" or not.  Who has that responsibility now?

Russ

> On Feb 4, 2021, at 2:49 PM, Robert Sparks <[email-masked]> wrote:
> 
> *Given the confusion on start time at the last couple of sessions, please carefully check the stated time and make sure your calendars agree *
> 
> The calendar is at https://calendar.google.com/calendar/ical/ietf.org_g4f732f5cdhl2to81jis83ch9s%40group.calendar.google.com/public/basic.ics
> 
> I will be adding detail tomorrow. If you have content to share, adding it earlier is better than later.
> 
> RjS

---

From: Robert Sparks <[email-masked]>
Date: Thu, 4 Feb 2021 15:13:24 -0600

> I am glad to see this.  We used to talk about moving "mission critical" tools from tools.ietf.org to Secretariat operation.  Is this subtle change is wording intended to convey a difference?

No, not really. The things that need to move have been known for some 
time - we're just adding some focus on finishing the move, with Henrik's 
help.

I'll try to add a bit more detail in the call notes, but the kinds of 
things we're talking about:

* Finishing using the datatracker to serve the htmlized drafts (this is 
closer to done that I remembered - we're down to some styling and 
building links at the top of the page using datatracker data)

* Moving the source code repositories and trac instances to the 
secretiariat. (And making sure we don't have any other trac instances 
we've missed - we found the BoF wiki still needs to move)

* Finish gathering what we need to inform building a replacement for the 
current xml2rfc and bibxml services

* Moving the code that builds developer database snapshots

> Years ago, the IAOC Tools Management Committee was the group that determine whether a particular tool was "mission critical" or not.  Who has that responsibility now?
I think this group should point out any that we've not moved already and 
are not listed above.