Subject: [TOOLS-DEVELOPMENT] Tools call agenda -- 9 Jun 2020 at 1800 UTC

From: Robert Sparks <[email-masked]>
Date: Fri, 5 Jun 2020 13:29:43 -0500

Please bash this agenda by email. In particular, if there are topics 
that need to be added, send them in as soon as possible.

RjS

-----

Tools Call Agenda -- 9 June 2020 at 1800 UTC

JOIN WEBEX MEETING
https://ietf.webex.com/ietf/j.php?MTID=m440dd848726339c03e605b9956e38bac
Meeting number (access code): 640 103 570
Meeting password: tools

JOIN BY PHONE
1-877-668-4493 Call-in toll free number (US/Canada)
1-650-479-3208 Call-in toll number (US/Canada)
Meeting number (access code): 640 103 570
Meeting password: tools

1. Hot Topics
    - RFC Production blocking issues - Alice / Henrik
    - IETF 108 tooling support - Robert / Alexa / Henrik
       - datatracker/registration system integration
       - datatracker/meetecho integration
    - Are there any other priority tool changes needed?

2. Development Projects
    - Meeting Application Improvements (IOLA) - Robert
    - Automated Scheduler Part II (DashCare) - Robert
    - RPC Security Code Review (ZX Security) - Robert
    - YangCatalog (Pantheon) - Éric / Robert
    - Moving the datatracker to Django 2.2 - Henrik
    - DMARC/SPF for aliases - Henrik
    - Capturing external resources in the datatracker - Robert
    - Github backups - Robert

3. Operations Projects
    - Are there any upcoming operations changes that need
      coordination with this team?

4. Planning for upcoming projects
    - Exploring fronting web services with nginx - Robert
    - Revising html/css/template structure for the website - Greg
    - Improving filtering for customised ical feeds -  Robert
    - Moving the datatracker to postgresql - Robert

5. Are there any unmet needs?
    - Open discussion

6. Any Other Business

---

From: Robert Sparks <[email-masked]>
Date: Fri, 5 Jun 2020 13:48:39 -0500

My notes to help the call move quickly.

Please feel free to add more notes by email before we get to the call.

>    - RFC Production blocking issues - Alice / Henrik
There was a bubble of issues this month requiring several xml2rfc 
releases. Note that this slowed the datatracker work on Django2 and 
meetecho integration somewhat.
>       - datatracker/registration system integration
There is a new API endpoint that the new registration system uses to 
tell the datatracker details about registrations, creating datatracker 
accounts as necessary.
> - datatracker/meetecho integration
We are integrating an openid provider into the datatracker, and 
providing the information necessary for meetecho to use to grant users 
the ability to speak in a given session.
>    - Meeting Application Improvements (IOLA) - Robert
IOLA is working through the feedback from the secretariat on the new 
schedule editor. None of this will block scheduling for 108, but the new 
scheduler may not be what gets used yet.
>    - Automated Scheduler Part II (DashCare) - Robert
This is code-complete and awaiting my review.
>    - RPC Security Code Review (ZX Security) - Robert
The code review is essentially complete. The most critical issue 
identified (a possible remote-execution exploit) has already been 
addressed by the RPC. We have populated a private github repository to 
do the remaining remediation work in.
>    - YangCatalog (Pantheon) - Éric / Robert

As Jay noted on list, an amended statement of work is now in place, and 
we are developing a concrete schedule for the new deliverables (copied 
here for convenience):

    * migrating yangcatalog to the cloud and implementing cloud features agreed with IETF LLC;
    * managing the cloud yangcatalog to meet performance and uptime requirements agreed with IETF LLC,
    * developing a web interface to enable administrative work to be performed by a third party, with features as specified by IETF LLC;
    * supporting the transfer of administrative work to a third party nominated by IETF LLC, including identifying and documenting tasks, and providing support and remote training for the third party.

>    - Capturing external resources in the datatracker - Robert
This work is very close to ready for merge. Rich Salz is reviewing the 
current branch.
>    - Github backups - Robert
We will use Martin Thompson's and Mike Bishop's scripts for backup. If 
we can integrate the external resource work this month, we'll use it as 
the source of repositories to make backups of and start those backups 
this month. If there is a delay on the external resource work, we'll 
look at a temporary measure to identify the repositories needing 
backup.  There are still improvements needed to the scripts to capture 
the content of open pull requests. Martin and Mike will be working on 
those as volunteers.
>    - Exploring fronting web services with nginx - Robert
I was unavailable to help Glen on this project most of May. We plan to 
start in again on this now.
>    - Improving filtering for customised ical feeds -  Robert
We are planning to address this need with a small contracted project.
>    - Moving the datatracker to postgresql - Robert
This is the next major change to the datatracker after the django2 work 
completes. We will likely wait to start on it to give Henrik time to 
help move the documentation of the v3 vocabulary forward.
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Jay Daley <[email-masked]>
Date: Mon, 8 Jun 2020 09:06:01 +1200

Unfortunately I will not be able to make this meeting as I have a clash with another meeting that needs to take precedence.

Jay

> On 6/06/2020, at 6:29 AM, Robert Sparks <[email-masked]> wrote:
> 
> Please bash this agenda by email. In particular, if there are topics that need to be added, send them in as soon as possible.
> 
> RjS
> 
> -----
> 

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Mon, 8 Jun 2020 10:04:37 +0000

About YangCatalog, I had a call this Monday morning with the Pantheon contractor (Miroslav) and Benoît Claise:

  *   The containerized version is ready to ship at yang2.amsl.com and as the current server uses old code, it is becoming ‘urgent’ to migrate to the new server. When migration is done, Benoit Claise is happy to send an email to Yang-doctors, netmod WG, ... asking for some more tests
  *   The work on web UI for administration (adding a new SDO or new vendor, cleaning files, looking in the logs/journals) will start mid-June
  *   Work on cloudified version is yet to start
  *   Benoit and I have not current plan to host a YC.O virtual hackathon project for IETF-108 (but ideas like YC.O CLI client or adding telemetry support to YC.O are floated right now – more to come next week probably)

Talk to you tomorrow

-éric

From: TOOLS-DEVELOPMENT <[email-masked]> on behalf of Robert Sparks <[email-masked]>
Date: Friday, 5 June 2020 at 20:49
To: "[email-masked]" <[email-masked]>
Subject: Re: [TOOLS-DEVELOPMENT] Tools call agenda -- 9 Jun 2020 at 1800 UTC

RjS

-----

JOIN WEBEX MEETING

JOIN BY PHONE

1. Hot Topics
   - RFC Production blocking issues - Alice / Henrik
There was a bubble of issues this month requiring several xml2rfc releases. Note that this slowed the datatracker work on Django2 and meetecho integration somewhat.

   - IETF 108 tooling support - Robert / Alexa / Henrik
      - datatracker/registration system integration
There is a new API endpoint that the new registration system uses to tell the datatracker details about registrations, creating datatracker accounts as necessary.

      - datatracker/meetecho integration
We are integrating an openid provider into the datatracker, and providing the information necessary for meetecho to use to grant users the ability to speak in a given session.

2. Development Projects
   - Meeting Application Improvements (IOLA) - Robert
IOLA is working through the feedback from the secretariat on the new schedule editor. None of this will block scheduling for 108, but the new scheduler may not be what gets used yet.

   - RPC Security Code Review (ZX Security) - Robert
The code review is essentially complete. The most critical issue identified (a possible remote-execution exploit) has already been addressed by the RPC. We have populated a private github repository to do the remaining remediation work in.

As Jay noted on list, an amended statement of work is now in place, and we are developing a concrete schedule for the new deliverables (copied here for convenience):

This work is very close to ready for merge. Rich Salz is reviewing the current branch.

   - Github backups - Robert
We will use Martin Thompson's and Mike Bishop's scripts for backup. If we can integrate the external resource work this month, we'll use it as the source of repositories to make backups of and start those backups this month. If there is a delay on the external resource work, we'll look at a temporary measure to identify the repositories needing backup.  There are still improvements needed to the scripts to capture the content of open pull requests. Martin and Mike will be working on those as volunteers.

3. Operations Projects

4. Planning for upcoming projects
   - Exploring fronting web services with nginx - Robert
I was unavailable to help Glen on this project most of May. We plan to start in again on this now.

   - Moving the datatracker to postgresql - Robert
This is the next major change to the datatracker after the django2 work completes. We will likely wait to start on it to give Henrik time to help move the documentation of the v3 vocabulary forward.

6. Any Other Business

_______________________________________________
TOOLS-DEVELOPMENT mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tools-development

---

From: Cindy Morgan <[email-masked]>
Date: Tue, 9 Jun 2020 12:30:11 -0700

Tools Call Meeting -- 9 June 2020 at 1800 UTC

Present:

- Alexey Melnikov 
- Alice Russo 
- Cindy Morgan 
- Éric Vyncke 
- Henrik Levkowetz 
- Rich Salz 
- Robert Sparks 
- Roman Danyliw 
- Russ Housley 
- Ryan Cross 

Regrets: 

- Alexa Morris 
- Glen Barney 
- Jay Daley
- Liz Flynn 

1. Hot Topics

Robert via email: There was a bubble of issues this month requiring several xml2rfc releases. Note that this slowed the datatracker work on Django2 and meetecho integration somewhat.

Alice: I went through all the docs, and recent releases have resolved several things. There is one doc in TI with an issue about line folding.

Robert: Is it pressing on production? How long does Henrik have to look at it?

Alice: It's in AUTH48. We need to let authors know if this will be changed or not.

Robert: There was a flurry of issues from the RPC over the past month, and a significant number of XML2RFC releases to fix those, so Henrik has had to focus on that more heavily than usual in this past month. Is there anything else we need to discuss on potential RPC blocking issues?

[No]

Robert via email: There is a new API endpoint that the new registration system uses to tell the datatracker details about registrations, creating datatracker accounts as necessary.

Robert: This is similar to the existing workflow, but the kickoff is different. 

Robert via email: We are integrating an openid provider into the datatracker, and providing the information necessary for meetecho to use to grant users the ability to speak in a given session.

Robert: The goal is to get to a point where Meetecho sign in and datatracker sign in is integrated. Éric asked about hums in Meetecho; I don't know about that but I know Alexa has been working on that.

Roman: There is active discussion in the IESG about how to do that. No specifics, but it's a hot topic of discussion on how to implement it.

Robert: So building requirements for Meetecho?

Roman: The UI wouldn't be that huge and we can probably get started on the backend when we decide what the buttons will do when you click them.

Rich: For clarification, the OpenID work, that would work to let the Datatracker be an identify provider for things like Webex?

Robert: That is the hope. We will be testing that to determine identity. Also OAUTH2 layer underneath it. 

Rich: That's amazingly awesome, thank you.

Henrik: For now, client registration is manual, so you'll have to have Robert or me or maybe Ryan to get a client set up, and there is also policy issues involved in that.

Rich: That's okay; one step at a time.

2. Development Projects

Robert via email: IOLA is working through the feedback from the secretariat on the new schedule editor. None of this will block scheduling for 108, but the new scheduler may not be what gets used yet.

Robert: He thinks he'll get through the current feedback in the next couple of weeks, and then another 4-6 weeks to go through the rest of it.

Robert via email: This is code-complete and awaiting my review.

Robert: Once we have this integrated, I will work with the Secretariat to show them how to use it and we'll see if it helps. It's going to be most useful when we get back to in-person meetings, or have online meetings with a similar density/conflicts.

Russ: We do have the same inputs, but it's the density you expect to be different?

Robert: Yes. It can be run on the online meetings, I just don't expect it to be as helpful as it will be when we have a lot of conflicts. 

Robert via email: The code review is essentially complete. The most critical issue identified (a possible remote-execution exploit) has already been addressed by the RPC. We have populated a private github repository to do the remaining remediation work in.

Robert: Once it's remediated, we'll take a snapshot of that repository, not a clone, that won't show the remediation work and create the initial public repository. Best guess is we'll be done with this within the next month. 

Robert via email: As Jay noted on list, an amended statement of work is now in place, and we are developing a concrete schedule for the new deliverables (copied here for convenience):

Eric via email: About YangCatalog, I had a call this Monday morning with the Pantheon contractor (Miroslav) and Benoît Claise:

• The containerized version is ready to ship at yang2.amsl.com and as 
  the current server uses old code, it is becoming ‘urgent’ to migrate 
  to the new server. When migration is done, Benoit Claise is happy to 
  send an email to Yang-doctors, netmod WG, ... asking for some more 
  tests
• The work on web UI for administration (adding a new SDO or new vendor, 
  cleaning files, looking in the logs/journals) will start mid-June
• Work on cloudified version is yet to start
• Benoit and I have not current plan to host a YC.O virtual hackathon 
  project for IETF-108 (but ideas like YC.O CLI client or adding 
  telemetry support to YC.O are floated right now – more to come next 
  week probably)

Robert: Current production server is lagging. Need to prioritize deploying the containerized version. Working on a schedule for this, will be starting on this over the next couple of weeks to deploy this over a cloud service.

Éric: Do you think we could swap the DNS to point to the YANG2 server?

Robert: If you just want that to become production, that's an easy swap.

Éric: But if we have to fall back, if Glen and Ryan can be available.

Robert: Can you send email to Glen detailing that question?

Éric: Will do.

Robert: So we will have that conversation in email.

Henrik: Next step is 2.1, and then 2.2. I have things ahead of those steps in the queue, so it's hard to really do time estimates for those, but my guess is within a month we should be up to 2.2.

Robert: And we had a task that I don't think got any cycles, on how to do DMARC for aliases. Glen and Henrik and John will get together on this. Henrik, will you take the token to drive that conversation, or should I?

Henrik: Whatever is best for you.

Robert: I am happy to let you do that.

Robert via email: This work is very close to ready for merge. Rich Salz is reviewing the current branch.

Robert: This is about the external URL resource thing the Datatracker already has. The initial use for this will be identifying the GitHub repositories we need to back up. Rich is reviewing the current branch and working on the initial migration. 

Rich: I'll have initial feedback to you before this weekend.

Robert via email: We will use Martin Thompson's and Mike Bishop's scripts for backup. If we can integrate the external resource work this month, we'll use it as the source of repositories to make backups of and start those backups this month. If there is a delay on the external resource work, we'll look at a temporary measure to identify the repositories needing backup.  There are still improvements needed to the scripts to capture the content of open pull requests. Martin and Mike will be working on those as volunteers.

Robert: One thing we don't have is getting the code diffs of the pull requests. They'll be working on this as volunteers. I am hoping we'll start running these before the next tools call. Trying to see if we can get the external resource work integrated into trunk so we can use that as the source of truth on what to back up. If there's a delay, we can build a temporary workaround for that.

3. Operations Projects

Robert: Without Glen on the call, I don't know that we can talk about this here. I'll follow up by email to see if there is anything.

Russ: The only thing I know about is the YANG 2 containerization that was in the email.

Robert via email: I was unavailable to help Glen on this project most of May. We plan to start in again on this now.

Robert: What we have right now is really unmanageable and we have a start for an RFP on this so we end up with something we can edit and manage ourselves.

   - Improving filtering for customized ical feeds -  Robert

Robert via email: We are planning to address this need with a small contracted project.

Robert: Especially for the upcoming meetings page, things like wanting to only see the WGs you're interested in. Also want to change the filter on the regular meeting page to use something other than the segment identifier we are currently using because it conflicts with other uses of the segment identifiers. This will be something we have a small contracted project on during this cycle.

Robert via email: This is the next major change to the datatracker after the django2 work completes. We will likely wait to start on it to give Henrik time to help move the documentation of the v3 vocabulary forward.

Robert: Will probably delay the migration of this until that is fairly settled. 

6. Any Other Business

Robert: Is everyone more comfortable continuing to use Webex, or is there a preference for moving to Zoom, or a lack of preference for Zoom?

Roman: Webex is easier for me.

Éric: For me, it's pretty obvious.

Robert: Thank you for taking the time. If there is anything else to discuss, please send mail to the list, otherwise I will see you all online, and thank you for your help.