Subject: [TOOLS-DEVELOPMENT] Tools Call Agenda -- 12 May 2020 at 2:00 Eastern

From: Russ Housley <[email-masked]>
Date: Sat, 9 May 2020 15:55:48 -0400

Tools Call Agenda -- 12 May 2020 at 2:00 Eastern

JOIN WEBEX MEETING
https://ietf.webex.com/ietf/j.php?MTID=m0f29496dd9847310ade6295e4f179f25
Meeting number (access code): 618 857 461
Meeting password: tools

JOIN BY PHONE
1-877-668-4493 Call-in toll free number (US/Canada) 
1-650-479-3208 Call-in toll number (US/Canada)
Meeting number (access code): 618 857 461
Meeting password: tools

1. Hot Topics
   - Are tools issues blocking any documents?
   - Are there any priority tool changes needed?

2. Development Projects
   - Contracted projects progress update and immediate plans
   - Volunteer projects progress update and immediate plans

3. Operations Projects
   - Projects progress update and immediate plans

4. Planning for upcoming projects
   - SoW under development
   - RFP progress update
   - Planning for sizable volunteer projects

5. Are there any unmet needs?
   - Open discussion

6. Any Other Business

---

From: Robert Sparks <[email-masked]>
Date: Mon, 11 May 2020 12:11:03 -0500

My notes for tomorrow's call;

 >   - Are there any priority tool changes needed?

* Building a good user experience with Meetecho for future interims
   and online full meetings.
    - We are still working through what a user will hand to webex to
      "log in". Testing/evaluation of the experience with Oauth2
      depends on Django 2. We have two fallbacks ready - one that
      utilizes personal api tokens from the datatracker, and one
      that uses the old concept of providing a registration number.
      Ryan is working towards an API endpoint in the datatracker that
      will accept registration information as the registration system
      gathers it.

* There were several requests to change the behavior of ics calendar
   for meeting/upcoming. We are still reviewing how to best respond to
   some of them.

 >    - Contracted projects progress update and immediate plans

We held a review session with the secretariat focusing on the new
meeting schedule editor. Liz asked for many improvements. A recording
of the session was sent to IOLA.

Dashcare has started work on the actual automatic schedule generator.

ZX Security has started the security review of the RPC code, and have
sent an initial set of comments.

We've made several changes to the datatracker at the IESGs request
focusing on interim meetings. These are already deployed (See
https://datatracker.ietf.org/release/). We have a request from the
IAB to allow programs to request meetings and manage materials similar
to working groups/research groups. This is implemented and will be
part of an upcoming release.

Work on converting the datatracker to Django 2 is nearing completion.

The wagtail portion of the website has been upgraded to Django 2 and
a recent release of wagtail. To do so, we removed the use and local
extensions to the deprecated Hallo editor. We should look at reimplementing
some of those extensions in the newer drafttail framework. It is now simpler
to keep the project aligned with new releases of wagtail as they come out.

We deployed an instance of CodiMD on Heroku and notified the chairs list.
It has not seen much use, and we haven't received any feedback past a few
initial positive responses. I will push for more feedback from the chairs.

We supplied a tool to help advance the NomCom eligibility discussions.

 >    - Volunteer projects progress update and immediate plans

We have scheduled an online sprint for 19May.

 >    - Projects progress update and immediate plans

We will be experimenting with fronting some of the proxied applications
with nginx in the next couple of weeks

 > 4. Planning for upcoming projects

We have not issued the RFP for github backups for two reasons:
It's not clear there is anyone with a product that could bid, and
Martin Thomson and Mike Bishop have created most of a (bespoke)
solution that will likely serve our needs.

Henrik will be the tools team advisor for the upcoming NomCom.

There have been several suggestions made in the last couple of
months around requirements for a revision of the errata verification
system. I am collecting those as input into a possible upcoming
project.

The Tools Architecture and Strategy Team held their first real-time
meeting. The agenda was organization and obtaining some initial
background.

 > 5. Are there any unmet needs?

_______________________________________________
TOOLS-DEVELOPMENT mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tools-development

---

From: Liz Flynn <[email-masked]>
Date: Fri, 15 May 2020 15:28:01 -0700

Tools Call 
May 12, 2020
Notes

1. Hot Topics

Alice notes that ticket number 508 involves an XML to RFC issue. Henrik will fix the error. 

Robert: We have a group working together to get to a place with better support with Meetecho for either interim meetings or online full IETF meetings. One aspect is ensuring there is a reasonably good user experience for joining a meeting. We are working toward datatracker integration and over the next couple of weeks we will see if we can get to something with a single login. If that fails, we'll go back to carrying a token to Meetecho from either the datatracker or the registration system. 

There have been a lot of requests about changing the behavior of the ICS files and having it stop forgetting about meetings that have passed.

Alissa: In the survey that we did about online meetings, the results of which Jay posted yesterday, we got some comments about people wanting some other ideas. It might be worth looking through comments there. 

Russ: I found the ability to download an ics file for just a single session very helpful. You have to open the datatracker page for that session to see it but choosing the ones to put in your calendar is good.

Robert: Our future list has a customizer similar to what we have for the full meeting on the Upcoming Meetings page. 

2. Development Projects

The new meeting editor is on its way but not quite to a point where it would be usable. We had a session with Secretariat and waiting for next update from IOLA. 

Dashcare has started work on the automated schedule generation project and expected to conclude within the month. This project just suggests a schedule. 

ZX Security has started their security review. There are some comments in the initial review that we'll be in touch with RPC to talk about making changes. There are some potential vulnerability points to look at. 

We got a request from the IAB to have their programs behave more like WGs, and the IESG's interim meeting changes are already deployed or in progress. We are still working on converting the datatracker to Django 2; Henrik ran javascript tests and got a failure in the latest round. Something is unstable and needs to be fixed. It looks very close now. 

The next big item will move datatracker on Postgress. 

The Wagtail portion of the website is now upgraded to Django 2. We can now stay in step with new Wagtail releases going forward. We had to deprecate a few extensions that couldn't move to the new version so we need to reimplement some functionality in the future. 

We deployed an instance of CodiMD which has gotten some use but not much. Robert will push the wgchairs list to see if anyone has used it. 

A virtual code sprint has been scheduled for May 19; from 10:00 EDT. 

3. Operations Projects

Glen: We had an interesting server problem yesterday with heavy traffic from malformed URLs. Apart from that, we're running very stable. 

Glen has nginx set up on the server and we'll start working towards gaining experience with it on some proxied applications. If successful nginx will replace the outer layer of Apache. Right now you go through an apache layer directly on the server that proxies to another apache inside the application. That proxy has quite a lot of expense and the community wisdom is that nginx does a more efficient job of proxying and serving static assets. In the long run if this works out no one will notice but the way we serve the websites will be more responsive. 

We have not issued the RFP for GitHub backups because 1) it's not clear there's anyone who could respond; 2) we have a bespoke solution that is likely going to cover our needs that's 95% done. For projects that have integrated all of Martin Thomson's work, the repository contains a continuously updated snapshot of the things we'd want to back up. Those are things like text in issues and labels. The primary bit of data that Mike Bishop's script is not yet pulling together is the content of open pull requests, so the script just needs to be extended. It looks like that's going to come together and be the solution we need and we won't issue an RFP. 

Permission is given as part of the pull request. 

Although there are two different ways of doing the backups, once the document authors or WG chairs add a URL to datatracker pages, the script will build its backups based on that information and there should be no manual intervention needed

No other RFPs are in progress. 

Henrik will be tools team advisor for the upcoming NomCom. 

There have been several suggestions made in the last couple of months around requirements for a revision of the errata verification system. I am collecting those as input into a possible upcoming
project.

The Tools Architecture and Strategy Team held their first real-time meeting. The agenda was organization and obtaining some initial background.

None discussed.

  - None discussed.

6. Any Other Business

We're going to be restructuring the tools team a bit to have a core group focused on implementation who can work together more closely and triage requirements coming in from the many different parts of the IETF community. We're going to have an implementation group of six people (Russ, Robert, Alexey, Henrik, Roman, Glen). The rest of us will be part of an at-large group which continues to help with coordination and syncs up on calls but won't be in on the day-to-day implementations conversations. Robert will be assuming role of chair. Thanks to Russ for his years of chairing this group. 

Once the new mailing list is set up and the websites are updated, Alissa will send a note to the community about these changes.

> On May 11, 2020, at 10:11 AM, Robert Sparks <[email-masked]> wrote:
>