Subject: [TOOLS-DEVELOPMENT] Tools Call Agenda -- 14 April 2020 at 1:00 Eastern

From: Russ Housley <[email-masked]>
Date: Wed, 8 Apr 2020 09:39:16 -0400

** TRYING A NEW OUTLINE FOR THE AGENDA **

Tools Call Agenda -- 14 April 2020 at 1:00 Eastern

JOIN WEBEX MEETING
https://ietf.webex.com/ietf/j.php?MTID=m440dd848726339c03e605b9956e38bac
Meeting number (access code): 640 103 570
Meeting password: tools

JOIN BY PHONE
1-877-668-4493 Call-in toll free number (US/Canada) 
1-650-479-3208 Call-in toll number (US/Canada)
Meeting number (access code): 640 103 570
Meeting password: tools

1. Hot Topics
   - Are tools issues blocking any documents?
   - Are there any priority tool changes needed?

2. Development Projects
   - Contracted projects progress update and immediate plans
   - Volunteer projects progress update and immediate plans

3. Operations Projects
   - Projects progress update and immediate plans

4. Planning for upcoming projects
   - SoW under development
   - RFP progress update
   - Planning for sizable volunteer projects

5. Are there any unmet needs?
   - Open discussion

6. Is the new agenda outline an improvement?
   - Open discussion

---

From: Robert Sparks <[email-masked]>
Date: Thu, 9 Apr 2020 13:33:07 -0500

My notes for next week's meeting:

 >    - Are there any priority tool changes needed?

     - We made many changes to the datatracker to support the 
virtualized IETF107
       and the increased use of interims after it. The rate of requests 
for new
       features and tweaks to the datatracker support the interims has 
begun to
       slow.

     - We are in discussions with Meetecho about integrating Meetecho 
with the
       virtual meetings.

 >    - Volunteer projects progress update and immediate plans

     - IOLA provided a first pass at a better meeting schedule editing
       interface. I've asked for some changes before we begin testing 
with the
       Secretariat. The implementation is such that the old and new 
interfaces
       are available at the same time.

     -  Dashcare has completed part 1 of the automated schedule builder. The
        results are in 6.126.0. Jay and I will work with Dashcare to start
        part 2.

     -  We had a kickoff call with ZX Security, and have provided the
        materials needed for the RPC Security code review. We currently
        expect work to start on this project either the last week of April
        or the first week of May.

     -  Work is underway on dropping Python 2 support in the datatracker
        codebase. The next steps will be moving to Django 2 and to 
PostgreSQL.

     -  I have completed the repairs to the website needed for snippets to
        display links correctly (see release 0.9.16). I have started work on
        converting the website to Django 2.0, and subsequently moving to the
        most recent version of wagtail. One item of note. We are removing a
        transcoder that was used to downconvert the custom javascript 
torchbox
        built for the site to something IE 11 (of the time) worked 
better with.

     -  We are talking with Pantheon about increasing their level of 
support for
        YangCatalog.org, including what it would take to deploy the 
containerized
        version of the application on a cloud service such as Amazon. We 
have begun
        working towards identifying the actions taken while operating 
yc.o (such as
        granting a new sdo access to the API) that can be performed by 
the Secretariat
        and building the right interfaces and training to transition 
those tasks.

     -  Rich Salz and I worked at the codesprint towards replacing the 
DocumentURL
        construct in the datatracker with a more generic 
ExternalResource, which
        would make it easier for chairs to provide github repository 
references and
        usernames to tooling that would be interested in such things. 
Work on this
        slowed just after the 107 week, but I expect to return to it soon.

 > 4. Planning for upcoming projects

     - The Github Backup SoW is still pending. Martin put together 
something that
       appears to back up everything needed for a group, but only if the 
group is
       configured to use his continuous integration tooling. This needs more
       investigation.

     - Testing on fronting the websites with nginx is still planned, but 
no progress
       was made this month.

 > 5. Are there any unmet needs?

     - Do we need to provide tooling or data-research to support the 
conversations
       around eligibility for future NomComs?

     - Last month, we mentioned trialing CodiMD with some upcoming 
interims, but
       action has not started on this idea.
 > _______________________________________________
 > TOOLS-DEVELOPMENT mailing list
 > [email-masked]
 > https://www.ietf.org/mailman/listinfo/tools-development

---

From: Jay Daley <[email-masked]>
Date: Fri, 10 Apr 2020 08:46:56 +1200

All

One of my top level goals is 

> 3. IETF Tools: Modernise information technology systems and platforms on which the IETF depends to meet existing and future requirements and provide a solid foundation for future development, improved reliability, performance and accessibility.

and for that I will be engaging quite heavily with the tools team over the next year or so both in the tools team meetings and individually.  I’m already very active behind the scenes but the tools team meetings are important to ensure that the work I’m directing is transparent and connected to the community.

However, I’m unable to make a regular meeting time of 1pm EDT as that’s 5am for me (when the clocks move back to EST it’s 7am, which us fine).  

Given that problem, I wanted to ask if anyone objects to us moving the time for this call to 3pm or 2:30pm for the next six months or so, so that I can fully participate?

thanks
Jay

> On 9/04/2020, at 1:39 AM, Russ Housley <[email-masked]> wrote:
> 

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: "John Levine" <[email-masked]>
Date: 9 Apr 2020 20:02:06 -0400

In article <[email-masked]> you write:
>Given that problem, I wanted to ask if anyone objects to us moving the time for this call to 3pm or
>2:30pm for the next six months or so, so that I can fully participate?

The RFC Editor meeting is 3-330 and it'd be nice to be able to go to both.

Later at 4PM here would be fine.

---

From: Alissa Cooper <[email-masked]>
Date: Mon, 13 Apr 2020 09:42:57 -0400

I will be taking care of my kids on Tuesdays for the foreseeable future, so I won’t be able to join the tools calls.

Alissa

> On Apr 8, 2020, at 9:39 AM, Russ Housley <[email-masked]> wrote:
>

---

From: Alissa Cooper <[email-masked]>
Date: Mon, 13 Apr 2020 10:32:18 -0400

Hi Robert,

> On Apr 9, 2020, at 2:33 PM, Robert Sparks <[email-masked]> wrote:
> >
>     - Do we need to provide tooling or data-research to support the conversations

Emphatic yes on data.

From Stephen’s last mail to eligibility-discuss, I assumed he and Brian were already talking to you about this. If not, let’s definitely sync up on the minimal data production that could be done to inform the discussion.

Thanks,
Alissa

> 
>     - Last month, we mentioned trialing CodiMD with some upcoming interims, but

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Tue, 14 Apr 2020 09:56:50 +0000

Jay and others,

1830 UTC (== 2:30 PM EST) would be OK for me (actually good timing) but please not later as it becomes my evening ;)

As a side note, my Tuesday is full of back to back calls, and as I need to get some food, I will join the call probably 20-30 minutes after its start

-éric

From: TOOLS-DEVELOPMENT <[email-masked]> on behalf of Jay Daley <[email-masked]>
Date: Thursday, 9 April 2020 at 22:47
To: IETF Tools Development <[email-masked]>
Subject: Re: [TOOLS-DEVELOPMENT] Tools Call Agenda -- 14 April 2020 at 1:00 Eastern

All

thanks
Jay

On 9/04/2020, at 1:39 AM, Russ Housley <[email-masked]<mailto:[email-masked]>> wrote:

JOIN WEBEX MEETING

JOIN BY PHONE

1. Hot Topics

2. Development Projects

3. Operations Projects

--
Jay Daley
IETF Executive Director
[email-masked]<mailto:[email-masked]>

---

From: Russ Housley <[email-masked]>
Date: Wed, 15 Apr 2020 15:56:04 -0400

> Given that problem, I wanted to ask if anyone objects to us moving the time for this call to 3pm or 2:30pm for the next six months or so, so that I can fully participate?

Based on this request and the discussion that followed, we will move the Tools Calls on May12, June 9, July 14, September 8, and October 13 to 2:00pm Eastern.  Remember that we do not hold a Tools Call in August.  Then, on November 1, DST ends in the US, so we will see if a different time is needed, otherwise we will go back to 1:00 Eastern.

Liz, would you please adjust the iCal.

Russ

---

From: Liz Flynn <[email-masked]>
Date: Wed, 15 Apr 2020 14:51:18 -0700

Hi everyone,

The calendar has been updated to reflect those changes! 

Liz Flynn
Project Manager / IETF
[email-masked]

> On Apr 15, 2020, at 12:56 PM, Russ Housley <[email-masked]> wrote:
> 
> Jay:
>