Subject: Re: [TOOLS-DEVELOPMENT] Backing up Github WG repositories

From: Robert Sparks <[email-masked]>
Date: Mon, 2 Mar 2020 14:11:28 -0600

I've started working Martin's and John's comments into the doc. What 
else do we need to add?

<https://github.com/rjsparks/github-backup-sow/>

RjS

On 2/28/20 8:14 AM, Robert Sparks wrote:
>
> On 2/28/20 3:26 AM, Martin Thomson wrote:
>> (Travel might delay more responses...)
>>
>> On Thu, Feb 27, 2020, at 13:55, Robert Sparks wrote:
>>> And one more thing to consider: This whole API requires providing the
>>> credentials of an _owner_ of the repository being backed up. I suspect
>>> that means we'll have an identity that we ask WG draft repositories to
>>> add as an owner. Does that match your expectations?
>> Now that I understand this more, that is just one of the problems: 
>> locking the repo every hour is likely to be too disruptive.
>
> locking is an option, not a requirement, and it's turned off by 
> default. I didn't see anything that indicated it would break things if 
> you didn't lock the repository.
>
> I think that option was there only to make it easier for people who 
> were really _migrating_ a repository to a different place to avoid 
> confusion or losing information during transition.
>
>>    I don't particularly like the idea that we have this tool as an 
>> owner, but that's less of a problem.

---

From: Robert Sparks <[email-masked]>
Date: Tue, 10 Mar 2020 10:25:18 -0500

Hi Martin -

Do you think this is ready to go out? There is still much design to be 
done, but I think that's to be done as part of the project.

RjS

On 3/2/20 2:11 PM, Robert Sparks wrote:
>> default. I didn't see anything that indicated it would break things 
>> if you didn't lock the repository.
>>
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: "Martin Thomson" <[email-masked]>
Date: Wed, 11 Mar 2020 16:11:09 +1100

Yes, I think that it is good.

BTW, you might be interested in the work Mike Bishop did on https://github.com/martinthomson/i-d-template/pull/206

I'd have to say that the backup is pretty complete and the script is small and quite maintainable.  The only drawback is that my tool for rendering the contents of the previous format also needs to be updated to use this format.

I have plans to integrate this with GitHub Actions.  Maybe you'll get everything you need from just mirroring repositories then :)