Subject: [TOOLS-DEVELOPMENT] Tools Call Agenda -- 17 March 2020 at 1:00 Eastern

From: Russ Housley <[email-masked]>
Date: Mon, 16 Mar 2020 17:03:05 -0400

Tools Call Agenda -- 17 March 2020 at 1:00 Eastern

JOIN WEBEX MEETING
https://ietf.webex.com/ietf/j.php?MTID=m440dd848726339c03e605b9956e38bac
Meeting number (access code): 640 103 570
Meeting password: tools

JOIN BY PHONE
1-877-668-4493 Call-in toll free number (US/Canada) 
1-650-479-3208 Call-in toll number (US/Canada)
Meeting number (access code): 640 103 570
Meeting password: tools

1. Datatracker Projects
   - Expected Datatracker Releases -- Robert and Henrik
     -- https://trac.tools.ietf.org/tools/ietfdb/browser/trunk/PLAN
   - Meeting application improvements by IOLA -- Robert
   - Automated schedule builder by DashCare -- Robert
   - Minor Tools Enhancements by Painless Security -- Robert

2. Community & Other Projects
   - WWW search to provide additional pointers -- Greg
   - Host third-party subresources on mailarchive -- Ryan

3. RFC Services Projects
   - Are tools issues blocking any documents? -- John and Henrik
   - Security Review of RPC Tools -- Robert and Jay

4. Server Infrastructure
   - Deployment of Python3 -- Robert
   - Expected Website Releases -- Robert
   - DMARC support for email aliases -- Henrik and Alexey
   - Backup for IETF-related portions of GitHub -- Robert

5. YANG Catalog
   - Posting YANG modules by other SDOs -- Eric and Robert
   - Putting yangcatalog.org in a Docker container -- Robert
   - Upgrade the operating system on the server -- Glen

6. Parking Lot
   - Transition Datatracker to Django2 and then Django3
   - Transition Mailarchive to Django2 and then Django3
   - Transition Wagtail for IETF website to Django2 and then Django3
   - Search over www, datatracker, and mailarchive

7. AOB

---

From: Robert Sparks <[email-masked]>
Date: Mon, 16 Mar 2020 16:16:12 -0500

>       -- https://trac.tools.ietf.org/tools/ietfdb/browser/trunk/PLAN
We have been focusing on supporting the changes to IETF 107.

There were six drafts negatively affected by the merge of the data 
changes made
during the first attempt at the server upgrade. One of these
(draft-ietf-dnssd-prireq) is still in the process of being corrected. 
The set
of drafts matched by community rules were also affected, which caused 
incorrect
results in the "Related Internet-Drafts" section of WG document pages 
but this
has already been addressed.

The next two major projects are removing Python 2 support and
moving to Django 2.
>     - Meeting application improvements by IOLA -- Robert
Work is underway, but behind schedule. IOLA has committed a new
graphical editor that I will set up in a test instance for the
secretariat to play with after the 107 week. I am still working with
IOLA to develop an updated completion date.
>     - Automated schedule builder by DashCare -- Robert
Part I is essentially complete, pending merging. Jay and I will meet
soon to discuss Part II.
>     - Minor Tools Enhancements by Painless Security -- Robert

Painless Security has made enhancements to the datatracker and the website.
Next they will be working towards enhancements to xml2rfc and the 
mailarchive.
>     - WWW search to provide additional pointers -- Greg
The links from the mailarchive were deployed with the Python 3 deployment.
We are not planning on anything additional here in the near future.
>     - Host third-party subresources on mailarchive -- Ryan
This is done given the Python 3 deployment.
>     - Security Review of RPC Tools -- Robert and Jay
This project has been awarded and I am working on scheduling a kick-off 
call.
>     - Deployment of Python3 -- Robert
Done.
>     - Expected Website Releases -- Robert
A major release removing torchbox's attempt at datatracker integration was
released this period. It ended up having a bug that is affecting Snippet 
links
to URLs when older pages are edited. The fix is known, and will be applied
after the 107 week.

The website is also on a _very_ old version of wagtail now. I am going to
prioritize moving it closer to head. At the moment, I'd be doing the work.
>     - DMARC support for email aliases -- Henrik and Alexey

No progress has been made on this front - it was slated for after the
server migration. It would be good to discuss its relative priority level
during this meeting.
>     - Backup for IETF-related portions of GitHub -- Robert
An SoW is in development. See 
<https://github.com/rjsparks/github-backup-sow/>.
In the discussion while developing it, we posited having a single 
identity that
became an owner of each WG ID repository. There is currently conversation on
the ietf-and-github mailing list that notes the risk of having such a thing.
The SoW allows for different credentials per repository, but we need to
understand what that means for the Secretariat (and eventually the 
datatracker)
from the perspective of managing the secret part of those credentials.
>     - Putting yangcatalog.org in a Docker container -- Robert
Benoit, Eric, Jay and I are working to find time to meet to set priorities
and a target date for deploying the containerized yc.o.
>     - Search over www, datatracker, and mailarchive
Should we put effort into making CodiMD available as a replacement or
alternatve to etherpad?

Concerns continue to be raised about datatracker performance. Should we
prioritize addressing these higher?

I'd like to schedule starting work on fronting our webservices with nginx
for shortly after the 107 week.
>
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Glen <[email-masked]>
Date: Mon, 16 Mar 2020 14:42:18 -0700

Done.

Glen