Subject: [TOOLS-DEVELOPMENT] Fwd: Re: [Tools-discuss] Etherpad no longer on standard port

From: Robert Sparks <[email-masked]>
Date: Fri, 6 Mar 2020 16:20:09 -0600

Carsten wrote:

>
> So my take is that there is additional incentive to look for what’s 
> next after Etherpad, for functional as much as for those operational 
> reasons.
> I repeat my ceterum censeo that hackmd/CodiMD is a viable candidate, 
> but that observation is not addressed at operational people at this 
> point (although we’d have to figure out whether that can be run 
> reliably — the sysadmins at my university tell me they can).

This looks like it would be easy to deploy to me and it passes a first 
sniff-test at keeping it going.

I was able to do a one-click deploy in heroku, and tweaking options to 
make it be fairly wide open was simple.

By default, it requires some simple registration (it allows on-instance 
registration with an email address that it doesn't verify). In the long 
run, it could be made to require datatracker credentials with what I 
currently think isn't a _lot_ of work (depending on the current quality 
of the django libraries to facilitate becoming an OAUTH2 provider).

I'd like to see us seriously investigate supporting this soon.

RjS

---

From: "John R. Levine" <[email-masked]>
Date: 6 Mar 2020 17:46:58 -0500

>> I repeat my ceterum censeo that hackmd/CodiMD is a viable candidate, but

> I was able to do a one-click deploy in heroku, and tweaking options to make 
> it be fairly wide open was simple.
>
> registration with an email address that it doesn't verify). In the long run, 
> it could be made to require datatracker credentials with what I currently 
> think isn't a _lot_ of work (depending on the current quality of the django 
> libraries to facilitate becoming an OAUTH2 provider).

HackMD is a commercial product from hackmd.io.  That doesn't make it 
impossible, and the price doesn't look ridiculous, but it does mean that 
it'd needs a a budget from the LLC if we want to use it beyond testing.

Regards,
John Levine, [email-masked], Primary Perpetrator of "The Internet for Dummies",
Please consider the environment before reading this e-mail. https://jl.ly

---

From: Robert Sparks <[email-masked]>
Date: Fri, 6 Mar 2020 16:50:51 -0600

On 3/6/20 4:46 PM, John R. Levine wrote:
>>> but
>> This looks like it would be easy to deploy to me and it passes a 
>> first sniff-test at keeping it going.
>>
>> I was able to do a one-click deploy in heroku, and tweaking options 
>> to make it be fairly wide open was simple.
>>
>> By default, it requires some simple registration (it allows 
>> on-instance registration with an email address that it doesn't 
>> verify). In the long run, it could be made to require datatracker 
>> credentials with what I currently think isn't a _lot_ of work 
>> (depending on the current quality of the django libraries to 
>> facilitate becoming an OAUTH2 provider).
>
> impossible, and the price doesn't look ridiculous, but it does mean 
> that it'd needs a a budget from the LLC if we want to use it beyond 
> testing.

CodiMD is a free and open subset of HackMD, and that's what I've tried 
running. Didn't require budget. I don't think we would need the full 
hackmd for what the kinds of things we've been doing with etherpad.

RjS

---

From: Robert Sparks <[email-masked]>
Date: Fri, 6 Mar 2020 16:55:07 -0600

> hackmd for what the kinds of things we've been doing with etherpad.

For more info see <https://github.com/hackmdio/codimd>, in particular note:

    CodiMD is the free software version of HackMD <https://hackmd.io>,
    developed and opened source by the HackMD team with reduced
    features, so you can use CodiMD for your community and own your
    data. /(See the origin of the name CodiMD
    <https://github.com/hackmdio/hackmd/issues/720>.)/

    CodiMD is perfect for open communities, while HackMD emphasizes on
    permission and access controls for commercial use cases.

> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 7 Mar 2020 11:16:36 +0100

On 2020-03-06, at 23:46, John R. Levine <[email-masked]> wrote:
> 
> HackMD is a commercial product from hackmd.io. 

Right.  I’m sorry for not having expressed myself very accurately here.
Hackmd started out as a web site, and that’s the name most people still refer to the project.
This is also the name the commercial side of the project retained.
The open source side of the project was renamed CodiMD, and that’s what I really meant.

CodiMD is indeed putting some emphasis on being easy to deploy.  (I even have a docker version of CodiMD on my laptop, in case I’m stuck in a meeting with bad outside connectivity…)

For integration of user authentication, CodiMD supports both LDAP and OAuth (both of which are enabled together as alternative login mechanisms on the “hackmd” of my university: LDAP for university account holders, and OAuth for authenticated guests via our gitlab).  CodiMD also provides a guest access scheme on its own.

As with most innovations at a university, our usage started out with the students: they flocked over from their piratepads to hackmd.io.  But, of course, nobody here likes having personal student data on an external system.  Hackmd (now CodiMD) turned out to be such a no-brainer to deploy that our IT people rolled it out before I even had a chance to ask for it.

Grüße, Carsten