Subject: [TOOLS-DEVELOPMENT] Tools Call Agenda -- 11 February 2020 at 1:00 Eastern

From: Russ Housley <[email-masked]>
Date: Tue, 4 Feb 2020 16:01:03 -0500

Tools Call Agenda -- 11 February 2020 at 1:00 Eastern

JOIN WEBEX MEETING
https://ietf.webex.com/ietf/j.php?MTID=m440dd848726339c03e605b9956e38bac
Meeting number (access code): 640 103 570
Meeting password: tools

JOIN BY PHONE
1-877-668-4493 Call-in toll free number (US/Canada) 
1-650-479-3208 Call-in toll number (US/Canada)
Meeting number (access code): 640 103 570
Meeting password: tools

1. Datatracker Projects
   - Expected Datatracker Releases -- Robert and Henrik
     -- https://trac.tools.ietf.org/tools/ietfdb/browser/trunk/PLAN
   - Meeting application improvements by IOLA -- Robert
   - Automated schedule builder by DashCare -- Robert
   - Minor Tools Enhancements by Painless Security -- Robert

2. Community & Other Projects
   - WWW search to provide additional pointers -- Greg
   - Host third-party subresources on mailarchive -- Ryan

3. RFC Services Projects
   - Are tools issues blocking any documents? -- John and Henrik
   - Security Review of RPC Tools -- Robert and Jay

4. Server Infrastructure
   - Deployment of Python3 -- Robert
   - Expected Website Releases -- Robert
   - DMARC support for email aliases -- Henrik and Alexey

5. YANG Catalog
   - Tasks in Priority order:
     -- Posting YANG modules by other SDOs -- Eric and Robert
     -- Putting yangcatalog.org in a Docker container -- Robert
     -- Upgrade the operating system on the server -- Robert

6. Parking Lot
   - Search over www, datatracker, and mailarchive
   - Transition Datatracker to Django2 and then Django3
   - Transition Mailarchive to Django2 and then Django3
   - Transition Wagtail for IETF website to Django2 and then Django3

7. AOB

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Wed, 5 Feb 2020 17:37:42 +0000

Dear all,

I will be abroad on vacations, so, please accept my apologies for not joining

-éric

On 04/02/2020, 22:01, "TOOLS-DEVELOPMENT on behalf of Russ Housley" <[email-masked] on behalf of [email-masked]> wrote:

    JOIN WEBEX MEETING
    
    JOIN BY PHONE

    1. Datatracker Projects

    3. RFC Services Projects
    
    4. Server Infrastructure
    
    5. YANG Catalog
    
    6. Parking Lot
    
    7. AOB
    
    _______________________________________________
    TOOLS-DEVELOPMENT mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/tools-development

---

From: Robert Sparks <[email-masked]>
Date: Mon, 10 Feb 2020 09:35:39 -0600

Agenda bash:

We should talk about the migration to the new server in section 4.

Notes inline for tomorrow's call:

>       -- https://trac.tools.ietf.org/tools/ietfdb/browser/trunk/PLAN
The PLAN was updated to raise the priority order of  capturing when the 
datatracker sends email (to facilitate re-sending messages when needed) 
and transitioning to Django 2.
>     - Meeting application improvements by IOLA -- Robert
On track as of mid-Jan. I'm awaiting a more recent update from IOLA.
>     - Automated schedule builder by DashCare -- Robert
Part one is expected to be complete by the end of Feb.
>     - Minor Tools Enhancements by Painless Security -- Robert
This team has completed 2 of the 3 planned initial datatracker 
enhancements. The plan is to familiarize them with working on as many of 
the tools as possible. The next tool I will ask them to do minor 
enhancements to is the main website.
>     - Security Review of RPC Tools -- Robert and Jay
This RFP has been issued - see 
<https://www.ietf.org/media/documents/IETF_RPC_Tools_Security_Review_RFP_05Feb20.pdf>. 
Bids are due 4Mar.
>     - Expected Website Releases -- Robert

I plan to do either a minor release or a patch to fix an issue with 
previewing pages in the authoring admin early this week.

I should have a major revision ready for review on wwwstaging in a few 
days. This revision removes the broken datatracker integration attempt, 
and simplifies many of the models in preparation for moving the website 
to a current revision of wagtail.

---

From: Bob Hinden <[email-masked]>
Date: Mon, 10 Feb 2020 11:08:26 -0800

Regrets, I can’t make the call.

Bob

> On Feb 10, 2020, at 7:35 AM, Robert Sparks <[email-masked]> wrote:
> 
> Agenda bash:
> 
> The PLAN was updated to raise the priority order of  capturing when the datatracker sends email (to facilitate re-sending messages when needed) and transitioning to Django 2.
> This team has completed 2 of the 3 planned initial datatracker enhancements. The plan is to familiarize them with working on as many of the tools as possible. The next tool I will ask them to do minor enhancements to is the main website.
>> 
> This RFP has been issued - see <https://www.ietf.org/media/documents/IETF_RPC_Tools_Security_Review_RFP_05Feb20.pdf>. Bids are due 4Mar.
>> 
>> 4. Server Infrastructure
> I plan to do either a minor release or a patch to fix an issue with previewing pages in the authoring admin early this week.
> 
> I should have a major revision ready for review on wwwstaging in a few days. This revision removes the broken datatracker integration attempt, and simplifies many of the models in preparation for moving the website to a current revision of wagtail.
>

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Tue, 11 Feb 2020 03:04:06 +0000

As I am abroad on vacations, I won't make the call 

-éric

On 10/02/2020, 12:12, "TOOLS-DEVELOPMENT on behalf of Robert Sparks" <[email-masked] on behalf of [email-masked]> wrote:

    Agenda bash: