Subject: [TOOLS-DEVELOPMENT] Trac - instances and issues

From: Jay Daley <[email-masked]>
Date: Wed, 12 Feb 2020 09:57:39 +1300

Here’s my analysis of the trac situation so far.  Any corrections/additions most welcome.

There are multiple trac ’sites’ (for want of a better word)

1.  https://trac.ietf.org
- This is the trac that the secretariat maintains
- Every new WG automatically gets a trac instance created for it here (343 current instances) but not all concluded WGs have one
- As far as Robert knows, the only thing used here is the wiki pages not the rest of the trac functionality
- This has a tools trac instance which is not used

2.  https://tools.ietf.org and https://trac.tools.ietf.org
- This is the site that is maintained by Henrik
- Some (All?) WGs are listed here (117 current and 515 concluded) with each having a set of status pages and one of the headings of the status page being a pointer to the wiki for 1. above
- The two URLs work interchangeably (which is what confused me about two instances per WG, when in fact there is only one)

3. https://trac.tools.ietf.org/tools/ietfdb/
- Same site as 2. above
- This is the datatracker trac instance
- The wiki and tickets functionality is used
- This connects to a subversion repository with the datatracker source enabling the browse source functionality
- The roadmap functionality is not used, instead the roadmap is kept in a source document https://trac.tools.ietf.org/tools/ietfdb/browser/trunk/PLAN
- Not all of the work items identified on the plan have a ticket associated with them

4. https://trac.tools.ietf.org/tools/xml2rfc/trac/
- Same site as 2. above
- This is the trac instance for xml2rfc
- The tickets functionality is used
- The wiki functionality is not used and instead there are static HTML pages at https://tools.ietf.org/tools/xml2rfc/ (also accessed through https://trac.tools.ietf.org/tools/xml2rfc/)
- This connects to a subversion repository with the xml2rfc source enabling the browse source functionality
- The roadmap functionality is not used and I do not know if a separate plan exists

I’m still thinking this through, but the immediate issues that concern me are

a.  Using the wrong tool for the job - i.e. using trac in places we really just need a wiki tool.

b.  Multiple blind alleys of unused functionality (mainly caused by a. above)

c.  Extremely difficult for a newcomer to find out what is current, what is old and what was never used.

d.  Inconsistencies such that if a newcomer does work something out they can't use that to help them understand the next part

e.  Not getting the most from trac (e.g. use of the roadmap feature)

Thanks to much patient explanation by Russ, Robert and Henrik I understand how we’ve got to where we’ve got and I don’t want this to go over old ground - we are where we are - my concern is how we improve the current situation in the best way possible for everyone.

Just to be clear, I’m not asking for anything to be done now, I’m just sharing my analysis so far for info with a view to starting a conversation about where to take this.

cheers
Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]
+64 21 678840

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 11 Feb 2020 22:47:13 +0100

Hi Jay,

One point, inline below:

> - The two URLs work interchangeably (which is what confused me about two instances per WG, when in fact there is only one)

These are not trac instances at all; they are the old WG pages I built
before the datatracker had any resources for the WGs.  These pages provided
the impetus for starting to build WG pages in the datatracker.

Their functionality has gradually been duplicated (and in many cases now
exceeded) in the datatracker, but there are still people who prefer the
more compact representation provided on the tools.ietf.org pages.

All data here is derived from the datatracker.

> Thanks to much patient explanation by Russ, Robert and Henrik I
> understand how we’ve got to where we’ve got and I don’t want this to
> go over old ground - we are where we are - my concern is how we
> improve the current situation in the best way possible for everyone.
> 
> Just to be clear, I’m not asking for anything to be done now, I’m
> just sharing my analysis so far for info with a view to starting a
> conversation about where to take this.

Understood.

Best,

	Henrik

---

From: Jay Daley <[email-masked]>
Date: Wed, 12 Feb 2020 10:50:33 +1300

> On 12/02/2020, at 10:47 AM, Henrik Levkowetz <[email-masked]> wrote:
> 
> Hi Jay,
> 
> One point, inline below:
> 
> more compact representation provided on the tools.ietf.org <http://tools.ietf.org/> pages.

Thanks Henrik - I understand now.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]
+64 21 678840