Subject: [TOOLS-DEVELOPMENT] Tools Call Agenda -- 14 January 2020 at 1:00 Eastern

From: Russ Housley <[email-masked]>
Date: Fri, 10 Jan 2020 15:05:35 -0500

Tools Call Agenda -- 14 January 2020 at 1:00 Eastern

JOIN WEBEX MEETING
https://ietf.webex.com/ietf/j.php?MTID=m440dd848726339c03e605b9956e38bac
Meeting number (access code): 640 103 570
Meeting password: tools

JOIN BY PHONE
1-877-668-4493 Call-in toll free number (US/Canada) 
1-650-479-3208 Call-in toll number (US/Canada)
Meeting number (access code): 640 103 570
Meeting password: tools

1. Datatracker Projects
   - Expected Datatracker Releases -- Robert and Henrik
     -- https://trac.tools.ietf.org/tools/ietfdb/browser/trunk/PLAN
   - Meeting application improvements by IOLA -- Robert
   - Automated schedule builder by DashCare -- Robert
   - Minor Tools Enhancements by Painless Security -- Robert

2. Community & Other Projects
   - WWW search to provide additional pointers -- Greg
   - Host third-party subresources on mailarchive -- Ryan

3. RFC Services Projects
   - RPC use of new RFC format tools -- Heather and Henrik
   - Security Review of RPC Tools
     -- RFP to be released later this month -- Robert and Jay

4. Server Infrastructure
   - Deployment of Python3 -- Robert
   - Expected Website Releases -- Robert
   - IESG discussions of DMARC -- Henrik and Alexey
     -- When do we expect the next release of OpenARC? Ever?

5. YANG Catalog
   - Upgrade the operating system on the server -- Robert
   - Putting yangcatalog.org in a Docker container -- Robert

6. Parking Lot
   - Search over www, datatracker, and mailarchive
   - Transition Datatracker to Django2 and then Django3
   - Transition Mailarchive to Django2 and then Django3
   - Transition Wagtail for IETF website to Django2 and then Django3

7. AOB

---

From: Robert Sparks <[email-masked]>
Date: Mon, 13 Jan 2020 09:19:04 -0600

My notes for the call.

>       -- https://trac.tools.ietf.org/tools/ietfdb/browser/trunk/PLAN

Please note the Dec/Jan releases at https://datatracker.ietf.org/release/

Focus continues to be getting ready for the python 3 deployment.

>     - Meeting application improvements by IOLA -- Robert
The model changes are already merged. Work on functionality and UI is 
underway.
>     - Automated schedule builder by DashCare -- Robert
Creating a catalog of needed constraint types is complete (but awaiting 
writeup). I am working out a schedule for implementation with DashCare.
>     - Minor Tools Enhancements by Painless Security -- Robert
We had a kickoff meeting yesterday, aiming Painless Security at a few 
minor datatracker and website projects. They will be going through the 
process of setting up development environments in the next couple of weeks.
>     - WWW search to provide additional pointers -- Greg
No change since last call. These are deployed on datatracker. They are 
implemented on the webserver and will deploy with the next release 
(along with analytics). It is still in the queue for implementation on 
the mailarchive, but that should happen around now.
>     - RPC use of new RFC format tools -- Heather and Henrik
While there's still activity here, I don't think any of it is likely to 
surprise anyone going forward. I think we can safely take this out as a 
top-level agenda item, unless the RPC thinks otherwise.
>     - Deployment of Python3 -- Robert
Glen has been very busy ensuring we have a stable server upgrade. We 
currently expect that to happen late this month (assuming things pass 
Glen's stablilty checks). We plan to move the the services we currently 
have deployed on python2 to python3 at that time (except, as noted in 
the PLAN, for Trac, which will remain on Python2.7 in a container).
>     - Expected Website Releases -- Robert
I'm awaiting word from Jay and/or the IESG before deploying the next 
release.
>     - Putting yangcatalog.org in a Docker container -- Robert
Pantheon has started up again under the 2020 contract, but their focus 
has been on supporting YangCatalog users so far this year.
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Jay Daley <[email-masked]>
Date: Tue, 14 Jan 2020 09:09:24 +1300

Robert

> On 14/01/2020, at 4:19 AM, Robert Sparks <[email-masked]> wrote:
> 
> My notes for the call.
> 
>> 
> No change since last call. These are deployed on datatracker. They are implemented on the webserver and will deploy with the next release (along with analytics). It is still in the queue for implementation on the mailarchive, but that should happen around now.

The Privacy Statement has now been updated to cover the deployment of analytics.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]
+64 21 678840