Subject: [TOOLS-DEVELOPMENT] Tools Call Agenda -- 12 November 2019 at 1:00 Eastern

From: Russ Housley <[email-masked]>
Date: Thu, 7 Nov 2019 22:22:10 -0500

Tools Call Agenda -- 12 November 2019 at 1:00 Eastern

JOIN WEBEX MEETING
https://ietf.webex.com/ietf/j.php?MTID=m440dd848726339c03e605b9956e38bac
Meeting number (access code): 640 103 570
Meeting password: tools

JOIN BY PHONE
1-877-668-4493 Call-in toll free number (US/Canada) 
1-650-479-3208 Call-in toll number (US/Canada)
Meeting number (access code): 640 103 570
Meeting password: tools

1. Datatracker Projects
   - Expected Datatracker Releases -- Robert and Henrik
     -- https://trac.tools.ietf.org/tools/ietfdb/browser/trunk/PLAN
   - Meeting Application Improvements by IOLA -- Robert
   - Datatracker maintenance by DashCare -- Robert
   - IRSG balloting by AKAYLA -- Robert
   - Deployment of Python3 datatracker -- Robert
     -- Impacts on related applications

2. Community & Other Projects
   - WWW search to provide additional pointers -- Greg
     -- Give pointers to datatracker and mailarchive
   - Host third-party subresources on mailarchive -- Ryan

3. RFC Services Projects
   - RPC use of new RFC format tools -- Heather and Henrik
   - Deploying in-line errata on rfc-editor.org? -- Alice
   - Security Review of RPC Tools -- Robert and Heather

4. Server Infrastructure
   - Expected Website Releases -- Robert
   - IESG discussions of DMARC -- Henrik and Alexey
     -- When do we expect the next release of OpenARC? Ever?

5. YANG Catalog
   - Putting yangcatalog.org in a Docker container -- Robert

6. Parking Lot
   - Search over www, datatracker, and mailarchive
   - Transition Datatracker to Django2
   - Transition Website to Django2

7. AOB

---

From: Robert Sparks <[email-masked]>
Date: Fri, 8 Nov 2019 09:55:17 -0600

My notes for the tools call:

>       -- https://trac.tools.ietf.org/tools/ietfdb/browser/trunk/PLAN
The PLAN has been stable for a few weeks. We've issued 7nreleases since 
the last call, which is a higher rate than usual. These reflect feature 
requests, the review tool maintenance work, and bugfixes coming in.
>     - Meeting Application Improvements by IOLA -- Robert
Still not started, and communication has stopped. This has been 
escalated to Jay and Portia.
>     - Datatracker maintenance by DashCare -- Robert
This project continues to progress excellently.
>     - IRSG balloting by AKAYLA -- Robert
I have started an acceptance review for this project. I expect to 
complete it before the Singapore meeting starts.
>     - Deployment of Python3 datatracker -- Robert

Currently gated two things:

1) We need to wrap Trac in a container that can run Python 2.7, since 
Trac won't become Python 3 ready until next year. This is the second 
item on the PLAN.

2) We want to coordinate this move with the upgrade the OS of the 
underlying machines. We will be meeting later to work out a plan.

>     - Security Review of RPC Tools -- Robert and Heather
We had no acceptable bids to the RFP.
>     - Expected Website Releases -- Robert

We have a matomo instrumented version of the website under test.

I don't expect major releases until well after the Singapore meeting.

The next major release will involve removing much of the unused 
datatracker integration.

>     - Putting yangcatalog.org in a Docker container -- Robert

I have a containerized instance of yangcatalog that starts (even if the 
start is very rough).

It is not yet clear if it actually all _works_.

Determining that will require some manual inspection / sanity testing, 
and I will need help from the yangcatalog enthusiasts (particularly Eric 
and Benoit), and Pantheon to complete that.

> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Ryan Cross <[email-masked]>
Date: Mon, 11 Nov 2019 23:33:09 -0800

Regrets, I will not be able to attend the call tomorrow. One note inline.

> On Nov 7, 2019, at 7:22 PM, Russ Housley <[email-masked]> wrote:
> 
These changes are made in the Python 3 branch.

---

From: Alissa Cooper <[email-masked]>
Date: Tue, 12 Nov 2019 11:01:59 -0500

Hi Robert,

> On Nov 8, 2019, at 10:55 AM, Robert Sparks <[email-masked]> wrote:
> 
> The PLAN has been stable for a few weeks. We've issued 7nreleases since the last call, which is a higher rate than usual. These reflect feature requests, the review tool maintenance work, and bugfixes coming in.
> Still not started, and communication has stopped. This has been escalated to Jay and Portia.
> I have started an acceptance review for this project. I expect to complete it before the Singapore meeting starts.
> 1) We need to wrap Trac in a container that can run Python 2.7, since Trac won't become Python 3 ready until next year. This is the second item on the PLAN.
> 
> 2) We want to coordinate this move with the upgrade the OS of the underlying machines. We will be meeting later to work out a plan.
> 

Do you have an approximate timing in mind? For planning purposes with Greg, I’m wondering when the analytics will go live.

Thanks,
Alissa

> 
> The next major release will involve removing much of the unused datatracker integration.
> 
> I have a containerized instance of yangcatalog that starts (even if the start is very rough).
> 
> Determining that will require some manual inspection / sanity testing, and I will need help from the yangcatalog enthusiasts (particularly Eric and Benoit), and Pantheon to complete that.
> 
>> 
>> 6. Parking Lot

---

From: Robert Sparks <[email-masked]>
Date: Tue, 12 Nov 2019 10:09:43 -0600

On 11/12/19 10:01 AM, Alissa Cooper wrote:
>> (trimming)

I don't have an approximate time for taking analytics live in mind, but 
I don't think I'm the long-pole in figuring that out.

On my end, I need to work out a deployment detail (I've been waiting for 
the matomo maintainers to build a new docker image, and they did so last 
week), but I need to know if the prototype site needs to stay up for the 
policy review before I start poking at it. If so, when do you expect 
that to take place?