Subject: [TOOLS-DEVELOPMENT] Tools Call Agenda -- 10 September 2019 at 1:00 Eastern

From: Russ Housley <[email-masked]>
Date: Mon, 9 Sep 2019 10:41:35 -0400

Tools Call Agenda -- 10 September 2019 at 1:00 Eastern

JOIN WEBEX MEETING
https://ietf.webex.com/ietf/j.php?MTID=m440dd848726339c03e605b9956e38bac
Meeting number (access code): 640 103 570
Meeting password: tools

JOIN BY PHONE
1-877-668-4493 Call-in toll free number (US/Canada) 
1-650-479-3208 Call-in toll number (US/Canada)
Meeting number (access code): 640 103 570
Meeting password: tools

1. Datatracker Projects
   - Expected Datatracker Releases -- Robert and Henrik
     -- https://trac.tools.ietf.org/tools/ietfdb/browser/trunk/PLAN
   - Python2 to Python3 transition -- Henrik
   - Meeting Application Improvements by IOLA -- Robert
   - Datatracker maintenance by DashCare -- Robert
   - IRSG balloting -- Robert

2. Community & Other Projects
   - WWW search to provide additional pointers -- Greg
     -- Give pointers to datatracker and mailarchive

3. RFC Services Projects
   - RPC testing of new RFC format tools -- Heather and Robert
   - Security Review of RPC Tools -- Robert and Heather
   - Rendering errata in more useful way -- Robert
     -- How will it be deployed on rfc-editor.org?

4. Server Infrastructure
   - IESG discussions of DMARC -- Henrik and Alexey
     -- When do we expect the next release of OpenARC? Ever?

5. YANG Catalog
   - Putting yangcatalog.org in a Docker container -- Robert
   - Adding features from the yangvalidator project -- Eric

6. SustainIETF.org
   - It redirects to ietf.org

7. Parking Lot
   - Search over www, datatracker, and mailarchive

8. AOB

---

From: Robert Sparks <[email-masked]>
Date: Mon, 9 Sep 2019 10:33:41 -0500

My notes for the call.

>       -- https://trac.tools.ietf.org/tools/ietfdb/browser/trunk/PLAN
Please note 6.101.0 at https://datatracker.ietf.org/release
>     - Meeting Application Improvements by IOLA -- Robert
We met with IOLA on Aug 21. They indicated that they were still 
backlogged and intended to start late Sep/ early Oct. I have a query out 
to IOLA for an update.
>     - Datatracker maintenance by DashCare -- Robert
We had a kick-off call for the review tool improvement project with 
DashCare on Aug 19. The developer is off to a quick start with many 
improvements already committed, showing a quickly obtained and very 
solid understanding of the datatracker overall.
>     - IRSG balloting -- Robert
Akayla had a slow start on the IRSG balloting project, but is now making 
regular progress. We expect the project to be substantially complete 
before IETF106 in November.
>       -- Give pointers to datatracker and mailarchive

The www project got a lot of attention from me this month, with a 
release (v0.9.7) that moved the IESG statement to live under the IESG 
pages instead of with the blog pages.

The site also had some significant performance issues that took time to 
diagnose and address. While diagnosing, we identified several major 
changes that need to be made to the way the website currently serves 
blog pages. These are being tracked at 
https://github.com/ietf-tools/wagtail_website/issues (in particular 
issues 10 and 11) and will be addressed in upcoming releases. Greg will 
be entering several other requests (including analytics integration) as 
issues soon.

>     - RPC testing of new RFC format tools -- Heather and Robert

This has mostly been going well. The questions and change requests are 
showing convergence, and I think we're ready to go.

That said, there was a memory-exhaustion issue noted last night with 
rfc-xmldiff. Glen and SoaringHawk are discussing it. I expect it will be 
addressed quickly.

>     - Security Review of RPC Tools -- Robert and Heather
On hold until after the swtichover.
>       -- How will it be deployed on rfc-editor.org?

This is deployed at https://www.rfc-editor.org/rfc/beta/errata.

We will be working at adding links from the datatracker to it (when 
appropriate) in the next few weeks.

>     - Putting yangcatalog.org in a Docker container -- Robert

This, and the rest of Yangcatalog development is proceeding, and quickly 
given the LOE (1.5 day/week) we have from the current contractor.

The architecture of the containerized yangcatalog project improved 
significantly this month, addressing several places where we were 
exposing network interfaces that we didn't need to.

We're trying using a github project to visualize progress on the 
yangcatalog project. It's available at 
https://github.com/orgs/YangCatalog/projects/1. For work on 
containerization only, filter the results to 
https://github.com/orgs/YangCatalog/projects/1?card_filter_query=repo%3Ayangcatalog%2Fdeployment

>     - Search over www, datatracker, and mailarchive
The automatic agenda builder SoW should go out for bids.
>
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Russ Housley <[email-masked]>
Date: Mon, 9 Sep 2019 12:26:46 -0400

Robert:

> The www project got a lot of attention from me this month, with a release (v0.9.7) that moved the IESG statement to live under the IESG pages instead of with the blog pages.
> 
> The site also had some significant performance issues that took time to diagnose and address. While diagnosing, we identified several major changes that need to be made to the way the website currently serves blog pages. These are being tracked at https://github.com/ietf-tools/wagtail_website/issues (in particular issues 10 and 11) and will be addressed in upcoming releases. Greg will be entering several other requests (including analytics integration) as issues soon.

Re: Issue #11

I assume there are two sides to this.  First, the Wagtail side needs to stop making the queries, and second, the now extraneous APIs can be removed from the datatracker.  Is that right?

Russ

---

From: Russ Housley <[email-masked]>
Date: Mon, 9 Sep 2019 12:28:54 -0400

> On Sep 9, 2019, at 11:33 AM, Robert Sparks <[email-masked]> wrote:
> 
>> 3. RFC Services Projects
> This has mostly been going well. The questions and change requests are showing convergence, and I think we're ready to go.
> 
> That said, there was a memory-exhaustion issue noted last night with rfc-xmldiff. Glen and SoaringHawk are discussing it. I expect it will be addressed quickly.
> 

Yes, I am aware.  I wonder if we should put the RFP out soon, so that we have a contractor selected to do the work before the end of the year.

Russ

---

From: Robert Sparks <[email-masked]>
Date: Mon, 9 Sep 2019 11:31:48 -0500

> I assume there are two sides to this.  First, the Wagtail side needs to stop making the queries, and second, the now extraneous APIs can be removed from the datatracker.  Is that right?

Those are different things - the second is tracked in #12.

The first thing is more like what you were addressing at the last 
codesprint - the view needs to do better work so the template doesn't 
hit the database so many times.

The only overlap between the two is that some of the queries the 
template is currently making will change (since they'll be going after 
something other than the locally-cached datatracker information).

---

From: Robert Sparks <[email-masked]>
Date: Mon, 9 Sep 2019 11:34:53 -0500

On 9/9/19 11:28 AM, Russ Housley wrote:
>
>
>> On Sep 9, 2019, at 11:33 AM, Robert Sparks <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>
>>> 3. RFC Services Projects
>> This has mostly been going well. The questions and change requests 
>> are showing convergence, and I think we're ready to go.
>>
>> rfc-xmldiff. Glen and SoaringHawk are discussing it. I expect it will 
>> be addressed quickly.
>>
> Yes, I am aware.  I wonder if we should put the RFP out soon, so that 
> we have a contractor selected to do the work before the end of the year.
The concern earlier was that questions related to the RFP would distract 
the RPC during the changeover. But since that changeover is expected 
next week, perhaps we can get this issued immediately after?

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Tue, 10 Sep 2019 11:50:16 +0000

Dear all,

Please that I will be in a train during the first half of the call then I will be changing platforms & co. So, if possible, then can we move the YangCatalog.Org topic earlier in the agenda ?

We have also now another Pantheon contractor (Stanislav Chlebec in the same SoW) working on unit testing to increase the stability of the code.

Also, not a lot of things have changed wrt yang validator.

-éric

On 09/09/2019, 16:41, "TOOLS-DEVELOPMENT on behalf of Russ Housley" <[email-masked] on behalf of [email-masked]> wrote:

    JOIN WEBEX MEETING
    
    JOIN BY PHONE

    1. Datatracker Projects

    3. RFC Services Projects
    
    4. Server Infrastructure
    
    5. YANG Catalog
    
    6. SustainIETF.org
    
    7. Parking Lot
    
    8. AOB

---

From: Greg Wood <[email-masked]>
Date: Tue, 10 Sep 2019 14:13:13 +0000

>>      -- Give pointers to datatracker and mailarchive

Robert and Russ and I discussed an approach. This Google Doc provides additional details:

https://docs.google.com/document/d/1jE0GnaIsfasTggr3DymJkbDzFKU1VLxTj36PO-uGhq4/edit?usp=sharing

> The site also had some significant performance issues that took time to diagnose and address. While diagnosing, we identified several major changes that need to be made to the way the website curre…

I’ve added several items. Once the analytics proposal has finished up community review, I’ll add that, too.

Let me know if more info would be helpful.

-Greg

---

From: Portia Wenze-Danley <[email-masked]>
Date: Tue, 10 Sep 2019 12:17:45 -0400

Hi Russ,

I’ve had a slight schedule change and must join another meeting at 1:30 today.

Thanks.
________________________________
Portia Wenze-Danley
IETF Administration LLC Executive Director (Interim)
(Formerly IETF Administrative Director (IAD)	
Internet Engineering Task Force (IETF)
[email-masked]

> On Sep 9, 2019, at 10:41 AM, Russ Housley <[email-masked]> wrote:
>

---

From: Liz Flynn <[email-masked]>
Date: Wed, 11 Sep 2019 14:45:32 -0700

Hi everyone,

Below are my notes from yesterday’s tools call. 

Liz Flynn
Project Manager / IETF
[email-masked]

=============

Tools Call Notes -- 10 September 2019 at 1:00 Eastern

1. Datatracker Projects
  - Expected Datatracker Releases -- Robert and Henrik
    -- https://trac.tools.ietf.org/tools/ietfdb/browser/trunk/PLAN
  - Python2 to Python3 transition – Henrik

Henrik: The next step will be taken when we have transitioned to the next version OS on the servers and when we have everything containerized or running under Python 3. The main waiting point is Trac, which we still don’t know if it will be released under 3 in time for us. Most likely the next work item is to containerize Trac. 

  - Meeting Application Improvements by IOLA – Robert

Robert: IOLA is still planning to complete the project by the date they had bid but they have been short on time.

  - Datatracker maintenance by DashCare – Robert

The developer is in a good place and they expect to have the project completed on time.

Akayla has been working on this and had a slow start. We’ve turned the bend and started with a reasonable pace of progress. We’ve updated the delivery time to be right around the time of IETF 106. 

Russ: Last time we talked about doing search over WWW, the datatracker, and the mail archive. That has been moved to the parking lot. Now, when you do a search on WWW you’ll get pointers to additional information in the datatracker and mail archive. This was fairly quick and the other thing is a tougher project. It will be implemented very shortly if it hasn’t been already. 

Robert: It will be in the next release or two of the website. 

3. RFC Services Projects

Heather: There is only one outstanding piece to test, re the metadata when a document has been obsoleted. Next week we’ll be ready to publish in v3. XML to RFC output is so close that we’re still on target for next week. 

Russ: Idea is that starting with documents approved by a stream next week, those will be v3 through the whole process? The ones already approved will be v2?

Alice: Documentss that are in auth48 will go into an auth48 round 2 and move to v3.  There are less than a handful of docs that will be published in v2. 
https://mailarchive.ietf.org/arch/msg/rfc-interest/yEsDj8BR6AwtLi6UduKOPVc9SIo) points to transition details (https://www.rfc-editor.org/rse/wiki/doku.php?id=v3implementation)

Robert: The directory structure in the details of the SOW needs to be updated. I will talk with Priyanka and re-circulate the SOW.

The beta of rfc-editor.org now includes errata. They can be linked from the Datatracker soon. Heather will talk to Alice and Sandy about the format of the errata and the URL; if “beta” should stay in the URL, which will require redirects later, or if the URL should be changed now. The errata pages can always be regenerated if people have a lot of suggestions for feature requests.

4. Server Infrastructure

Henrik: We will probably see OpenARC but maybe not soon. During the last IETF the code we need was written. It’s maybe being tested and it’s maybe been committed, but there’s no release. I will poke them again.

5. YANG Catalog
  - Putting yangcatalog.org in a Docker container – Robert

The main developer does not have more time available for us but is making progress. See https://github.com/orgs/YangCatalog/projects/1 for progress. Containerization is in the middle of the list of priorities.

  - Adding features from the yangvalidator project – Eric

Eric: We have someone committed for .5 day a week to build unit tests. Work is underway.
I’ve done nothing regarding yang validator yet. 

6. SustainIETF.org

Right now this is just being redirected to ietf.org. It’s up to the LLC to decide if they want to do something else with it. This will be taken off the agenda for future calls unless there is something new to do with it. 

7. Parking Lot

8. AOB

> On Sep 10, 2019, at 7:13 AM, Greg Wood <[email-masked]> wrote:
>