Subject: Re: [TOOLS-DEVELOPMENT] Tools Call Agenda -- 9 July 2019 at 1:00 Eastern

From: Robert Sparks <[email-masked]>
Date: Fri, 5 Jul 2019 15:03:06 -0500

Notes for Tuesday's call:

On 6/29/19 10:14 AM, Russ Housley wrote:
> Tools Call Agenda -- 9 July 2019 at 1:00 Eastern
>
>
> JOIN WEBEX MEETING
> https://ietf.webex.com/ietf/j.php?MTID=m440dd848726339c03e605b9956e38bac
> Meeting number (access code): 640 103 570
> Meeting password: tools
>
> JOIN BY PHONE
> 1-877-668-4493 Call-in toll free number (US/Canada)
> 1-650-479-3208 Call-in toll number (US/Canada)
> Meeting number (access code): 640 103 570
> Meeting password: tools
>
>
> 1. Datatracker Projects
>     - Expected Datatracker Releases -- Robert and Henrik
>       -- https://trac.tools.ietf.org/tools/ietfdb/browser/trunk/PLAN

The datatracker focus is on the python3 transition, with a usual amount 
of bugfix/small feature request releases.

Notably, we've been improving the support in the meeting app for groups 
of type 'adhoc' (such as hotrfc), improving the IPR app.

Ryan and I will be working to add more information to the meeting 
attendance import into the datatracker to make the datatracker's idea of 
nomcom eligibility more accurate.

>     - Python2 to Python3 transition -- Henrik
>     - Meeting Application Improvements by IOLA -- Robert
No change. IOLA's expected start is in August.
>     - IRSG balloting -- Robert
AKAYLA has started work.
>
> 2. Community & Other Projects
>     - Search across the IETF web presence -- Greg
>       -- Search over www, datatracker, and mailarchive
>
> 3. RFC Services Projects
>     - RPC testing of new RFC format tools -- Heather and Robert
>     - Security Review of RPC Tools -- Robert and Heather
>     - Rendering errata in more useful way -- Robert
>       -- Code was updated after some testing
>       -- How will it be deployed on rfc-editor.org?
There's nothing new to report here. The code is ready to use - the 
question about how it will be deployed on rfc-editor.org is (as I 
understand it) deferred until after the v3 transition. Perhaps this 
should move to the parking lot?
>
> 4. Server Infrastructure
>     - IESG discussions of DMARC -- Henrik and Alexey
>       -- When do we expect the next release of OpenARC? Ever?
>
> 5. YANG Catalog
>     - Putting yangcatalog.org in a Docker container -- Robert
I'm working with Pantheon to do a prototype install of yangcatalog,org 
in one of my development environments (preferably my laptop) to refine 
the process before we ask Glen to go through it. We've already 
identified several places that need adjustment and will be addressing 
them in the coming weeks.
>     - Adding features from the yangvalidator project -- Eric
>
> 6. SustainIETF.org
>     - Transfer domain name to the IETF Trust -- Glen
>     - Web page still points to [email-masked] -- Greg
>
> 7. Parking Lot
>     - Discontinue pipermail email archives -- Robert and Ryan
>       -- MHonArc URLs have be redirected to mail-archive
>
> 8. AOB
>
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Tue, 9 Jul 2019 13:53:13 +0000

I am unsure whether I can join as I will be in the high speed train back from Paris to Belgium...

The YangValidator.Org is a simple check of the syntax of YANG modules using different compilers, the submitted YANG modules are not kept and are discarded. Very similar to what is done in data tracker.

Technical work items:
- transfer the 2 DNS zones yangvalidator.[org|com]
- ensure Python 3 is used
- ensure that docker works fine
- ensure that the Django/NGINX vhost works fine (as 3 FQDN are hosted on the same IP address)

-éric

On 29/06/2019, 17:15, "TOOLS-DEVELOPMENT on behalf of Russ Housley" <[email-masked] on behalf of [email-masked]> wrote:

    JOIN WEBEX MEETING
    
    JOIN BY PHONE

    1. Datatracker Projects

    3. RFC Services Projects
    
    4. Server Infrastructure
    
    5. YANG Catalog
    
    6. SustainIETF.org
    
    7. Parking Lot
    
    8. AOB

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 9 Jul 2019 18:50:30 +0200

More on the Python3 work inline:

> of bugfix/small feature request releases.

The conversion to python3 is nearing completion, with 94 individual
commits encompassing 3124 changed lines.  The test suite tests clean,
and the first run of the test-crawler revealed only one needed code
change.

Planning of deployment comes next; this will need to consider how to
handle the mailarchive, Trac wikis, and the IAOC website, which currently
are deployed with Apache mod_wsgi and will have to be containerized or
aligned with the Python3 version used for the datatracker.

Some hurdles remain:  Trac is not available in a Python 3 version yet,
which means that the wiki access maintenance command, which updates
wiki permissions according to WG and RG chair changes, still need to
run under Python2.7.  This can be handled with parallel py27 and py37
deployment, but raises the question of whether to run the last Python2
release for wiki maintenance going forward, or put additional work into
the Python3 conversion in order to make it run under both Python 2 and 3.

	Henrik

---

From: Liz Flynn <[email-masked]>
Date: Tue, 9 Jul 2019 15:41:06 -0700

Hi everyone,

Below are my notes from this morning’s tools call, in addition to all of your helpful notes. Thanks everyone!

Liz Flynn
Project Manager / IETF
[email-masked]

========================

Tools Call Notes -- 9 July 2019

1. Datatracker Projects

Henrik: You can see my mail for details; we are close to completion on Python3. It's going fairly smoothly. 

Robert: The big thing in Henrik's note is we're going to have to take a look at whether we containerize the Datatracker at this point, or if we run Python3 and containerize the Python2 things. Henrik and I will be working through that. 

These won't begin until August.

This work is underway.

Russ: Robert, what would it take to do a search across IETF web presence (datatracker and mail archive)?

Robert: I believe that research was in Greg's hands, not mine. 

Alissa: I talked to Greg a bit about this last week and I think he's trying to determine what should drive the requirements. He's working on it but I don't think there's anything to report back yet. 

3. RFC Services Projects

Russ: All new format tools have been in testing for a while. 

Alice: We're in full team testing mode and we've been sending Henrik a lot of questions and updating procedures. We have potential style guide updates, FAQ updates, etc. We are elbow-deep. 

Robert: Does it all feel like it's moving towards a reasonable conclusion?

Alice: I don't think there are any blockers. I would like to get instructions for people who use text editors where that use specific instructions about vocabulary. We could put it in the FAQ or somewhere with basic information about the install of xmlv3.

Action--Alice will share one they've already figured out on rfc-interest and see if people have figured out how to do it on others.

Robert: I'm still in conversation with Heather about when getting the SOW out wouldn't impact the RPC. She's concerned that people bidding will interfere with the RPC during the hard part of the transition. She's pushing to have us wait to issue that RFP until after August. 

Robert: Heather owns that deployment decision and I suspect it falls into the after-transition bucket. 

4. Server Infrastructure

Russ: Last time we were here, Alexey was going to poke the developers. 

Henrik: They said they don't have any resources to do this now. New since last time. I haven't seen any grumbles with the current solution, even though it is not optimal. I think we're at the point now where it's really a matter of 'does that working group want their stuff tested?' Rather than 'do we need to get it changed?' It would be a good idea to see if we can gather two or three of the WG people in Montreal and ask them that question face to face. 

Action--Henrik will start a thread to arrange something in Montreal, adding Russ.

5. YANG Catalog

Robert: There is a mostly containerized version running on a test instance. There are some small issues but he's making progress; I still want to go through the exercise of deploying it myself somewhere. We are on track to have it done by the end of the year when that contract ends.

Glen: We can transfer those domains along with the others. I just need whoever the current owner is to unlock them and send me the codes. As soon as I get those I can complete the transfer without issue. 

Glen: We have the primary cloud server running, a backup instance, and a remote master backup system. We've got several backups going now. 

Alissa: The Trust needs to agree to receive the domain. 

Russ: Who carried that message when we did this for Yang catalog? Portia did. 

Action--Portia will do the same for yangvalidator.org.

6. SustainIETF.org

Russ: We were in the middle of transfer to the Trust and waiting on the transfer code. Are we still waiting?

Glen: Yes. Gregg Lechner has not responded to three emails. I've asked Greg Wood to follow up as well. First email was on June 5.

7. Parking Lot

8. AOB

Robert: We've got two SOWs that are close to ready to do something with, modulo Alissa's request for adjusted introductions. Was that forward looking or do you want us to change these?

Alissa: I'd love to see it starting with these, and then we can use similar text for all of them. If there's urgency and that would get in the way, it's not a must-have.

Robert: We're planning on just asking the IDIQ vendors to give us bids for at least one of them. If we get bids from them we'll be good to go. If we have to send it out to general RFP we can build better introductions. 

The review tool RFP can go out now. 

==================================

> On Jul 9, 2019, at 9:50 AM, Henrik Levkowetz <[email-masked]> wrote:
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/tools-development <https://www.ietf.org/mailman/listinfo/tools-development>

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Wed, 10 Jul 2019 06:59:41 +0000

Liz

Thank you for the notes but about the YangCatalog agenda item, Glen’s reply about “domains” was rather on the YangValidator topic.

Unsure how my audio was when I spoke (Thalys high speed train is really slow when going into the ‘physical’ tunnel under Brussels city and WiFi is not perfect) but would you mind adding:

  *   My thanks to Glen for the back-up of YANG Catalog
  *   My approval of Robert’s comments on yangcatalog progress
  *   YangValidator feedback: at least 50% done

Best regards

-éric

PS: I smiled when reading your intro “my notes from this morning’s tools call” as for Henrik & I it was more dinner time ;-)
PS2: assuming that Henrik was not enjoying breakfast in the Caribbean Islands ;-)

From: TOOLS-DEVELOPMENT <[email-masked]> on behalf of Liz Flynn <[email-masked]>
Date: Wednesday, 10 July 2019 at 00:41
To: IETF Tools Development <[email-masked]>
Subject: Re: [TOOLS-DEVELOPMENT] Tools Call Agenda -- 9 July 2019 at 1:00 Eastern

5. YANG Catalog
  - Putting yangcatalog.org<http://yangcatalog.org> in a Docker container -- Robert

Action--Portia will do the same for yangvalidator.org<http://yangvalidator.org>.

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 10 Jul 2019 09:11:19 +0200

> PS2: assuming that Henrik was not enjoying breakfast in the Caribbean Islands ;-)

No such luck; Stockholm (which at this time of year can be quite pleasant,
but still has a very different flavour than the Caribbean :-)

	Henrik