Subject: [TOOLS-DEVELOPMENT] Transition of sustainietf.org to IETF control

From: Russ Housley <[email-masked]>
Date: Wed, 5 Jun 2019 15:57:30 -0400

Dear Tools Team:

The IETF LLC is working on transferring control of the IETF Endowment bank accounts from ISOC to the IETF, a process which should be completed on June 28. As a result, the related website and domain (sustainietf.org) need to be transferred to IETF.

I have asked Glen to work with ISOC to get the domain name transferred to the IETF Trust.

The web site is a WordPress-driven site. I am unaware of any any associated source control.

In addition, the site points people to [email-masked], so we will need to create a new mailbox for that.  I do not yet understand who will read the mail sent there, so I do not have a suggest way forward yet.

Is this a candidate for a new container?

Russ

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 5 Jun 2019 22:21:44 +0200

Hi Russ,

> Is this a candidate for a new container?

Given the history of security issues with wordpress sites, I think isolating
this in a container is an excellent idea.

	Henrik

---

From: Robert Sparks <[email-masked]>
Date: Wed, 5 Jun 2019 15:22:13 -0500

Yes, if we take this, I strongly suggest putting it in a container, with 
its database also containerized. If it is just wordpress (that is, 
nobody's done anything special), all we'd really need is a copy of the 
database (IIRC, wordpress keeps its static content (like photos) in that 
database).

I think whoever is supposed to manage the content (see e.g. the "Donor 
Wall" at the bottom of the page) should get some training from whoever's 
been doing that at ISOC so far.

You're thinking ISOC would forward [email-masked] to whatever 
@ietf.org address we created? It seems to me that this will have to land 
on a person who can manage taking a donation. Until the LLC appoints 
someone else, I think that has to be the executive director, no?

RjS

On 6/5/19 2:57 PM, Russ Housley wrote:
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Russ Housley <[email-masked]>
Date: Wed, 5 Jun 2019 16:40:20 -0400

Greg Wood suggested that the site could be could be restructured to remove the email address altogether.  However, we need to have [email-masked] forwarded to some IETF email address, and of course, someone needs to be responsible or reading the traffic that comes there.

Russ

> On Jun 5, 2019, at 4:22 PM, Robert Sparks <[email-masked]> wrote:
> 
> Yes, if we take this, I strongly suggest putting it in a container, with its database also containerized. If it is just wordpress (that is, nobody's done anything special), all we'd really need is a copy of the database (IIRC, wordpress keeps its static content (like photos) in that database).
> 
> I think whoever is supposed to manage the content (see e.g. the "Donor Wall" at the bottom of the page) should get some training from whoever's been doing that at ISOC so far.
> 
> You're thinking ISOC would forward [email-masked] to whatever @ietf.org address we created? It seems to me that this will have to land on a person who can manage taking a donation. Until the LLC appoints someone else, I think that has to be the executive director, no?
> 
> RjS
> 
>

---

From: Alissa Cooper <[email-masked]>
Date: Thu, 6 Jun 2019 08:49:29 +0200

There is discussion in the LLC Board about taking the site down altogether, so I would suggest that folks hold off on making plans for it for a bit.

Alissa

> On Jun 5, 2019, at 10:40 PM, Russ Housley <[email-masked]> wrote:
>

---

From: Alissa Cooper <[email-masked]>
Date: Thu, 6 Jun 2019 09:08:41 +0200

To clarify: planning for the domain transfer at this point seems fine since that is a certainty, but the future of the site content is unclear.

Alissa

> On Jun 6, 2019, at 8:49 AM, Alissa Cooper <[email-masked]> wrote:
>

---

From: Portia Wenze-Danley <[email-masked]>
Date: Thu, 6 Jun 2019 10:25:23 -0400

Additionally once the LLC finalizes details of the future site, the ED will most likely be the person to receive endowment email.

Thanks.
________________________________
Portia Wenze-Danley
IETF Administration LLC Executive Director (Interim)
(Formerly IETF Administrative Director (IAD)	
Internet Engineering Task Force (IETF)
[email-masked]

> On Jun 6, 2019, at 3:08 AM, Alissa Cooper <[email-masked]> wrote:
>