Subject: Re: [TOOLS-DEVELOPMENT] Getting a list of recently adopted document

From: Roman Danyliw <[email-masked]>
Date: Thu, 2 May 2019 18:14:18 +0000

Hi Rob!

Sorry for the long delay.  I missed you response.

You have it right.  The interest would be for the IETF WG stream only.

Roman

> -----Original Message-----
> From: TOOLS-DEVELOPMENT [mailto:[email-masked]]
> On Behalf Of Robert Sparks
> Sent: Thursday, April 11, 2019 9:43 AM
> To: [email-masked]
> Subject: Re: [TOOLS-DEVELOPMENT] Getting a list of recently adopted
> document
> 
> It would not be hard to build, and Spencer gave us very early warning on the
> idea, so it's mostly thought through already.
> 
> But we need to be sure we build what's really wanted, and advertise it
> correctly.
> 
> As stated, you want this list to be only _IETF_ WG adoptions, correct?
> We would not include IRTF RG adoptions (or IAB or any other stream),
> correct?
> 
> RjS
> 
> On 4/11/19 6:29 AM, Roman Danyliw wrote:
> > Hi Tools Team!
> >
> > I'm helping Greg Wood launch an "IETF Notifications of Emerging Work"
> project.  The thinking is we'd like to have a way to easily summarize new
> work the IETF is starting.  To make this tractable, "new work" has been
> defined as all of the drafts that have been recently adopted per a given look-
> back period by a WG (i.e., draft-ietf-<wg name>-*-00).
> >
> > The channels in which this would be summarized/announced is yet to be
> determined, but the raw data required per -00 draft is the draft name, WG,
> title, and abstract.
> >
> > Doing this manually wouldn't be feasible, so we were looking for assistance
> with automation.  How far off is such a regular report from something that
> already exists?
> >
> > Roman
> >
> > _______________________________________________
> > TOOLS-DEVELOPMENT mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/tools-development
> 
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Robert Sparks <[email-masked]>
Date: Thu, 16 May 2019 13:41:19 -0500

Another thread to pick up -

Have you decided on the "channels" below? What I'd heard from Spencer 
was that we'd have a new list and other things could feed off that list. 
Do we need more? If not, has the IESG chosen a list name?

RjS

---

From: Roman Danyliw <[email-masked]>
Date: Thu, 16 May 2019 19:05:10 +0000

Hi Robert!

Greg has the vision here.  I thought it was more of a report that would be cherry-picked into other channels like Twitter, the web-site.  I didn't think it was another mailing list.

Greg: right?  I don't think we discussed how this information would be delivered.

Roman

> From: Robert Sparks [mailto:[email-masked]]
> Sent: Thursday, May 16, 2019 2:41 PM
> To: Roman Danyliw <[email-masked]>
> Cc: [email-masked]
> >> It would not be hard to build, and Spencer gave us very early warning
> >> on the idea, so it's mostly thought through already.
> >>
> >> But we need to be sure we build what's really wanted, and advertise
> >> it correctly.
> >>
> >> project.  The thinking is we'd like to have a way to easily summarize
> >> new work the IETF is starting.  To make this tractable, "new work"
> >> has been defined as all of the drafts that have been recently adopted
> >> per a given look- back period by a WG (i.e., draft-ietf-<wg name>-*-00).
> >> determined, but the raw data required per -00 draft is the draft
> >> name, WG, title, and abstract.
> >> with automation.  How far off is such a regular report from something
> >> that already exists?
> >>> Roman
> >>>

---

From: Robert Sparks <[email-masked]>
Date: Thu, 16 May 2019 14:39:38 -0500

> Greg: right?  I don't think we discussed how this information would be delivered.
Alternatives include a subscription feed or direct email to some address.

---

From: Greg Wood <[email-masked]>
Date: Thu, 16 May 2019 19:47:58 +0000

> On May 16, 2019, at 3:39 PM, Robert Sparks <[email-masked]> wrote:
> 
> 

Specific delivery modes discussed by the IESG Comms review group included an email list called something like [email-masked]. I don’t know whether the list name has been confirmed.

A Twitter feed similar to https://twitter.com/rfcbot (https://github.com/bradleyfalzon/rfc-bot) and https://twitter.com/rfcdujour (https://github.com/exponential-decay/rfc-du-jour) called something like @ietf-new was also discussed.

-Greg