Subject: [TOOLS-DEVELOPMENT] Tools Call Agenda -- 9 April 2019 at 1:00 Eastern

From: Russ Housley <[email-masked]>
Date: Wed, 3 Apr 2019 15:27:19 -0400

Tools Call Agenda -- 9 April 2019 at 1:00 Eastern

JOIN WEBEX MEETING
https://ietf.webex.com/ietf/j.php?MTID=m440dd848726339c03e605b9956e38bac
Meeting number (access code): 640 103 570
Meeting password: tools

JOIN BY PHONE
1-877-668-4493 Call-in toll free number (US/Canada) 
1-650-479-3208 Call-in toll number (US/Canada)
Meeting number (access code): 640 103 570
Meeting password: tools

1. Datatracker Projects
   - Expected Datatracker Releases -- Robert and Henrik
     -- http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan
     -- Python2 to Python3 transition

2. Community & Other Projects
   - Deploy website using Wagtail 2.0 and later -- Robert and Matt
   - Transfer operations of guides.ietf.org the Secretariat -- Robert

3. RFC Services Projects
   - RPC testing of new RFC format tools -- Heather and Robert
   - Security Review of RPC Tools -- Robert and Heather
   - Rendering errata in more useful way -- Robert
     -- Ready for RFP -- Portia

4. Server Infrastructure
   - IESG discussions of DMARC -- Henrik and Alexey
     -- When do we expect the next release of OpenARC?

5. YANG Catalog
   - Transfer yangcatalog.org to the IETF Trust -- Eric
   - Transfer operations to the IETF Secretariat -- Eric and Glen

6. Parking Lot
   - Discontinue pipermail email archives -- Robert and Ryan

7. AOB

---

From: Glen <[email-masked]>
Date: Fri, 5 Apr 2019 12:23:02 -0700

In the interest of pre-call clarifications:

>    - Transfer yangcatalog.org to the IETF Trust -- Eric

I have the token for this.  I have a few steps to take before I'll be ready
to complete the move, but expect the domain transfer to be completed within
the next few weeks.

>    - Transfer operations to the IETF Secretariat -- Eric and Glen

There are probably a number of steps to this that remain.  The AMS-provided
server in OVH Canada appears to have resolved the prior connection
challenges faced by Eric.  The previous plan was for Eric to finish the
work, and then for us to review the setup with an eye to integrating the
service into the existing IETF service field.  If that is still the plan,
then Eric has the token to finish his work, and then I have the token to
review and migrate.

But I think there has also been discussion about using this as a
containerization target, packaging it up instead into a Docker container
for subsequent deployment.  If that is the plan, then I *think* maybe Eric
has the token to finish his work, and then Robert wanted to review for
Docker containerization.

I could be completely wrong, this is just how I recall prior discussions,
and I mention it now so that we can clarify the plan on the call and keep
the project moving in the desired direction.

Glen

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Mon, 8 Apr 2019 05:52:57 +0000

Glen,

The domain can indeed be transferred at any time.

And yang.amsl.com runs indeed outside if the usual IETF infrastructure. The Docker containerization has started during the hackathon and AFAIK the Pantheon contractor works on it with good progress (but not yet there AFAIK)

-éric

From: TOOLS-DEVELOPMENT <[email-masked]> on behalf of Glen Barney <[email-masked]>
Date: Friday, 5 April 2019 at 21:23
To: IETF Tools Development <[email-masked]>
Subject: Re: [TOOLS-DEVELOPMENT] Tools Call Agenda -- 9 April 2019 at 1:00 Eastern

On Wed, Apr 3, 2019 at 12:27 PM Russ Housley <[email-masked]<mailto:[email-masked]>> wrote:
>    - Transfer yangcatalog.org<http://yangcatalog.org> to the IETF Trust -- Eric

I have the token for this.  I have a few steps to take before I'll be ready to complete the move, but expect the domain transfer to be completed within the next few weeks.

>    - Transfer operations to the IETF Secretariat -- Eric and Glen

There are probably a number of steps to this that remain.  The AMS-provided server in OVH Canada appears to have resolved the prior connection challenges faced by Eric.  The previous plan was for Eric to finish the work, and then for us to review the setup with an eye to integrating the service into the existing IETF service field.  If that is still the plan, then Eric has the token to finish his work, and then I have the token to review and migrate.

But I think there has also been discussion about using this as a containerization target, packaging it up instead into a Docker container for subsequent deployment.  If that is the plan, then I *think* maybe Eric has the token to finish his work, and then Robert wanted to review for Docker containerization.

I could be completely wrong, this is just how I recall prior discussions, and I mention it now so that we can clarify the plan on the call and keep the project moving in the desired direction.

Glen

---

From: Alissa Cooper <[email-masked]>
Date: Mon, 8 Apr 2019 16:53:02 -0400

Regrets. I have a conflict tomorrow.

Alissa

> On Apr 3, 2019, at 3:27 PM, Russ Housley <[email-masked]> wrote:
> 
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Liz Flynn <[email-masked]>
Date: Tue, 9 Apr 2019 14:49:27 -0700

Hi everyone,

Please see below for notes from today’s tools call. 

Liz Flynn
Project Manager / IETF
[email-masked]

> On Apr 3, 2019, at 12:27 PM, Russ Housley <[email-masked]> wrote:
> 

Yesterday’s Datatracker release contained the activity from the Code Sprint at IETF 104.

Rather than the merge plan, we should be tracking the link to the Datatracker plan <https://trac.tools.ietf.org/tools/ietfdb/browser/trunk/PLAN <https://trac.tools.ietf.org/tools/ietfdb/browser/trunk/PLAN>>. The plan has been updated to prioritize transition to Python 3, and there’s only one thing still ahead of that (a structural change to DocAlias). Once that model change is done we will focus on Python 3.

>   - Deploy website using Wagtail 2.0 and later -- Robert and Matt

Robert: Wagtail deployment was yesterday. It’s a first step toward containerizing the website. 

Glen: There are a few minor things to clean up, like http authorization protections for some sections. This is not an issue that could delay opening meeting registration; if anything it would only affect staff access to administrative pages.

>   - Transfer operations of guides.ietf.org the Secretariat — Robert

Robert plans to fully containerize this site so it can be cloud deployed and it is quite likely to be done by the next Tools team call.

>   - RPC testing of new RFC format tools -- Heather and Robert

The size of things being requested is getting smaller. No big surprises here.

>   - Security Review of RPC Tools -- Robert and Heather

Security review is still on hold. Ideally the test environment will be complete enough before the cutover, but it will be easier to do after the cutover.

>     -- Ready for RFP — Portia

An RFP was released yesterday. Mark Nottingham has asked why the tight deadline; we’re just following the schedule that has been developed. If he knows anyone who might have bid but was turned off by the deadline, let us know and we can talk about extending it. Robert will respond to Mark with that message.

>     -- When do we expect the next release of OpenARC?

No news from the ARC folks. Henrik will follow up with them by mail.

>   - Transfer operations to the IETF Secretariat -- Eric and Glen

Robert will be taking over the day to day management of the Yang catalog. The transfer can be done anytime. 

Glen will do a temporary transfer now and address cleanup of primary accounts later.