Subject: [TOOLS-DEVELOPMENT] Fwd: Re: Meetecho Thoughts

From: Robert Sparks <[email-masked]>
Date: Tue, 2 Apr 2019 12:50:26 -0500

Tools team:

Below is a short conversation with Tom Pusateri (the creator of the 
IETFers iOS app) about the usability of the current youtube videos and 
what we might strive for that's better.

Do any of you know people who could help us do better than we are currently?

Should we ask Meetecho what they think they could do to get closer to 
what Tom describes?

RjS

-------- Forwarded Message --------
Subject: 	Re: Meetecho Thoughts
Date: 	Tue, 2 Apr 2019 12:02:41 -0400
From: 	Tom Pusateri <[email-masked]>
To: 	Robert Sparks <[email-masked]>

Certainly. The more awareness the better.

Tom

> On Apr 2, 2019, at 11:22 AM, Robert Sparks <[email-masked]> wrote:
>
> Got it.
>
> May I forward the thread so far to the tools team (or at least to Russ)?
>
> RjS
>
> On 4/1/19 4:23 PM, Tom Pusateri wrote:
>> Robert,
>> I probably shouldn’t have mentioned SMIL because that’s a solution 
>> not a problem. I’m not trying to dictate a solution, only an open 
>> format that we can experiment with the streams to combine them in 
>> more useful ways. I’ve parsed the jabber logs in the past and that’s 
>> doable but there’s very little information in them anymore.
>>
>> I think the slide change info can be done in real time by looking at 
>> the video (that will take some code) or using a custom presenter.
>>
>> My purpose is mainly to try to get people thinking in a way and have 
>> a goal to shoot for instead of just continuing in the current mode 
>> which is difficult to integrate and is not a great user experience. 
>> Youtube videos don’t play well with mobile data plans when mostly 
>> what you want is audio and synchronized slides.
>>
>> Thanks,
>> Tom
>>
>>
>>> On Apr 1, 2019, at 4:50 PM, Robert Sparks <[email-masked]> wrote:
>>>
>>> Hi Tom -
>>>
>>> If memory serves, SMIL is still quite difficult to create, and 
>>> capturing the events you detail below will be labor intensive 
>>> (particularly the speaker switches). I can bring this up with the 
>>> tools team, but unless I'm mis-remembering, your ask here is quite 
>>> large.
>>>
>>> RjS
>>>
>>> On 4/1/19 2:14 PM, Tom Pusateri wrote:
>>>> Robert,
>>>> I sent this summary below to Portia and Alexa based on a quick 
>>>> meeting in Prague. I would like to see the deliverables from 
>>>> Meetecho be more open than a youtube video and an mp3 file per 
>>>> session. They suggested I talk with you first to see how my goals 
>>>> align with the datatracker futures. Can we talk some time about this?
>>>>
>>>> I find the youtube replays to be a poor user experience and I would 
>>>> like to do something better and think if we could get separate 
>>>> output streams synced together with SMIL descriptions, we might be 
>>>> able to experiment a bit.
>>>>
>>>> Thanks,
>>>> Tom
>>>>
>>>>
>>>> IETF produces lots of media at main meetings, side meetings, remote 
>>>> participation meetings, etc.
>>>>
>>>> Audio
>>>> Slides
>>>> Video
>>>> Jabber comments
>>>> Events
>>>> • Each speaker at the front of the room
>>>> • Each person coming to the microphone in the audience
>>>> • Slide changes
>>>>
>>>> All media for a single session can be brought together in SMIL
>>>>
>>>> https://en.wikipedia.org/wiki/Synchronized_Multimedia_Integration_Language
>>>>
>>>> Then, many outputs can be generated from combinations of media and 
>>>> events.
>>>>
>>>> Examples:
>>>> Audio only for low bandwidth consumption
>>>> Combination audio/slides with automatic slide changes (mp4)
>>>> Overlay jabber messages synchronized
>>>> Overlay Speaker identification with profile pics
>>>>
>>>> One size fits all Youtube output format is not flexible enough for 
>>>> best user experience in app integration

---

From: Adam Roach <[email-masked]>
Date: Tue, 2 Apr 2019 16:01:13 -0500

FWIW, Meetecho already produces a playback application that gets you 
several of the features that Tom has described. See, e.g.:

https://play.conf.meetecho.com/Playout/?session=IETF104-DOH-20190326-1120

You can find these on the IETF HTML Agenda by clicking on the "M" 
meetecho button.

/a

On 4/2/19 12:50 PM, Robert Sparks wrote:
>>>>> I find the youtube replays to be a poor user experience and I 
>>>>> would like to do something better and think if we could get 
>>>>> separate output streams synced together with SMIL descriptions, we 
>>>>> might be able to experiment a bit.
>>>>>
>>>>> Thanks,
>>>>> Tom
>>>>>
>>>>>
>>>>> IETF produces lots of media at main meetings, side meetings, 
>>>>> remote participation meetings, etc.
>>>>>
>>>>> Audio
>>>>> Slides
>>>>> Video
>>>>> Jabber comments
>>>>> Events
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Robert Sparks <[email-masked]>
Date: Tue, 2 Apr 2019 16:03:24 -0500

Yes, but Tom's looking for something using an open format that he can 
integrate into things like his app.

On 4/2/19 4:01 PM, Adam Roach wrote:
>> IETFers iOS app) about the usability of the current youtube videos 
>> and what we might strive for that's better.
>>
>>>> more useful ways. I’ve parsed the jabber logs in the past and 
>>>> that’s doable but there’s very little information in them anymore.
>>>>
>>>> I think the slide change info can be done in real time by looking 
>>>> at the video (that will take some code) or using a custom presenter.
>>>>
>>>> My purpose is mainly to try to get people thinking in a way and 
>>>> have a goal to shoot for instead of just continuing in the current 
>>>> mode which is difficult to integrate and is not a great user 
>>>> experience. Youtube videos don’t play well with mobile data plans 
>>>> when mostly what you want is audio and synchronized slides.
>>>>
>>>> Thanks,
>>>> Tom
>>>>
>>>>
>>>>>> separate output streams synced together with SMIL descriptions, 
>>>>>> we might be able to experiment a bit.
>>>>>>
>>>>>> Thanks,
>>>>>> Tom
>>>>>>
>>>>>>
>>>>>> Then, many outputs can be generated from combinations of media 
>>>>>> and events.
>>>>>>
>>>>>> Examples:
>>>>>> One size fits all Youtube output format is not flexible enough 
>>>>>> for best user experience in app integration
>>
>>

---

From: Adam Roach <[email-masked]>
Date: Tue, 2 Apr 2019 16:21:46 -0500

I suspect it's mostly a matter of asking the MeetEcho folks for pointers 
to their formats. For example, the Jabber transcripts can be seen in an 
easy-to-use JSON format here:

https://play.conf.meetecho.com/Playout/session/IETF104-DOH-20190326-1120

And the timestamped transcript is here:

https://play.conf.meetecho.com/Playout/resources/IETF104-DOH-20190326-1120

/a

On 4/2/19 4:03 PM, Robert Sparks wrote:
>>> Should we ask Meetecho what they think they could do to get closer 
>>> to what Tom describes?
>>>
>>> RjS
>>>
>>>>>> tools team, but unless I'm mis-remembering, your ask here is 
>>>>>> quite large.
>>>>>>
>>>>>> RjS
>>>>>>
>>>>>>> session. They suggested I talk with you first to see how my 
>>>>>>> goals align with the datatracker futures. Can we talk some time 
>>>>>>> about this?
>>>>>>>

---

From: Alexa Morris <[email-masked]>
Date: Fri, 12 Apr 2019 14:16:14 -0700

Just to provide an update here, Robert and I are going to have a call with Tom and the Meetecho team in a couple of weeks, with the goal of better understanding what changes would be involved from the Meetecho side. We will report back on what we learn.

Alexa

> On Apr 2, 2019, at 2:21 PM, Adam Roach <[email-masked]> wrote:
> 
> I suspect it's mostly a matter of asking the MeetEcho folks for pointers to their formats. For example, the Jabber transcripts can be seen in an easy-to-use JSON format here:
> 
> https://play.conf.meetecho.com/Playout/session/IETF104-DOH-20190326-1120 <https://play.conf.meetecho.com/Playout/session/IETF104-DOH-20190326-1120>
> 
> https://play.conf.meetecho.com/Playout/resources/IETF104-DOH-20190326-1120 <https://play.conf.meetecho.com/Playout/resources/IETF104-DOH-20190326-1120>
> 
> /a
> 
> 
>> Yes, but Tom's looking for something using an open format that he can integrate into things like his app.
>>> FWIW, Meetecho already produces a playback application that gets you several of the features that Tom has described. See, e.g.:
>>> 
>>> https://play.conf.meetecho.com/Playout/?session=IETF104-DOH-20190326-1120 <https://play.conf.meetecho.com/Playout/?session=IETF104-DOH-20190326-1120>
>>> 
>>> You can find these on the IETF HTML Agenda by clicking on the "M" meetecho button.
>>> 
>>> /a
>>> 
>>> 
>>>> Below is a short conversation with Tom Pusateri (the creator of the IETFers iOS app) about the usability of the current youtube videos and what we might strive for that's better.
>>>> 
>>>> Should we ask Meetecho what they think they could do to get closer to what Tom describes?
>>>> RjS
>>>> 
>>>> From:	Tom Pusateri <[email-masked]> <mailto:[email-masked]>
>>>> To:	Robert Sparks <[email-masked]> <mailto:[email-masked]>
>>>> 
>>>>> On Apr 2, 2019, at 11:22 AM, Robert Sparks <[email-masked]> <mailto:[email-masked]> wrote:
>>>>> 
>>>>> Got it.
>>>>> 
>>>>>> I probably shouldn’t have mentioned SMIL because that’s a solution not a problem. I’m not trying to dictate a solution, only an open format that we can experiment with the streams to combine them in more useful ways. I’ve parsed the jabber logs in the past and that’s doable but there’s very little information in them anymore.
>>>>>> 
>>>>>> I think the slide change info can be done in real time by looking at the video (that will take some code) or using a custom presenter.
>>>>>> 
>>>>>> My purpose is mainly to try to get people thinking in a way and have a goal to shoot for instead of just continuing in the current mode which is difficult to integrate and is not a great user experience. Youtube videos don’t play well with mobile data plans when mostly what you want is audio and synchronized slides.
>>>>>> 
>>>>>> Thanks,
>>>>>> Tom
>>>>>> 
>>>>>> 
>>>>>>> On Apr 1, 2019, at 4:50 PM, Robert Sparks <[email-masked]> <mailto:[email-masked]> wrote:
>>>>>>> 
>>>>>>> Hi Tom -
>>>>>>> 
>>>>>>> If memory serves, SMIL is still quite difficult to create, and capturing the events you detail below will be labor intensive (particularly the speaker switches). I can bring this up with the tools team, but unless I'm mis-remembering, your ask here is quite large.
>>>>>>> 
>>>>>>> RjS
>>>>>>> 
>>>>>>>> I sent this summary below to Portia and Alexa based on a quick meeting in Prague. I would like to see the deliverables from Meetecho be more open than a youtube video and an mp3 file per session. They suggested I talk with you first to see how my goals align with the datatracker futures. Can we talk some time about this?
>>>>>>>> 
>>>>>>>> I find the youtube replays to be a poor user experience and I would like to do something better and think if we could get separate output streams synced together with SMIL descriptions, we might be able to experiment a bit.
>>>>>>>> 
>>>>>>>> Thanks,
>>>>>>>> Tom
>>>>>>>> 
>>>>>>>> 
>>>>>>>> IETF produces lots of media at main meetings, side meetings, remote participation meetings, etc.
>>>>>>>> 
>>>>>>>> Audio
>>>>>>>> Slides
>>>>>>>> Video
>>>>>>>> Jabber comments
>>>>>>>> Events
>>>>>>>> https://en.wikipedia.org/wiki/Synchronized_Multimedia_Integration_Language <https://en.wikipedia.org/wiki/Synchronized_Multimedia_Integration_Language>
>>>>>>>> 
>>>>>>>> Then, many outputs can be generated from combinations of media and events.
>>>>>>>> 
>>>>>>>> Examples:
>>>>>>>> One size fits all Youtube output format is not flexible enough for best user experience in app integration
>>>> 
>>>> 
>>>> 
>>>> [email-masked] <mailto:[email-masked]>
>>>> https://www.ietf.org/mailman/listinfo/tools-development <https://www.ietf.org/mailman/listinfo/tools-development>
>>> 
>