Subject: [TOOLS-DEVELOPMENT] Getting a list of recently adopted document

From: Roman Danyliw <[email-masked]>
Date: Thu, 11 Apr 2019 11:29:42 +0000

Hi Tools Team!

I'm helping Greg Wood launch an "IETF Notifications of Emerging Work" project.  The thinking is we'd like to have a way to easily summarize new work the IETF is starting.  To make this tractable, "new work" has been defined as all of the drafts that have been recently adopted per a given look-back period by a WG (i.e., draft-ietf-<wg name>-*-00).

The channels in which this would be summarized/announced is yet to be determined, but the raw data required per -00 draft is the draft name, WG, title, and abstract.

Doing this manually wouldn't be feasible, so we were looking for assistance with automation.  How far off is such a regular report from something that already exists?

Roman

---

From: Robert Sparks <[email-masked]>
Date: Thu, 11 Apr 2019 08:42:35 -0500

It would not be hard to build, and Spencer gave us very early warning on 
the idea, so it's mostly thought through already.

But we need to be sure we build what's really wanted, and advertise it 
correctly.

As stated, you want this list to be only _IETF_ WG adoptions, correct? 
We would not include IRTF RG adoptions (or IAB or any other stream), 
correct?

RjS

On 4/11/19 6:29 AM, Roman Danyliw wrote:
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development