Subject: [TOOLS-DEVELOPMENT] IETF tools github organizational repository

From: Robert Sparks <[email-masked]>
Date: Wed, 10 Apr 2019 15:38:15 -0500

FYI

I have created an ietf-tools github organizational repository (attached 
to the LLC) and placed the website code in it as the first project.

It sits here:

https://github.com/ietf-tools

RjS

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 11 Apr 2019 12:56:39 +1000

Hi Robert,

That's great!

I took a quick look through the mail archive, but didn't see any context for this. Is the intent to eventually get all of the tools here? Moved, or mirrored? Will we be able to take pull requests?

One thing that would be super-helpful is a brief summary of the scope and structure of the repo (and mappings to Web locations, where appropriate) in README.md. E.g., because this included `datatracker`, I was expecting to find the ballot classes discussed in the SoW for the IRSG here, but a search came up empty.

Happy to help where and how I can.

Cheers,

> On 11 Apr 2019, at 6:38 am, Robert Sparks <[email-masked]> wrote:
> 
> FYI
> 
> I have created an ietf-tools github organizational repository (attached to the LLC) and placed the website code in it as the first project.
> 
> It sits here:
> 
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

--
Mark Nottingham   https://www.mnot.net/

---

From: Robert Sparks <[email-masked]>
Date: Thu, 11 Apr 2019 08:45:48 -0500

> I took a quick look through the mail archive, but didn't see any context for this. Is the intent to eventually get all of the tools here? Moved, or mirrored? Will we be able to take pull requests?

The step we are taking now is to host projects that started in git in 
github.

We do not plan to move the datatracker, or other projects already 
started in svn, to github. There have been discussions of mirroring, but 
they have not been prioritized.

---

From: Robert Sparks <[email-masked]>
Date: Thu, 11 Apr 2019 08:49:17 -0500

Btw - I will work the location of the datatracker source into the IRSG 
ballot SoW, but so I don't leave you waiting for an edit, you can find it at

<https://trac.tools.ietf.org/tools/ietfdb/browser/>

The various DocEvent classes mentioned are here:

<https://trac.tools.ietf.org/tools/ietfdb/browser/trunk/ietf/doc/models.py>

RjS