Subject: [TOOLS-DEVELOPMENT] Draft of an SoW for the 2019 yangcatalog projects

From: Robert Sparks <[email-masked]>
Date: Thu, 17 Jan 2019 13:48:19 -0600

I've restructured Eric's original draft of this SoW to make what is 
being bid on a little more concrete.

The first two sections look very similar, and it is tempting to combine 
them. However, from IM conversations with Eric, he feels keeping them 
separate is useful, and we may choose to award them to different 
contractors.

Also, we should discuss how long the RFP process is likely to take. Eric 
was originally hoping to have contractors in place in early February, 
but I think the RFP process will take at least 6 weeks. If we were to 
finalize the SoW quickly, we would still be looking at early to 
mid-March for awarding contracts.

RjS

---

From: Alissa Cooper <[email-masked]>
Date: Thu, 17 Jan 2019 13:54:37 -0800

Hi Robert,

> On Jan 17, 2019, at 11:48 AM, Robert Sparks <[email-masked]> wrote:
> 
> I've restructured Eric's original draft of this SoW to make what is being bid on a little more concrete.
> 
> The first two sections look very similar, and it is tempting to combine them. However, from IM conversations with Eric, he feels keeping them separate is useful, and we may choose to award them to different contractors.
> 
> Also, we should discuss how long the RFP process is likely to take. Eric was originally hoping to have contractors in place in early February, but I think the RFP process will take at least 6 weeks. If we were to finalize the SoW quickly, we would still be looking at early to mid-March for awarding contracts.

Can you say how you calculated that amount of time? Given the nature of this project, it seems like we could put out the call for 2.5-3 weeks and then hopefully select a bidder within a week or two, ideally.

Alissa

> 
> RjS
> 
> 
> 
> <sow-2019-yangcatalog-v1.pdf><sow-2019-yangcatalog-v1.docx>_______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Robert Sparks <[email-masked]>
Date: Thu, 17 Jan 2019 16:00:19 -0600

On 1/17/19 3:54 PM, Alissa Cooper wrote:
> Can you say how you calculated that amount of time?

Just what past RFPs have taken, assuming we could streamline some stuff 
at the end.

Look at the top of page 5 of this simple RFP for example: 
<https://iaoc.ietf.org/documents/RFC-Editor-RFC-Format-CSS-Design-RFP-01-2016-07-20.pdf>

We could go faster, but we would have to change the question period.

> Given the nature of this project, it seems like we could put out the call for 2.5-3 weeks and then hopefully select a bidder within a week or two, ideally.
>
> Alissa
>
>> RjS
>>
>>
>>

---

From: Alissa Cooper <[email-masked]>
Date: Thu, 17 Jan 2019 14:05:12 -0800

> On Jan 17, 2019, at 2:00 PM, Robert Sparks <[email-masked]> wrote:
> 
> 
> Just what past RFPs have taken, assuming we could streamline some stuff at the end.
> 
> Look at the top of page 5 of this simple RFP for example: <https://iaoc.ietf.org/documents/RFC-Editor-RFC-Format-CSS-Design-RFP-01-2016-07-20.pdf>
> 

Perhaps we could just have the question period overlap with the first half of the request period, and commit to answering questions within 72 hours.

Alissa

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Thu, 17 Jan 2019 22:30:46 +0000

Robert

Thank you for the restructured SoW.

Now, I would like to really insist on getting the section 1 for early February (the original plan was end 2018). Indeed, I need to transition a lot of my current work load to leave room for my upcoming role in the IESG. And if the contractor is not Pantheon, then I will no time at all in March to help the transition.

So, really the earlier, the better.

Regards

-éric

On 17/01/2019, 11:48, "TOOLS-DEVELOPMENT on behalf of Robert Sparks" <[email-masked] on behalf of [email-masked]> wrote:

    
    
    RjS

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Thu, 17 Jan 2019 22:40:45 +0000

Sorry Alissa and Robert, reading your emails after sending my own :-O

Indeed, we can commit to reply within 2 working days (at least I can commit).

-éric

On 17/01/2019, 14:05, "TOOLS-DEVELOPMENT on behalf of Alissa Cooper" <[email-masked] on behalf of [email-masked]> wrote:

    
    
    Alissa
    
    >>> https://www.ietf.org/mailman/listinfo/tools-development
    
    _______________________________________________
    TOOLS-DEVELOPMENT mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/tools-development

---

From: Robert Sparks <[email-masked]>
Date: Fri, 18 Jan 2019 09:32:01 -0600

On 1/17/19 4:05 PM, Alissa Cooper wrote:
> Perhaps we could just have the question period overlap with the first half of the request period,

I'm not quite following - the question period is the first step. I'm not 
sure what you're suggesting overlap with? If it's providing answers as 
they come in, sure, but there's still got to be a time where we cut off 
questions and ask for bids, so I think the only thing we can do is just 
shorten the question (and answer) period.

Compressing the schedule we've seen in the past as much as I think makes 
sense (for this project anyway), I could see us following something 
roughly like this (In calendar days assuming we start such that the 3 
day answer period does not overlap a weekend, which means day 0 is 
Mon-Wed, and that this goes out in a chunk of calendar that has no 
holidays in it - otherwise, we have to let the weekend(s) and holidays 
stretch this out).

day  0: RFP Issued
day  7: Questions and Inquiries deadline
day 10: Answers to questions issued, RFP Addenda and Update issued
day 17: Proposals due
day 24: Selection made, negotiations begin
day 31: Contract execution
day 35: Work begins

Again, some of this compression is due to the nature of what this 
particular RFP is asking for. I would not feel comfortable generalizing 
it to RFPs.

Anyone should feel free to say I've overcompressed this.

In any case, does that capture your suggestion?

>   and commit to answering questions within 72 hours.
>
> Alissa
>
>>

---

From: Russ Housley <[email-masked]>
Date: Fri, 18 Jan 2019 17:01:55 -0500

Robert:

I suggest that we structure it as three tasks in one SOW, and the bidder may bid on one, two, or all three.  Further, the hourly rate for a person dong the first task may be different from the rate of the person doing the second task.

See attachment.

Russ

---

From: Robert Sparks <[email-masked]>
Date: Fri, 18 Jan 2019 16:08:14 -0600

On 1/18/19 4:01 PM, Russ Housley wrote:
> Robert:
>
> I suggest that we structure it as three tasks in one SOW, and the bidder may bid on one, two, or all three.
That was what I tried to write in the first place.
>   Further, the hourly rate for a person dong the first task may be different from the rate of the person doing the second task.
Right - that's why it's a different bid.
> See attachment.
The only change I see in the attachment that concerns me is you removed 
the request to bid the cost of attending the hackathon at IETF104 and 
replaced it with a statement that covering the hours would be 
guaranteed. What about travel expenses?

---

From: Portia Wenze-Danley <[email-masked]>
Date: Fri, 18 Jan 2019 17:14:58 -0500

> On Jan 18, 2019, at 5:08 PM, Robert Sparks <[email-masked]> wrote:
> 
> 
> The only change I see in the attachment that concerns me is you removed the request to bid the cost of attending the hackathon at IETF104 and replaced it with a statement that covering the hours would be guaranteed. What about travel expenses?

	+1

---

From: Russ Housley <[email-masked]>
Date: Fri, 18 Jan 2019 17:29:53 -0500

> The only change I see in the attachment that concerns me is you removed the request to bid the cost of attending the hackathon at IETF104 and replaced it with a statement that covering the hours wo…

I do not see anything in the original wording that says anything about travel.  I am assuming we should cover travel too.  I suggest:

	This task requires a bid for hourly work as requested by the

	IETF Tools Team, as well as hours and actual travel expenses

	to attend the IETF-104 Hackathon. Hours and travel expenses

	 to attend the IETF-104 Hackathon are guaranteed to the winner.

	 Additional hours depend on the work that is needed over the

	 period of the contract.

Russ

---

From: Robert Sparks <[email-masked]>
Date: Fri, 18 Jan 2019 16:38:42 -0600

On 1/18/19 4:29 PM, Russ Housley wrote:
>
>
>> On Jan 18, 2019, at 5:08 PM, Robert Sparks <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>
>>
>>> I suggest that we structure it as three tasks in one SOW, and the 
>>> bidder may bid on one, two, or all three.
>>>  Further, the hourly rate for a person dong the first task may be 
>>> different from the rate of the person doing the second task.
>> The only change I see in the attachment that concerns me is you 
>> removed the request to bid the cost of attending the hackathon at 
>> IETF104 and replaced it with a statement that covering the hours 
>> would be guaranteed. What about travel expenses?
>
> I do not see anything in the original wording that says anything about 
> travel.
It wasn't explicit enough at "a bid for attending the IETF-104 Hackathon".
>  I am assuming we should cover travel too.  I suggest:
>
That works for me.

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Sat, 19 Jan 2019 18:56:12 +0000

Sorry for being a 'PIA' but I am really eager to see things moving wrt the 'call for tender' (or whatever process used by the IETF) to get proposals from potential contractors and to successfully pass the operations and maintenance of yangcatalog.org 

What is the timing to issue the SoW to potential contractors? Has it already been issued?

Have a nice WE

-éric (blocked in SFO as ORD is too snowy to depart -- unsure when I will land in BRU, oh man...)

On 17/01/2019, 14:30, "TOOLS-DEVELOPMENT on behalf of Eric Vyncke (evyncke)" <[email-masked] on behalf of [email-masked]> wrote:

    Robert

    
    
    Regards
    
    -éric

        

        RjS

---

From: Alissa Cooper <[email-masked]>
Date: Tue, 22 Jan 2019 14:22:22 -0500

> On Jan 18, 2019, at 10:32 AM, Robert Sparks <[email-masked]> wrote:
> 
> 
> I'm not quite following - the question period is the first step. I'm not sure what you're suggesting overlap with? If it's providing answers as they come in, sure, but there's still got to be a time where we cut off questions and ask for bids, so I think the only thing we can do is just shorten the question (and answer) period.
> 
> Compressing the schedule we've seen in the past as much as I think makes sense (for this project anyway), I could see us following something roughly like this (In calendar days assuming we start such that the 3 day answer period does not overlap a weekend, which means day 0 is Mon-Wed, and that this goes out in a chunk of calendar that has no holidays in it - otherwise, we have to let the weekend(s) and holidays stretch this out).
> 
> day  0: RFP Issued

This looks good to me. If we could do s/day 17/day 14/ (and consequent adjustments in the following dates) I would be marginally happier but I know this is pushing it.

Thanks,
Alissa

> 
> Again, some of this compression is due to the nature of what this particular RFP is asking for. I would not feel comfortable generalizing it to RFPs.
>

---

From: Alissa Cooper <[email-masked]>
Date: Tue, 22 Jan 2019 14:31:02 -0500

> On Jan 18, 2019, at 5:38 PM, Robert Sparks <[email-masked]> wrote:
> 
> 
>>> On Jan 18, 2019, at 5:08 PM, Robert Sparks <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>> 
>> I do not see anything in the original wording that says anything about travel.

+1, this looks ready to ship with Russ’s edit.
Alissa

---

From: Robert Sparks <[email-masked]>
Date: Tue, 22 Jan 2019 14:08:03 -0600

Attached is a clean version with Russ' edits incorporated.

On 1/22/19 1:31 PM, Alissa Cooper wrote:
>
>
>> On Jan 18, 2019, at 5:38 PM, Robert Sparks <[email-masked] 
>> [email-masked] <mailto:[email-masked]>