Subject: [TOOLS-DEVELOPMENT] Next (and I think final) version of the Meeting application SoW

From: Robert Sparks <[email-masked]>
Date: Thu, 17 Jan 2019 13:13:48 -0600

I've incorporated comments from Russ, and at his suggestion renamed the 
file using a schema we can follow with the remaining SoWs to cause them 
to group nicely in Finder.

I believe this is ready to go out for IDIQ bids.

RjS

---

From: Russ Housley <[email-masked]>
Date: Mon, 21 Jan 2019 11:47:24 -0500

This looks good to me.

I noticed one typo:  at/meeting/important-dates
There should be a space after "at"

I think this is ready to go out for bids.

Russ

---

From: Alissa Cooper <[email-masked]>
Date: Tue, 22 Jan 2019 15:55:36 -0500

Have we done any serious investigation of whether we could use an off-the-shelf tool like Sched to meet the bulk of our needs, rather than continuing to develop more bespoke functionality that we have to maintain over time for meeting scheduling and display? I know we think the IETF is a special flower, but in many ways it isn’t, e.g., we have a bunch of tracks and sessions that need to be de-conflicted based on certain criteria and fit into a grid.

I’m also curious who we expect to consume the improved meeting statistics. As far as I know, no one on the IESG makes use of the existing reports cited in the RFP. Generally I find the datatracker statistics kind of hard to consume for a number of reasons, so I would hesitate to add more functionality there without a compelling justification.

Thanks,
Alissa

> On Jan 17, 2019, at 2:13 PM, Robert Sparks <[email-masked]> wrote:
> 
> I've incorporated comments from Russ, and at his suggestion renamed the file using a schema we can follow with the remaining SoWs to cause them to group nicely in Finder.
> 
> <sow_2019_meeting_v2.pdf><sow_2019_meeting_v2.docx>_______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Robert Sparks <[email-masked]>
Date: Tue, 22 Jan 2019 15:10:13 -0600

On 1/22/19 2:55 PM, Alissa Cooper wrote:
> Have we done any serious investigation of whether we could use an off-the-shelf tool like Sched to meet the bulk
That's the crucial word.
> of our needs, rather than continuing to develop more bespoke functionality that we have to maintain over time for meeting scheduling and display?
No, but I don't think it would actually meet the bulk of our needs. We 
might be able to separate the "building a schedule" part of the app from 
the "managing materials, displayed agenda, and proceedings" part of the 
app, but doing so is likely as large as what we are proposing to do now.
>   I know we think the IETF is a special flower, but in many ways it isn’t, e.g., we have a bunch of tracks and sessions that need to be de-conflicted based on certain criteria and fit into a grid.
Sure. But there integrating the output of that grid into the meeting 
materials management stuff we have - are you proposing we don't do that 
part anymore, or switch to some other commercial conferencing system and 
only do what it lets you do with materials?
>
> I’m also curious who we expect to consume the improved meeting statistics.
AFAIK, only the IESG.
>   As far as I know, no one on the IESG makes use of the existing reports cited in the RFP.
Alexa -  who keeps asking for this report?
> Generally I find the datatracker statistics kind of hard to consume for a number of reasons, so I would hesitate to add more functionality there without a compelling justification.
>
> Thanks,
> Alissa
>

---

From: Russ Housley <[email-masked]>
Date: Tue, 22 Jan 2019 16:22:14 -0500

> Have we done any serious investigation of whether we could use an off-the-shelf tool like Sched to meet the bulk of our needs, rather than continuing to develop more bespoke functionality that we h…

We looked at a bunch of different packages before we went down the current path.  That was now a few years ago.

I did a very quick look at Sched, and it seems to be more of a service than a software package.  A non-profit pays $3000/year for a subscription, so it will not integrate easily with the way we handle proceedings.

	It says things like:	You can export your sessions and their details as a spreadsheet.

	This makes me think that we would spend as much making it fit together as we would on the new code.

This did not exist when we started: http://blog.eventzilla.net/new-features/how-to-setup-and-manage-multi-session-and-multi-track-schedule-for-your-conference/

	A quick review, and it falls very short of our needs.

Another one is: https://whova.com/blog/multitrack-agendas-approachable-and-manageable/

	This seems to be aimed at the attendee, not the meeting planner.

> I’m also curious who we expect to consume the improved meeting statistics. As far as I know, no one on the IESG makes use of the existing reports cited in the RFP. Generally I find the datatracker…

The current manual report is for the IESG.  They idea is to automate it, but if it is not useful, we can drop that from the SOW altogether.

Russ

---

From: Alissa Cooper <[email-masked]>
Date: Wed, 23 Jan 2019 14:32:34 -0500

Hi Robert,

> On Jan 22, 2019, at 4:10 PM, Robert Sparks <[email-masked]> wrote:
> 
> 
> No, but I don't think it would actually meet the bulk of our needs. We might be able to separate the "building a schedule" part of the app from the "managing materials, displayed agenda, and proceedings" part of the app, but doing so is likely as large as what we are proposing to do now.
> Sure. But there integrating the output of that grid into the meeting materials management stuff we have - are you proposing we don't do that part anymore, or switch to some other commercial conferencing system and only do what it lets you do with materials?

I wasn’t proposing anything, I was just wondering if we had done a thorough investigation, and it sounds like we did a few years ago. I was wondering about this not to compare the specific chunk of work captured in the RFP to the amount of work it would take to switch to something off-the-shelf, because that doesn’t seem like a fair comparison. I was wondering because it seems like over time our maintenance and support story might be simpler if we don’t continue building up bespoke features for ourselves. 

Obviously I haven’t done the investigation myself to know whether any of these services have APIs that let you easily extract meeting materials, agendas, etc. as might be needed if we wanted to use a different service for schedule-building and display than for proceedings.

Alissa