Subject: [TOOLS-DEVELOPMENT] yangcatalog

From: Lou Berger <[email-masked]>
Date: Fri, 9 Nov 2018 10:54:52 +0700

Hi Russ, (Benoit)

     I'm happy to hear that the IETF tools team will be taking over 
yangcatalog.org.  I have a few questions about the site/tool given that 
they have been an independent project:

How are you thinking it will be tied into our existing IETF sites?

How are you thinking of tracking bugs and feature requests? Integrate 
into the typical IETF tools infrastructure or run independently?

Are there domains and/or copyrights that need to be transferred to the 
IETF (trust)?

Thanks,

Lou

---

From: Russ Housley <[email-masked]>
Date: Thu, 8 Nov 2018 23:21:07 -0500

> On Nov 8, 2018, at 10:54 PM, Lou Berger <[email-masked]> wrote:
> 
> Hi Russ, (Benoit)
> 
>     I'm happy to hear that the IETF tools team will be taking over yangcatalog.org.  I have a few questions about the site/tool given that they have been an independent project:
> 

Not.  It will just be on the same servers.

> How are you thinking of tracking bugs and feature requests? Integrate into the typical IETF tools infrastructure or run independently?

We are just beginning to talk about that.  Suggestions welcome.

> Are there domains and/or copyrights that need to be transferred to the IETF (trust)?

Yes.  I believe that yangcatalog.org <http://yangcatalog.org/> will be transferred to the IETF Trust, but we have not started the process yet.

Russ

---

From: Lou Berger <[email-masked]>
Date: Fri, 9 Nov 2018 14:18:46 +0700

Hi,

On 11/9/2018 11:21 AM, Russ Housley wrote:
>
>
>> On Nov 8, 2018, at 10:54 PM, Lou Berger <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>
>> Hi Russ, (Benoit)
>>
>> yangcatalog.org <http://yangcatalog.org>.  I have a few questions 
>> about the site/tool given that they have been an independent project:
>>
same=existing?  sure, you can always revisit this when it goes it to bid.
> We are just beginning to talk about that.  Suggestions welcome.

I'm okay with any documented process -- I think it goes to how you want 
to manage the project and how integrated you want it to be .  Right now, 
I don't see any 'IETF branding' on the site, I think this can be 
documented/decided along with any rebranding.

> Yes.  I believe that yangcatalog.org <http://yangcatalog.org> will be 
> transferred to the IETF Trust, but we have not started the process yet.
>
Okay, thanks.  I think it would be good to sort out ownership of code 
and derivative changes as part of this transition.

Thanks,

Lou

---

From: Russ Housley <[email-masked]>
Date: Fri, 9 Nov 2018 03:31:20 -0500

> On Nov 9, 2018, at 2:18 AM, Lou Berger <[email-masked]> wrote:
> 
> Hi,
> 
>>> On Nov 8, 2018, at 10:54 PM, Lou Berger <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>> Hi Russ, (Benoit)
>>> 
>>>     I'm happy to hear that the IETF tools team will be taking over yangcatalog.org <http://yangcatalog.org>.  I have a few questions about the site/tool given that they have been an independent project:
>>> 

The existing services that are used for ietf.org <http://ietf.org/>, iab.org <http://iab.org/>, and irtf.org <http://irtf.org/>.

> I'm okay with any documented process -- I think it goes to how you want to manage the project and how integrated you want it to be .  Right now, I don't see any 'IETF branding' on the site, I think this can be documented/decided along with any rebranding.

We want to make sure that all standards bodies are able to use it.  I do not know if branding would deter that.

All of the yangcatalog code is currently on GitHub.  My guess is there is no reason to move it, and there is a natural set of issue trackers and such in that environment.

>> Yes.  I believe that yangcatalog.org <http://yangcatalog.org> will be transferred to the IETF Trust, but we have not started the process yet.
>> 
> Okay, thanks.  I think it would be good to sort out ownership of code and derivative changes as part of this transition.

I believe that is all clear; see https://github.com/yang-catalog/yang/blob/master/README.md <https://github.com/yang-catalog/yang/blob/master/README.md>

Russ

---

From: Lou Berger <[email-masked]>
Date: Fri, 9 Nov 2018 15:43:58 +0700

On 11/9/2018 3:31 PM, Russ Housley wrote:
> I believe that is all clear; see 
> https://github.com/yang-catalog/yang/blob/master/README.md
>
I'm referring to the source code that we're now going to be paying to 
maintain/extend.  The piece I looked at has a cisco copyright and seemed 
to allow derivative works, but I'm not a lawyer...

Lou

---

From: Russ Housley <[email-masked]>
Date: Fri, 9 Nov 2018 05:02:20 -0500

> On Nov 9, 2018, at 3:43 AM, Lou Berger <[email-masked]> wrote:
> 
>> I believe that is all clear; see https://github.com/yang-catalog/yang/blob/master/README.md
>> 
> I'm referring to the source code that we're now going to be paying to maintain/extend.  The piece I looked at has a cisco copyright and seemed to allow derivative works, but I'm not a lawyer...

My understanding is that all of the code allows derivative works.  Portia, can you have the developers confirm that is the case?

Russ

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Fri, 9 Nov 2018 13:07:17 +0000

Sorry for late reply, already in the plane back from Bangkok.

In short:
- I hope that the yangcatalog.org will stay alive but obviously the control should be transferred to IETF pointing to IETF servers (currently on a dual-stacked VM in OVH/France). Yangcatalog.ietf.org could be a CNAME of course
- the source code is at https://github.com/YangCatalog
- the intent of Cisco for all those repos is to be Apache 2.0. We may have forgotten a couple of files without this license => this will be fixed indeed
- there are 2 packages which are not open source and requires a license from Cisco.
	* ConfD (used as a DB + NETCONF interface __ ): I have managed to get a one-year evaluation license with implicit yearly renewal (we will need to finalize this before January)
	* YangSuite (https://yangsuite.cisco.com) to be honest, we may have to remove this part and replace it by another open source 'explorer' such as YDK (Cisco will take this action on our own budget)
- until the transfer, we use the github issues tracker system, but, after IETF takes over: whatever you prefer ;-)
- BTW, happy to switch from Hackathon to Code Sprint for a couple of IETF on the yangcatalog
- obviously branding will be IETF but I hope that the credit will stay to Benoît and Cisco

We should have talked about those issues in the morning but we can have a call whenever you want: we (Cisco) want to have an easy no-string-attached transfer.

Regards

-éric

On 09/11/2018, 10:55, "TOOLS-DEVELOPMENT on behalf of Lou Berger" <[email-masked] on behalf of [email-masked]> wrote:

    Hi Russ, (Benoit)

    

    Thanks,
    
    Lou

    _______________________________________________
    TOOLS-DEVELOPMENT mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/tools-development

---

From: Benoit Claise <[email-masked]>
Date: Sun, 11 Nov 2018 12:30:57 +0700

On 09/11/2018 15:43, Lou Berger wrote:
>>> Okay, thanks.  I think it would be good to sort out ownership of 
>>> code and derivative changes as part of this transition.
>>
> maintain/extend.  The piece I looked at has a cisco copyright and 
> seemed to allow derivative works, but I'm not a lawyer...
Which one?
It might be true for the YANG Suite, as we discussed during the 
IESG/IEEE coordination call.

Regards, B.

---

From: Lou Berger <[email-masked]>
Date: Sun, 11 Nov 2018 16:21:49 +0700

> IESG/IEEE coordination call.

I followed the first link under

https://yangcatalog.org/contribute.html

and found

https://github.com/YangCatalog/backend/blob/master/setup.py

Lou

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Sun, 11 Nov 2018 09:50:01 +0000

Lou,

The intent for Cisco is really to give away the code as open-source with no strings attached to it: free use, free modifications, ... 

I selected https://en.wikipedia.org/wiki/Apache_License version 2 as it seems to allow the free use. The only 'constraint' is to keep the Copyright statement (mainly as a credit to the authors) but of course, as soon as the IETF modifies a single line, feel free to add a Copyright IETF.

In  the same vein, we can add you and other people in the IETF tools team as admin on the Github.

Again, our goal is to give the code for free. If the Apache2 license is not suitable, let's talk: this should not be a road block.

Have a nice flight back home if still in BKK for the IEEE meeting

-éric

On 11/11/2018, 10:22, "Lou Berger" <[email-masked]> wrote:

    
    
    and found

    Lou

---

From: Lou Berger <[email-masked]>
Date: Sun, 11 Nov 2018 17:34:59 +0700

Hi Eric,

> The intent for Cisco is really to give away the code as open-source with no strings attached to it: free use, free modifications, ...

This sounds great.  As I mentioned in my previous work, it looks like 
the current license/copyright seems sufficient for our needs, *but* this 
isn't for me to judge as it is a legal question.

> I selected https://en.wikipedia.org/wiki/Apache_License version 2 as it seems to allow the free use. The only 'constraint' is to keep the Copyright statement (mainly as a credit to the authors) but…

Looking at section 4 of 
https://trustee.ietf.org/license-info/IETF-TLP-5.htm the trust is 
certainly happy with  joint copyrights and the identified BSD -- again 
this isn't for me to say, I was just raising the issue as I'm sensitized 
to trust issues being a trustee.

> In  the same vein, we can add you and other people in the IETF tools team as admin on the Github.

Thank you, I think this is a good idea.  The who should be whoever 
Russ/the tools team identifies.

> Again, our goal is to give the code for free. If the Apache2 license is not suitable, let's talk: this should not be a road block.

For me personally, I think it's fine -- but I'm not the right person to 
make this call.  I think the tools team can coordinate with the IETF and 
Trust as needed on this.

> Have a nice flight back home if still in BKK for the IEEE meeting

Thanks! (unfortunately, it isn't until Thursday...)

Lou

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Sun, 11 Nov 2018 11:27:30 +0000

So, it looks like we, as engineers, are agreeing :)

Let me know if lawyers think differently

-éric

On 11/11/2018, 12:01, "Lou Berger" <[email-masked]> wrote:

    Hi Eric,

    
    
    Looking at section 4 of 

    

    
    
    Lou