Subject: [TOOLS-DEVELOPMENT] Tools Call Agenda -- 20 November 2018 at 1:00 Eastern

From: Russ Housley <[email-masked]>
Date: Tue, 13 Nov 2018 22:15:56 -0500

Tools Call Agenda -- 20 November 2018 at 1:00 Eastern

JOIN WEBEX MEETING
https://ietf.webex.com/ietf/j.php?MTID=m440dd848726339c03e605b9956e38bac
Meeting number (access code): 640 103 570
Meeting password: tools

JOIN BY PHONE
1-877-668-4493 Call-in toll free number (US/Canada) 
1-650-479-3208 Call-in toll number (US/Canada)
Meeting number (access code): 640 103 570
Meeting password: tools

1. Datatracker Projects
   - Expected Datatracker Releases -- Robert and Henrik
     -- http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan
   - GDPR Compliance -- Robert and Henrik
     -- Confirm information without opt-in has been deleted

2. Community & Other Projects
   - Discontinue MonArch email archives -- Robert and Ryan

3. RFC Services Projects
   - RFC Format Contracts -- Heather and Robert
     -- IDnits
     -- Publication Formatter
     -- Text Submission
     -- RFClint
     -- SVGcheck
     -- XMLdiff

4. Server Infrastructure
   - IESG discussions of DMARC -- Henrik and Alexey
     -- Is there any status on ARC?

5. YANG Catalog
   - Feature additions -- Eric
   - Transfer yangcatalog.org to the IETF Trust -- Eric

6. Parking Lot
   - Prepare the RFC Production Center code for publication

7. AOB

---

From: Robert Sparks <[email-masked]>
Date: Mon, 19 Nov 2018 15:57:09 -0600

Some notes:

>       -- http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan

The MergePlan is updated.

It would be good to go ahead and add 
<https://trac.tools.ietf.org/tools/ietfdb/browser/trunk/PLAN> to the 
list in the future agendas since I'm finding I consistently point people 
there anyhow.

One thing to note is the addition of work on allowing documents to 
return to "I-D exists". I've had one possible solution checked by a few 
people, but after discussion with Henrik, there's another approach we 
want to explore - I expect to have that sanity-checkable in December.

>     - Discontinue MonArch email archives -- Robert and Ryan
Waiting for cycles. We still haven't received any negative feedback to 
the message sent here: 
<https://mailarchive.ietf.org/arch/msg/ietf/89Lo0-f3aCgznBIN6_1HibbyCd4>, 
but I missed an opportunity to wave this in front of the community again 
during the Bangkok meeting. I think we can proceed with the transition 
and suggest a mid-December timeframe for doing so.
>     - RFC Format Contracts -- Heather and Robert
On track, but with some adjustments to how we are working on the 
specifications (essentially, that's been put on hold until after coding 
is complete). What remains is idnits and the PDF/a formatter. After 
visiting with Heather and the RPC, I think we may want to prioritize the 
PDF formatter in front of idnits.
>     - Prepare the RFC Production Center code for publication

There are some website related things that would be good to talk about 
on the call -

Right now, there are pages like the iesg minutes that the website points 
into www6 to serve, because there's not currently a nice way to just 
show a text file on the webserver. We can build a page that shows a text 
file (we did proof of concept work on that in Montreal), but I think we 
need to discuss a fundamental requirements question. Is it the intent 
that the website is the _only_ way to see things like the iesg minutes 
going forward, or are we still expected to support retrieving those by 
rsync (and ftp as long as that is still active)?

There are some pages that have restricted access. Do we want to do this 
with the website going forward, or should we be nudging anything that 
requires restricted access towards the datatracker, wikis, or other tools?

And a note: the website has not been redirecting to https as a rule. 
Matt will be adjusting it so that it will.

>
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Bob Hinden <[email-masked]>
Date: Tue, 20 Nov 2018 09:03:35 -0800

My regrets for today’s call.

Bob

> On Nov 13, 2018, at 7:15 PM, Russ Housley <[email-masked]> wrote:
>

---

From: Ben Campbell <[email-masked]>
Date: Tue, 20 Nov 2018 11:48:22 -0600

Apologies for the late notice, but I will be regrets today.

Ben.

> On Nov 13, 2018, at 9:15 PM, Russ Housley <[email-masked]> wrote:
>

---

From: Alexey Melnikov <[email-masked]>
Date: Tue, 20 Nov 2018 17:51:47 +0000

> Apologies for the late notice, but I will be regrets today.

Regrets from me as well.

> Email had 1 attachment:
> + signature.asc
>   1k (application/pgp-signature)

---

From: Russ Housley <[email-masked]>
Date: Tue, 20 Nov 2018 13:41:33 -0500

> Regrets from me as well.

We missed you.  Is there anything you can share on this agenda item?

>>>    -- Is there any status on ARC?

Thanks in advance,
  Russ

---

From: Matt Larson <[email-masked]>
Date: Wed, 21 Nov 2018 10:19:27 -0500

Greetings everyone,

The site now redirects http requests to https globally.

Matt

> On Nov 19, 2018, at 4:57 PM, Robert Sparks <[email-masked]> wrote:
> 
> 
> And a note: the website has not been redirecting to https as a rule. Matt will be adjusting it so that it will.
> 
> 

-------------------------------------------
Matthew Larson, Software Engineer
Association Management Solutions
Forum Management, Meeting and Event Planning
5177 Brandin Court
Fremont, CA  94538
http://www.amsl.com

Association Management Solutions
Forum Management, Meeting and Event Planning

---

From: Russ Housley <[email-masked]>
Date: Tue, 27 Nov 2018 14:35:57 -0500

>>>    -- Is there any status on ARC?

Any news on this agenda item?

Russ