Subject: [TOOLS-DEVELOPMENT] Tools Call Agenda -- 9 October 2018 at 1:00 Eastern

From: Russ Housley <[email-masked]>
Date: Sat, 6 Oct 2018 13:37:28 -0400

Tools Call Agenda -- 9 October 2018 at 1:00 Eastern

JOIN WEBEX MEETING
https://ietf.webex.com/ietf/j.php?MTID=m440dd848726339c03e605b9956e38bac
Meeting number (access code): 640 103 570
Meeting password: tools

JOIN BY PHONE
1-877-668-4493 Call-in toll free number (US/Canada) 
1-650-479-3208 Call-in toll number (US/Canada)
Meeting number (access code): 640 103 570
Meeting password: tools

1. Datatracker Projects
   - Expected Datatracker Releases -- Robert and Henrik
     -- http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan
   - GDPR Compliance -- Robert and Henrik

2. Community & Other Projects
   - Discontinue MonArch email archives -- Robert and Ryan

3. RFC Services Projects
   - RFC Format Contracts -- Heather and Robert
     -- IDnits
     -- Publication Formatter
     -- Text Submission
     -- RFClint
     -- SVGcheck
     -- XMLdiff

4. Server Infrastructure
   - IESG discussions of DMARC -- Henrik and Alexey
     -- Is there any status on ARC?
   - Is the IESG ready for non-ASCII I-Ds? -- Alexey

5. YANG Catalog
   - Feature additions -- Eric

6. Parking Lot
   - Prepare the RFC Production Center code for publication

7. AOB

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Sun, 7 Oct 2018 16:03:15 +0000

Dear all,

I am afraid that for my first participation in this monthly call, I will be in a high speed train between Paris & Belgium. Sometimes mobile communication are not that good :-( so do not be surprised if I am silent.

Talk to you next week

-éric

On 06/10/2018, 19:37, "TOOLS-DEVELOPMENT on behalf of Russ Housley" <[email-masked] on behalf of [email-masked]> wrote:

    JOIN WEBEX MEETING
    
    JOIN BY PHONE

    1. Datatracker Projects

    3. RFC Services Projects
    
    4. Server Infrastructure
    
    5. YANG Catalog
    
    6. Parking Lot
    
    7. AOB
    
    _______________________________________________
    TOOLS-DEVELOPMENT mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/tools-development

---

From: Robert Sparks <[email-masked]>
Date: Mon, 8 Oct 2018 15:00:47 -0500

Some notes.

>     - GDPR Compliance -- Robert and Henrik
The Plan and MergePlan are updated. I don't believe we have anything 
upcoming that will be surprising or need extra coordination.
>     - Discontinue MonArch email archives -- Robert and Ryan
I sent the message we worked on here to the community last week. The 
responses so far have been positive,  and it generated a new feature 
request.

Should we forward what went to ietf-announce to wg-chairs?
>     - RFC Format Contracts -- Heather and Robert
All on target - I don't think we have anything new to discuss here.
>     - Feature additions -- Eric
There are a few different things here we should track in our discussions:

a) Development of new functionality (Feature additions as above). Eric 
is helping to gather the list of items we can turn into an SoW for that.

b) Transitioning operation of the current yangcatalog to the secretariat.
     - Eric hopes we could do this by the end of the year, but if we 
need to fund more development to facilitate the transition, it will have 
to wait for 2019 funds.

c) Moving to a tools-team-driven maintenance model for the yangcatalog.

>     - Prepare the RFC Production Center code for publication
Could we, probably early in the call, talk briefly about the upcoming 
project list?

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 8 Oct 2018 22:12:09 +0200

A few additional notes:

> upcoming that will be surprising or need extra coordination.

I concur.  Some details:

Some work has been done on the group features branch, but tweaks and
bugfixes related to the GDPR mailings, Login handling, and NomCom tools
have delayed this.  A new tool to read email delivery messages and
deactivate email addresses with permanent failures has been released
and used to handle bounces from the GDPR consent request mailings.

Consent request email requests have been sent out, initial round plus 2
reminders; the last one today (Monday).  Data removal is scheduled for
the 22nd.

	Henrik

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Tue, 9 Oct 2018 06:38:33 +0000

As I will be in the Thalys train during the call: no guarantee to have a decent phone call even if I will try.

Some notes prefixed with EV>

    > 5. YANG Catalog

EV> Status of https://www.yangcatalog.org now over IPv6 ;-) but more important no more SQLite or PHP (except one remaining page), everything is Python & MySQL & Django & UWSGI. Start-up procedures are automatic, so, the server has become 'easy to operate'. All code is at: https://github.com/YangCatalog with Apache 2 license. There are still one or two bugs being ironed out by the contractor Pantheon.

EV> There are two applications from Cisco which are not open source:
- ConfD (ex tail-f) Premium which is critical as all the data is stored in its engine and NETCONF is used by some SDO to upload/modify YANG models. The Product Manager of this tool has agreed to grant IETF a free evaluation license of one year with implicit and automatic renewal.
- YangSuite which is a useful but not critical addition to yangcatalog, it is at https://ys.yangcatalog.org I am still in discussion with the team to have it either open sourced or have a free license for the IETF.

EV> The server also uses Yumaworks tool yangdump-pro to check the validity of all uploaded YANG models (in addition to other compilers such as the open source pyang of libyang). This Summer, Yumaworks has agreed to have a free download account for IETF (of course we will need to put you in direct touch with them)

EV> agreed

EV> there should be no more development to make the transition but it will take some hours of myself and someone from the secretariat I am afraid.

EV> it would be nice indeed. It currently runs on Ubuntu 18.04, 30 GB RAM (typical use 25 GB), 200 GB SSD (used at 17%), 8 cores (used at 20% peek and we are doing migration/test)