Subject: [TOOLS-DEVELOPMENT] Request for Tools Team to provide support for more flexible meeting grid

From: Eric Rescorla <[email-masked]>
Date: Sat, 29 Sep 2018 13:29:54 -0700

Hi Folks,

The Secretariat has asked for some changes to the agenda. Can you give us
some sense of the level of effort/cost/timeline for this?

The Secretariat develops the framework for each meeting, and that framework
is imposed on all 8 parallel tracks. While this works for most sessions,
there are occasionally groups that want to meet differently, e.g., ANRW,
regext and rfcweb. Several hacks have been implemented so that these
outlying sessions are captured within the overall agenda, however the
solutions are acknowledged to be imperfect. As a result, there are several
ongoing issues:

- Attendees who rely on the Datatracker version of the agenda may miss
these sessions, which are managed behind the scenes as a "non session
event" (e.g., a beverage break), and which therefore do not appear with the
other technical sessions (this happened with ANRW)
- Attendees who rely exclusively on the mobile app version of the agenda
may miss these sessions, which do not always render properly

-Ekr

---

From: Robert Sparks <[email-masked]>
Date: Sat, 29 Sep 2018 16:54:29 -0600

Hi Ekr -

We had already been exploring options here with the secretariat, have a few initial brainstorm ideas, and are planning to tackle this as part of a larger contracted project to improve the scheduling tool next year. 

One option thats looking feasible without a huge model change is to give each room its own grid. That way not all rooms have to run on the same track. This will require less disruption than moving to a completely freeform calendaring model, but will still require a big change to the way the agenda is shown, and the way external apps like the mobile app you mention handle the schedule internally. 

We’ll need to continue to brainstorm with the secretariat and build a good description of the changes we want. It’s, of course, not feasible to make a change like this before ietf103. I suspect the overall project to improve the scheduling tool will go past 104, but getting a more flexible grid (especially if a grid per room is good enough) before 104 is probably doable as an early deliverable. 

RjS

Sent from my iPhone

> On Sep 29, 2018, at 2:29 PM, Eric Rescorla <[email-masked]> wrote:
> 
> Hi Folks,
> 
> The Secretariat has asked for some changes to the agenda. Can you give us some sense of the level of effort/cost/timeline for this?
> 
> The Secretariat develops the framework for each meeting, and that framework is imposed on all 8 parallel tracks. While this works for most  sessions, there are occasionally groups that want to meet differently, e.g., ANRW, regext and rfcweb. Several hacks have been implemented so that these outlying sessions are captured within the overall agenda, however the solutions are acknowledged to be imperfect. As a result, there are several ongoing issues:
> 
> - Attendees who rely on the Datatracker version of the agenda may miss these sessions, which are managed behind the scenes as a "non session event" (e.g., a beverage break), and which therefore do not appear with the other technical sessions (this happened with ANRW)
> - Attendees who rely exclusively on the mobile app version of the agenda may miss these sessions, which do not always render properly 
> 
> -Ekr
> 
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Eric Rescorla <[email-masked]>
Date: Sat, 29 Sep 2018 15:56:36 -0700

On Sat, Sep 29, 2018 at 3:54 PM Robert Sparks <[email-masked]> wrote:

> Hi Ekr -
>
> We had already been exploring options here with the secretariat,

Great., Alexa sent me the description I had, so I figured I better pass it
along, but it's great to see you've already started.

have a few initial brainstorm ideas, and are planning to tackle this as
> part of a larger contracted project to improve the scheduling tool next
> year.
>
> One option thats looking feasible without a huge model change is to give
> each room its own grid. That way not all rooms have to run on the same
> track. This will require less disruption than moving to a completely
> freeform calendaring model, but will still require a big change to the way
> the agenda is shown, and the way external apps like the mobile app you
> mention handle the schedule internally.
>
> We’ll need to continue to brainstorm with the secretariat and build a good
> description of the changes we want. It’s, of course, not feasible to make a
> change like this before ietf103. I suspect the overall project to improve
> the scheduling tool will go past 104, but getting a more flexible grid
> (especially if a grid per room is good enough) before 104 is probably
> doable as an early deliverable.
>

That sounds great. How do things look like from a resourcing perspective?
Do you need IESG to help set priorities? something else?

-Ekr

> > The Secretariat has asked for some changes to the agenda. Can you give
> us some sense of the level of effort/cost/timeline for this?
> >
> > The Secretariat develops the framework for each meeting, and that
> framework is imposed on all 8 parallel tracks. While this works for most
> sessions, there are occasionally groups that want to meet differently,
> e.g., ANRW, regext and rfcweb. Several hacks have been implemented so that
> these outlying sessions are captured within the overall agenda, however the

---

From: Robert Sparks <[email-masked]>
Date: Sat, 29 Sep 2018 17:13:01 -0600

Sent from my iPhone

> On Sep 29, 2018, at 4:56 PM, Eric Rescorla <[email-masked]> wrote:
> 
> 
> 
> Great., Alexa sent me the description I had, so I figured I better pass it along, but it's great to see you've already started.
> 
> 
>> have a few initial brainstorm ideas, and are planning to tackle this as part of a larger contracted project to improve the scheduling tool next year. 
>> 
> That sounds great. How do things look like from a resourcing perspective? Do you need IESG to help set priorities? something else?

I expect we’ll be talking about the projects that are large enough to need funding, but have been backlogged behind the format tooling (which dominated our budget this year) over the next couple of months. I expect prioritization to fall out naturally, and the IESG will certainly be part of setting that. I anticipate the scheduler will be very high, if not first, in the list. The tools call in a couple of weeks would be good time to talk about it.

---

From: Eric Rescorla <[email-masked]>
Date: Sat, 29 Sep 2018 16:22:40 -0700

Thanks!

-Ekr

On Sat, Sep 29, 2018 at 4:13 PM Robert Sparks <[email-masked]> wrote:

>> We’ll need to continue to brainstorm with the secretariat and build a
>> good description of the changes we want. It’s, of course, not feasible to
>> make a change like this before ietf103. I suspect the overall project to
>> improve the scheduling tool will go past 104, but getting a more flexible
>> grid (especially if a grid per room is good enough) before 104 is probably
> I expect we’ll be talking about the projects that are large enough to need
> funding, but have been backlogged behind the format tooling (which
> dominated our budget this year) over the next couple of months. I expect
> prioritization to fall out naturally, and the IESG will certainly be part
> of setting that. I anticipate the scheduler will be very high, if not
> first, in the list. The tools call in a couple of weeks would be good time
> to talk about it.
>
>
> -Ekr
>
>
>> RjS
>>
>>
>> Sent from my iPhone
>>
>> > - Attendees who rely exclusively on the mobile app version of the
>> agenda may miss these sessions, which do not always render properly
>> >
>> > -Ekr
>> >