Subject: [TOOLS-DEVELOPMENT] Issue with text files in Wagtail

From: Alexa Morris <[email-masked]>
Date: Tue, 10 Jul 2018 14:50:24 -0700

Following up on this morning’s discussion, here is a bit more information about the Wagtail text file issue. As far as we can determine, there are three sets of files currently affected:

- IESG minutes
- Appeals and appeal responses
- IESG-internal docs linked from or embedded in the IESG telechat agenda (minutes to be approved, roll call, action item list); note that permission to view this is limited to those with an IESG or Secretariat role.

All of those files, even ones added or updated after the website switchover, currently live on www6 (the old site) and we are pointing to them from www7 (the new site).

If you want to upload a file in Wagtail, it will end up with a url structure like “www.ietf.org/documents/randomnumber/filename”. See https://ietf.org/documents/170/demo_text_file.txt for an example of a file I just uploaded. All documents (e.g., PDF policies, PPT presentations, IESG minutes) go into the same documents directory. The number in the URL (e.g., 170) appears to be a subdirectory for that file, with the file itself living in that subdirectory.

If it's still the case that the IETF wants to have things like minutes organized into predictable directories, say for people who are scraping minutes with their own tools, then I think this organizational structure is an issue. 

Note also that as far as I could determine, there is no way to display things uploaded to the documents directory in your browser; you must save and then open the file. However, that may be because I don't know what I'm doing... 

I'm happy to discuss this further in Montreal.

-Alexa

---

From: Russ Housley <[email-masked]>
Date: Tue, 10 Jul 2018 18:18:02 -0400

> On Jul 10, 2018, at 5:50 PM, Alexa Morris <[email-masked]> wrote:
> 

It seems to treat them like objects that can be downloaded but not displayed, like a .zip file.

If you are available at the start of the code sprint, please come talk about it.

Russ

---

From: Alexa Morris <[email-masked]>
Date: Tue, 10 Jul 2018 15:26:06 -0700

> On Jul 10, 2018, at 3:18 PM, Russ Housley <[email-masked]> wrote:
> 
> 
> 

I am, and I will!

Alexa