Subject: [TOOLS-DEVELOPMENT] Tools Call Agenda -- 12 June 2018 at 1:00 Eastern

From: Russ Housley <[email-masked]>
Date: Fri, 8 Jun 2018 11:37:33 -0400

Tools Call Agenda -- 12 June 2018 at 1:00 Eastern

JOIN WEBEX MEETING
https://ietf.webex.com/ietf/j.php?MTID=m440dd848726339c03e605b9956e38bac
Meeting number (access code): 640 103 570
Meeting password: tools

JOIN BY PHONE
1-877-668-4493 Call-in toll free number (US/Canada) 
1-650-479-3208 Call-in toll number (US/Canada)
Meeting number (access code): 640 103 570
Meeting password: tools

1. Datatracker Projects
   - Expected Datatracker Releases -- Robert and Henrik
     -- http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan
   - GDPR Compliance -- Robert and Henrik

2. Community & Other Projects
   - Discontinue MonArch email archives -- Robert and Ryan
     -- Community clearly still likes MonArch speed

3. RFC Services Projects
   - RFC Format Contracts -- Heather and Robert
     -- IDnits
     -- Publication Formatter
     -- Text Submission
     -- RFClint
     -- SVGcheck
     -- XMLdiff

4. Server Infrastructure
   - IESG discussions of DMARC -- Henrik and Alexey
     -- Deployed for all mail lists
     -- Should we transition to ARC?  If so, how do we test it?

5. Parking Lot
   - Prepare the RFC Production Center code for publication

6. AOB

---

From: Alexey Melnikov <[email-masked]>
Date: Sun, 10 Jun 2018 20:21:53 +0100

Hi Russ,

On Fri, Jun 8, 2018, at 4:37 PM, Russ Housley wrote:

>      -- Should we transition to ARC?

Yes, we should at least try it out.

>  If so, how do we test it?

Disable Henrik's workaround for a few test mailing lists (with known p=reject participants) and try to gather information about bounces from DMARC/ARC enforcing recipients (these would be observed by moderators of such mailing lists). We should also ask mailing list participants whether they are noticing any gaps in message threads.

I was also asked by Allison about status of IRTF related feature requests. Can somebody tell me where they are on the overall priority list?

Best Regards,
Alexey

---

From: Robert Sparks <[email-masked]>
Date: Sun, 10 Jun 2018 16:07:08 -0500

https://trac.tools.ietf.org/tools/ietfdb/ticket/2495

https://trac.tools.ietf.org/tools/ietfdb/ticket/2494

Here was the original list with comments:
> 1. Need to be able to do a datatracker search by IRTF state - currently
> these are not available terms in the  advanced search State pulldown
Fixed (by Mat Ford) and released
> 2. Rationalize the datatracker view when one searches "irtf" - some of
> the documents are labeled "IRTF RFC Stream," others "Active RG Document"
> - these aren't  useful as is (see attached PNG)...
This turned out to be driven by misreading what the results were. We had 
round of email with Allison and found (and deployed) ways to improve the 
way results were displayed to avoid that misreading.
>
> 3. Datatracker view when one searches "irtf" or looks at any IRTF
> document needs to show both the IRTF State and the Tags for the state -
> the tags are missing now
Still open:
https://trac.tools.ietf.org/tools/ietfdb/ticket/2494
Medium priority - not likely to get attention until a codesprint (or if 
a volunteer picks it up earlier)
>
>
> 4. Create an online ballot for the IRSG Poll for IRTF documents.
> Functions -
>    
> 4a. Create IRSG Poll ballot (IRTF Chair only)
> This is basically similar to IESG telechat ballot.
Still open:
https://trac.tools.ietf.org/tools/ietfdb/ticket/2495
Also medium priority, and not likely to get attention until a codesprint.
This one's a bit bigger task, I may end up needing to do it.

> 4b. Enter ballot position, Yes/No Objection/Not Ready/Recuse - (all IRSG 

> members)
>
> 4c. Enter comments - one kind only, no Discuss - (all IRSG members)
>
> 4d. Comments and ballot position get emailed to IRTF Chair, IRSG, RG
> Chair of group, document authors, and RG list
>
>   4e. Mark ballot complete (IRTF Chair only) - not automatic since we
> have a looser definition than IESG's
>
>   4f. Once ballot is marked complete, IRTF Chair can request conflict
> review. Need to be able to do a datatracker search by IRSG state -
> currently these are not available terms in the State pulldown
All part of 2495
>
>
> 5. Conflict Review fixes needed:
>
> 5a. Currently the conflict review request by IRTF Chair does not include
> enough notifications - email to IRTF Chair, IRSG, RG Chairs of group,
> document authors, and RG list
Fixed with https://trac.tools.ietf.org/tools/ietfdb/ticket/2496
>
> 5b. Currently a conflict review automatically assigns the document to
> the IETF Chair and sets it into the next telechat agenda.  The IETF
> Chair manually changes both of these, and we need notifications when the
> new AD assignment occurs and when the telechat agenda date is set:  same
> set as line above
Fixed with https://trac.tools.ietf.org/tools/ietfdb/ticket/2497

>
> Best Regards,
> Alexey
>
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: "Heather Flanagan (RFC Series Editor)" <[email-masked]>
Date: Mon, 11 Jun 2018 12:07:06 +0200

Hi all,

I'm at a conference in Trondheim and will not be able to make the call. 
I'm hoping the notes provide an update on the RFC Tools; I haven't heard 
anything recently outside the RPC's testing.

Thanks,
Heather

---

From: Eric Rescorla <[email-masked]>
Date: Mon, 11 Jun 2018 06:50:14 -0700

I am at Mozilla's all hands and also will likely not be able to make the
call.

---

From: Ben Campbell <[email-masked]>
Date: Tue, 12 Jun 2018 11:09:41 -0500

I need to visit yet another family member in the hospital, so regrets for me, too.

Sent from my iPhone

> On Jun 11, 2018, at 8:50 AM, Eric Rescorla <[email-masked]> wrote:
> 
> I am at Mozilla's all hands and also will likely not be able to make the call.
> 
>> On Mon, Jun 11, 2018 at 3:07 AM, Heather Flanagan (RFC Series Editor) <[email-masked]> wrote:
>> Hi all,
>> 
>> I'm at a conference in Trondheim and will not be able to make the call. I'm hoping the notes provide an update on the RFC Tools; I haven't heard anything recently outside the RPC's testing.
>> 
>> Thanks,
>> Heather
>> 
>> 
>>>       -- http://trac.tools.ietf..org/tools/ietfdb/wiki/MergePlan