Subject: Re: [TOOLS-DEVELOPMENT] Tools Call Agenda -- 8 May 2018 at 1:00 Eastern

From: Ryan Cross <[email-masked]>
Date: Tue, 5 Jun 2018 17:00:25 -0700

All,

On the last tools call I was asked to gather some metrics comparing the response times of the mail archive static pages vs. the MHonArc pages.  To do this I used httperf, https://github.com/httperf/httperf <https://github.com/httperf/httperf>, to gather stats using test runs of 24 sample URLs.  Here is a summary.

MHonArc
Request rate: 58.5 req/s (17.1 ms/req)
- very fast

Mailarchive static pages, not cached
Request rate: 2.3 req/s (431.0 ms/req)
- much slower but still under 500ms

Mailarchive static pages, cached
Request rate: 71.7 req/s (14.0 ms/req)
- faster than MHonArc

The third run is passed through Cloudflare CDN.  Real performance will vary as the first page retrieval needs to get passed to the origin server.  Subsequent retrievals are very fast.  The most recent index pages are flushed from cache any time a new message for the list arrives so they would be most susceptible to cache misses.  Older pages don’t change at all meaning good cache performance.  

See full httperf reports below.

MHonArc
Total: connections 1 requests 24 replies 24 test-duration 0.410 s

Connection rate: 2.4 conn/s (410.4 ms/conn, <=1 concurrent connections)
Connection time [ms]: min 410.4 avg 410.4 max 410.4 median 410.5 stddev 0.0
Connection time [ms]: connect 1.5
Connection length [replies/conn]: 24.000

Request rate: 58.5 req/s (17.1 ms/req)
Request size [B]: 107.0

Reply rate [replies/s]: min 0.0 avg 0.0 max 0.0 stddev 0.0 (0 samples)
Reply time [ms]: response 11.5 transfer 5.6
Reply size [B]: header 531.0 content 65421.0 footer 2.0 (total 65954.0)
Reply status: 1xx=0 2xx=24 3xx=0 4xx=0 5xx=0

CPU time [s]: user 0.15 system 0.26 (user 37.1% system 62.9% total 100.0%)
Net I/O: 3773.0 KB/s (30.9*10^6 bps)

Errors: total 0 client-timo 0 socket-timo 0 connrefused 0 connreset 0
Errors: fd-unavail 0 addrunavail 0 ftab-full 0 other 0

Mailarchive static pages, not cached
Total: connections 1 requests 24 replies 24 test-duration 10.344 s

Connection rate: 0.1 conn/s (10343.7 ms/conn, <=1 concurrent connections)
Connection time [ms]: min 10343.7 avg 10343.7 max 10343.7 median 10343.5 stddev 0.0
Connection time [ms]: connect 6.4
Connection length [replies/conn]: 24.000

Request rate: 2.3 req/s (431.0 ms/req)
Request size [B]: 100.0

Reply rate [replies/s]: min 2.2 avg 2.3 max 2.4 stddev 0.1 (2 samples)
Reply time [ms]: response 385.3 transfer 45.4
Reply size [B]: header 335.0 content 104483.0 footer 0.0 (total 104818.0)
Reply status: 1xx=0 2xx=24 3xx=0 4xx=0 5xx=0

CPU time [s]: user 4.36 system 5.98 (user 42.2% system 57.8% total 100.0%)
Net I/O: 237.7 KB/s (1.9*10^6 bps)

Errors: total 0 client-timo 0 socket-timo 0 connrefused 0 connreset 0
Errors: fd-unavail 0 addrunavail 0 ftab-full 0 other 0

Mailarchive static pages, cached
Total: connections 1 requests 24 replies 24 test-duration 0.335 s

Connection rate: 3.0 conn/s (334.9 ms/conn, <=1 concurrent connections)
Connection time [ms]: min 334.9 avg 334.9 max 334.9 median 334.5 stddev 0.0
Connection time [ms]: connect 1.4
Connection length [replies/conn]: 24.000

Request rate: 71.7 req/s (14.0 ms/req)
Request size [B]: 110.0

Reply rate [replies/s]: min 0.0 avg 0.0 max 0.0 stddev 0.0 (0 samples)
Reply time [ms]: response 4.9 transfer 8.9
Reply size [B]: header 609.0 content 104493.0 footer 2.0 (total 105104.0)
Reply status: 1xx=0 2xx=24 3xx=0 4xx=0 5xx=0

CPU time [s]: user 0.12 system 0.21 (user 36.3% system 63.6% total 100.0%)
Net I/O: 7363.2 KB/s (60.3*10^6 bps)

Errors: total 0 client-timo 0 socket-timo 0 connrefused 0 connreset 0
Errors: fd-unavail 0 addrunavail 0 ftab-full 0 other 0

> On May 9, 2018, at 12:51 PM, Ryan Cross <[email-masked]> wrote:
> 
> All,
> 
> The latest version of the mail archive is available here:
> http://mailarchivetest.ietf.org/arch/ <http://mailarchivetest.ietf.org/arch/>
> 
> The contents are not current, but a snapshot from April.  There is a new Settings menu on the top of the page.  Here you can turn Legacy mode on or off.  When legacy mode is on the user will be directed to MHonArc like pages when browsing a list by date or by thread.  These pages are cached by CloudFlare.  The URL scheme is date based, one month of messages per page.  For example:
> http://mailarchivetest.ietf.org/arch/browse/static/ietf/2018-04/ <http://mailarchivetest.ietf.org/arch/browse/static/ietf/2018-04/>
> 
> For lists with less volume, less than 750 messages a year, index pages are consolidated by year.  For example:
> http://mailarchivetest.ietf.org/arch/browse/static/nemo/2009/ <http://mailarchivetest.ietf.org/arch/browse/static/nemo/2009/>
> 
> The user can edit the URL to jump to a particular date.  Client side redirects are used when needed to map between year / month pages, based on the rules above.
> 
> Please take a look and reply with any comments or feedback.
> 
> Thank You,
> Ryan
> 
> 
>> On Apr 26, 2018, at 1:48 PM, Russ Housley <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Tools Call Agenda -- 8 May 2018 at 1:00 Eastern
>> 
>> 
>> JOIN WEBEX MEETING
>> https://ietf.webex.com/ietf/j.php?MTID=m440dd848726339c03e605b9956e38bac <https://ietf.webex.com/ietf/j.php?MTID=m440dd848726339c03e605b9956e38bac>
>> Meeting number (access code): 640 103 570
>> Meeting password: tools
>> 
>> JOIN BY PHONE
>> 1-877-668-4493 Call-in toll free number (US/Canada) 
>> 1-650-479-3208 Call-in toll number (US/Canada)
>> Meeting number (access code): 640 103 570
>> Meeting password: tools
>> 
>> 
>> 1. Datatracker Projects
>>   - Expected Datatracker Releases -- Robert and Henrik
>>     -- http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan
>>   - GDPR Compliance -- Robert and Henrik
>> 
>> 2. Community & Other Projects
>>   - Discontinue MonArch email archives -- Robert
>>     -- Community clearly still likes MonArch speed
>> 
>> 3. RFC Services Projects
>>   - RFC Format Contracts -- Heather and Robert
>>     -- IDnits
>>     -- Publication Formatter
>>     -- Text Submission
>>     -- RFClint
>>     -- SVGcheck
>>     -- XMLdiff
>> 
>> 4. Server Infrastructure
>>   - IESG discussions of DMARC -- Henrik and Alexey
>>     -- Deployed for volunteer WGs.  Is it ready for all mail lists?
>> 
>> 5. Parking Lot
>>   - Prepare the RFC Production Center code for publication
>> 
>> 6. AOB
>> 
>> _______________________________________________
>> TOOLS-DEVELOPMENT mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/tools-development
> 
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Russ Housley <[email-masked]>
Date: Wed, 6 Jun 2018 10:48:10 -0400

> The third run is passed through Cloudflare CDN.  Real performance will vary as the first page retrieval needs to get passed to the origin server.  Subsequent retrievals are very fast.  The most rec…

The first measurement is using Cloudflare as well, right?

Russ

---

From: Ryan Cross <[email-masked]>
Date: Wed, 6 Jun 2018 11:29:40 -0700

Russ,

No.  The MHonArc archives are not served through Cloudflare, due to staleness issues.

Ryan

> On Jun 6, 2018, at 7:48 AM, Russ Housley <[email-masked]> wrote:
> 
> Ryan:
> 
>> MHonArc