Subject: Re: [TOOLS-DEVELOPMENT] Tools Call Agenda -- 6 February 2018 at 1:00 Eastern

From: Ryan Cross <[email-masked]>
Date: Tue, 6 Mar 2018 10:49:23 -0800

As Henrik noted in his summary I have been working on static index pages for those who
prefer the MHonArc interface.  I am happy to demo this functionality to all who are
interested at the meeting in London.

Thanks,
Ryan

> On Feb 5, 2018, at 1:19 PM, Russ Housley <[email-masked]> wrote:
> 
> Tools Call Agenda -- 6 February 2018 at 1:00 Eastern
> 
> 
> JOIN WEBEX MEETING
> https://ietf.webex.com/ietf/j.php?MTID=m440dd848726339c03e605b9956e38bac
> Meeting number (access code): 640 103 570
> Meeting password: tools
> 
> JOIN BY PHONE
> 1-877-668-4493 Call-in toll free number (US/Canada) 
> 1-650-479-3208 Call-in toll number (US/Canada)
> Meeting number (access code): 640 103 570
> Meeting password: tools
> 
> 
> 1. Datatracker Projects
>   - Expected Datatracker Releases -- Robert and Henrik
>     -- http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan
>   - IPR changes for BCP79bis
>   - Migrate to Django 1.11
> 
> 2. Community & Other Projects
>   - Discontinue MonArch email archives -- Robert
> 
> 3. RFC Services Projects
>   - RFC Format Contracts -- Heather and Robert
>     -- IDnits
>     -- Publication Formatter
>     -- Text Submission
>     -- RFClint
>     -- SVGcheck
>     -- XMLdiff
> 
> 4. Server Infrastructure
>   - IESG discussions of DMARC -- Henrik and Alexey
>     -- Mailman upgrade
>     -- Impact on Internet-Draft-specific mail aliases
> 
> 5. Parking Lot
>   - Prepare the RFC Production Center code for publication
> 
> 6. AOB
> 
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Bob Hinden <[email-masked]>
Date: Tue, 6 Mar 2018 11:10:17 -0800

Ryan,

I would like to see it.

Thanks,
Bob

> On Mar 6, 2018, at 10:49 AM, Ryan Cross <[email-masked]> wrote:
>

---

From: Liz Flynn <[email-masked]>
Date: Tue, 6 Mar 2018 15:40:21 -0800

Hi everyone,

Here are the notes I took during today’s call. Please let me know if there’s anything I spelled wrong or didn’t understand!

1. Datatracker Projects
  - Expected Datatracker Releases -- Robert and Henrik
    -- http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan
  - Migrate to Django 1.11 -- Done
  	Henrik is now working on sanitization of uploaded html documents, expected release
this week.

2. Community & Other Projects
  - Discontinue MonArch email archives -- Robert
    -- Community clearly still likes MonArch speed
    	Ryan has started work on static pages for the new mail archive. 

3. RFC Services Projects
  - RFC Format Contracts -- Heather and Robert
    -- IDnits
    -- Publication Formatter
    -- Text Submission
    -- RFClint
    -- SVGcheck
    -- XMLdiff
    Early drops of RFClint, SVGcheck and XMLdiff are available, work is now
focused on packaging.  The first drop of the text publication formatter is
expected later this month.
Alice: Should we expect to be notified when there's a package to install?
Henrik: The first drop is not available as packages. When they are available as packages, which
I expect within a copule of weeks, you should be notified and then it's appropriate to 
install and test. 

Publication format - if Henrik pushes, he may be able to have something in your hands before the meeting
but he's not going to promise. 

4. Server Infrastructure
  - IESG discussions of DMARC -- Henrik and Alexey
  Alexey: We will need to simulate errors by posting to the mailing list for the test. I'll try to get to this on Friday.
  I will reach out to the people who I know caused problems in the past, and also use my own email address.
  We said about two weeks ago we'd do this for two weeks, so I need to send another message
  that it will be a bit more time.
  Henrik: So when this testing period is over, we can do nothing, continue with this, or 
  try to put ARC in place. ARC has a drop that in theory we should be able to deploy. We haven't
  tested it. I think we should start by test installing it on the sandbox server. 
  Alexey: Maybe we should give it a try and see what happens. We might need to talk with
  the DMARC people in London.

    -- Deployed for volunteer WGs.  Are they happy?
    -- Mail list system is too fragile.  What can be done?
		Let's discuss when more people are available.
    Deployment with a workable choice of address encoding took place on 28 March.
No feedback yet?  

5. Parking Lot

6. AOB
No AOB.

Liz Flynn
Project Manager / IETF
[email-masked]

> On Mar 6, 2018, at 11:10 AM, Bob Hinden <[email-masked]> wrote:
> 
> Ryan,
> 
> I would like to see it.
> 
> Thanks,
> Bob
>

---

From: Russ Housley <[email-masked]>
Date: Wed, 7 Mar 2018 16:25:31 -0500

The notes were for the call on march 6th (not Feb. 6th as shows in the subject line).

> On Mar 6, 2018, at 6:40 PM, Liz Flynn <[email-masked]> wrote:
> 
> 4. Server Infrastructure

The deployment was Feb. 28th, right?

Russ

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 7 Mar 2018 22:42:35 +0100

> The deployment was Feb. 28th, right?

Yes, that's right.

The logs indicate that 22 separate messages have gone through with from
address rewrite since then; here are the counts per address:

3    '"Lubashev, Igor" <[email-masked]>' to '"Lubashev, Igor" <ilubashe=[email-masked]>'
1    '"Salz, Rich" <[email-masked]>' to '"Salz, Rich" <rsalz=[email-masked]>'
1    'Benjamin Kaduk <[email-masked]>' to 'Benjamin Kaduk <bkaduk=[email-masked]>'
1    'Erik Kline <[email-masked]>' to 'Erik Kline <ek=[email-masked]>'
7    'Ian Swett <[email-masked]>' to 'Ian Swett <ianswett=[email-masked]>'
1    'Nick Banks <[email-masked]>' to 'Nick Banks <nibanks=[email-masked]>'
5    'Praveen Balasubramanian <[email-masked]>' to 'Praveen Balasubramanian <pravb=[email-masked]>'
2    'Ryan Hamilton <[email-masked]>' to 'Ryan Hamilton <rch=[email-masked]>'
1    'Victor Vasiliev <[email-masked]>' to 'Victor Vasiliev <vasilvv=[email-masked]>'

	Henrik