Subject: [TOOLS-DEVELOPMENT] Preview release of Text Submission Converter, id2xml

From: Megan Ferguson <[email-masked]>
Date: Tue, 19 Dec 2017 13:47:48 -0800

Hi Henrik,

Input file: draft-ietf-curdle-ssh-ext-info-15
id2xml version: 1.4.0
Issue: “Updates" truncation
Level: Minor
Files available: 
https://www.rfc-editor.org/rfc/v3test/draft-ietf-curdle-ssh-ext-info-15.original
https://www.rfc-editor.org/rfc/v3test/draft-ietf-curdle-ssh-ext-info-15.original.xml

Just an FYI that it looks like there is some trouble translating the “Updates” field when it contains a comma-separated list.

From .original
Updates: 4252, 4253, 4254 (if approved) 

From .xml
<rfc submissionType=“IETF" docName="draft-ietf-curdle-ssh-ext-info-15.txt" category="std" updates="4254”>

[Note - this also occurs if there is an “and” before the final value or if there is a different number of updated RFCs.]

When we removed the commas (as in the following), the xml output was correct:

Updates: 4252 4253 4254 (if approved)
or
Updates: 4252 4253 and 4254 (if approved)

Translated in xml to:

<rfc submissionType="IETF" docName="draft-ietf-curdle-ssh-ext-info-15.txt" category="std" updates="4252, 4253, 4254”>

Note - we get correct output for each of the following:

Updates: 4252 and 4253
Updates: 4252 & 4253

We will continue to manually update the comma-separated versions unless we hear from you that it can be addressed with the tool.

Happy holidays!

Megan

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 19 Dec 2017 23:39:54 +0100

Hi Megan,

On 2017-12-19 22:47, Megan Ferguson wrote:
> Just an FYI that it looks like there is some trouble translating the
> “Updates” field when it contains a comma-separated list.

Huh.  That's silly and unnecessary.  The tool should handle that better.

I've fixed this in my sources; it will be part of the next release.

Thanks for the alert!

Best regards,

	Henrik

---

From: Megan Ferguson <[email-masked]>
Date: Tue, 19 Dec 2017 18:42:30 -0800

Henrik,

Thank you for the quick turnaround!

May I add one further request that is not document specific?

We were discussing the fact that other tools include a comment mentioning the tool 
of their creation along with the date and time.

For example, the current xml2rfc output of nroff includes this comment:
.\" automatically generated by xml2rfc v2.7.0 on 2017-07-13T22:16:35Z

This would be helpful for our internal processing as we implement id2xml on more and more files.

Whenever you make your next release (obviously not high priority), would it be possible to add 
something along those lines?  

Thank you.

Megan

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 20 Dec 2017 10:26:21 +0100

Hi Megan,

> something along those lines?

Oh, certainly.  This is something I find useful, and I can't think why
I haven't already put it in there.  I've added it, and it will be part
of the next release.

Best regards,

	Henrik