Subject: Re: [TOOLS-DEVELOPMENT] Tools Call Agenda -- 5 December 2017 at 1:00 Eastern

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 5 Dec 2017 15:21:02 +0100

Some notes:

On 2017-11-29 00:03, Russ Housley wrote:
> Tools Call Agenda -- 5 December 2017 at 1:00 Eastern
> 
> 
> JOIN WEBEX MEETING
> https://ietf.webex.com/ietf/j.php?MTID=m440dd848726339c03e605b9956e38bac
> Meeting number (access code): 640 103 570
> Meeting password: tools
> 
> JOIN BY PHONE
> 1-877-668-4493 Call-in toll free number (US/Canada) 
> 1-650-479-3208 Call-in toll number (US/Canada)
> Meeting number (access code): 640 103 570
> Meeting password: tools
> 
> 
> 1. Datatracker Projects
>    - Expected Datatracker Releases -- Robert and Henrik
>      -- http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan

Updated.  The releases since last time has been related to meeting fixes,
the ietf-100 sprint, and more meeting-related fixes.  Work on an API for
IESG ballot posting is progressing in a separate branch; should be ready
for merge and release during the next week.

> 2. Community & Other Projects
>    - Discontinue MonArch email archives -- Robert
>    - IETF Website Makeover -- Greg and Russ
> 
> 3. RFC Services Projects
>    - RFC Format -- Heather and Robert
>      -- Under contract:
>         --- IDnits
>         --- Publication Formatter
>         --- Text Submission
>      -- Waiting for bids:
>         --- RFClint
>         --- SVGcheck
>         --- XMLdiff
> 
> 4. Server Infrastructure
>    - IESG discussions of DMARC -- Henrik and Alexey

Some testing remaining before workaround deployment; ready within a few
weeks.

>      -- Mailman upgrade
>      -- Impact on Internet-Draft-specific mail aliases
> 
> 5. Parking Lot
>    - Prepare the RFC Production Center code for publication
>    - Migrate to Django 1.11 after Singapore -- Henrik

Now #14 on the planned items list.  Should be brought up, as 1.10 is not
receiving security updates any more.

	Henrik

> 
> 6. AOB
> 
> 7. TMC
>   - RFC Format Bids
> 
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development
>

---

From: Heather Flanagan <[email-masked]>
Date: Tue, 5 Dec 2017 14:27:05 +0000

Regrets from me today

Sent from my iPad

> On Dec 5, 2017, at 14:21, Henrik Levkowetz <[email-masked]> wrote:
> 
> Some notes:
>

---

From: Bob Hinden <[email-masked]>
Date: Tue, 5 Dec 2017 08:03:17 -0800

I have an appointment at 9:30, will try to call in when it is done.

Bob

> On Dec 5, 2017, at 6:27 AM, Heather Flanagan <[email-masked]> wrote:
> 
> Regrets from me today
> 
> Sent from my iPad
>

---

From: Alexa Morris <[email-masked]>
Date: Tue, 5 Dec 2017 08:06:21 -0800

Hi Everyone,

Sorry to send this note out so close to today’s call but there are some IPR tooling updates that need to be prioritized and inserted into the queue. At the IETF 100 WG Chairs Forum, Jorge Contreras presented on “The Whys and Whats of bcp79bis” and out of that discussion emerged a few working group chairs feature requests. The requests are captured here: https://trac.ietf.org/trac/wgchairs/wiki/WGChairsForum and are: 

1) Update disclosure form to include fields required by BCP79bis
Right now there is one field that asks for “Patent, Serial, Publication, Registration, or Application/File number(s), Date(s) granted or applied for, Country, and any additional notes” and the information is not validated. As a result, it’s often the case that users provide only some of the information. The intent is to have fields for each of the requested bits of info.  

2) Make sure IPRs disclosures follow RFCs that update or obsolete other RFCs

3) Simplify process to update an existing disclosure and/or note if it’s no longer applicable

Jorge and I met after the session to review the online form together and Henrik joined us to discuss options. 

Can we briefly discuss on the call today so that they are inserted into the queue and prioritized appropriately?

Thanks,
Alexa

> On Nov 28, 2017, at 3:03 PM, Russ Housley <[email-masked]> wrote:
>

---

From: Ben Campbell <[email-masked]>
Date: Tue, 5 Dec 2017 10:29:09 -0600

I am on a flight arriving about when this starts. Will try to call in but may be late. 

Ben.

Sent from my iPhone

> On Dec 5, 2017, at 8:27 AM, Heather Flanagan <[email-masked]> wrote:
> 
> Regrets from me today
> 
> Sent from my iPad
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 5 Dec 2017 18:00:39 +0100

Supplementary information below:

> Can we briefly discuss on the call today so that they are inserted into the queue and prioritized appropriately?

When I provisionally entered the item to do these IPR disclosure changes
to the planned work, I placed it in position 16 in the queue.  It probably
should be moved up.  This is also the case for the Django 1.11 upgrade.

Here is an excerpt from the PLAN file as it looks at the moment, truncated
after the IPR item:

* Add an API to post IESG ballot comments

* Revisit the review tool, work through the accumulated tickets.

* Add sanitization of uploaded html documents.

* Introduce an API for Meetecho to use to associate recordings with sessions
  (and perhaps automate making copies of those videos)

* Upgrade html5lib to the latest release, the same for bleach which uses it.

* Reworked UI and refactored backend for the secretariat meeting scheduling
  tool.

* Test suite improvements.  Reduce and seek to eliminate causes of differences
  in code coverage between runs in the same and in different environments.

* Rework email sending so that all emails sent by the datatracker, except for
  logging and failure emails sent to ADMINS, are captured as a Message object.

* Polish the htmlization pages, making the style identical with
  tools.ietf.org.

* Revisit RFC author ordering and author information based on rfc-index.xml

* Revisit photo uploads: Add photo upload for people with roles.  Add
  photos to wg pages and group overview pages.

* Revisit floorplans: Add room coordinate input tool (javascript).
  Add NOC object annotation possibilities.  Add support for break areas
  on multiple floors (probably means modelling break areas the same way
  as other sessions, and removing the break_area char_field on Meeting.

* Add per-session calendar links to the session pages.

* Upgrade Django to version 1.11

* Transition to Python 3.  This will make it easier to add add support for
  internationalsed email, and also other i18n enhancements.

* Update IPR disclosure pages with 1) itemized section V, 2) use the RFC
  Updates and Obsoletes fields to add document relationships to be followed by
  IPR searches, 3) show current values in the IPR update form, and 4) show
  updates in a diff format (old/new columns).

	Henrik

---

From: Alice Russo <[email-masked]>
Date: Tue, 5 Dec 2017 10:04:41 -0800

A note re: IPR tooling request from the WG chairs forum

> 2) Make sure IPRs disclosures follow RFCs that update or obsolete other RFCs

The current tool does the right thing when searching by RFC number.  Example: searching by 5234 returns results for 7 documents (https://datatracker.ietf.org/ipr/search/?draft=&rfc=5234&submit=rfc).

Apparently it's the *intended* obsoleting (or updating) relationship that is desired. When I asked about it, Ben Campbell clarified:
> the situation we were talking about is where draft-ietf-wg-RFCXXXXbis does not automatically show disclosures against RFCXXXX. Once that RFC is published as RFCYYYY obsoleting RFCXXXX, the “obsoleted” relationship fixes the problem. But usually working groups are making IPR related decisions against the draft, not the final RFC.

Thanks,
Alice

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 5 Dec 2017 19:38:06 +0100

Hi Alice,

On 2017-12-05 19:04, Alice Russo wrote:
> The current tool does the right thing when searching by RFC number.
> Example: searching by 5234 returns results for 7 documents
> (https://datatracker.ietf.org/ipr/search/?draft=&rfc=5234&submit=rfc).
>
>
> 
Apparently it's the *intended* obsoleting (or updating) relationship that is desired. When I asked about it, Ben Campbell clarified:
>> the situation we were talking about is where
>> draft-ietf-wg-RFCXXXXbis does not automatically show disclosures
>> against RFCXXXX. Once that RFC is published as RFCYYYY obsoleting
>> RFCXXXX, the “obsoleted” relationship fixes the problem. But
>> usually working groups are making IPR related decisions against the
>> draft, not the final RFC.

Aha.  That was valuable.  Thank you.  I've updated the description in
the priority list too, in order to not loose track of this.

Best regards,

	Henrik