Subject: [TOOLS-DEVELOPMENT] Tools Call Agenda -- 7 November 2017 at 1:00 Eastern

From: Russ Housley <[email-masked]>
Date: Fri, 3 Nov 2017 13:57:34 -0400

Tools Call Agenda -- 7 November 2017 at 1:00 Eastern

JOIN WEBEX MEETING
https://ietf.webex.com/ietf/j.php?MTID=m440dd848726339c03e605b9956e38bac
Meeting number (access code): 640 103 570
Meeting password: tools

JOIN BY PHONE
1-877-668-4493 Call-in toll free number (US/Canada) 
1-650-479-3208 Call-in toll number (US/Canada)
Meeting number (access code): 640 103 570
Meeting password: tools

1. Datatracker Projects
   - Expected Datatracker Releases -- Robert and Henrik
     -- http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan
   - Volunteer Enhancements
     -- Improve NomCom feedback tools -- Robert

2. Community & Other Projects
   - Discontinue MonArch email archives -- Robert
   - IETF Website Makeover -- Greg and Russ

3. RFC Services Projects
   - RFC Format Contracts -- Heather and Robert
     -- IDnits
     -- Publication Formatter
     -- RFClint
     -- SVGcheck
     -- Text Submission
     -- XMLdiff

4. Server Infrastructure
   - IESG discussions of DMARC -- Henrik and Alexey
     -- Mailman upgrade
     -- Impact on Internet-Draft-specific mail aliases

5. Parking Lot
   - Prepare the RFC Production Center code for publication
   - Migrate to Django 1.11 after Singapore -- Henrik

6. AOB

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 6 Nov 2017 11:16:12 +0100

Some notes inline:

>      -- http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan

The merge plan has been updated.  There's been 2 feature releases and 3
bugfix releases since the last call, details here: 
https://datatracker.ietf.org/release/

>    - IESG discussions of DMARC -- Henrik and Alexey

The dmarc workaround code has been packaged, but testing has proven
difficult; have had to write a new tool for test traffic injection.
Working on this interleaved with datatracker work and meeting prep.

>      -- Impact on Internet-Draft-specific mail aliases

Aliases should be handled by the workaround code, too.

>    - Migrate to Django 1.11 after Singapore -- Henrik

Yes.  This is now item number 12 on the work plan; it can be pushed up if
desired, but most items above it seems to be more urgent.

> 
> 6. AOB
> 
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development
>

---

From: Ryan Cross <[email-masked]>
Date: Mon, 6 Nov 2017 10:13:03 -0800

> On Nov 3, 2017, at 10:57 AM, Russ Housley <[email-masked]> wrote:
> 
Working on queue of Trac issues.  Since the last call one task of note is the
effort to support Elasticsearch as the search backend for the archive.  Load
testing and some production integration issues are still outstanding on this.

---

From: Ben Campbell <[email-masked]>
Date: Tue, 7 Nov 2017 11:58:24 -0600

I am going to have to offer regrets today. Apologies for the last minute notice.

Sent from my iPhone

> On Nov 3, 2017, at 12:57 PM, Russ Housley <[email-masked]> wrote:
>