Subject: [TOOLS-DEVELOPMENT] Tools Call Agenda -- 12 SEP 2017 at 1:00 Eastern

From: Russ Housley <[email-masked]>
Date: Thu, 7 Sep 2017 12:12:08 -0400

Tools Call Agenda -- 12 SEP 2017 at 1:00 Eastern

JOIN WEBEX MEETING
https://ietf.webex.com/ietf/j.php?MTID=m440dd848726339c03e605b9956e38bac
Meeting number (access code): 640 103 570
Meeting password: tools

JOIN BY PHONE
1-877-668-4493 Call-in toll free number (US/Canada) 
1-650-479-3208 Call-in toll number (US/Canada)
Meeting number (access code): 640 103 570
Meeting password: tools

1. Datatracker Projects
   - Expected Datatracker Releases -- Robert and Henrik
     -- http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan
   - Volunteer Enhancements
     -- Submit an I-D directly from GitHub -- Robert
     -- Improve NomCom feedback tools -- Robert
   - Migrate to Django 1.11 when it is released -- Henrik

2. Community & Other Projects
   - Discontinue MonArch email archives -- Robert
   - IETF Website Makeover -- Greg and Russ

3. RFC Services Projects
   - RFC Format Contracts -- Heather and Robert
     -- IDnits
     -- Publication Formatter
     -- RFClint
     -- SVGcheck
     -- Text Submission
     -- XMLdiff

4. Server Infrastructure
   - IESG discussions of DMARC -- Robert and Alexey
     -- Mailman upgrade
     -- Impact on Internet-Draft-specific mail aliases
   - Libraries for HTML of I-Ds -- Henrik

5. Parking Lot
   - Migrate from Python 2.7 to Python 3
   - CDN support for HTML and PDF I-Ds -- Henrik
   - Migrate from MySQL to PostgreSQL -- Henrik
   - Improve infrastructure for finding and fetching artifacts -- Robert
   - Author information for very old I-Ds in the datatracker -- Robert
   - Replace I-Ds in proceedings with links to archive copy?
   - VM Architecture for Servers -- Robert
   - Add view of recent ballots by telechat
   - Allow meetecho to associate recordings with sessions as they become available
   - Mailman support for internationalized email addresses
     -- Requires Mailman 3.1, which is expected in early 2017
   - Meeting registration support for internationalized email addresses
     -- Mailman must be done first; user is added to meeting mail lists
   - Prepare the RFC Production Center code for publication

6. AOB

- - - - - - - -

7. TMC: Managing Meetecho Enhancements

8. TMC: IETF Meeting Agenda Editor (used by Secretariat)

---

From: Robert Sparks <[email-masked]>
Date: Fri, 8 Sep 2017 10:20:42 -0500

>       -- http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan
On track. Plan adjusted per discussions in Prague (and subsequent email
thread re: the scheduling tool).
>       -- Submit an I-D directly from GitHub -- Robert
Next in queue.
>       -- Improve NomCom feedback tools -- Robert
Continuing to make progress.

Of note: We've recently added code to a logged in user's edit profile 
page that shows
whether the datatracker believes they are nomcom eligible.

Recently done: 
<https://trac.tools.ietf.org/tools/ietfdb/query?status=closed&status=deployed&changetime=4+weeks+ago..now&component=nomcom%2F&owner=&group=priority&col=id&col=summary&col=component&col=status&col=type&col=priority&col=milestone&col=reporter&report=29&desc=1&order=id>

Still to do: 
<https://trac.tools.ietf.org/tools/ietfdb/query?status=assigned&status=new&status=reopened&owner=&component=nomcom%2F&group=priority&col=id&col=summary&col=component&col=status&col=type&col=priority&col=milestone&col=reporter&report=29&desc=1&order=id>

>     - Migrate to Django 1.11 when it is released -- Henrik
We should update this item since 1.11 has been released for some time.
This is on the Plan. Our best guess is it will be into next year before 
it comes to the top of the queue.
>     - Discontinue MonArch email archives -- Robert
We had 'Next steps in IETF list email archiving' thread, which pulled a 
few more bug reports and feature requests. Ryan has addressed most of 
those. There was a subthread on file-based archives. The discussion was 
not inconsistent with what the mailarchive tool exports (though there 
are still improvements needed to that export when the export is large).
I think we treat this as "in progress" still, but I don't expect it to 
move significantly (except for continued work on enhancement requests) 
in the next couple of months.
>     - RFC Format Contracts -- Heather and Robert
The ElfTools work is proceeding according to plan (with some minor 
adjustments - the text to v3 converter will be coming in a little early, 
nudging v3 to text out a couple of weeks).

The SeanTek work is greatly delayed. I've taken swags at updated dates 
(marked with * on 
<https://trac.tools.ietf.org/tools/ietfdb/wiki/FormatToolsPlan>.
>       -- Impact on Internet-Draft-specific mail aliases
I've lost track of this.
>     - Libraries for HTML of I-Ds -- Henrik
Can we declare parking lot bankruptcy? I think these are either in the 
PLAN or captured as a ticket. I think we can stop listing most, if not 
all, of these in this document? (If we need to put more detail in either 
the PLAN or an associated ticket to not lose data, we can do that).
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Alexey Melnikov <[email-masked]>
Date: Mon, 11 Sep 2017 16:07:26 +0100

> >       -- Impact on Internet-Draft-specific mail aliases

In short term, the following list of actions need to be taken:

1) Create DMARC DNS record with p=none, so that we can start collecting
reports. Who is in charge of DNS records for ietf.org domain? I can send
details separately.

2) Discuss agreement with Valimail about collecting and extracting of
DMARC reports. This will need an update for DMARC DNS record, but this
can be done later than #1).

3) Henrik, what is the status of the DMARC workaround code?

Best Regards,
Alexey

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 11 Sep 2017 17:15:18 +0200

> 3) Henrik, what is the status of the DMARC workaround code?

Waiting for hours; should be able to spend time on this during this week.

Best regards,

	Henrik

---

From: Glen <[email-masked]>
Date: Mon, 11 Sep 2017 09:18:50 -0700

> reports. Who is in charge of DNS records for ietf.org domain? I can send

I am in charge of DNS.

You can email me separately when you are ready, but please CC Russ, Robert
and Henrik as well.

Thanks,
Glen