Subject: [TOOLS-DEVELOPMENT] Tools minutes 2017-07-11

From: Liz Flynn <[email-masked]>
Date: Wed, 12 Jul 2017 09:28:37 -0700

Hi all,

Here are the minutes I captured from yesterday’s call. I’m sure I missed a lot of the technical details but I believe I captured status updates and action items. Please let me know if I missed anything. 

Tools Committee Meeting
2017-07-11 Minutes

1. Datatracker Projects
  - Expected Datatracker Releases -- Robert and Henrik
    -- http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan
    
		Releases since the last Tools call have had a large number of small,
		high-impact fixes. 
    
  - Volunteer Enhancements
    -- Submit an I-D directly from GitHub -- Robert
    		Still in queue, hoping to spend time in Prague.
    -- Improve NomCom feedback tools -- Robert
    		Have fixed the round robining bug for assignments.
  - Migrate to Django 1.11 when it is released -- Henrik
  			Still waiting, it's a few steps down on the list. 

2. Community & Other Projects
  - Discontinue MonArch email archives -- Robert
  		Haven't given this any cycles since the last call. Hoping to get feedback in Prague.
  - IETF Website Makeover -- Greg and Russ
  		We hoped to turn on beta testing on Friday, which didn't happen. One bug needs to
  		be fixed first; it has been fixed by Torchbox but has not been released yet. 

3. RFC Services Projects
  - RFC Format Contracts -- Heather and Robert
    -- IDnits
    -- Publication Formatter
    -- RFClint
    -- SVGcheck
    -- Text Submission
    -- XMLdiff
    
    Henrik has started to look at the prep tool but needs more responses on what's posted to the 
    XML to RFC database. 
    Heather: One thing I'm doing for Prague is an update for the WG Chairs lunch, I can
    remind them about this.
    Tony: I've been working on making these new tools available via the website, the 
    text to XML tool is accessible and I'm working on the B2 to B3 conversion. 
    Tony Q: I've been doing things off the experimental page on the website, should we make
    this accessible from the main page?
    Russ: The Production Center is finding ID to XML sufficiently robust to use in production; 
    if that's true it's ready for the rest of the group.
    Henrik: I think it would be reasonable to make both of the tools available on the default
    page (ID to XML, and B2 to B3).

4. Server Infrastructure
  - IESG discussions of DMARC -- Robert and Alexey
  		We asked IESG for a priority decision and never got an answer, so we decided to
  		finish the Yang work, which we've now done.
  		Ben: Alissa has asked for an update for the IESG report, but it doesn't need to be
  		this detailed. Any thoughts?
  		Robert: Essence will be that infrastructure improvements needed to test the ideas
  		we've previously discussed are in the process of completion and we expect to start
  		that testing soon, but we need to hear from Alexey to quantify that. Guess - August/
  		September.
  		
    -- Mailman upgrade
    -- Impact on Internet-Draft-specific mail aliases
  - Libraries for HTML of I-Ds -- Henrik
  			This is complete. It's a python library module and it's available to install
  			with the usual installer. Henrik will send a note to Tools-Discuss about it.

5. Parking Lot
  - Migrate from Python 2.7 to Python 3
  - CDN support for HTML and PDF I-Ds -- Henrik
  - Migrate from MySQL to PostgreSQL -- Henrik
  - Improve infrastructure for finding and fetching artifacts -- Robert
  - Author information for very old I-Ds in the datatracker -- Robert
  - Replace I-Ds in proceedings with links to archive copy?
  - VM Architecture for Servers -- Robert
  - Add view of recent ballots by telechat
  - Allow meetecho to associate recordings with sessions as they become available
  - Mailman support for internationalized email addresses
    -- Requires Mailman 3.1, which is expected in early 2017
    		Glen: If 3.1 is out I haven't found it. I will have Matt check and confirm
    		it has what we want and get started staging it. Will provide status report
    		by the next call.
  - Meeting registration support for internationalized email addresses
    -- Mailman must be done first; user is added to meeting mail lists

6. AOB

In-person meeting in Prague to review priorities?
If we can find a time.

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 12 Jul 2017 18:33:49 +0200

Hi Liz,

2 tweaks inline:

>     Henrik has started to look at the prep tool but needs more responses on what's posted to the 

	to the xml2rfc mailing list

>     page (ID to XML, and B2 to B3).

	v2 to v2 ("v2v3")

> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development
>

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Wed, 12 Jul 2017 16:49:29 +0000

Change Henrik’s nit to “v2 to v3” :)

On 7/12/17, 12:33 PM, "TOOLS-DEVELOPMENT on behalf of Henrik Levkowetz" <[email-masked] on behalf of [email-masked]> wrote:

    Hi Liz,
    
    2 tweaks inline:

    
    
    	v2 to v2 ("v2v3")

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 12 Jul 2017 19:49:56 +0200

> Change Henrik’s nit to “v2 to v3” :)

Heh.  Ack!