Subject: [TOOLS-DEVELOPMENT] Tools Call Agenda -- 11 July 2017 at 1:00 Eastern

From: Russ Housley <[email-masked]>
Date: Wed, 5 Jul 2017 11:05:35 -0400

Tools Call Agenda -- 11 July 2017 at 1:00 Eastern

JOIN WEBEX MEETING
https://ietf.webex.com/ietf/j.php?MTID=m440dd848726339c03e605b9956e38bac
Meeting number (access code): 640 103 570
Meeting password: tools

JOIN BY PHONE
1-877-668-4493 Call-in toll free number (US/Canada) 
1-650-479-3208 Call-in toll number (US/Canada)
Meeting number (access code): 640 103 570
Meeting password: tools

1. Datatracker Projects
   - Expected Datatracker Releases -- Robert and Henrik
     -- http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan
   - Volunteer Enhancements
     -- Submit an I-D directly from GitHub -- Robert
     -- Improve NomCom feedback tools -- Robert
   - Migrate to Django 1.11 when it is released -- Henrik

2. Community & Other Projects
   - Discontinue MonArch email archives -- Robert
   - IETF Website Makeover -- Greg and Russ

3. RFC Services Projects
   - RFC Format Contracts -- Heather and Robert
     -- IDnits
     -- Publication Formatter
     -- RFClint
     -- SVGcheck
     -- Text Submission
     -- XMLdiff

4. Server Infrastructure
   - IESG discussions of DMARC -- Robert and Alexey
     -- Mailman upgrade
     -- Impact on Internet-Draft-specific mail aliases
   - Libraries for HTML of I-Ds -- Henrik

5. Parking Lot
   - Migrate from Python 2.7 to Python 3
   - CDN support for HTML and PDF I-Ds -- Henrik
   - Migrate from MySQL to PostgreSQL -- Henrik
   - Improve infrastructure for finding and fetching artifacts -- Robert
   - Author information for very old I-Ds in the datatracker -- Robert
   - Replace I-Ds in proceedings with links to archive copy?
   - VM Architecture for Servers -- Robert
   - Add view of recent ballots by telechat
   - Allow meetecho to associate recordings with sessions as they become available
   - Mailman support for internationalized email addresses
     -- Requires Mailman 3.1, which is expected in early 2017
   - Meeting registration support for internationalized email addresses
     -- Mailman must be done first; user is added to meeting mail lists

6. AOB

---

From: Robert Sparks <[email-masked]>
Date: Mon, 10 Jul 2017 16:00:28 -0500

Notes for tomorrow's call

>       -- http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan
Updated.
Note that we had several releases this month touching _many_ parts of 
the tracker.
There was a focus on improving YANG checkers, dealing with submission 
edge cases, and
the issue with unfair review assignments has been addressed.
>       -- Submit an I-D directly from GitHub -- Robert
Still in queue. I think we'll make progress on this during Prague
>       -- Improve NomCom feedback tools -- Robert
Still in progress.
>     - Discontinue MonArch email archives -- Robert
Nothing new to report.
>     - RFC Format Contracts -- Heather and Robert
Work has started.
>       -- Text Submission
id2xml continues to get testing/use.
A recent xml2rfc release includes the v2 -> v3 converter.
>     - IESG discussions of DMARC -- Robert and Alexey
Alexey - is there anything to report here?
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Ben Campbell <[email-masked]>
Date: Tue, 11 Jul 2017 11:47:46 -0500

> On Jul 10, 2017, at 4:00 PM, Robert Sparks <[email-masked]> wrote:
> 
>> 4. Server Infrastructure

Alissa has asked for a status update to put in the IESG report for IETF99.

---

From: Alexey Melnikov <[email-masked]>
Date: Tue, 11 Jul 2017 18:53:03 +0100

Sorry for my rubbish WebEx access again, I got disconnected just before DMARC! I will followup with Henrik directly.

---

From: Lou Berger <[email-masked]>
Date: Tue, 11 Jul 2017 13:47:42 -0400

Hi, I guess it was a short meeting -- just tried to dial in and no one
was there ;-)

One item

On 7/10/2017 5:00 PM, Robert Sparks wrote:
> ...

Is work on the archive complete?  If so, was feedback solicited from the
community, notably those that raised complaints?  (I recall some
discussion on this from the last IETF, but thought this was a preview
and not final version.)

Thanks,
Lou

---

From: Russ Housley <[email-masked]>
Date: Tue, 11 Jul 2017 14:05:34 -0400

> Hi, I guess it was a short meeting -- just tried to dial in and no one

33 minutes.

> discussion on this from the last IETF, but thought this was a preview

Robert agreed to kick off a community discussion to confirm that the new mail archive tool is meeting out needs.

Russ

---

From: Lou Berger <[email-masked]>
Date: Tue, 11 Jul 2017 14:29:53 -0400

umm, did anyone test this on small screen/handhelds?  In my 2 min test
from chrome in a small window and on android I'm seeing a bunch of
usability issues and at least one bug...

---

From: Lou Berger <[email-masked]>
Date: Tue, 11 Jul 2017 14:30:51 -0400

> Robert agreed to kick off a community discussion to confirm that the new mail archive tool is meeting out needs.
(sent out of order)

Perfect - thanks...

Lou

---

From: Robert Sparks <[email-masked]>
Date: Tue, 11 Jul 2017 13:40:28 -0500

I asked several people do that and have been told there are some using 
it regularly (I've dropped in occasionally from my iPhone), but if 
you're finding new things (regressions perhaps?), please report them. 
The right place to do so is here:

https://trac.tools.ietf.org/tools/ietfdb/newticket

Please select the "Mail Archive: User Interface" component.

RjS

---

From: Lou Berger <[email-masked]>
Date: Tue, 11 Jul 2017 16:31:52 -0400

Ack.  Will do when I can...