Subject: Re: [TOOLS-DEVELOPMENT] Preview release of Text Submission Converter, id2xml

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 13 Jul 2017 17:47:41 +0200

Hi Megan,

There were a few questions in my latest replies in this thread which
I don't see have been answered.  Re-sending just those, starting with
the one below:

On 2017-06-29 21:49, Henrik Levkowetz wrote:
> Hi Megan,

<<snip>>

>> 2) This document uses the lowercase “defined in section x” vs. “defined in Section x”.  These are not 
>> picked up as <xref targets>.
> 
> Yees.  I tried to accept lowercase 'section x' in the draft htmlization
> script some years ago, and that increased the incidence of false markup
> considerably.
> 
> I can change this to accept also 'section' if you wish, but I would not
> advice doing so.  Would you reflect on this, and let me know if I should
> change this or keep recognising only 'Section' ?

Any guidance here?

Best regards,

	Henrik

---

From: Megan Ferguson <[email-masked]>
Date: Fri, 14 Jul 2017 09:48:56 -0700

Hi Henrik,

Thanks for the reminder!

>> change this or keep recognising only 'Section' ?

After discussing this one internally, we think best to follow your advice to only recognize “Section”.  

Thanks for your information on this!

Megan

---

From: Megan Ferguson <[email-masked]>
Date: Mon, 24 Jul 2017 15:33:55 -0700

Hi Henrik,

Input file: draft-pantos-http-live-streaming-23
Version: id2xml 1.0.3 
Issue: Punctuation in organization element in reference entries
Files available: 
https://www.rfc-editor.org/rfc/v3test/draft-pantos-http-live-streaming-23v3.original
https://www.rfc-editor.org/rfc/v3test/draft-pantos-http-live-streaming-23v3.txt
https://www.rfc-editor.org/rfc/v3test/draft-pantos-http-live-streaming-23v3.xml

1) We got the following errors in parsing references that were able to be resolved by removing any
punctuation from the organization (which served as author).  Is this something that can be resolved?

draft-pantos-http-live-streaming-23v3.txt(2997): Warning: Failed parsing a reference.  Are all elements separated by
   commas (not periods, not just spaces)?:
   [AES_128]  U.S. Department of Commerce/National Institute of
              Standards and Technology, "Advanced Encryption Standard
              (AES), FIPS PUB 197", November 2001, <http://csrc.nist
              .gov/publications/fips/fips197/fips-197.pdf>.

draft-pantos-http-live-streaming-23v3.txt(3143): Warning: Failed parsing a reference.  Are all elements separated by
   commas (not periods, not just spaces)?:
   [WebVTT]   World Wide Web Consortium (W3C), "WebVTT: The Web Video
              Text Tracks Format", July 2013,
              <http://dev.w3.org/html5/webvtt/>.

draft-pantos-http-live-streaming-23v3.txt(3155): Warning: Failed parsing a reference.  Are all elements separated by
   commas (not periods, not just spaces)?:
   [ID3]      ID3.org, "The ID3 audio file data tagging format",
              <http://www.id3.org/Developer_Information>.

draft-pantos-http-live-streaming-23v3.txt(3158): Warning: Failed parsing a reference.  Are all elements separated by
   commas (not periods, not just spaces)?:
   [M3U]      Nullsoft, Inc., "The M3U Playlist format, originally
              invented for the Winamp media player",
              <http://wikipedia.org/wiki/M3U>.

Thank you!

Megan

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 25 Jul 2017 12:16:20 +0200

Hi Megan,

> punctuation from the organization (which served as author).  Is this something that can be resolved?

The code I prepared before IETF 99, which I'll release shortly (I want to
complete all the changes I mentioned in my reply of July 13) handles all
of these except for 'Nullsoft, Inc.'.  If I change 'Nullsoft, Inc.' to
'Nullsoft Inc.', that one is handled too.

You should expect 1.0.4 to be released and available within a few days.

Best regards,

	Henrik

---

From: Megan Ferguson <[email-masked]>
Date: Tue, 25 Jul 2017 10:30:05 -0700

Hi Henrik,

Thanks for the reply.

> 'Nullsoft Inc.', that one is handled too.
MF - We will keep comma removal from these types of cases on the list of items that need manual update.

> You should expect 1.0.4 to be released and available within a few days.
MF - Great - thank you!

Megan

---

From: Megan Ferguson <[email-masked]>
Date: Tue, 25 Jul 2017 22:09:54 -0700

Hi Henrik,

Just an additional note that this document had odd handling of hyphenated items across lines.  
Some of them break in odd places and some have a space inserted that is not in the original text.  

Would you mind taking a look at the file below?

https://www.rfc-editor.org/rfc/v3test/draft-pantos-http-live-streaming-23v3-rfcdiff.html

[Perhaps this is already handled in your new version, but I realized I did not add this to my original mail regarding this document…]

Thank you!

Megan

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 26 Jul 2017 15:08:06 +0200

Hi Megan,

On 2017-07-26 07:09, Megan Ferguson wrote:
> Hi Henrik,
> 
> Just an additional note that this document had odd handling of
> hyphenated items across lines. Some of them break in odd places and
> some have a space inserted that is not in the original text.
> 

I see breaks on hyphens (which xml2rfc is set to do) and breaks after
a single hyphen at the start of a word, which looks wrong, but seems
to be the current xml2rfc behaviour.  I think we should consider that
a bug, and look at fixing xml2rfc to not do that.  However, hyphens at
the start of a word are uncommon, and from what I understand (see below)
not actually intended to be present in the current document.

Places where it looks as if a space has been inserted are places where
a long hyphenated word, such as EXT-X-STREAM-INF, has been broken at a
line ending in an incorrect way (well, at least I believe it is an
incorrect way), by placing the hyphen after the break, on the second line,
instead of making it the last character before the break.  I don't think
it makes sense to try to construct a rule which will discover this case
and deal with it correctly; it would be far to prone to make mistakes
between this case and variations on lists starting with hyphens, I think.

Example:

On page 31, line 31:

      If the value is the enumerated-string value NONE, all EXT-X
      -STREAM-INF tags MUST have this attribute with a value of NONE,
      indicating that there are no closed captions in any Variant Stream
      in the Master Playlist.  Having closed captions in one Variant
      Stream but not another can trigger playback inconsistencies.

I'd either move the hyphen up to EXT-X-, or just join the first and
second line in the input file;  id2xml and xml2rfc will deal with both
of these cases correctly, and break after the appropriate hyphen in the
output.

> [Perhaps this is already handled in your new version, but I realized I
> did not add this to my original mail regarding this document…]

Ack, good that you brought this up -- I haven't seen this case before,
and if you want a different behaviour from xml2rfc than the current one,
we should talk about it.

Best regards,

	Henrik

> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development
>