Subject: [TOOLS-DEVELOPMENT] Fyi example repo using xml2rfc cgi

From: Lou Berger <[email-masked]>
Date: Thu, 20 Jul 2017 19:01:32 +0200

See https://github.com/louberger/dlep-extensions

And

https://github.com/ietf-rtg-area-yang-arch-dt/meta-model

Lou

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Thu, 20 Jul 2017 21:15:27 +0000

On 7/20/17, 1:01 PM, "TOOLS-DEVELOPMENT on behalf of Lou Berger" <[email-masked] on behalf of [email-masked]> wrote:
    See https://github.com/louberger/dlep-extensions    
    And
    https://github.com/ietf-rtg-area-yang-arch-dt/meta-model
    Lou

Thanks Lou

Yup, the URLs found on those pages are consistent with what I’ve used myself and seen used in other places.

What would you think of replacing the URL such as 

 https://xml2rfc.tools.ietf.org/cgi-bin/xml2rfc.cgi?url=https://raw.githubusercontent.com/ietf-rtg-area-yang-arch-dt/meta-model/master/logical-network-element/draft-ietf-rtgwg-lne-model.xml&modeAsFormat=html%2Fascii

with

https://xml2rfc.tools.ietf.org/cgi-bin/github2html/ietf-rtg-area-yang-arch-dt/meta-model/master/logical-network-element/draft-ietf-rtgwg-lne-model.xml

Would that be useful?

	Tony

---

From: Lou Berger <[email-masked]>
Date: Fri, 21 Jul 2017 00:50:57 +0200

Hi tony,

On July 20, 2017 11:16:28 PM "HANSEN, TONY L" <[email-masked]> wrote:

> On 7/20/17, 1:01 PM, "TOOLS-DEVELOPMENT on behalf of Lou Berger" 
> <[email-masked] on behalf of [email-masked]> wrote:

 it's not really a material difference to me.

Thanks,

Lou

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Fri, 21 Jul 2017 02:00:07 +0000

On 7/20/17, 6:50 PM, "Lou Berger" <[email-masked]> wrote:

    Hi tony,

    

That’s fair. Thanks for your feedback.

	Tony

---

From: Lou Berger <[email-masked]>
Date: Fri, 21 Jul 2017 09:50:52 +0200

Hi Tony,
	I did think of one thing that would be good to improve related to this:
the ability to pass the results of web xml2rfc to idnits

for example, the following doesn't work:

https://tools.ietf.org/idnits?url=https://xml2rfc.tools.ietf.org/cgi-bin/xml2rfc.cgi?url=https://raw.githubusercontent.com/ietf-rtg-area-yang-arch-dt/meta-model/master/logical-network-element/draft-ietf-rtgwg-lne-model.xml&modeAsFormat=ascii

Lou

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Fri, 21 Jul 2017 13:58:26 +0000

On 7/21/17, 3:50 AM, "Lou Berger" <[email-masked]> wrote:

    Hi Tony,

    
    Lou

This is an integration problem between web xml2rfc and idnits. Idnits returns the following error:

       Unexpected file name

       The uploaded file didn't have the expected .txt extenstion.

Henrik, these are the headers that are returned from xml2rfc:

	HTTP/1.1 200 OK
	Date: Fri, 21 Jul 2017 13:22:03 GMT
	Server: Apache/2.2.22 (Debian)
	Vary: Accept-Encoding
	Transfer-Encoding: chunked
	Content-Type: text/plain; charset=ISO-8859-1

I then modified xml2rfc-dev.cgi to generate this additional header:

	Content-Disposition: inline; filename="url.txt"

But it made no difference.

What in particular is idnits looking for?

	Tony

---

From: Lou Berger <[email-masked]>
Date: Mon, 31 Jul 2017 08:42:04 -0400

Henrik,
	What are your thoughts on this?
Thanks,
Lou

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 31 Jul 2017 16:41:53 +0200

Hi Tony,

Lou just poked me on this; sorry for loosing track of it.

Inline:

> But it made no difference.

I've added support for a filename being provided with the Content-Disposition
header field; this should work now.

> What in particular is idnits looking for?

Simply the extension to which the uploaded file was saved, which was taken
from the upload form name, or the url directly, earlier.

Best regards,

	Henrik

> 	Tony
> 
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development
>

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Mon, 31 Jul 2017 15:58:22 +0000

Thank you, Henrik.

I successfully tested the new idnits with the dev version of xml2rfc.cgi. So I pushed the necessary changes out to the xml2rfc.cgi as well.

So this works now:

https://tools.ietf.org/idnits?url=https://xml2rfc.tools.ietf.org/cgi-bin/xml2rfc-dev.cgi?url=https://raw.githubusercontent.com/ietf-rtg-area-yang-arch-dt/meta-model/master/logical-network-element/draft-ietf-rtgwg-lne-model.xml&modeAsFormat=ascii

As does this shorter call:

https://tools.ietf.org/idnits?url=https://xml2rfc.tools.ietf.org/cgi-bin/github2text/ietf-rtg-area-yang-arch-dt/meta-model/master/logical-network-element/draft-ietf-rtgwg-lne-model.xml

	Tony

On 7/31/17, 10:42 AM, "Henrik Levkowetz" <[email-masked]> wrote:

    Hi Tony,

    Inline:

    

    Best regards,
    
    	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 31 Jul 2017 18:02:13 +0200

Nice! :-)

	Henrik

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Mon, 31 Jul 2017 16:08:57 +0000

:)

For those copying the URLs below, instead of this:

you should use this:

(note the “-dev” was deleted)

	Tony

On 7/31/17, 12:02 PM, "Henrik Levkowetz" <[email-masked]> wrote:

    Nice! :-)
    
    	Henrik

---

From: Lou Berger <[email-masked]>
Date: Mon, 31 Jul 2017 13:03:16 -0400

This is great! Thank you.

Now I'll have to automate checks as part of ci...

Lou

On July 31, 2017 12:09:57 PM "HANSEN, TONY L" <[email-masked]> wrote:

>     > I successfully tested the new idnits with the dev version of xml2rfc.cgi. 
>     So I pushed the necessary changes out to the xml2rfc.cgi as well.
>     >
>     > So this works now:
>     >
>     >

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Mon, 31 Jul 2017 17:52:57 +0000

It’ll be interesting seeing what you come up with for CI. I’m particularly interested on having an eye on it towards reuse.

	Tony

On 7/31/17, 1:03 PM, "Lou Berger" <[email-masked]> wrote:

    
    Lou

    On July 31, 2017 12:09:57 PM "HANSEN, TONY L" <[email-masked]> wrote:
    
    > https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_idnits-3Furl-3Dhttps-3A__xml2rfc.tools.ietf.org_cgi-2Dbin_xml2rfc-2Ddev.cgi-3Furl-3Dhttps-3A__raw.githubusercontent.com_ietf-2Drtg-2Darea-2Dyang-2Darch-2Ddt_meta-2Dmodel_master_logical-2Dnetwork-2Delement_draft-2Dietf-2Drtgwg-2Dlne-2Dmodel.xml-26modeAsFormat-3Dascii&d=DwIDaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=hOxZsFWl-FxWFgkUsBHVdrMwb5VYk7o662f_Gi0u3cc&s=1VxgfkpC57NdUoZdM488jKmeUmQTJKS9IwCZVtNuzb4&e= 
    >
    > you should use this:
    >
    > https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_idnits-3Furl-3Dhttps-3A__xml2rfc.tools.ietf.org_cgi-2Dbin_xml2rfc.cgi-3Furl-3Dhttps-3A__raw.githubusercontent.com_ietf-2Drtg-2Darea-2Dyang-2Darch-2Ddt_meta-2Dmodel_master_logical-2Dnetwork-2Delement_draft-2Dietf-2Drtgwg-2Dlne-2Dmodel.xml-26modeAsFormat-3Dascii&d=DwIDaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=hOxZsFWl-FxWFgkUsBHVdrMwb5VYk7o662f_Gi0u3cc&s=nPdoOL7br7spMxa1G27CadbyOVkxofQBxdaMbp4tI5s&e= 
    >
    >     https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_idnits-3Furl-3Dhttps-3A__xml2rfc.tools.ietf.org_cgi-2Dbin_xml2rfc-2Ddev.cgi-3Furl-3Dhttps-3A__raw.githubusercontent.com_ietf-2Drtg-2Darea-2Dyang-2Darch-2Ddt_meta-2Dmodel_master_logical-2Dnetwork-2Delement_draft-2Dietf-2Drtgwg-2Dlne-2Dmodel.xml-26modeAsFormat-3Dascii&d=DwIDaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=hOxZsFWl-FxWFgkUsBHVdrMwb5VYk7o662f_Gi0u3cc&s=1VxgfkpC57NdUoZdM488jKmeUmQTJKS9IwCZVtNuzb4&e= 
    >     >
    >     https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_idnits-3Furl-3Dhttps-3A__xml2rfc.tools.ietf.org_cgi-2Dbin_github2text_ietf-2Drtg-2Darea-2Dyang-2Darch-2Ddt_meta-2Dmodel_master_logical-2Dnetwork-2Delement_draft-2Dietf-2Drtgwg-2Dlne-2Dmodel.xml&d=DwIDaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=hOxZsFWl-FxWFgkUsBHVdrMwb5VYk7o662f_Gi0u3cc&s=d7QFknn1jl4tGSJcp7Wmouzm0-eiQ3N9rzKu1qxKZmE&e= 
    >     >
    >     > 	Tony
    >     >
    >     https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_idnits-3Furl-3Dhttps-3A__xml2rfc.tools.ietf.org_cgi-2Dbin_xml2rfc.cgi-3Furl-3Dhttps-3A__raw.githubusercontent.com_ietf-2Drtg-2Darea-2Dyang-2Darch-2Ddt_meta-2Dmodel_master_logical-2Dnetwork-2Delement_draft-2Dietf-2Drtgwg-2Dlne-2Dmodel.xml-26modeAsFormat-3Dascii&d=DwIDaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=hOxZsFWl-FxWFgkUsBHVdrMwb5VYk7o662f_Gi0u3cc&s=nPdoOL7br7spMxa1G27CadbyOVkxofQBxdaMbp4tI5s&e= 
    >     >     >
    >     >     >     Lou
    >     >     >
    >     >     >
    >     >     > https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_tools-2Ddevelopment&d=DwIDaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=hOxZsFWl-FxWFgkUsBHVdrMwb5VYk7o662f_Gi0u3cc&s=ulDT5puwELnP0Ha9sKrP3MFwXpqZRSwH8NL519otzek&e= 
    >     >     >
    >     >
    >     >
    >     >
    >
    >
    >