Subject: [TOOLS-DEVELOPMENT] Request for a datatracker change

From: Alexey Melnikov <[email-masked]>
Date: Mon, 19 Jun 2017 16:44:45 +0100

I hope this would be easy to add. This just needs to be a URL.

Begin forwarded message:

> From: Martin Thomson <[email-masked]>
> Date: 12 June 2017 at 16:41:01 BST
> To: Alexey Melnikov <[email-masked]>
> Subject: Field for drafts
> 
> Please add a link to draft metadata so that we can point to the
> github/source control for the draft.

---

From: Russ Housley <[email-masked]>
Date: Mon, 19 Jun 2017 11:26:54 -0400

Which metadata is of interest?  Is it just the information at the top of the doc page (see https://datatracker.ietf.org/doc/draft-thomson-postel-was-wrong/ for an example)?  Or, is som of the information that requires additional button clicks also of interest?

Russ

> On Jun 19, 2017, at 11:44 AM, Alexey Melnikov <[email-masked]> wrote:
> 
>> From: Martin Thomson <[email-masked] <mailto:[email-masked]>>
>> To: Alexey Melnikov <[email-masked] <mailto:[email-masked]>>

---

From: Robert Sparks <[email-masked]>
Date: Mon, 19 Jun 2017 11:03:57 -0500

I think this is asking that we have a section like "Additional URLs" for 
documents the same as we have for groups.

Am I missing the point?

RjS

On 6/19/17 10:26 AM, Russ Housley wrote:
> Which metadata is of interest?  Is it just the information at the top 
> of the doc page (see 
> https://datatracker.ietf.org/doc/draft-thomson-postel-was-wrong/ for 
> an example)?  Or, is som of the information that requires additional 
> button clicks also of interest?
>
> Russ
>
>
>> On Jun 19, 2017, at 11:44 AM, Alexey Melnikov <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>
>>> *From:* Martin Thomson <[email-masked] 
>>> <mailto:[email-masked]>>
>>> *Date:* 12 June 2017 at 16:41:01 BST
>>> *To:* Alexey Melnikov <[email-masked] 
>>> <mailto:[email-masked]>>
>>> *Subject:* *Field for drafts*
>>>
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Alexey Melnikov <[email-masked]>
Date: Mon, 19 Jun 2017 17:18:51 +0100

On Mon, Jun 19, 2017, at 05:03 PM, Robert Sparks wrote:
> I think this is asking that we have a section like "Additional URLs"
> for documents the same as we have for groups.That is my understanding. It should be editable by WG
Chairs/ADs/editors.
>> button clicks also of interest?>> 
>> Russ
>> 
>> 
>>> On Jun 19, 2017, at 11:44 AM, Alexey Melnikov
>>> <[email-masked]> wrote:>>> 
>>> 
>>>> *From:* Martin Thomson <[email-masked]>
>>>> *To:* Alexey Melnikov <[email-masked]>
>> _______________________________________________ TOOLS-DEVELOPMENT
>> mailing list [email-masked]
> _________________________________________________

---

From: Robert Sparks <[email-masked]>
Date: Mon, 19 Jun 2017 12:23:24 -0500

On 6/19/17 11:18 AM, Alexey Melnikov wrote:
>> for documents the same as we have for groups.
>>
> That is my understanding. It should be editable by WG Chairs/ADs/editors.
I'm not sure that editors should be in that set. Maybe for WG drafts, 
but for individual submissions, I expect it is too open.
>>> Which metadata is of interest?  Is it just the information at the 
>>> top of the doc page (see 
>>>> <[email-masked] <mailto:[email-masked]>> wrote:
>>>>
>>>>
>>> [email-masked] <mailto:[email-masked]>
>> [email-masked] <mailto:[email-masked]>

---

From: Alexey Melnikov <[email-masked]>
Date: Mon, 19 Jun 2017 18:37:17 +0100

Hi Robert,

>>> for documents the same as we have for groups.>> That is my understanding. It should be editable by WG
>> Chairs/ADs/editors.> I'm not sure that editors should be in that set. Maybe for WG drafts,
> but for individual submissions, I expect it is too open.This is a detail, but can you elaborate on your concern? Are you
concerned about malicious URIs?
For individual submissions it seems sensible that editors of the
document can set/change the repository URI.For WGs, I think it is Ok to leave this ability to WG chairs and ADs,
but I don't see much harm for allowing editors to do that.
Best Regards,
Alexey

>>>> https://datatracker.ietf.org/doc/draft-thomson-postel-was-wrong/
>>>> for an example)?  Or, is som of the information that requires
>>>> additional button clicks also of interest?>>>> 
>>>> Russ
>>>> 
>>>> 
>>>>> <[email-masked]> wrote:>>>>> 
>>>>>

---

From: Robert Sparks <[email-masked]>
Date: Mon, 19 Jun 2017 12:51:33 -0500

On 6/19/17 12:37 PM, Alexey Melnikov wrote:
>>>> I think this is asking that we have a section like "Additional 
>>>> URLs" for documents the same as we have for groups.
>>>>
> This is a detail, but can you elaborate on your concern? Are you 
Yes, this is a place where someone can enter an arbitrary URI and and 
arbitrary bit of descriptive text into the datatracker.
> document can set/change the repository URI.
> For WGs, I think it is Ok to leave this ability to WG chairs and ADs, 
>>>>> additional button clicks also of interest?
>>>>>
>>>>> Russ
>>>>>
>>>>>

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 19 Jun 2017 20:18:15 +0200

> documents the same as we have for groups.

Sounds right to me.  Adding this to the todo list for an upcoming release.

	Henrik

---

From: Martin Thomson <[email-masked]>
Date: Tue, 20 Jun 2017 09:05:54 +1000

It would be awesome if that page would link to
https://github.com/martinthomson/postel-was-wrong

I'm happy to provide that link in whatever way best suits, but ideally
it would be automated or able to be automated (during draft
submission, for instance).  That's all.

On 20 June 2017 at 01:26, Russ Housley <[email-masked]> wrote:
> Which metadata is of interest?  Is it just the information at the top of the
> doc page (see
> https://datatracker.ietf.org/doc/draft-thomson-postel-was-wrong/ for an
> example)?  Or, is som of the information that requires additional button
> clicks also of interest?
>
> Russ
>
>