Subject: [TOOLS-DEVELOPMENT] Tools Call Agenda -- 13 June 2017 at 1:00 Eastern

From: Russ Housley <[email-masked]>
Date: Wed, 7 Jun 2017 12:08:23 -0400

Tools Call Agenda -- 13 June 2017 at 1:00 Eastern

JOIN WEBEX MEETING
https://ietf.webex.com/ietf/j.php?MTID=m440dd848726339c03e605b9956e38bac
Meeting number (access code): 640 103 570
Meeting password: tools

JOIN BY PHONE
1-877-668-4493 Call-in toll free number (US/Canada) 
1-650-479-3208 Call-in toll number (US/Canada)
Meeting number (access code): 640 103 570
Meeting password: tools

1. Datatracker Projects
   - Expected Datatracker Releases -- Robert and Henrik
     -- http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan
   - Volunteer Enhancements
     -- Submit an I-D directly from GitHub -- Robert
     -- Improve NomCom feedback tools -- Robert
   - Migrate to Django 1.11 when it is released -- Henrik

2. Community & Other Projects
   - Discontinue MonArch email archives -- Robert
   - IETF Website Makeover -- Greg and Russ

3. RFC Services Projects
   - RFC Format Contracts -- Heather and Robert
     -- IDnits
     -- Publication Formatter
     -- RFClint
     -- SVGcheck
     -- Text Submission
     -- XMLdiff

4. Server Infrastructure
   - IESG discussions of DMARC -- Robert and Alexey
     -- Mailman upgrade
     -- Impact on Internet-Draft-specific mail aliases
   - Libraries for HTML of I-Ds -- Henrik

5. Parking Lot
   - Migrate from Python 2.7 to Python 3
   - CDN support for HTML and PDF I-Ds -- Henrik
   - Migrate from MySQL to PostgreSQL -- Henrik
   - Improve infrastructure for finding and fetching artifacts -- Robert
   - Author information for very old I-Ds in the datatracker -- Robert
   - Replace I-Ds in proceedings with links to archive copy?
   - Performance improvements and transition to Postgres -- Henrik
   - VM Architecture for Servers -- Robert
   - Add view of recent ballots by telechat
   - Allow meetecho to associate recordings with sessions as they become available
   - Mailman support for internationalized email addresses
     -- Requires Mailman 3.1, which is expected in early 2017
   - Meeting registration support for internationalized email addresses
     -- Mailman must be done first; user is added to meeting mail lists

6. AOB

---

From: Robert Sparks <[email-masked]>
Date: Tue, 13 Jun 2017 10:40:05 -0500

Notes inline:

>       -- http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan
Updated. See also 
https://trac.tools.ietf.org/tools/ietfdb/browser/trunk/PLAN
>       -- Submit an I-D directly from GitHub -- Robert
Still in queue - not started
>       -- Improve NomCom feedback tools -- Robert
In progress - lots finished and deployed.

See
<https://trac.tools.ietf.org/tools/ietfdb/query?status=closed&status=deployed&changetime=6+weeks+ago..now&component=nomcom%2F&group=priority&col=id&col=summary&col=component&col=status&col=type&col=priority&col=milestone&col=reporter&report=29&desc=1&order=id>
<https://datatracker.ietf.org/release/6.53.0/>
<https://datatracker.ietf.org/release/6.52.0/>

Of particular note: The nomcom can now collect feedback on an arbitrary 
question.

Remaining:
<https://trac.tools.ietf.org/tools/ietfdb/report/32>

>     - Discontinue MonArch email archives -- Robert
Nothing new since last call to report on this.
>     - RFC Format Contracts -- Heather and Robert
See https://trac.tools.ietf.org/tools/ietfdb/wiki/FormatToolsPlan.
The text submission converter to v2 (id2xml) is released and is in 
testing with the production center.
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Robert Sparks <[email-masked]>
Date: Tue, 13 Jun 2017 10:54:30 -0500

New things to consider:

* The review tool is unfairly assigning load to reviewers 
(https://trac.tools.ietf.org/tools/ietfdb/ticket/2305)

* The meeting scheduling tool needs some maintenance 
(https://trac.tools.ietf.org/tools/ietfdb/ticket/2313)

* Lou forwarded a request to make webex recordings of interims more 
easily available from the proceedings.

On 6/13/17 10:40 AM, Robert Sparks wrote:
> Of particular note: The nomcom can now collect feedback on an 
> arbitrary question.
>
> Remaining:

---

From: Lou Berger <[email-masked]>
Date: Tue, 13 Jun 2017 12:07:42 -0400

> easily available from the proceedings.
Thanks - the germination of this is access to interim recordings in a
non-proprietary (and multi-platform) format...

Lou