Subject: [TOOLS-DEVELOPMENT] Tools Call Agenda -- 9 May 2017 at 1:00 Eastern

From: Russ Housley <[email-masked]>
Date: Tue, 2 May 2017 14:13:38 -0400

Tools Call Agenda -- 9 May 2017 at 1:00 Eastern

JOIN WEBEX MEETING
https://ietf.webex.com/ietf/j.php?MTID=m440dd848726339c03e605b9956e38bac
Meeting number (access code): 640 103 570
Meeting password: tools

JOIN BY PHONE
1-877-668-4493 Call-in toll free number (US/Canada) 
1-650-479-3208 Call-in toll number (US/Canada)
Meeting number (access code): 640 103 570
Meeting password: tools

1. Datatracker Projects
   - Expected Datatracker Releases -- Robert and Henrik
     -- http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan
   - Volunteer Enhancements
     -- Submit an I-D directly from GitHub -- Unknown
     -- Integrate downref registry with IETF Last Call -- Russ
   - Contracts for Datatracker Enhancements -- Robert
     -- Author Statistics

2. Community & Other Projects
   - Improvements to the mail archive application -- Robert and Ryan
   - IETF Website Makeover -- Greg and Russ

3. RFC Services Projects
   - RFC Format Contracts -- Heather and Robert
     -- IDnits
     -- Publication Formatter
     -- RFClint
     -- SVGcheck
     -- Text Submission
     -- XMLdiff

4. Server Infrastructure
   - IESG discussions of DMARC -- Robert and Alexey
     -- Mailman upgrade
     -- Impact on Internet-Draft-specific mail aliases
   - Libraries for HTML of I-Ds -- Henrik

5. Parking Lot
   - Migrate to Django 1.11 when it is released -- Henrik
   - Migrate from Python 2.7 to Pyton 3
   - CDN support for HTML and PDF I-Ds -- Henrik
   - Migrate from MySQL to PostgreSQL -- Henrik
   - Discontinue MonArch email archives -- Robert
   - Improve infrastructure for finding and fetching artifacts -- Robert
   - Author information for very old I-Ds in the datatracker -- Robert
   - Replace I-Ds in proceedings with links to archive copy?
   - Performance improvements and transition to Postgres -- Henrik
   - VM Architecture for Servers -- Robert
   - Add view of recent ballots by telechat to
   - Allow meetecho to associate recordings with sessions as they become available
   - Mailman support for internationalized email addresses
     -- Requires Mailman 3.1, which is expected in early 2017
   - Meeting registration support for internationalized email addresses
     -- Mailman must be done first; user is added to meeting mail lists

6. AOB

---

From: Robert Sparks <[email-masked]>
Date: Mon, 8 May 2017 13:07:41 -0500

Notes for tomorrow's call

>       -- Submit an I-D directly from GitHub -- Unknown
Henrik and I can talk to this going forward. The status right now is 
that it's waiting for cycles - Henrik and I need to have a design 
conversation, and then follow up with Martin to make sure where we're 
going to go matches expectations.
>     - Contracts for Datatracker Enhancements -- Robert
The remaining meeting statistics portion has been added. I expect we 
will merge and deploy this soon.
Note that early testing highlights again that our older documentauthor 
information is often wrong. I've been working towards improving that for 
RFCs. What I'm learning there will inform how we try to make things 
better for older drafts.
>     - Improvements to the mail archive application -- Robert and Ryan
The project for this round of improvements is complete.
Ryan has demonstrated that the URL redirection code (for when we are 
eventually able to move away from mhonarc) is functioning correctly 
using the testlist.
>     - RFC Format Contracts -- Heather and Robert
The first deliverable for the text submission conversion tool is very 
close to ready to test.
Work on SVGcheck is still just beginning.
>       -- Impact on Internet-Draft-specific mail aliases
This is nearing the head of Henrik's queue.
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: "Heather Flanagan (RFC Series Editor)" <[email-masked]>
Date: Mon, 8 May 2017 11:47:56 -0700

> Work on SVGcheck is still just beginning.

I've also asked Sandy to report on the call what she's discovered so far
wrt testing non-ASCII characters in the existing environment.

-Heather

---

From: Sandy Ginoza <[email-masked]>
Date: Tue, 9 May 2017 09:40:46 -0700

Hi all,

> On May 8, 2017, at 11:47 AM, Heather Flanagan (RFC Series Editor) <[email-masked]> wrote:
> 
>> The first deliverable for the text submission conversion tool is very close to ready to test. 
> I've also asked Sandy to report on the call what she's discovered so far wrt testing non-ASCII characters in the existing environment.
> 
The nroff program (make file) we use reads the user's environment.  When the variable LANGUAGE is set to utf-8, nroff converts the ' and - characters (and probably some others) to their 'pretty' utf-8 equivalents.  This is the default behavior for nroff when the LANGUAGE variable is set.  Some browsers are OK with the resulting text file, as they assume utf-8 encoding when they see extended characters without explicit encoding (i.e. Google Chrome).  Other browsers assume that .txt files will be encoded with ASCII and print odd characters when they hit non-ASCII characters in a .txt file (i.e, Safari).

To continue with testing we have created a copy of our make file that produces ASCII only when the LANGUAGE variable is set to UTF-8.  I need to do more testing and understand whether it’s possible (with our current tools) to create a .txt file with UTF-8 that does not automatically convert the ‘ and - characters to their UTF-8 forms (because UTF-8 chars are only supposed to appear where needed).   I also need to see what the output looks like using the sed command Henrik provided that adds the BOM.

Talk to you all soon.

Sandy

---

From: Julian Reschke <[email-masked]>
Date: Tue, 9 May 2017 19:59:12 +0200

On 2017-05-09 18:40, Sandy Ginoza wrote:
> ...
> To continue with testing we have created a copy of our make file that
> produces ASCII only when the LANGUAGE variable is set to UTF-8.  I need
> to do more testing and understand whether it’s possible (with our
> current tools) to create a .txt file with UTF-8 that does not
> automatically convert the ‘ and - characters to their UTF-8 forms
> (because UTF-8 chars are only supposed to appear where needed).   I also
> need to see what the output looks like using the sed command Henrik
> provided that adds the BOM.
>
> Talk to you all soon.
> ...

This:

https://github.com/fish-shell/fish-shell/issues/2673#issuecomment-254925374

might be related...

---

From: Sandy Ginoza <[email-masked]>
Date: Tue, 9 May 2017 11:17:51 -0700

Hi again,

> On May 9, 2017, at 9:40 AM, Sandy Ginoza <[email-masked]> wrote:
> 
> I also need to see what the output looks like using the sed command Henrik provided that adds the BOM.
> 

Just a few additional comments on this one, as I realize that my explanation on the call may not have answered the question.

The BOM is separate from the issue regarding the make file converting characters to UTF-8.  It is related to this item in that it is a new step for us and needs to be tested before we can publish files that include UTF-8.

Thanks for the suggestion regarding having a script that converts specific UTF-8 characters back to ASCII.  The obvious ones so far have been ‘ (single quote), “ (double quote), and - (hyphen).   I’ll do some more testing to see if other characters are impacted by this conversion as well, but that may work. 

Thanks,
Sandy

---

From: Sandy Ginoza <[email-masked]>
Date: Tue, 9 May 2017 11:21:28 -0700

Thanks Julian - we’ll look into this! 

> On May 9, 2017, at 10:59 AM, Julian Reschke <[email-masked]> wrote:
>

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Tue, 9 May 2017 18:42:25 +0000

From the page Julian posted, it looks like ` (grave accent) might also be affected.
Run a test with the 95 printable characters in it and see what gets mangled.

                Tony

From: TOOLS-DEVELOPMENT <[email-masked]> on behalf of Sandy Ginoza <[email-masked]>
Date: Tuesday, May 9, 2017 at 2:17 PM
To: "Heather Flanagan (RFC Series Editor)" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [TOOLS-DEVELOPMENT] Tools Call Agenda -- 9 May 2017 at 1:00 Eastern

Hi again,

On May 9, 2017, at 9:40 AM, Sandy Ginoza <[email-masked]<mailto:[email-masked]>> wrote:

Thanks,
Sandy