Subject: [TOOLS-DEVELOPMENT] Tools Call Agenda -- 11 Apr 2017 at 1:00 Eastern

From: Russ Housley <[email-masked]>
Date: Fri, 7 Apr 2017 16:56:53 -0400

Tools Call Agenda -- 11 Apr 2017 at 1:00 Eastern

JOIN WEBEX MEETING
https://ietf.webex.com/ietf/j.php?MTID=m440dd848726339c03e605b9956e38bac
Meeting number (access code): 640 103 570
Meeting password: tools

JOIN BY PHONE
1-877-668-4493 Call-in toll free number (US/Canada) 
1-650-479-3208 Call-in toll number (US/Canada)
Meeting number (access code): 640 103 570
Meeting password: tools

1. Datatracker Projects
   - Expected Datatracker Releases -- Robert and Henrik
     -- http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan
   - Contracts for Datatracker Enhancements -- Robert
     -- Author Statistics

2. Community & Other Projects
   - Improvements to the mail archive application -- Robert and Ryan
   - IETF Website Makeover -- Greg and Russ

3. RFC Services Projects
   - RFC Format Contracts -- Heather and Robert
     -- CSS for the RFCs
     -- IDnits
     -- Publication Formatter
     -- RFClint
     -- SVGcheck
     -- Text Submission
     -- XMLdiff

4. Server Infrastructure
   - IESG discussions of DMARC -- Robert and Alexey
     -- Mailman upgrade
     -- Impact on Internet-Draft-specific mail aliases
   - Libraries for HTML of I-Ds -- Henrik

5. Parking Lot
   - Migrate to Django 1.11 when it is released -- Henrik
   - Migrate from Python 2.7 to Pyton 3
   - CDN support for HTML and PDF I-Ds -- Henrik
   - Migrate from MySQL to PostgreSQL -- Henrik
   - Discontinue MonArch email archives -- Robert
   - Improve infrastructure for finding and fetching artifacts -- Robert
   - Author information for very old I-Ds in the datatracker -- Robert
   - Replace I-Ds in proceedings with links to archive copy?
   - Performance improvements and transition to Postgres -- Henrik
   - VM Architecture for Servers -- Robert
   - Submit an I-D directly from GitHub
   - Move downref registry, and integrate with IETF LC generation
   - Add view of recent ballots by telechat to
   - Allow meetecho to associate recordings with sessions as they become available
   - Mailman support for internationalized email addresses
     -- Requires Mailman 3.1, which is expected in early 2017
   - Meeting registration support for internationalized email addresses
     -- Mailman must be done first; user is added to meeting mail lists

6. AOB

---

From: "Heather Flanagan (RFC Series Editor)" <[email-masked]>
Date: Tue, 11 Apr 2017 09:22:31 -0500

Regrets from me today, but for my updates:

>    - RFC Format Contracts -- Heather and Robert

I believe this is done until we're ready to start using it. I've gotten
the feedback needed from the community, and the only area of debate is
that hamburger menue (yes or no?)

>      -- XMLdiff

I chatted briefly with both Henrik and Sean during IETF 98, and both did
not have any questions for me. In terms of issues being recorded on the
RFC Format GitHub repository for the -bis drafts
(https://github.com/rfc-format), Julian has submitted a number of
issues, and Joe has responded to most if not all of those issues. I
still need to chat with Robert about which (if any) of those items need
to impact the work Henrik is doing.

I think Robert has more updates to offer on the progress of the
development work.

-Heather

---

From: "Ben Campbell" <[email-masked]>
Date: Tue, 11 Apr 2017 10:28:51 -0400

Regrets for me as well, due to a day-job conflict. I am in the vicinity 
of Robert, so he can grab me if my presence is needed.

Thanks!

Ben.

On 11 Apr 2017, at 10:22, Heather Flanagan (RFC Series Editor) wrote:

> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Russ Housley <[email-masked]>
Date: Tue, 11 Apr 2017 10:38:11 -0400

Heather:

Thanks.  Should the CSS be removed from the agenda for future calls?

Russ

> On Apr 11, 2017, at 10:22 AM, Heather Flanagan (RFC Series Editor) <[email-masked]> wrote:
>

---

From: "Heather Flanagan (RFC Series Editor)" <[email-masked]>
Date: Tue, 11 Apr 2017 09:44:25 -0500

Or moved to the parking lot; we may come back to this when we're closer
to testing the outputs of the format tools.

-Heather

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 11 Apr 2017 17:01:59 +0200

Some notes inline, for today's call:

>      -- http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan

I've updated the merge plan; the downref registry will come in first
thanks to Russ' work.  A release of that is expected this week.  Next
is improvements to the Yang support.

>    - Libraries for HTML of I-Ds -- Henrik

The code has been extracted and included as a module in the datatracker,
in release 6.48.0; release as a standalone library is pending, waiting
for experience with using it within the datatracker to show that it is
stable.