Subject: [TOOLS-DEVELOPMENT] Fwd: IETF Website revamp

From: Russ Housley <[email-masked]>
Date: Mon, 13 Mar 2017 16:49:19 -0400

I will provide the username and password to the test site on the call tomorrow.  It is not being included here because this mail list has a public archive.

Russ

> From: Russ Housley <[email-masked]>
> Subject: [IAB] IETF Website revamp
> Date: March 13, 2017 at 4:46:15 PM EDT
> To: IESG <[email-masked]>, IAB <[email-masked]>, IAOC <[email-masked]>
> 
> All,
> 
> As you may know, I have recently taken over from Joe Hildebrand as the designated project manager for the revamp of the IETF website.
> 
> I would like to provide a brief update on:
> 	• the status of the project,
> 	• plans for gathering review and input--particularly from the IETF community,
> 	• a timeline for moving the revamped site to production, and
> 	• a proposal for the ongoing improvement and evolution of the website.
> 
> The IAOC project page (https://iaoc.ietf.org/projects.html) will be updated shortly to include this information as well.
> 
> The current plan as foresees finishing initial build, incorporating feedback, and cutting over to production in about 7 weeks.  Additional rounds of development are expected to take place later this year to address non-critical input from the community.  In addition to ongoing maintenance, we will seek input and feedback as the website continues to evolve.
> 
> While work is still underway, you can take an initial view of the revamped website at:
> 
> 	https://www7.ietf.org
> 
> by using these credentials:
> 
> 	Username:  XXXXXXXX
> 	Password:  XXXXXXXX
> 
> Please do not share these credentials for the moment as we are still working out content and some minor bugs in the content management system before broader review.
> 
> Your review and input on the rollout plan, scheduled to begin tomorrow, is appreciated. It aims to include focused outreach to key groups, online workshops and in-person feedback opportunities at the IETF meeting in Chicago, and ongoing improvement. Further detail is provided below.
> 
> Thanks to Joe Hildebrand for his role as program manager for the vast majority of this project.  Many thanks to Greg Wood for his guidance and assistance throughout this project.
> 
> Thanks,
>  Russ Housley
> 
> = = = = = = = = = =
> 
> www.ietf.org Website Revamp Update
> 2017-03-13
> 
> RROJECT STATUS
> 
> The www.ietf.org website revamp project was undertaken per the Scope of Work (SOW) (https://iaoc.ietf.org/documents/IETF-Website-SOW-20140604-Final.pdf), which was developed by the IAOC Technology Management Committee with IETF community review and input.
> 
> In addition to being shaped by the project goals, key audiences (IETF participants, potential IETF participants, and non-participants) were interviewed to understand how a revamped IETF website could best serve them. The Community Review Committee (CRC) provided guidance to translate the goals and audience requirements into website design. The IETF Tools team created an interface that allows the www.ietf.org website to incorporate information about Working Groups, people, RFCs, and Internet-Drafts directly from the IETF Datatracker.
> 
> The IETF community was given a preview of, and solicited for input on, the site design around IETF 93. A further update was provided in June 2016 (https://www.ietf.org/blog/2016/06/www-ietf-org-revamp-update/). Since then, the revamped design has been implemented on a development server provided by the selected vendor (Torchbox, https://www.torchbox.com) using an open source content management system (Wagtail, https://www.wagtail.io). This design is currently running on an Secretariat-controlled server at https://www7.ietf.org (with restricted access).
> 
> Final bug fixing has taken longer than initially expected. However, during this time a significant amount of content has been loaded into the revamped website. Some work does remain to fine tune and complete the content transfer and fix a few final bugs found in the page templates. To help ensure consistent content, an editorial plan has been developed for the top pages of the revamped website; see
> https://docs.google.com/spreadsheets/d/1LCk9Fn2kdeJPNPg5z5yIDmHs8KM_HEKbDS4k2PVLNSo/edit?usp=sharing
> 
> A key requirement of the SOW is URL continuity to ensure well-known resources are reachable at their current (probably bookmarked) web location. This has not been implemented yet. Appropriate methods for doing so will be determined in coordination with the Secretariat and IETF Tools teams as part of moving the revamped site to production. They will be implemented when the revamped site is switched to production.
> 
> TESTING AND ROLLOUT
> 
> To test the design and gather information about how it might be improved, a plan to gather feedback has been developed. The plan matches the goals of the SOW and includes a) sharing the site with the entire IETF community prior to IETF 98, and b) gathering input from key groups. A timeline is available; see
> https://docs.google.com/spreadsheets/d/11t9A2Vfa0MVsADSZUTrm_y_7i8T2_mnh_Nk0tTKWZfI/edit
> 
> Key elements include:
> 	• Reviewing with the Community Review Committee;
> 	• Checking in with key IETF groups (Education & Mentoring directorate, Tools team, etc.);
> 	• Gathering focused feedback from key audiences outside the IETF community, and
> 	• Engaging with the IETF community through various means.
> 
> For IETF community input, online workshops similar to those conducted for the IASA 2.0 discussion are proposed. Additionally, we propose holding office hours (a table near the IETF registration desk) during IETF 98. The goal of both of these approaches is to engage the community in ways that promote dialog and allow for conversation. And, of course, the site will be shared via the usual mailing lists (and hopefully a blog entry).
> 
> Feedback will be encouraged via Github (https://github.com/ietf/www.ietf.org/issues).  This provides a method for prompting specific information about issues when the are submitted, making assignments for resolution where appropriate, and tracking progress and completion of a each raised issue. A feedback email address will also be provided in the hope that this project will not generate too much traffic on [email-masked].
> 
> TIMELINE FOR MOVING TO PRODUCTION
> 
> The proposed timeline anticipates moving to production by the first week of May 2017, pending a go/no-go decision the preceding week. This includes several rounds of “bug fixing”, which will address both content and functionality. As noted above, a key step in the move to production will be to implement URL continuity for identified items. It is important to note also that--while we anticipate all important content will be transitioned to the revamped site before cut over--even after cut over, all the content from the current website will saved should it be needed.
> 
> ONGOING IMPROVEMENT AND EVOLUTION
> 
> The 2017 budget anticipates further evolution and development of the website. It also anticipates the regular maintenance of software. There will be close coordination with the IETF Tools team to ensure ongoing improved coordination with the Datatracker and other tools. Possibilities for enhancing and improving the website further should be considered as we begin planning for 2018.
> 
>

---

From: Lou Berger <[email-masked]>
Date: Tue, 14 Mar 2017 17:40:20 -0400

Two comments:

1) second level menu popups (under:ABOUT,  TOPICS OF INTEREST,  HOW WE
WORK,  INTERNET STANDARDS) are not usable for me and are highly
frustrating.  The mouse overs trigger non-selectable  items - the items
*almost* always disappear as I try to select them.  I'm tried windows
10, Chrome Version 56.0.2924.87 and Version 57.0.2987.98,

2) I couldn't find a list of working groups under about->groups or "how
we work"->"working groups"
.
Lou

On 3/13/2017 4:49 PM, Russ Housley wrote:
> I will provide the username and password to the test site on the call
> tomorrow.  It is not being included here because this mail list has a
> public archive.
>
> Russ
>
>
>> *From: *Russ Housley <[email-masked] <mailto:[email-masked]>>
>> *Subject: **[IAB] IETF Website revamp*
>> *Date: *March 13, 2017 at 4:46:15 PM EDT
>> *To: *IESG <[email-masked] <mailto:[email-masked]>>, IAB <[email-masked]
>> <mailto:[email-masked]>>, IAOC <[email-masked] <mailto:[email-masked]>>
>>
>> All,
>>
>> As you may know, I have recently taken over from Joe Hildebrand as
>> the designated project manager for the revamp of the IETF website.
>>
>> The IAOC project page (https://iaoc.ietf.org/projects.html) will be
>> updated shortly to include this information as well.
>>
>> The current plan as foresees finishing initial build, incorporating
>> feedback, and cutting over to production in about 7 weeks.
>>  Additional rounds of development are expected to take place later
>> this year to address non-critical input from the community.  In
>> addition to ongoing maintenance, we will seek input and feedback as
>> the website continues to evolve.
>>
>> Please do not share these credentials for the moment as we are still
>> working out content and some minor bugs in the content management
>> system before broader review.
>>
>> Your review and input on the rollout plan, scheduled to begin
>> tomorrow, is appreciated. It aims to include focused outreach to key
>> groups, online workshops and in-person feedback opportunities at the
>> IETF meeting in Chicago, and ongoing improvement. Further detail is
>> provided below.
>>
>> Thanks to Joe Hildebrand for his role as program manager for the vast
>> majority of this project.  Many thanks to Greg Wood for his guidance
>> and assistance throughout this project.
>>
>> Thanks,
>>  Russ Housley
>>
>> = = = = = = = = = =
>>
>> The www.ietf.org website revamp project was undertaken per the Scope
>> of Work (SOW)
>> (https://iaoc.ietf.org/documents/IETF-Website-SOW-20140604-Final.pdf),
>> which was developed by the IAOC Technology Management Committee with
>> IETF community review and input.
>>
>> In addition to being shaped by the project goals, key audiences (IETF
>> participants, potential IETF participants, and non-participants) were
>> interviewed to understand how a revamped IETF website could best
>> serve them. The Community Review Committee (CRC) provided guidance to
>> translate the goals and audience requirements into website design.
>> The IETF Tools team created an interface that allows the www.ietf.org
>> website to incorporate information about Working Groups, people,
>> RFCs, and Internet-Drafts directly from the IETF Datatracker.
>>
>> The IETF community was given a preview of, and solicited for input
>> on, the site design around IETF 93. A further update was provided in
>> June 2016
>> (https://www.ietf.org/blog/2016/06/www-ietf-org-revamp-update/).
>> Since then, the revamped design has been implemented on a development
>> server provided by the selected vendor (Torchbox,
>> https://www.torchbox.com) using an open source content management
>> system (Wagtail, https://www.wagtail.io). This design is currently
>> running on an Secretariat-controlled server at https://www7.ietf.org
>> (with restricted access).
>>
>> Final bug fixing has taken longer than initially expected. However,
>> during this time a significant amount of content has been loaded into
>> the revamped website. Some work does remain to fine tune and complete
>> the content transfer and fix a few final bugs found in the page
>> templates. To help ensure consistent content, an editorial plan has
>> been developed for the top pages of the revamped website; see
>> A key requirement of the SOW is URL continuity to ensure well-known
>> resources are reachable at their current (probably bookmarked) web
>> location. This has not been implemented yet. Appropriate methods for
>> doing so will be determined in coordination with the Secretariat and
>> IETF Tools teams as part of moving the revamped site to production.
>> They will be implemented when the revamped site is switched to
>> production.
>>
>> TESTING AND ROLLOUT
>>
>> To test the design and gather information about how it might be
>> improved, a plan to gather feedback has been developed. The plan
>> matches the goals of the SOW and includes a) sharing the site with
>> the entire IETF community prior to IETF 98, and b) gathering input
>> from key groups. A timeline is available; see
>> For IETF community input, online workshops similar to those conducted
>> for the IASA 2.0 discussion are proposed. Additionally, we propose
>> holding office hours (a table near the IETF registration desk) during
>> IETF 98. The goal of both of these approaches is to engage the
>> community in ways that promote dialog and allow for conversation.
>> And, of course, the site will be shared via the usual mailing lists
>> (and hopefully a blog entry).
>>
>> Feedback will be encouraged via Github
>> (https://github.com/ietf/www.ietf.org/issues).  This provides a
>> method for prompting specific information about issues when the are
>> submitted, making assignments for resolution where appropriate, and
>> tracking progress and completion of a each raised issue. A feedback
>> email address will also be provided in the hope that this project
>> will not generate too much traffic on [email-masked].
>>
>> The proposed timeline anticipates moving to production by the first
>> week of May 2017, pending a go/no-go decision the preceding week.
>> This includes several rounds of “bug fixing”, which will address both
>> content and functionality. As noted above, a key step in the move to
>> production will be to implement URL continuity for identified items.
>> It is important to note also that--while we anticipate all important
>> content will be transitioned to the revamped site before cut
>> over--even after cut over, all the content from the current website
>> will saved should it be needed.
>>
>> The 2017 budget anticipates further evolution and development of the
>> website. It also anticipates the regular maintenance of software.
>> There will be close coordination with the IETF Tools team to ensure
>> ongoing improved coordination with the Datatracker and other tools.
>> Possibilities for enhancing and improving the website further should
>> be considered as we begin planning for 2018.
>>
>>
>
>
>
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Greg Wood <[email-masked]>
Date: Tue, 14 Mar 2017 17:45:57 -0400

Hi Lou,

First, thanks for taking a look.

> On Mar 14, 2017, at 5:40 PM, Lou Berger <[email-masked]> wrote:
> 
> Two comments:
> 

Thanks for reporting this. We’ll look into and figure it out.

> we work"->"working groups”

You are absolutely correct. As I mentioned on the call, the content is still being built out, so there are significant gaps. In fact some of the placeholder content is just wrong at this point.) The plan is to have these filled out by the end of this week.

A general note: For things that are directly maintained in datatracker, like lists of working groups, the strong preference will be to simply point to datatracker.

-Greg

>>> *From: *Russ Housley <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>>
>>> *To: *IESG <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>>, IAB <[email-masked] <mailto:[email-masked]>
>>> <mailto:[email-masked] <mailto:[email-masked]>>>, IAOC <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>>
>>> 
>>> All,
>>> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/tools-development <https://www.ietf.org/mailman/listinfo/tools-development>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/tools-development <https://www.ietf.org/mailman/listinfo/tools-development>

---

From: Lou Berger <[email-masked]>
Date: Tue, 14 Mar 2017 18:07:28 -0400

On 3/14/2017 5:45 PM, Greg Wood wrote:
> ...
> You are absolutely correct. As I mentioned on the call, the content is
> still being built out, so there are significant gaps. In fact some of
> the placeholder content is just wrong at this point.) The plan is to
> have these filled out by the end of this week.
>
understood.

> A general note: For things that are directly maintained in
> datatracker, like lists of working groups, the strong preference will
> be to simply point to datatracker.
That would be great.  I was surprised to *not* find such a link for WGs
somewhere obvious -- I did find it under contacts which was odd and
unexpected...
Thanks
Lou

>>>> *From: *Russ Housley <[email-masked]
>>>> <mailto:[email-masked]> <mailto:[email-masked]>>
>>>> *To: *IESG <[email-masked]
>>>> <mailto:[email-masked]> <mailto:[email-masked]>>, IAB <[email-masked]
>>>> <mailto:[email-masked]>
>>>> <mailto:[email-masked]>>, IAOC <[email-masked]
>>>> <mailto:[email-masked]> <mailto:[email-masked]>>
>>>>
>>>> All,
>>>>