Subject: [TOOLS-DEVELOPMENT] Tools Call Agenda -- 14 Mar 2017 at 1:00 Eastern

From: Russ Housley <[email-masked]>
Date: Mon, 13 Mar 2017 10:34:06 -0400

Tools Call Agenda -- 14 Mar 2017 at 1:00 Eastern

JOIN WEBEX MEETING
https://ietf.webex.com/ietf/j.php?MTID=m440dd848726339c03e605b9956e38bac
Meeting number (access code): 640 103 570
Meeting password: tools

JOIN BY PHONE
1-877-668-4493 Call-in toll free number (US/Canada) 
1-650-479-3208 Call-in toll number (US/Canada)
Meeting number (access code): 640 103 570
Meeting password: tools

1. Datatracker Projects
   - Expected Datatracker Releases -- Robert and Henrik
     -- http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan
   - Contracts for Datatracker Enhancements -- Robert
     -- Author Statistics

2. Community & Other Projects
   - Improvements to the mail archive application -- Robert and Ryan
   - IETF Website Makeover -- Greg and Russ

3. RFC Services Projects
   - RFC Format Contracts -- Heather and Robert
     -- CSS for the RFCs
     -- IDnits
     -- Publication Formatter
     -- RFClint
     -- SVGcheck
     -- Text Submission
     -- XMLdiff

4. Server Infrastructure
   - IESG discussions of DMARC -- Robert and Ben
     -- Mailman upgrade
     -- Impact on Internet-Draft-specific mail aliases
   - Finish cleanup from migration to Django 1.10 -- Henrik
   - Libraries for HTML of I-Ds -- Henrik

5. Parking Lot
   - Migrate to Django 1.11 when it is released -- Henrik
   - Migrate from Python 2.7 to Pyton 3
   - CDN support for HTML and PDF I-Ds -- Henrik
   - Migrate from MySQL to PostgreSQL -- Henrik
   - Discontinue MonArch email archives -- Robert
   - Improve infrastructure for finding and fetching artifacts -- Robert
   - Author information for very old I-Ds in the datatracker -- Robert
   - Replace I-Ds in proceedings with links to archive copy?
   - Performance improvements and transition to Postgres -- Henrik
   - VM Architecture for Servers -- Robert
   - Submit an I-D directly from GitHub
   - Move downref registry , and integrate with IETF LC generation
   - Add view of recent ballots by telechat to
   - Allow meetecho to associate recordings with sessions as they become available
   - Mailman support for internationalized email addresses
     -- Requires Mailman 3.1, which is expected in early 2017
   - Meeting registration support for internationalized email addresses
     -- Mailman must be done first; user is added to meeting mail lists

6. AOB

---

From: Jari Arkko <[email-masked]>
Date: Mon, 13 Mar 2017 16:46:33 +0200

Regrets. In flight.

Jari

---

From: "Heather Flanagan (RFC Series Editor)" <[email-masked]>
Date: Mon, 13 Mar 2017 07:52:27 -0700

>    - RFC Format Contracts -- Heather and Robert

I'd like to add a general update on RPC programming efforts.

-hf

---

From: Russ Housley <[email-masked]>
Date: Mon, 13 Mar 2017 11:08:57 -0400

Ok.  I’ll add it before the RFC Format item.

Russ

> On Mar 13, 2017, at 10:52 AM, Heather Flanagan (RFC Series Editor) <[email-masked]> wrote:
> 
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Robert Sparks <[email-masked]>
Date: Mon, 13 Mar 2017 11:18:44 -0500

Notes inline for tomorrow's call

>       -- http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan
Please also note the 6 fairly large releases since the last call.
>     - Contracts for Datatracker Enhancements -- Robert
Progressing well. Charts and stats for authors and documents are done. 
There are known issues with quality of the author data, particularly for 
older drafts - we are investigating how to improve that. Russ and the 
secretariat are working on how to put appropriately anonymized meeting 
attendance data into the datatracker - adding charts and stats for that 
data will not take long once the form of the data is known.
>     - RFC Format Contracts -- Heather and Robert
Significant progress has been made on the text to xml2rfc converter.
Work on svgcheck is just starting.
I have a preliminary roadmap for the remaining items at
<https://trac.tools.ietf.org/tools/ietfdb/wiki/FormatToolsPlan>
I am still vetting the dates there with the contractors, so expect them 
to change some.
>     - IESG discussions of DMARC -- Robert and Ben
I don't think we'll have anything to discuss on this on the call. The 
plan hasn't changed since we discussed it last. The first big 
precondition step (OS upgrade with mailman upgrade) will be happening 
this week.
>     - Migrate from Python 2.7 to Pyton 3
That one should come out of the parking lot. We should start planning 
for the impact on other parts of the system, particularly the imap 
server and codestand.
>       -- Mailman must be done first; user is added to meeting mail lists
I don't think we need to discuss anything about it on the call, but it 
would be very good for everyone here to pay attention to the thread 
Benoit has started on this list about managing things like yang models 
going forward.