Subject: [TOOLS-DEVELOPMENT] Tools Call Agenda -- 14 Feb 2017 at 1:00 Eastern

From: Russ Housley <[email-masked]>
Date: Sun, 12 Feb 2017 06:58:48 -0500

Tools Call Agenda -- 14 Feb 2017 at 1:00 Eastern

1. Datatracker Projects
   - Expected Datatracker Releases -- Robert and Henrik
     -- http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan
   - Contracts for Datatracker Enhancements -- Robert
     -- Author Statistics

2. Community & Other Projects
   - Improvements to the mail archive application -- Robert and Ryan
   - IETF Website Makeover -- Greg and Joe

3. RFC Services Projects
   - Contracts for Improvements to RFC Services -- Heather and Robert
     -- CSS for the RFCs
     -- IDnits
     -- Publication Formatter
     -- RFClint
     -- SVGcheck
     -- Text Submission
     -- XMLdiff

4. Server Infrastructure
   - IESG discussions of DMARC -- Robert and Ben
     -- Mailman upgrade
     -- Impact on Internet-Draft-specific mail aliases
   - Migrate toward Django 1.9 and 1.10 -- Henrik
   - Libraries for HTML of I-Ds -- Henrik

5. Parking Lot
   - CDN support for HTML and PDF I-Ds -- Henrik
   - Migrate from MySQL to PostgreSQL -- Henrik
   - Discontinue MonArch email archives -- Robert
   - Improve infrastructure for finding and fetching artifacts -- Robert
   - Author information for very old I-Ds in the datatracker -- Robert
   - Replace I-Ds in proceedings with links to archive copy?
   - Performance improvements and transition to Postgres -- Henrik
   - VM Architecture for Servers -- Robert
   - Submit an I-D directly from GitHub
   - Move downref registry , and integrate with IETF LC generation
   - Add view of recent ballots by telechat to
   - Allow meetecho to associate recordings with sessions as they become available
   - Mailman support for internationalized email addresses
     -- Requires Mailman 3.1, which is expected in early 2017
   - Meeting registration support for internationalized email addresses
     -- Mailman must be done first; user is added to meeting mail lists

6. AOB

== == == == == == ==

TMC will discuss the RFP responses after the tools call.

---

From: Greg Wood <[email-masked]>
Date: Tue, 14 Feb 2017 09:57:02 -0500

Apologies, I have a conflict with the IETF meeting team call at exactly the same time so won’t make the call today. An update below.

> On Feb 12, 2017, at 6:58 AM, Russ Housley <[email-masked]> wrote:
> 

Update on IETF Website revamp project

Following a conversation I had with TBX on Thursday, Joe and I discussed the status of the website revamp on Friday.

Issues

1) Fixing front-end bugs: Blocking community review process
There are several outstanding bugs with templates (filed on Codebase) that TBX acknowledge and agree to fix. However, they have had a resource shortage (sysadmin time to prep for frontender fixing) that is preventing the fixes from happening. They expect to have a new sysadmin on board this week and are expecting these fixes to be ready for deployment by the end of the week (17 Feb). 

The implication of the delay in getting these resolved from our end is that the front-end bugs won’t allow proper community review of the content—that is the presentation will be sufficiently broken to be distracting from the testing/review we want to undertake. Given past delays, we are waiting to move forward with scheduling reviews until these are definitely resolved.

2) Addressing resource consumption (Elasticsearch): Blocking final deployment 
Again, the constraint is sysadmin time at TBX to liaise with Glen and team to find a solution. In this case, it will take some time for the new sysadmin (expected to start Monday) to become familiar with the issue and to develop/propose fixes for it. The expectation from TBX is that this will take ~3 weeks after the new sysadmin starts. 

While this is not a blocker for content testing, the same caveat about needing to actually have a solution in hand before counting on it applies.

Work this week:

A) Continue to refine content, processes and documentation on the revamped site

B) Reset community review timing/cycle once fixes from TBX are confirmed.

C) Continue work on content conversion and process documentation

D) Confirm ability of and method for Wagtail to “alias in” old directories from the old website (e.g. https://www.ietf.org/proceedings/ <https://www.ietf.org/proceedings/>)

E) Develop master list of required aliases.

-Greg

> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development