Subject: Re: [TOOLS-DEVELOPMENT] Differences in thread view in archives

From: Ryan Cross <[email-masked]>
Date: Wed, 25 Jan 2017 10:13:23 -0800

Hi Lou,

This issue should be resolved now.

Thanks,
Ryan

> On Dec 16, 2016, at 3:11 AM, Lou Berger <[email-masked]> wrote:
> 
> Thanks ryan.  It looks better.
> 
> The "next" navigation is broken at least in mobile view
> 
> 1) go to wg
> 2) select thread view
> 3) select last message
> 4) navigate to message via arrow
>   Question: is there a reason to being able to select message without navigating the link?
> 5) select thread view at bottom of message
> 6) select next at bottom of list
> 
> Result is you end up back on the same page.
> 
> Lou
> 
> 
> On December 15, 2016 5:47:50 PM Ryan Cross <[email-masked]> wrote:
> 
>> I identified an issue with some recent messages that were sent to more then one
>> IETF list not being indented properly in the thread view.  This problem has been resolved.
>> 
>> Regards,
>> Ryan
>> 
>>> On Dec 13, 2016, at 3:32 PM, Ryan Cross <[email-masked]> wrote:
>>> 
>>> Hi Lou,
>>> 
>>> I would expect the new archive tool to have a thread view more in line with that
>>> displayed in MHonArc.  I am not sure why some messages aren’t being indented but
>>> I will investigate.  Thank you for reporting this issue.
>>> 
>>> Regards,
>>> Ryan
>>> 
>>>> On Dec 13, 2016, at 3:09 PM, Lou Berger <[email-masked]> wrote:
>>>> 
>>>> Hi,
>>>> 
>>>>  I took a quick look at the thread view in the new archive tool and
>>>> am a bit confused at what I'm seeing.  I'm comparing:
>>>> 
>>>> 
>>>> https://mailarchive.ietf.org/arch/search/?email_list=netconf&gbt=1&q=netmod+wg
>>>> 
>>>> 
>>>> and
>>>> 
>>>>  https://www.ietf.org/mail-archive/web/netmod/current/threads.html
>>>> 
>>>> The latter provides threading that is pretty aligned with what you'd see
>>>> in a mailer thread view (and what folks used to see).  The former has
>>>> threading for some messages but not others, as an example check out how
>>>> the following shows in both:
>>>> 
>>>> * /Subject/: Re: [netmod] [Netconf] WG adoption poll
>>>>  draft-nmdsdt-netmod-revised-datastores-00
>>>> * /From/: Andy Bierman <andy at yumaworks.com <mailto:[email-masked]>>
>>>> * /Date/: Tue, 13 Dec 2016 13:51:50 -0800
>>>> 
>>>> Is the current view expected behavior and if so can someone explain
>>>> what's going on.  (If not, where's the right place to open a ticket?)
>>>> 
>>>> Thanks,
>>>> 
>>>> Lou
>>>> 
>>>> 
>>>> _______________________________________________
>>>> TOOLS-DEVELOPMENT mailing list
>>>> [email-masked]
>>>> https://www.ietf.org/mailman/listinfo/tools-development
>>> 
>>> _______________________________________________
>>> TOOLS-DEVELOPMENT mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/tools-development
>> 
>> 
> 
>

---

From: Lou Berger <[email-masked]>
Date: Wed, 25 Jan 2017 14:06:25 -0500

Ryan,
the next problem does indeed appear fixed - thanks. 

navigation still takes a double tap depending on where you touch/click...

Thanks,
Lou

---

From: Ryan Cross <[email-masked]>
Date: Wed, 25 Jan 2017 13:01:05 -0800

Hi Lou,

In mobile view, the entire subject text should be a clickable link to navigate to the
message details.  In desktop view you can navigate by double-clicking the row
or using the arrow icon.  Note, this is by design, so that single clicking the row
will load the message content in the preview pane below.  Is your experience 
different than this?

Thanks,
Ryan

> On Jan 25, 2017, at 11:06 AM, Lou Berger <[email-masked]> wrote:
> 
> 
> Ryan,