Subject: [TOOLS-DEVELOPMENT] Tools Call Agenda -- 13 Dec 2016 at 1:00 Eastern

From: Russ Housley <[email-masked]>
Date: Mon, 5 Dec 2016 10:38:15 -0500

Tools Call Agenda -- 13 Dec 2016 at 1:00 Eastern

1. Datatracker Projects
   - Expected Datatracker Releases -- Robert and Henrik
     -- http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan
   - Contracts for Datatracker Enhancements -- Robert
     -- Review Tracking
     -- Author Statistics

2. Community & Other Projects
   - Improvements to the mail archive application -- Robert and Ryan
   - IETF Website Makeover -- Greg and Joe

3. RFC Services Projects
   - Contracts for Improvements to RFC Services -- Heather and Robert
     -- CSS for the RFCs
     -- RFC Format-related Developments

4. Server Infrastructure
   - IESG discussions of DMARC -- Robert and Ben
   - Migrate toward Django 1.8, 1.9, and 1.10 -- Henrik

5. Parking Lot
   - Libraries for HTML of I-Ds -- Henrik
   - CDN support for HTML and PDF I-Ds -- Henrik
   - Migrate from MySQL to PostgreSQL -- Henrik
   - Discontinue MonArch email archives -- Robert
   - Improve infrastructure for finding and fetching artifacts -- Robert
   - Author information for very old I-Ds in the datatracker -- Robert
   - Replace I-Ds in proceedings with links to archive copy?
   - Performance improvements and transition to Postgres -- Henrik
   - VM Architecture for Servers -- Robert
   - Submit an I-D directly from GitHub
   - Mailman support for internationalized email addresses
     -- Requires Mailman 3.1, which is expected in early 2017
   - Meeting registration support for internationalized email addresses
     -- Mailman must be done first; user is added to meeting mail lists

6. AOB

---

From: Robert Sparks <[email-masked]>
Date: Mon, 12 Dec 2016 09:30:04 -0600

Some notes for tomorrows meeting:

>       -- http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan
The plan is updated. We'll be talking about much of it in later sections.
Note that I've up-leveled what's on the MergePlan page - I'm trying to make
it's focus more on the near-term high-level big changes that might disrupt
people working in other parts of the system. There are more details (and a
longer view) in the PLAN file that page links to.
For this part of the call, please skim those pages to make sure we have
are reflecting relative priorities correctly.
>     - Contracts for Datatracker Enhancements -- Robert
This is accepted and deployed. We are getting lots of change requests and
requests for new features, and have been working through them rapidly.
See
<https://trac.tools.ietf.org/tools/ietfdb/report/33> for the currently 
open tickets.

<https://trac.tools.ietf.org/tools/ietfdb/report/28> shows a summary of 
what we've recently closed (in all components, not just the /review 
component)

>       -- Author Statistics
Started - awaiting a status update from IOLA.
>     - IESG discussions of DMARC -- Robert and Ben
Alexey is still gathering information and the IESG is still discussing 
what decision they are willing to make. Given the impending holidays, I 
don't expect we will do anything to production until mid-January. I 
don't think we need to spend time on this during tomorrow's call.
>     - Libraries for HTML of I-Ds -- Henrik
Bring this one out of the parking lot. Note that it is currently on the 
mergeplan.
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 12 Dec 2016 17:14:05 +0100

Additional notes inline:

>>     - Migrate toward Django 1.8, 1.9, and 1.10 -- Henrik

The migration to Django 1.8 is pretty much done; I've merged the work
to trunk and I'm running final tests now, before committing and releasing.

In addition to deprecations and backward-incompatible changes, Django 1.8
introduced type checking of foreign-key and many-to-many-key arguments when
doing database queries.  This brought to light a number of places where
we provided the wrong argument types (or multiple inconsistent argument
types) to queries.  These have all been fixed, and the code is more solid
as a result.

Next up is migration to Django 1.9.

---

From: Robert Sparks <[email-masked]>
Date: Mon, 12 Dec 2016 12:10:18 -0600

> are reflecting relative priorities correctly.
I meant to mention: Thre new-ish things that are on the list to check 
the relative priorities for:

* The IESG would like the downref registry moved into the datatracker 
and to have it integrated with last call generation
* The IESG would like a view of recent ballots by telechat to help
* We should add an API to allow meetecho to associate recordings with 
sessions as soon as they become available.

We currently have these prioritized as seen at 
<https://trac.tools.ietf.org/tools/ietfdb/browser/trunk/PLAN>, after the 
htmlization of document views and the next round of improvements to the 
Yang checker.
> <https://trac.tools.ietf.org/tools/ietfdb/report/28> shows a summary 
> of what we've recently closed (in all components, not just the /review 
> component)
>
>>       -- Author Statistics
> what decision they are willing to make. Given the impending holidays, 
> I don't expect we will do anything to production until mid-January. I 
> Bring this one out of the parking lot. Note that it is currently on 
> the mergeplan.

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Mon, 12 Dec 2016 19:35:35 +0000

I haven’t seen any webex details lately. 

	Tony

On 12/12/16, 1:10 PM, "TOOLS-DEVELOPMENT on behalf of Robert Sparks" <[email-masked] on behalf of [email-masked]> wrote:

---

From: Robert Sparks <[email-masked]>
Date: Mon, 12 Dec 2016 13:56:12 -0600

should be at the calendar at https://ical.ietf.org/public.php/IAOC/Tools

This is what I see there:

-----

JOIN WEBEX MEETING
https://workgreen.webex.com/workgreen/j.php?MTID=mc345fa798d129bbbe1a89dcce8df76aa
Meeting number (access code): 829 074 044

JOIN BY PHONE
1-877-668-4490 Call-in toll-free number (US/Canada)
1-408-792-6300 Call-in toll number (US/Canada)

Global call-in numbers:
https://workgreen.webex.com/workgreen/globalcallin.php?serviceType=MC&ED=353607892&tollFree=1

Toll-free dialing restrictions:
https://www.webex.com/pdf/tollfree_restrictions.pdf

Can't join the meeting?
https://help.webex.com/docs/DOC-5412

IMPORTANT NOTICE: Please note that this WebEx service allows audio and 
other information sent during the session to be recorded, which may be 
discoverable in a legal matter. By joining this session, you 
automatically consent to such recordings. If you do not consent to being 
recorded, discuss your concerns with the host or do not join the session.

---

From: Bob Hinden <[email-masked]>
Date: Mon, 12 Dec 2016 11:51:31 -0800

Robert,

> On Dec 12, 2016, at 10:10 AM, Robert Sparks <[email-masked]> wrote:
> 
> 
> 
> I meant to mention: Thre new-ish things that are on the list to check the relative priorities for:
> 
> * The IESG would like the downref registry moved into the datatracker and to have it integrated with last call generation
> * We should add an API to allow meetecho to associate recordings with sessions as soon as they become available.
> 
> We currently have these prioritized as seen at <https://trac.tools.ietf.org/tools/ietfdb/browser/trunk/PLAN>, after the htmlization of document views and the next round of improvements to the Yang checker.

One thing I have been thinking about is to send an email notice to document shepherd when one of their documents in on an IESG agenda.  This would save them having to check each IESG agenda themselves.  Or is there already a way to do this?

Thanks,
Bob

---

From: Robert Sparks <[email-masked]>
Date: Mon, 12 Dec 2016 14:07:20 -0600

On 12/12/16 1:51 PM, Bob Hinden wrote:
<trim/>
> One thing I have been thinking about is to send an email notice to document shepherd when one of their documents in on an IESG agenda.  This would save them having to check each IESG agenda themsel…

They should be getting a message as soon as the document is scheduled on 
a telechat already.
See : 
<https://datatracker.ietf.org/mailtrigger/name/doc_telechat_details_changed/>

I did a quick skim through the code and all the paths that set a 
telechat date are using that unless I missed something.
Do you have an example where a shepherd _didn't_ get notified recently?

RjS

---

From: Bob Hinden <[email-masked]>
Date: Mon, 12 Dec 2016 12:16:37 -0800

> On Dec 12, 2016, at 12:07 PM, Robert Sparks <[email-masked]> wrote:
> 
> 
> 
> They should be getting a message as soon as the document is scheduled on a telechat already.
> See : <https://datatracker.ietf.org/mailtrigger/name/doc_telechat_details_changed/>
> 
> I did a quick skim through the code and all the paths that set a telechat date are using that unless I missed something.

I don’t remember having received one.  For example, draft-ietf-6man-default-iids is on the IESG agenda for 12/15/2016.  I chair 6MAN, but I don’t think I have received a notice for that meeting.  Reading the trigger page, I assume I should have received an email.

Thanks,
Bob

---

From: Robert Sparks <[email-masked]>
Date: Mon, 12 Dec 2016 14:25:44 -0600

It was sent to you on 17 Nov (when the document was placed on that telechat.

The subject was "Telechat update notice: 
<draft-ietf-6man-default-iids-16.txt>

This was the To: line -

To: "Robert M. Hinden" <[email-masked]>, 
<[email-masked]>, <[email-masked]>, 
<[email-masked]>, "The IESG" <[email-masked]>, 
<[email-masked]>

and if it helps, this was the Message-ID -

Message-ID: 
<[email-masked]>

RjS

---

From: Bob Hinden <[email-masked]>
Date: Mon, 12 Dec 2016 12:48:30 -0800

Robert,

Not sure why I missed it, but I did find it.  Too much email I guess :-(

Thanks,
Bob

> On Dec 12, 2016, at 12:25 PM, Robert Sparks <[email-masked]> wrote:
> 
> The subject was "Telechat update notice: <draft-ietf-6man-default-iids-16.txt>
> 
> This was the To: line -
> 
> To: "Robert M. Hinden" <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, "The IESG" <[email-masked]>, <[email-masked]>
> 
> Message-ID: <[email-masked]>
> 
> RjS
>

---

From: Russ Housley <[email-masked]>
Date: Mon, 12 Dec 2016 16:00:07 -0500

> * We should add an API to allow meetecho to associate recordings with sessions as soon as they become available.

These need to be volunteer efforts.  Can you give a feeling about their scope?

Russ

---

From: Robert Sparks <[email-masked]>
Date: Mon, 12 Dec 2016 15:32:15 -0600

> Not sure why I missed it, but I did find it.  Too much email I guess :-(
Before we give up on the thread, maybe we should poke at whether you 
really missed it, or if it was so long ago it wasn't relevant?
(Are we sending the information you really want at the right time?)

RjS

---

From: Robert Sparks <[email-masked]>
Date: Mon, 12 Dec 2016 15:36:08 -0600

> These need to be volunteer efforts.  Can you give a feeling about their scope?
Yes, I expected we would wrangle volunteers or maintenance time to do these.

I don't think any of them are _big_. The downref registry move is the 
largest, and only because importing the information that's in the wiki 
(history) will require some research. If I were to do it, I think it 
would take less than a week. The other two are probably a day or so each.

---

From: Bob Hinden <[email-masked]>
Date: Mon, 12 Dec 2016 13:51:39 -0800

Robert,

> On Dec 12, 2016, at 1:32 PM, Robert Sparks <[email-masked]> wrote:
> 
> 
> 
> Before we give up on the thread, maybe we should poke at whether you really missed it, or if it was so long ago it wasn't relevant?

It would be helpful if it included something to make it easier to add to my calendar.  Ideally an .ics file that included the webex info.

Thanks,
Bob

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Mon, 12 Dec 2016 22:08:04 +0000

Thanks, Robert.

	Tony

On 12/12/16, 2:56 PM, "TOOLS-DEVELOPMENT on behalf of Robert Sparks" <[email-masked] on behalf of [email-masked]> wrote:

---

From: Robert Sparks <[email-masked]>
Date: Tue, 13 Dec 2016 11:58:24 -0600

Hrmm - looks like the calendar didn't get updated with a good webex - 
the link that's there is for a meeting last week

Anyone have better coordinates?

---

From: "Ben Campbell" <[email-masked]>
Date: Tue, 13 Dec 2016 12:02:02 -0600

Mine shows Dec 6, which was the originally scheduled date. But the join 
button is greyed-out.

Any chance we could get a recurring meeting scheduled with the same 
webex info?

On 13 Dec 2016, at 11:58, Robert Sparks wrote:

>> On 12/12/16, 2:56 PM, "TOOLS-DEVELOPMENT on behalf of Robert Sparks" 
>> <[email-masked] on behalf of 
>> [email-masked]> wrote:
>>
>>      should be at the calendar at 
>> https://ical.ietf.org/public.php/IAOC/Tools
>>
>>
>

---

From: Lou Berger <[email-masked]>
Date: Tue, 13 Dec 2016 13:02:37 -0500

ray is on the road, does anyone else have the credentials to start the
call...

---

From: Alexa Morris <[email-masked]>
Date: Tue, 13 Dec 2016 10:04:03 -0800

We can use my personal meeting room: https://ietf.webex.com/join/amorris for today.

Alexa

On Dec 13, 2016, at 10:02 AM, Ben Campbell <[email-masked]> wrote:

> Mine shows Dec 6, which was the originally scheduled date. But the join button is greyed-out.
> 
> Any chance we could get a recurring meeting scheduled with the same webex info?
> 
>> Hrmm - looks like the calendar didn't get updated with a good webex - the link that's there is for a meeting last week
>> 

----------
Alexa Morris / Executive Director / IETF
+1.510.492.4001
Email: [email-masked]

---

From: Robert Sparks <[email-masked]>
Date: Tue, 13 Dec 2016 12:06:32 -0600

Russ and I are at 
https://workgreen.webex.com/workgreen/e.php?MTID=m13da73a14043c273131cf626b098691c