Subject: [TOOLS-DEVELOPMENT] Fwd: use of Git-hub

From: Lou Berger <[email-masked]>
Date: Mon, 31 Oct 2016 07:04:54 -0400

Fyi...

--- Forwarded message ---
From: Stewart Bryant <[email-masked]>
Date: October 31, 2016 5:10:14 AM
Subject: use of Git-hub
To: [email-masked]

I suppose it was obvious that people would use git-hub for IETF work, I
have certainly been using it as a way of managing the drafts that I
write, but the thread that just started causes me to ask a couple of
questions:

Firstly whether the IETF should more formally adopt Git technology as
its in-house draft management system once a document becomes a WG document?

Secondly with the move to .md isn't it time that we allowed the markdown
files to be uploaded with the draft in a similar way to .xml. I used to
do the .xml upload just as a way to recover the source if I lost it
locally, however for a number of us, .xml is no longer the source, but
an intermediate file is on of no real use until the RFC Editor ask for it.

Stewart

---

From: Joe Hildebrand <[email-masked]>
Date: Mon, 31 Oct 2016 05:43:19 -0600

Quickest and easiest fix would be for kramdown-rfc2629 to include the markdown source as a comment at the end of the XML.

Extra points for being able to recover it easily.  Keep in mind that the sequence "--" is not allowed in an XML comment, so it needs to be escaped correctly.

> On Oct 31, 2016, at 5:04 AM, Lou Berger <[email-masked]> wrote:
> 
> Fyi...
> 
> 
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

-- 
Joe Hildebrand

---

From: Julian Reschke <[email-masked]>
Date: Mon, 31 Oct 2016 13:32:40 +0100

> Extra points for being able to recover it easily.  Keep in mind that the sequence "--" is not allowed in an XML comment, so it needs to be escaped correctly.

If that's the goal, it better be done by kramdown itself :-)

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 31 Oct 2016 15:18:18 +0100

Good idea.

However note that the “source” of the document may be a directory with data files, a makefile, and a markdown document with many include statements.  Anyway, it would be easy to include the “compiled” markdown source (all includes processed) in the XML. I’d gzip and base64*) it for use by an extraction tool.  I’ll do that (and provide the extractor) in the next version.

Should this be in a comment or is there an XML element we could hijack for that?

Grüße, Carsten

*) old-style base64 if we need to make it compatible XML comments...
On 31 October 2016 at 12:43:31, Joe Hildebrand ([email-masked]) wrote:

--  
Joe Hildebrand

---

From: Julian Reschke <[email-masked]>
Date: Mon, 31 Oct 2016 15:29:17 +0100

On 2016-10-31 15:18, Carsten Bormann wrote:
> Good idea.
>
> However note that the “source” of the document may be a directory with
> data files, a makefile, and a markdown document with many include
> statements.  Anyway, it would be easy to include the “compiled” markdown
> source (all includes processed) in the XML. I’d gzip and base64*) it for
> use by an extraction tool.  I’ll do that (and provide the extractor) in
> the next version.
>

I think for now a comment is best.

Or make it an eref and put the value into a data: URI.

/me ducks

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 31 Oct 2016 16:21:19 +0100

OK, done in 1.0.38.
(We’ll see who is foolish enough to update kramdown-rfc on Internet-Drafts day :-)

Grüße, Carsten

On 31 October 2016 at 15:29:28, Julian Reschke ([email-masked]) wrote: