Subject: [TOOLS-DEVELOPMENT] Tools Call Agenda -- 13 Sept. 2016 at 1:00 Eastern

From: Russ Housley <[email-masked]>
Date: Wed, 7 Sep 2016 17:08:51 -0400

Tools Call Agenda -- 13 Sept. 2016 at 1:00 Eastern

1. Datatracker Projects
   - Expected Datatracker Releases -- Robert and Henrik
     -- http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan
   - Contracts for Datatracker Enhancements -- Robert
     -- Tracking Internet-Draft Manual Post Requests
     -- Review Tracking
   - Meeting Materials Management -- Robert
   - Merge Meeting Materials and Proceedings -- Robert
   - Author Statistics -- Russ
   - Libraries for HTML of I-Ds -- Henrik

2. Community & Other Projects
   - Improvements to the mail archive application -- Robert and Ryan
   - Adding rfc-editor.org mail lists to the archive -- Robert
   - IETF Website Makeover -- Greg and Joe

3. RFC Services Projects
   - Contracts for Improvements to RFC Services -- Heather
     -- RFC Editor Statistics and Metrics
   - RSE's Design Teams -- Heather
   - RFC Format-related SOWs -- Robert
   - CSS for the RFCs -- Heather

4. Transition of Mission Critical Tools
   - Moving issue trackers and wikis for IETF WGs on ietf.org -- Henrik

5. Server Infrastructure
   - Migrate from Django 1.8 to 1.9 -- Henrik
   - Migrate from MySQL to PostgreSQL -- Henrik
   - CDN support for HTML and PDF I-Ds -- Henrik

6. IDIQ Contractors
   - RFP for more IDIQ contractors -- Ray

7. Parking Lot
   - Discontinue MonArch email archives -- Robert
   - Improve infrastructure for finding and fetching artifacts -- Robert
   - Author information for very old I-Ds in the datatracker -- Robert
   - Replace I-Ds in proceedings with links to archive copy?
   - Performance improvements and transition to Postgres -- Henrik
   - VM Architecture for Servers -- Robert
   - Submit an I-D directly from GitHub
   - Mailman support for internationalized email addresses

8. AOB

---

From: Robert Sparks <[email-masked]>
Date: Fri, 9 Sep 2016 11:40:12 -0500

Notes for the call.

>       -- http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan
That MergePlan page has been updated, and there's more detail at
https://trac.tools.ietf.org/tools/ietfdb/browser/trunk/PLAN if you're 
interested.
The imminently expected releases are
Sep 	improved Manual Post management
Sep 	WG Wiki Glue
Sep 	Proceedings and Materials Management
Oct 	Review Tracking

Since it's been awhile since the last call (in July), it's also worth 
calling attention to the 9 releases in the interim:
https://datatracker.ietf.org/release/

>       -- Tracking Internet-Draft Manual Post Requests
Very close to release - will probably be released before next week's call.
>       -- Review Tracking
In last stages of development. Ole is working with Tero and me to refine 
how to provide the various "mark this reviewer unavailable" features 
called out in the RFC. I expect this to come in before Seoul.
>     - Merge Meeting Materials and Proceedings -- Robert
Let's combine those two bullets going forward.
Ryan and I have made a lot of progress on this - I'm in the last stages 
(I hope) of upgrading the material management part.
Our goal is to have this into production before the official schedule is 
provided for Seoul.
>     - Improvements to the mail archive application -- Robert and Ryan
Ryan will cover this.
>     - Adding rfc-editor.org mail lists to the archive -- Robert
I think what we're primarily looking for on the call is a high-level "do 
this" or not.
A design decision to be made is whether to add these to the instance we 
have at mailarchive so that one search will search all the lists, or 
spin up another copy that is rfc-editor list specific. I lean strongly 
towards the first. But that brings up a technical issue with how to get 
the bits to the ingestor as new messages arrive, since those lists are 
hosted on different machines.
>     - RFC Format-related SOWs -- Robert
I don't think there's anything new to report about these SoWs per-se. 
They were updated since we last met.
Should this bullet be replaced with something talking about the progress 
of the RFP?
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Glen <[email-masked]>
Date: Fri, 9 Sep 2016 10:19:25 -0700

Notes to Robert's Notes:

On Fri, Sep 9, 2016 at 9:40 AM, Robert Sparks <[email-masked]> wrote:
> I think what we're primarily looking for on the call is a high-level "do this" or not.
> A design decision to be made is whether to add these to the instance we have at mailarchive so that one search will search all the lists, or spin up another copy that is rfc-editor list specific. I lean strongly towards the first. But that brings up a technical issue with how to get the bits to the ingestor as new messages arrive, since those lists are hosted on different machines.

I, too, to phrase it oppositely, lean *strongly against* "spinning up
another copy".  That seems non-trivial, and would require a lot of
work and discussion.

I agree that - IF the high-level call is "do this" - we want to add
them to the existing instance.

And I do not see any technical issue with that whatsoever:  I happen
to know personally the system administrator of the RFC-Editor server,
and if I bribe him with a nice lunch somewhere, I'm sure he'll turn
over the archives to us.  Then Ryan can merge them in to the existing
system.   As for new messages - we just subscribe an ingestion address
to the RFC lists, pointed to the archive tool.  We already do this for
other externally-hosted lists:  totally not a problem at all.

Glen

---

From: Heather Flanagan <[email-masked]>
Date: Mon, 12 Sep 2016 08:15:10 -0700

Adding my own comments

On September 9, 2016 at 9:35:15 AM, Robert Sparks ([email-masked]) wrote:

I think making the rfc-interest list more easily searchable by the community most likely to do so is a Very Good Idea. I say we do this, and have the mailarchive search all the lists. 

3. RFC Services Projects

This is done.

I don't think there's anything new to report about these SoWs per-se. They were updated since we last met.
Should this bullet be replaced with something talking about the progress of the RFP?

I am Very Anxious that the RFP has not been posted. We’re six weeks behind where I thought we’d be, and I don’t understand why. I thought we’d agreed that the RFPs would go to the IAOC and out as soon as possible after the docs were approved for publication?

I have heard rumor that we have a potential bidder on this. I need others to look at this (if it’s true) since there may something that looks like a conflict of interest for me with it.

-- 
Heather Flanagan
RFC Series Editor

---

From: Ryan Cross <[email-masked]>
Date: Thu, 15 Sep 2016 14:17:45 -0700

Per direction on the Tools Call, the rfc-interest and rfc-dist mailing lists have been added to the IETF Mail Archive here:

https://mailarchive.ietf.org/arch/search/?email_list=rfc-interest <https://mailarchive.ietf.org/arch/search/?email_list=rfc-interest>
https://mailarchive.ietf.org/arch/search/?email_list=rfc-dist <https://mailarchive.ietf.org/arch/search/?email_list=rfc-dist>

This includes historic messages and all new messages.

Ryan Cross
AMS

> On Sep 12, 2016, at 8:15 AM, Heather Flanagan <[email-masked]> wrote:
> 
> Adding my own comments
> 
> On September 9, 2016 at 9:35:15 AM, Robert Sparks ([email-masked] <mailto:[email-masked]>) wrote:
> 
>>    - Adding rfc-editor.org <http://rfc-editor.org/> mail lists to the archive -- Robert
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/tools-development <https://www.ietf.org/mailman/listinfo/tools-development>

---

From: Russ Housley <[email-masked]>
Date: Wed, 21 Sep 2016 11:46:54 -0400

Thank you!

On Sep 15, 2016, at 5:17 PM, Ryan Cross <[email-masked]> wrote:

> https://mailarchive.ietf.org/arch/search/?email_list=rfc-interest
> https://mailarchive.ietf.org/arch/search/?email_list=rfc-dist
>