Subject: [TOOLS-DEVELOPMENT] Link to RFC Format SOWs

From: Robert Sparks <[email-masked]>
Date: Wed, 6 Jul 2016 16:52:25 -0500

As discussed on yesterday's tools call -

Please review the SoWs at http://www.nostrum.com/~rjsparks/rfced/

We expect to issue them as part of an RFP shortly after the Berlin meeting.

I'm sure there are several things that need to be updated - please help 
me find them.

RjS

---

From: Sandy Ginoza <[email-masked]>
Date: Mon, 11 Jul 2016 14:06:01 -0700

Hi Robert,

Thanks for your work on these.  Just a few quick notes/thoughts below - please let me know if anything is unclear.

Thanks,
Sandy

1) http://www.nostrum.com/~rjsparks/rfced/PublicationFormatter-06.pdf

-  update to point to RFC 7322 (referring to Sec 4 is correct)

   draft‐iab‐styleguide (section 4)

2) http://www.nostrum.com/~rjsparks/rfced/TextSubmissionConverter-02.pdf

- just curious why this is a “nice to have”? 
 
   Running at a Windows command prompt would be nice to have but is not required.    

- update to point to 7841 (instead of 5741).  

- wondering if a requirement should be added that it must be done in a way that is easy to update (as boilerplate material can change)?

Boilerplate that matches what is currently defined in RFC5741 (and would be
accepted by id‐nits). The appropriate attributes to the <rfc> element will replace
such boilerplate. A section that appears where boilerplate is expected, but does
not match currently acceptable boilerplate, must be preserved and converted
the same as an ordinary section would be

3) http://www.nostrum.com/~rjsparks/rfced/idnits-03.pdf

- is any check needed when there are UTF-8-encoded chars, for example, including a warning when chars in html are output differently in txt? 

- is it a vocab thing to ask that xml2rfc make obsoletes/updates appear in ascending order per Sec 4.1.4 of 7322?

- wonder if we can make it so that errors will be returned when an alternate stream doc includes 6.c.iii paragraph (or any other possible combination that is not allowed)?  

- should update this one to be “no table of contents” per 7322 (TOC is required for all docs regardless of doc length)

   has more than 15 pages and not Table of Contents

perhaps add: 
- rfcs-what-i-mean?
- check to see if obsoleted (and possibly updated) RFC has errata?
- check for hyphen<space> in the middle of lines?  I’m not sure this is necessary since a lot of the checking will be done on XML files?

   document has hyphenated line‐breaks

4) http://www.nostrum.com/~rjsparks/rfced/rfclint-04.pdf

Perhaps add: 
- matchref and rfcs-what-i-mean? 
- check to see if obsoleted (and possibly updated) RFC has errata?

I’m not sure if we can add these to both idnits and rfclint because we’re trying to avoid dupes.  

This is probably too big of a change at this time, but I started to wonder whether it would be better to have one tool that has an idnits / rfclint option?  That way, some checks could be run multiple times as the document progresses.

5) http://www.nostrum.com/~rjsparks/rfced/svgcheck-02.pdf

none

6) http://www.nostrum.com/~rjsparks/rfced/xmlDiff-03.pdf

none

On Jul 6, 2016, at 2:52 PM, Robert Sparks <[email-masked]> wrote:

> I'm sure there are several things that need to be updated - please help me find them.
> 
> RjS
> 
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development
>

---

From: Sandy Ginoza <[email-masked]>
Date: Mon, 18 Jul 2016 04:05:45 -0700

Hi Again,

I added an example of a combination of copyright text that is not allowed below.  

Thanks,
Sandy

> - wonder if we can make it so that errors will be returned when an alternate stream doc includes 6.c.iii paragraph (or any other possible combination that is not allowed)? 

Another example of a combination that is not allowed:

   This document may not be modified, and derivative works of it may not
   be created, except to format it for publication as an RFC or to
   translate it into languages other than English.

   This document may contain material from IETF Documents or IETF
   Contributions published or made publicly available before November
   10, 2008.  The person(s) controlling the copyright in some of this
   material may not have granted the IETF Trust the right to allow
   modifications of such material outside the IETF Standards Process.
   Without obtaining an adequate license from the person(s) controlling
   the copyright in such materials, this document may not be modified
   outside the IETF Standards Process, and derivative works of it may
   not be created outside the IETF Standards Process, except to format
   it for publication as an RFC or to translate it into languages other
   than English.

---

From: Robert Sparks <[email-masked]>
Date: Tue, 26 Jul 2016 14:21:05 -0500

(Replying to both messages inline)

Thanks for looking closely at each of these docs- these helped me find 
other things to bring up to current as I worked through them.

On 7/18/16 6:05 AM, Sandy Ginoza wrote:
> On Jul 11, 2016, at 2:06 PM, Sandy Ginoza <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>> Hi Robert,
>>
>> Thanks for your work on these.  Just a few quick notes/thoughts below 
>> - please let me know if anything is unclear.
>>
>> Thanks,
>> Sandy
>>
>>
>> <http://www.nostrum.com/%7Erjsparks/rfced/PublicationFormatter-06.pdf>
>>
Fixed (and there were a lot of draft-somebody that needed to be 
draft-iab changes throughout the SoWs).
>>
>>
>> 2) 
>> http://www.nostrum.com/~rjsparks/rfced/TextSubmissionConverter-02.pdf 
>> <http://www.nostrum.com/%7Erjsparks/rfced/TextSubmissionConverter-02.pdf>
>>
Because it would be nice for the community to be able to run this on 
their arbitrary laptops.
We discussed whether to make this a "must have" when we first put the 
SoW together, and decided to stay at "nice to have" since we'd be 
providing an online conversion tool.
>> - update to point to 7841 (instead of 5741).
Done
>>
>> - wondering if a requirement should be added that it must be done in 
>> a way that is easy to update (as boilerplate material can change)?
Done
>> <http://www.nostrum.com/%7Erjsparks/rfced/idnits-03.pdf>
>>
>> - is any check needed when there are UTF-8-encoded chars, for 
>> example, including a warning when chars in html are output 
>> differently in txt?
I think we should leave this to one of the first rounds of improvements 
once we have the tool.
>>
>> - is it a vocab thing to ask that xml2rfc make obsoletes/updates 
>> appear in ascending order per Sec 4.1.4 of 7322?
Yes, for xml source, but No for txt source. I added a check (with 
warning) for txt inputs.
>>
>> - wonder if we can make it so that errors will be returned when an 
>> alternate stream doc includes 6.c.iii paragraph (or any other 
>> possible combination that is not allowed)?
Hrmm - this is complex. Again, I think this is a candidate for the first 
round of improvements once we get the tool started.
>> - should update this one to be “no table of contents” per 7322 (TOC 
>> is required for all docs regardless of doc length)
>>
Done
>> - rfcs-what-i-mean?
Where? I'm not sure where that would go in idnits.
>> - check to see if obsoleted (and possibly updated) RFC has errata?
I'd like to make that a future effort.
>> - check for hyphen<space> in the middle of lines?  I’m not sure this 
>> is necessary since a lot of the checking will be done on XML files?
>>
Added (to the section that looks at txt input files).
>> <http://www.nostrum.com/%7Erjsparks/rfced/rfclint-04.pdf>
>>
>> Perhaps add:
I don't think we currently have a clear description of what those do 
that we can provide to an external developer. Until we have that, the 
developer wouldn't know how to bid. Lets bring these in as future 
improvements
>> - check to see if obsoleted (and possibly updated) RFC has errata?
As above, I'd like to make that a specific future effort.
>> This is probably too big of a change at this time, but I started to 
>> wonder whether it would be better to have one tool that has an idnits 
>> / rfclint option?  That way, some checks could be run multiple times 
>> as the document progresses.
Nothing should prevent running either tool multiple times as you go along.
>> <http://www.nostrum.com/%7Erjsparks/rfced/svgcheck-02.pdf>
>>
>> none
>>
>>
>> <http://www.nostrum.com/%7Erjsparks/rfced/xmlDiff-03.pdf>
>>
>> none
>>
>>
>> On Jul 6, 2016, at 2:52 PM, Robert Sparks <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>
>>> <http://www.nostrum.com/%7Erjsparks/rfced/>
>>>
>>> [email-masked] <mailto:[email-masked]>
>> [email-masked] <mailto:[email-masked]>