Subject: [TOOLS-DEVELOPMENT] Tools Call Agenda -- 16 June 2016 at 1:00 Eastern

From: Russ Housley <[email-masked]>
Date: Tue, 14 Jun 2016 07:26:05 -0400

Tools Call Agenda -- 16 June 2016 at 1:00 Eastern

1. Datatracker Projects
   - Expected Datatracker Releases -- Robert and Henrik
     -- http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan
   - Contracts for Datatracker Enhancements -- Robert
     -- Interim Meeting Management
     -- Tracking Internet-Draft Manual Post Requests
     -- Review Tracking
   - Meeting Materials Management -- Robert
   - Merge Meeting Materials and Proceedings -- Robert
   - Author Statistics -- ON HOLD

2. Community & Other Projects
   - Improvements to the mail archive application -- Robert and Ryan
   - IETF Website Makeover -- Greg and Joe

3. RFC Services Projects
   - Contracts for Improvements to RFC Services -- Heather
     -- RFC Editor Statistics and Metrics
   - RSE's Design Teams -- Heather
   - RFC Format-related SOWs -- Robert
   - CSS for the RFCs -- Heather

4. Transition of Mission Critical Tools
   - Moving issue trackers and wikis for IETF WGs on ietf.org -- Henrik

5. Server Infrastructure
   - Migrate from Django 1.8 to 1.9 -- Henrik
   - Migrate from MySQL to PostgreSQL -- Henrik
   - CDN support for HTML and PDF I-Ds -- Henrik

6. IDIQ Contractors
   - RFP for more IDIQ contractors -- Ray

7. Parking Lot
   - Discontinue MonArch email archives -- Robert
   - Improve infrastructure for finding and fetching artifacts -- Robert
   - Author information for very old I-Ds in the datatracker -- Robert
   - Replace I-Ds in proceedings with links to archive copy?
   - Performance improvements and transition to Postgres -- Henrik
   - VM Architecture for Servers -- Robert
   - Submit an I-D directly from GitHub

8. AOB

---

From: Robert Sparks <[email-masked]>
Date: Thu, 16 Jun 2016 10:40:34 -0500

A few short notes for the call:

Agenda bash : I'd like time to talk about codematch.

Some additional places where we should spend more time than usual below.

>       -- Interim Meeting Management
Ready for merge - added to the mergequeue
>       -- Tracking Internet-Draft Manual Post Requests
In testing - several issues identified for correction
>       -- Review Tracking
Making rapid progress -  expect early testing/demos of some components 
in Berlin
>     - Meeting Materials Management -- Robert
Nothing new for this cycle.
>     - Merge Meeting Materials and Proceedings -- Robert
Nothing new for this cycle.
>     - IETF Website Makeover -- Greg and Joe
We should speak a few minutes here about the recent photo/bio 
datatracker release.
>       -- RFC Editor Statistics and Metrics
We should speak a few minutes here about accepting and deploying this 
project.
>     - RFC Format-related SOWs -- Robert
Nothing new to discuss, (but note Russ' thread asking for packaging text)
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Robert Sparks <[email-masked]>
Date: Thu, 16 Jun 2016 10:45:57 -0500

A couple of other things (for the AOB part perhaps)

* I'm prototyping capturing programs as groups in the datatracker. When 
I take the next run at that (informed by prototype feedback), how should 
it be prioritized compared to these other projects?

* We are making some progress on removing spam from the repository, and 
stemming the tide of new spam, list by list. We're doing this by looking 
for a List-Id only (there were previous suggestions to check for dkim, 
which we are not doing - should that still be a goal?).