Subject: [TOOLS-DEVELOPMENT] Rough Notes was Fwd: Tools Meeting - March 8 2016 - Notes

From: Ray Pelletier <[email-masked]>
Date: Tue, 8 Mar 2016 14:58:23 -0500

Thanks Michele.

Ray

> Begin forwarded message:
> 
> From: Michele Gehrke <[email-masked]>
> Subject: Tools Meeting - March 8 2016 - Notes
> Date: March 8, 2016 at 2:52:53 PM EST
> To: Ray Pelletier <[email-masked]>
> 
> 
> 
> 1. Datatracker Projects
>   - Expected Datatracker Releases -- Robert and Henrik
>     -- http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan <http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan>
> 1.16 is the most recent release. 
>  
>   - Add the YANG checker to the I-D Submission Tool – Henrik – This has been completed.
>   - Contracts for Datatracker Enhancements -- Robert
>     -- Interim Meeting Management – This task will go quickly.
>     -- Tracking Internet-Draft Manual Post Requests – This task is well underway.
>     -- Review Tracking – Ole is finishing out communications re-write.
>  
>   - Meeting Materials Management – Robert explained that the latest releases are making this task easier. We have the ability to associate drafts with their sessions. Remaining work is under discussion. Pre-release draft has been shared and waiting for comments. In approximately 2-3 weeks, this should be solved incrementally vs funding a project.
>   - Author Statistics -- ON HOLD – Sending this out for bid needs to be investigated.
>  
> 2. Community & Other Projects
>   - Improvements to the mail archive application – Robert – A draft was approved last week. Next step is funding the work and getting it done.
>   - Improve infrastructure for finding and fetching artifacts – Robert – This task was moved to the parking lot last time. Needs to be deleted.
>   - IETF Website Makeover --– Robert has no additional insight at this time.
>  
> 3. RFC Services Projects
>   - Contracts for Improvements to RFC Services -- Heather
>     -- RFC Editor Statistics and Metrics – Started work, has copy of database, expected to complete on time.
>   - RSE's Design Teams – Heather – Format drafts are out for community comment which ends Friday, March 11th.
> CSS SOW – we are looking for last comments so we can share with community.
>   - RFC Format-related SOWs – Robert – Last 2 meetings we've asked people to read them again but have not received any feedback. Last call coming soon. Timeline: RFP community review ends Friday March 11th, IAB will have to approve the documents, next several weeks possibly April.
>  
> 4. Transition of Mission Critical Tools
>   - Moving issue trackers and wikis for IETF WGs on ietf.org <http://ietf.org/> – Henrik – Code should be in place before Buenos Aires – by the beginning of May, this should be completed. AMS is ready to receive.
>  
> 5. Server Infrastructure
>   - CDN support for HTML I-Ds – Henrik – We are moving some of the generation stuff over to the data tracker. Will happen sometime after Buenos Aires – our target is in time of Berlin.  
>   - Correct "broken" messages in the email archives -- Robert and Ryan
>     -- Is this finished? This has been completed, but as expected, we found a few things to address. Start taking steps as soon as the transition effort begins with the AMS folks. Delete this item for next call.
>  
> 6. IDIQ Contractors
>   - RFP for more IDIQ contractors – Ray – This remains open until filled. We are looking for someone with Python programming skills.
>  
> 7. Parking Lot
>   - Discontinue MonArch email archives -- Robert
>   - Improve infrastructure for finding and fetching artifacts -- Robert
>   - Author information for very old I-Ds in the datatracker -- Robert
>   - Replace I-Ds in proceedings with links to archive copy?
>   - Performance improvements and transition to Postgres -- Henrik
>   - VM Architecture for Servers -- Robert
>   - Submit an I-D directly from GitHub
>  
> 8. AOB
> IETF Websie makeover
> Alexa has not seen any progress on this in the last week. Ray, Joe, Greg and Alexa to have a call.
>  
> Glen explained that we are up on the new server. We purchased a 2nd server for Sunnyvale. New operating system on and tested. Cut over yesterday and ran into some downtime issues that only lasted a few minutes. Still working on a few bug fixes. Special thanks for Robert and Henrik for their work.
>  
> Robert suggested a face to face meeting in Buenos Aires of the Tools team to whiteboard some priorities. All agreed. Ray to send a doodle poll.
> 
> 
>

---

From: Robert Sparks <[email-masked]>
Date: Tue, 8 Mar 2016 14:08:44 -0600

Some clarifications inline:

On 3/8/16 1:58 PM, Ray Pelletier wrote:
> Thanks Michele.
>
> Ray
>
>> Begin forwarded message:
>>
>> *From: *Michele Gehrke <[email-masked] <mailto:[email-masked]>>
>> *Subject: **Tools Meeting - March 8 2016 - Notes*
>> *Date: *March 8, 2016 at 2:52:53 PM EST
>> *To: *Ray Pelletier <[email-masked] <mailto:[email-masked]>>
>>
>>
>>
>> 1. Datatracker Projects
>>     --http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan
Should be 6.16.0
>>     -- Interim Meeting Management – This task will go quickly.
"This will go quickly" was a comment on how long it would take to go 
through this
"Contracts for Datatracker Enhancements" section, not on the Interim 
meeting management tool
task. That should have captured that the task is underway.
>>     -- Review Tracking – Ole is finishing out communications re-write.
Community application, not communications.
Work on Review Tracking will start when that's done (probably this week 
or next).
>>
>>   - Meeting Materials Management – Robert explained that the latest 
>> releases are making this task easier. We have the ability to 
>> associate drafts with their sessions. Remaining work is under 
>> discussion. Pre-release draft has been shared and waiting for 
>> comments. In approximately 2-3 weeks,
we will know if
>> this should be solved incrementally vs funding a project.
>>   - Improvements to the mail archive application – Robert – A draft 
>> was approved last week. Next step is funding the work and getting it 
>> done.
>>   - Improve infrastructure for finding and fetching artifacts – 
>> Robert – This task was moved to the parking lot last time. Needs to 
>> be deleted.
>>   - RSE's Design Teams – Heather – Format drafts are out for 
>> community comment which ends Friday, March 11^th .
>>   - RFC Format-related SOWs – Robert – Last 2 meetings we've asked 
>> people to read them again but have not received any feedback. Last 
>> call coming soon. Timeline: RFP community review ends Friday March 
>> 11^th , IAB will have to approve the documents, next several weeks 
>> possibly April.
>>
>>   - Moving issue trackers and wikis for IETF WGs onietf.org 
>> <http://ietf.org/>– Henrik – Code should be in place before Buenos 
>> Aires – by the beginning of May, this should be completed. AMS is 
>> ready to receive.
>>
>> 5. Server Infrastructure
>>   - CDN support for HTML I-Ds – Henrik – We are moving some of the 
>> generation stuff over to the data tracker. Will happen sometime after 
>> Buenos Aires – our target is in time of Berlin.
>>     -- Is this finished? This has been completed, but as expected, we 
>> found a few things to address. Start taking steps as soon as the 
>> transition effort begins with the AMS folks. Delete this item for 
>> next call.
>>
>> 6. IDIQ Contractors
>>   - RFP for more IDIQ contractors – Ray – This remains open until 
>> filled. We are looking for someone with Python programming skills.
>>
>> 7. Parking Lot
>> Glen explained that we are up on the new server. We purchased a 
>> 2nd server for Sunnyvale. New operating system on and tested. Cut 
>> over yesterday and ran into some downtime issues that only lasted a 
>> few minutes. Still working on a few bug fixes. Special thanks for 
>> Robert and Henrik for their work.
>> Robert suggested a face to face meeting in Buenos Aires of the Tools 
>> team to whiteboard some priorities. All agreed. Ray to send a doodle 
>> poll.
>>
>>
>>
>
>
>
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development