Subject: [TOOLS-DEVELOPMENT] New IETF Server Ready for Final Testing

From: Russ Housley <[email-masked]>
Date: Wed, 2 Mar 2016 12:03:02 -0500

1. The IETF Secretariat has completed configuration of a new server for the IETF in a data center in Sunnyvale, California.  We are targeting Monday, March 7th for this new server to become our primary.  AMS calls refers to the new server as IETFC.  It is ready for final testing before it becomes our primary server.  

2.  If you find problems, please send email to Glen Barney <[email-masked]>.  Please provide details of the error and instructions for reproducing it.

3. The new server uses a new version of OpenSuse Linux.  This new version will bring with it new versions of Apache, Python, and many other software packages. This includes a new version of Mailman, which has support for DMARC workarounds.

4. If you have a few cycles, please help test.  The goal is to ensure that everything works correctly before the new server becomes our primary.

5. To test, add an entry to your "hosts" file to force access to the new server instead of the one in the DNS:

	4.31.198.41  ietf.org www.ietf.org dt.ietf.org datatracker.ietf.org
	   codematch.ietf.org ftp.ietf.org iaoc.ietf.org imap.ietf.org
	   mail.ietf.org mailarchive.ietf.org rsync.ietf.org rt.ietf.org
	   search.ietf.org sec.ietf.org pub.ietf.org trustee.ietf.org iesg.org
	   www.iesg.org iab.org www.iab.org irtf.org www.irtf.org

	2001:1900:3001:11::29  ietf.org www.ietf.org dt.ietf.org datatracker.ietf.org
	   codematch.ietf.org ftp.ietf.org iaoc.ietf.org imap.ietf.org
	   mail.ietf.org mailarchive.ietf.org rsync.ietf.org rt.ietf.org
	   search.ietf.org sec.ietf.org pub.ietf.org trustee.ietf.org iesg.org
	   www.iesg.org iab.org www.iab.org irtf.org www.irtf.org

Once you make this change, you will probably need to restart your browsers.

6. The database on this server contains a snapshot of the data from a few days ago.  It is safe to do testing that changes the database.  The production data will be copied as part of the cutover.

7. Email on this server is disabled.  The IETF Secretariat has done injection testing of email on this server, and it is working; however, since testing may well generate unwanted (and errant) email messages, we have email disabled to avoid confusion.

8. Because the IETF Jabber server is a really server-to-server, it will not be possible for you to test the Jabber server in advance.  Note that jabber.ietf.org is not listed in the hosts configuration above.

9. The calendar server ("davical") did not successfully port to the new server.  since we are not creating a calendar for each WG, this is not a problem.  AMS is working with Cindy, Amy, and Ray on a way to support the calendars that we do support.  Note that ical.ietf.org is not listed in the hosts configuration above.

10. When you are done, please DO NOT FORGET to remove the hosts file when you are done testing.

Thanks for you help,
  Russ

---

From: Russ Housley <[email-masked]>
Date: Wed, 2 Mar 2016 23:26:23 -0500

I have just learned that Windows will truncate lines in the hosts file that are longer than 150 characters.  Who knew?

Anyway, you may find this a better approach to avoid that issue:

   4.31.198.41  ietf.org www.ietf.org dt.ietf.org datatracker.ietf.org
   4.31.198.41  codematch.ietf.org ftp.ietf.org iaoc.ietf.org imap.ietf.org
   4.31.198.41  mail.ietf.org mailarchive.ietf.org rsync.ietf.org rt.ietf.org
   4.31.198.41  search.ietf.org sec.ietf.org pub.ietf.org trustee.ietf.org iesg.org
   4.31.198.41  www.iesg.org iab.org www.iab.org irtf.org www.irtf.org

Russ

On Mar 2, 2016, at 12:03 PM, Russ Housley wrote:

> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development