Subject: [TOOLS-DEVELOPMENT] Tools Call Agenda -- 9 February 2016 at 13:00 Eastern

From: Russ Housley <[email-masked]>
Date: Sun, 7 Feb 2016 15:54:31 -0500

Tools Call Agenda -- 9 February 2016 at 13:00 Eastern

1. Datatracker Projects
   - Expected Datatracker Releases -- Robert and Henrik
     -- http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan
   - Contracts for Datatracker Enhancements -- Robert
     -- Interim Meeting Management
     -- Tracking Internet-Draft Manual Post Requests
     -- Review Tracking
   - Meeting Materials Management -- Robert
   - Author Statistics -- Russ
   - Add the YANG checker to the I-D Submission Tool -- Robert

2. Community & Other Projects
   - Improvements to the mail archive application -- Robert
   - Improve infrastructure for finding and fetching artifacts -- Robert
   - IETF Website Makeover -- Joe and Greg

3. RFC Services Projects
   - Contracts for Improvements to RFC Services -- Robert
     -- RFC Editor Statistics and Metrics
   - RSE's Design Teams -- Heather
   - RFC Format-related SOWs -- Robert

4. Transition of Mission Critical Tools
   - Moving issue trackers and wikis for IETF WGs on ietf.org

5. Server Infrastructure
   - CDN support for HTML I-Ds -- Henrik
   - Correct "broken" messages in the email archives -- Robert and Ryan

6. IDIQ Contractors
   - RFP for more IDIQ contractors -- Ray

7. Parking Lot
   - Discontinue MonArch email archives -- Robert
   - Mentor Support Tool -- AMS
   - Author information for very old I-Ds in the datatracker -- Robert
   - Replace I-Ds in proceedings with links to archive copy?
   - Can the test process for the NomCom Tool be more comprehensive?
   - Performance improvements and transition to Postgres -- Henrik
   - VM Architecture for Servers -- Robert
   - Submit an I-D directly from GitHub

8. AOB

---

From: Robert Sparks <[email-masked]>
Date: Mon, 8 Feb 2016 12:39:05 -0600

Some notes

>       -- http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan
See also http://wiki.tools.ietf.org/tools/ietfdb/browser/trunk/PLAN
Note the large recent release described at 
https://datatracker.ietf.org/release/

>       -- Tracking Internet-Draft Manual Post Requests
Contracts are going into place for these three. Kickoff meetings are the 
next step, but have not yet happened.
>     - Meeting Materials Management -- Robert
This weekend's release contained a lot of prep work for this project.
The new meetings tab simplifies navigation to the meeting materials tools.
With those changes in place, writing cohesive requirements is more 
reasonable, and I've started.
As those come together, we can re-assess whether this needs to be a bid 
project or if it's something Ryan, Henrik, and I can finish incrementally.
>     - Add the YANG checker to the I-D Submission Tool -- Robert
Henrik should speak to that one
>     - Improvements to the mail archive application -- Robert
doc in last call until 18Feb
>     - Improve infrastructure for finding and fetching artifacts -- Robert
Nothing new here
>       -- RFC Editor Statistics and Metrics
Heather should speak to that one.
>     - RFC Format-related SOWs -- Robert
No change to the SoWs. The drafts they rely on are still working their 
way through the IAB.
>     - Correct "broken" messages in the email archives -- Robert and Ryan
Wrapping up.
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: "Heather Flanagan (RFC Series Editor)" <[email-masked]>
Date: Mon, 8 Feb 2016 10:51:10 -0800

> Heather should speak to that one.
I have a kick-off call with Sandy, Alice, and John L. immediately before
the tools call tomorrow. John has a copy of the database (modulo some
private tables that include editorial comments and assignments) and a
copy of the New and Improved SLA, so tomorrow's call should mostly be
Q&A. I will be keeping Robert informed on progress as we go along.

- -Heather