Subject: [TOOLS-DEVELOPMENT] New RFC/ID Format and Tools

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Thu, 28 Jan 2016 16:29:01 +0000

Hi!

While filling in for Kathleen..

We've been discussing in the IESG the potential impact of the new format, specifically on the process to review documents .  The consensus is that we should go slow (not allow all the new features at the same time), but also that we will most likely want to review the same formats we're reviewing today (I use the html version off the tools.ietf.org page, for example) -- the assumption is then that tools will take care of rendering any new characters (for example) correctly and that there would be an indication if there was a difference with respect to the canonical (if something couldn't be rendered correctly, for example).

I'm assuming that these are topics that have already come up and that there is already a plan in place for the tooling.  Is there a pointer to the plan/tools/road map?  Apologies if you have already talked to the IESG about it and I just didn't pay enough attention.

Thanks!

Alvaro.

---

From: Robert Sparks <[email-masked]>
Date: Thu, 28 Jan 2016 11:00:57 -0600

Alvaro -

The statements of work for developing the tools are here:
<http://www.nostrum.com/~rjsparks/rfced/>
You'll be particularly interested in xmlDiff I think.

The rendering tools will report if something happens that is an 
exception in rendering (such as your "couldn't be rendered correctly" 
example).

We have discussed several time whether we will provide something that 
attempts to diff between formats, and the conclusion has always been 
that such a thing is a project for AI researchers.

The actual work on creating these tools is waiting for the format 
documents finish the approval process.

RjS

On 1/28/16 10:29 AM, Alvaro Retana (aretana) wrote:
> We've been discussing in the IESG the potential impact of the new 
> format, specifically on the process to review documents .  The 
> consensus is that we should go slow (not allow all the new features at 
> the same time), but also that we will most likely want to review the 
> same formats we're reviewing today (I use the html version off the 
> tools.ietf.org page, for example) -- the assumption is then that tools 
> will take care of rendering any new characters (for example) correctly 
> and that there would be an indication if there was a difference with 
> respect to the canonical (if something couldn't be rendered correctly, 
> for example).
>
> I'm assuming that these are topics that have already come up and that 
> there is already a plan in place for the tooling.  Is there a pointer 
> to the plan/tools/road map?  Apologies if you have already talked to 
> the IESG about it and I just didn't pay enough attention.
>
> Thanks!
>
> Alvaro.
>
>
>
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development