Subject: [TOOLS-DEVELOPMENT] Tools Call Agenda -- 12 January 2016 at 13:00 Eastern

From: Russ Housley <[email-masked]>
Date: Sat, 9 Jan 2016 16:27:08 -0500

Tools Call Agenda -- 12 January 2016 at 13:00 Eastern

1. Datatracker Projects
   - Expected Datatracker Releases -- Robert and Henrik
     -- http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan
   - Tracking Internet-Draft Manual Post Requests -- Robert
   - Interim Meeting Management -- Robert
   - Review Tracking -- Robert
   - Author Statistics -- Russ
   - Meeting Materials Management -- Robert
   - Add the YANG checker to the I-D Submission Tool -- Robert

2. Community & Other Projects
   - Improve infrastructure for finding and fetching artifacts -- Robert
   - IETF Website Makeover -- Joe and Greg

3. RFC Services Projects
   - RFC Editor Statistics and Metrics -- Heather
   - RSE's Design Teams -- Heather
   - RFC Format-related SOWs -- Robert

4. Transition of Mission Critical Tools
   - Moving issue trackers and wikis for IETF WGs on ietf.org

5. Server Infrastructure
   - CDN support for HTML I-Ds -- Henrik
   - Correct "broken" messages in the email archives -- Robert and Ryan

6. IDIQ Contractors
   - RFP for more IDIQ contractors -- Ray

7. Parking Lot
   - Discontinue MonArch email archives -- Robert
   - Mentor Support Tool -- AMS
   - Author information for very old I-Ds in the datatracker -- Robert
   - Replace I-Ds in proceedings with links to archive copy?
   - Can the test process for the NomCom Tool be more comprehensive?
   - Performance improvements and transition to Postgres -- Henrik
   - VM Architecture for Servers -- Robert
   - Submit an I-D directly from GitHub

8. AOB

---

From: Robert Sparks <[email-masked]>
Date: Mon, 11 Jan 2016 10:14:47 -0600

Notes inline:

>       -- http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan
We should have a few releases in the next couple of weeks focusing on 
getting the maintenance work people have been doing over the last few 
weeks released, getting the nomcom improvements into production, and 
integrating YANG verification into the submission tool.

>     - Tracking Internet-Draft Manual Post Requests -- Robert
In RFB period
>     - Interim Meeting Management -- Robert
In RFB period
>     - Review Tracking -- Robert
In RFP period
>     - Author Statistics -- Russ
On Hold pending other projects
>     - Meeting Materials Management -- Robert
Direction change proposed on tools-development@ - so far Russ is the 
only person to reply.
>     - Add the YANG checker to the I-D Submission Tool -- Robert
In progress - should be deployed this month.
>     - Improve infrastructure for finding and fetching artifacts -- Robert
Nothing new to report.
>     - RFC Format-related SOWs -- Robert
In IAB review - authors are integrating feedback.
>     - Correct "broken" messages in the email archives -- Robert and Ryan
Work beginning.
>     - Discontinue MonArch email archives -- Robert
Russ - we should add an "improvements to the mailarchive application, 
outside the parking lot.
I revised the requirements draft and sent it to tools-discuss@ and ietf@.
I'll be asking Jari to take it through LC soon (I'll make that request 
late this week unless some dramatic discussion shows up before then).
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Heather Flanagan <[email-masked]>
Date: Mon, 11 Jan 2016 08:41:37 -0800

> On Jan 11, 2016, at 8:14 AM, Robert Sparks <[email-masked]> wrote:
> 
>> 
>> 3. RFC Services Projects
>>    - RFC Editor Statistics and Metrics — Heather

RFP is out; waiting for bids. Ray may have more info

> In IAB review - authors are integrating feedback.

What Robert said. The IAB has a deadline of January 13 to do their review, and several members of the design team (myself included) have a bit more work to do to incorporate (or not) the comments offered

-Heather

---

From: Ryan Cross <[email-masked]>
Date: Mon, 11 Jan 2016 10:53:17 -0800

>>    - Correct "broken" messages in the email archives -- Robert and Ryan

Fixes for unindented header continuation lines is complete.
Proceeding with work on the message corruption due to improper file locking.

- Ryan

---

From: Russ Housley <[email-masked]>
Date: Mon, 11 Jan 2016 17:04:02 -0500

> Russ - we should add an "improvements to the mailarchive application, outside the parking lot.
> I'll be asking Jari to take it through LC soon (I'll make that request late this week unless some dramatic discussion shows up before then)

Done in this revised agenda ...

1. Datatracker Projects

2. Community & Other Projects
   - Improvements to the mail archive application -- Robert
   - Improve infrastructure for finding and fetching artifacts -- Robert
   - IETF Website Makeover -- Joe and Greg

3. RFC Services Projects

5. Server Infrastructure

6. IDIQ Contractors

7. Parking Lot

8. AOB