Subject: [TOOLS-DEVELOPMENT] Rough Notes Tools Call 12 Jan 2016 2016-01-12

From: Ray Pelletier <[email-masked]>
Date: Tue, 12 Jan 2016 13:28:59 -0500

Attendees
Robert
Henrik
Ray
Lou
Ryan
Heather
Jari
Alvaro
Greg
Alexa
Alice
Tony
karen
Glen

Tools Call Agenda -- 12 January 2016 at 13:00 Eastern

1. Datatracker Projects
  - Expected Datatracker Releases -- Robert and Henrik
    -- http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan

We should have a few releases in the next couple of weeks focusing on getting the maintenance work people have been doing over the last few weeks released, getting the nomcom improvements into production, and integrating YANG verification into the submission tool.

Henrik - 1st release today or tomorrow plus a lot of work from Lars giving us history, timeline 

  - Tracking Internet-Draft Manual Post Requests -- Robert
In RFB period

  - Interim Meeting Management -- Robert
In RFB period

  - Review Tracking -- Robert
In RFP period

  - Author Statistics -- Russ
On Hold pending other projects

  - Meeting Materials Management -- Robert
Direction change proposed on tools-development@ - so far Russ is the only person to reply.

  - Add the YANG checker to the I-D Submission Tool -- Robert
In progress - should be deployed this month.

2. Community & Other Projects
  - Improvements to the mail archive application -- Robert
Nothing new to report.
Timeline - ask Jari to send to LC later this week

  - Improve infrastructure for finding and fetching artifacts -- Robert
NA

  - IETF Website Makeover -- Joe and Greg
Greg - working towards timeline; moving content to CMS; exploring and possibly engaging
outside help; transitioned in next two weeks; 
Alexa - staff reviewing

3. RFC Services Projects
  - RFC Editor Statistics and Metrics -- Heather
RFP is out; waiting for bids.

  - RSE's Design Teams -- Heather
Heather - The IAB has a deadline of January 13 to do their review, and several members of the design team (myself included) have a bit more work to do to incorporate (or not) the comments offered; IAB and RSOC reviews; Goald Community Review by end of month

  - RFC Format-related SOWs -- Robert
In IAB review - authors are integrating feedback.

4. Transition of Mission Critical Tools
  - Moving issue trackers and wikis for IETF WGs on ietf.org
Robert - project - integrating if issue  tracker behind the Yang integration 

5. Server Infrastructure
  - CDN support for HTML I-Ds -- Henrik
Nothing more, not to happen soon; needs lots of restructuring; Move to 
parking lot.

  - Correct "broken" messages in the email archives -- Robert and Ryan
Work beginning.
Ryan - Fixes for unindented header continuation lines is complete.
Proceeding with work on the message corruption due to improper file locking.
Robert - IESG approved.

6. IDIQ Contractors
  - RFP for more IDIQ contractors -- Ray

7. Parking Lot
  - Discontinue MonArch email archives -- Robert
Russ - we should add an "improvements to the mailarchive application, outside the parking lot.
I revised the requirements draft and sent it to tools-discuss@ and ietf@.
I'll be asking Jari to take it through LC soon (I'll make that request late this week unless some dramatic discussion shows up before then).

  - Mentor Support Tool -- AMS
  - Author information for very old I-Ds in the datatracker -- Robert
  - Replace I-Ds in proceedings with links to archive copy?
  - Can the test process for the NomCom Tool be more comprehensive?
  - Performance improvements and transition to Postgres -- Henrik
  - VM Architecture for Servers -- Robert
  - Submit an I-D directly from GitHub

8. AOB

Robert
  When we get to BA wants to report out on IMAP and MailArc severs on operations
Glen will look at it; impact looks to be pleasantly minimal;
Robert to reach out to Alexey

Robert - use of volunteers to address smaller issues in mail archives; moderate priority, i.e., March, early April; ahead of changing the underpinnings to data tracker 

Jari - is that a performance related move?
Robert - no

Lou
  Status of video as part of proceedings.

Alexa - working on that right now.

Greg - playlists set up on YouTube

---

From: Lou Berger <[email-masked]>
Date: Tue, 12 Jan 2016 13:46:20 -0500

Ray,
    Thanks for the very quick turn on the notes -- hugely helpful!

Two nits:

> Timeline - ask Jari to send to LC later this week
RFP targeted for March, with project completion targeted for the summer.

...
> Alexa - working on that right now.

Status update to be provided at the next meeting.

Thanks again for the quick turn on the notes,
Lou

---

From: Alexa Morris <[email-masked]>
Date: Wed, 13 Jan 2016 12:57:52 -0800

> Status update to be provided at the next meeting.

All IETF 94 working group session and plenary Meetecho videos are now part of the Proceedings (http://ietf.org/proceedings/94/).  The process to add to the videos to earlier proceedings is slightly more complicated and requires some code changes,  but we will start working on that next. 

Alexa

----------
Alexa Morris / Executive Director / IETF
48377 Fremont Blvd., Suite 117, Fremont, CA  94538
Phone: +1.510.492.4089 / Fax: +1.510.492.4001
Email: [email-masked]

Managed by Association Management Solutions (AMS)
Forum Management, Meeting and Event Planning
www.amsl.com <http://www.amsl.com/>

---

From: Lou Berger <[email-masked]>
Date: Wed, 13 Jan 2016 16:04:26 -0500

Alexa,
Excellent!  Are the sources archived on an ietf site too,or is that still TBD?

Thanks,
Lpu

On January 13, 2016 3:58:20 PM Alexa Morris <[email-masked]> wrote:

> All IETF 94 working group session and plenary Meetecho videos are now part 
> of the Proceedings (http://ietf.org/proceedings/94/).  The process to add 
> to the videos to earlier proceedings is slightly more complicated and 
> requires some code changes,  but we will start working on that next.
>
> Alexa
>
> ----------