Subject: [TOOLS-DEVELOPMENT] Tools Call Agenda -- 15 December 2015 at 13:00 Eastern

From: Russ Housley <[email-masked]>
Date: Mon, 14 Dec 2015 15:45:10 -0500

Tools Call Agenda -- 15 December 2015 at 13:00 Eastern

1. Datatracker Projects
   - Expected Datatracker Releases -- Robert and Henrik
     -- http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan
   - Tracking Internet-Draft Manual Post Requests -- Robert
   - Interim Meeting Management -- Robert
   - Review Tracking -- Robert
   - Author Statistics -- Russ
   - Meeting Materials Management -- Robert
   - Add the YANG checker to the I-D Submission Tool -- Robert

2. Community & Other Projects
   - Improve infrastructure for finding and fetching artifacts -- Robert
   - IETF Website Makeover -- Joe and Greg

3. RFC Services Projects
   - RFC Editor Statistics and Metrics -- Heather
   - RSE's Design Teams -- Heather
   - RFC Format-related SOWs -- Robert

4. Transition of Mission Critical Tools
   - Moving issue trackers and wikis for IETF WGs on ietf.org

5. Server Infrastructure
   - CDN support for HTML I-Ds -- Henrik
   - Correct "broken" messages in the email archives -- Robert and Ryan
   - Discontinue MonArch email archives -- Robert

6. IDIQ Contractors
   - RFP for more IDIQ contractors -- Ray

7. Parking Lot
   - Mentor Support Tool -- AMS
   - Author information for very old I-Ds in the datatracker -- Robert
   - Replace I-Ds in proceedings with links to archive copy?
   - Can the test process for the NomCom Tool be more comprehensive?
   - Performance improvements and transition to Postgres -- Henrik
   - VM Architecture for Servers -- Robert
   - Submit an I-D directly from GitHub

8. AOB

---

From: Ray Pelletier <[email-masked]>
Date: Tue, 15 Dec 2015 15:31:33 -0500

Attendees
Russ
Ray
Robert
Matt
Heather
Ryan
Alexa
Alvaro
Alice
Karen
Kathleen
Benson
Greg
Lou
Jari

1. Datatracker Projects
  - Expected Datatracker Releases -- Robert and Henrik
    -- http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan
 See <http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan> and 
<http://wiki.tools.ietf.org/tools/ietfdb/browser/trunk/PLAN>

 I am focusing on improvements to the nomcom code, and hope to 
have a commit ready for merge to trunk by the end of the winter break.

  - Tracking Internet-Draft Manual Post Requests -- Robert
	Ray - IDIQ RFB in draft - out today or tomorrow

  - Interim Meeting Management -- Robert
	Ray - IDIQ RFB in draft - out today or tomorrow

	Ray - RFP this week

  - Author Statistics -- Russ
	Holding to get costs for above

  - Meeting Materials Management -- Robert
	 Robert is just beginning the SOW.  Expect IDIQ bid in mid-2016.

  - Add the YANG checker to the I-D Submission Tool -- Robert
	Henrik - extraction part ready to go; not integrating now; still need to massage Yang checker; expected within 
a couple weeks; before going off on vacation

2. Community & Other Projects
  - Improve infrastructure for finding and fetching artifacts -- Robert
	On Hold
  - IETF Website Makeover -- Joe and Greg
	Greg- in midst of plotting out content transition; action plan;extra step that requires
page template for each piece identified; plan to be sent to Alexa and Joe by week’s end

3. RFC Services Projects
  - RFC Editor Statistics and Metrics -- Heather
	Looking for feedback on SOW; Robert - ready to go

  - RSE's Design Teams -- Heather
	Waiting to consume IAB feedback; expects to complete mid-January

	N/A

4. Transition of Mission Critical Tools
  - Moving issue trackers and wikis for IETF WGs on ietf.org
	Glue code would be deployed in early 2016

5. Server Infrastructure
  - CDN support for HTML I-Ds -- Henrik
	Uncertain how to take forward; requires splitting tools servers; one for CDN
	Consider moving HTML drafts to IETF server
	Either rsync from tools; or generate from tools server
	Behind the Glue code

  - Correct "broken" messages in the email archives -- Robert and Ryan
	AMS agreed with estimates
	Get on IAOC agenda for 17 Dec

  - Discontinue MonArch email archives -- Robert
	Awaiting completion of Broken messages
	Has received minor comments 
	Right thing to take to Last Call; mid-January
	ietf list when on LC
	Jari ok with timing through IESG

6. IDIQ Contractors
  - RFP for more IDIQ contractors -- Ray
	Have not received any additional expression of interest
	People to poke python developers

7. Parking Lot

8. AOB

Lou - GitHosting to replacing svn

Russ - amount of stuff to bring over, significant; 

Lou - stood one up, wasn’t hard and really nice base capability

Robert - lots of missing pieces; talk to Joe Hildebrand

Henrik - why GitHub?
	It’s that people want some of the features

> On Dec 14, 2015, at 3:45 PM, Russ Housley <[email-masked]> wrote:
> 
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development