Subject: [TOOLS-DEVELOPMENT] Tools Call Agenda for 9 June 2015

From: Russ Housley <[email-masked]>
Date: Tue, 2 Jun 2015 17:39:03 -0400

Tools Call Agenda -- 9 June 2015 at 13:00 Eastern

1. Datatracker Projects
  - Expected Datatracker Releases -- Robert and Henrik
    -- http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan
  - Submission tool automatically generates text from XML -- Robert
  - Liaison Tool improvements -- Robert
  - Performance improvements -- Henrik
  - Review Tracking -- Robert
  - iCal for face-to-face and virtual interim meetings -- Robert
  - Automation for WG iCal creation and deletion -- Robert
  - Making email sending table driven -- Henrik and Robert
  - Upload PPT or PDF or both for meeting materials -- Robert

2. Community & Other Projects
  - Present a directory view of active, archived, and unknown I-Ds	-- Robert
  - Improve infrastructure for finding and fetching artifacts -- Robert
  - IETF Website Makeover -- Joe and Greg

3. RFC Services Projects
  - xml2rfc bug fixes -- Alice and Henrik
  - RFC Editor Website Makeover -- Alice and Heather
  - RFC Format-related SOWs -- Robert
  - RSE's Design Teams -- Heather

4. Transition of Mission Critical Tools
  - Moving issue trackers and wikis for IETF WGs on ietf.org

5. Server Infrastructure
  - iCal servers -- AMS
    -- How can we support calendars for "all interim meetings"?
    -- How can we support calendars for "interim meetings in an area"?
  - IMAP access to the email archives -- Robert
  - VM Architecture for Servers -- Robert

6. IDIQ Contractors
  - RFP for more IDIQ contractors -- Ray

7. Parking Lot
  - Mentor Support Tool -- AMS
  - RFC Editor automatic stats and reporting RFP -- Heather
  - Author information for very old I-Ds in the datatracker -- Robert
  - Replace I-Ds in proceedings with links to archive copy?
  - Can the test process for the NomCom Tool be more comprehensive?

8. AOB

---

From: Robert Sparks <[email-masked]>
Date: Wed, 03 Jun 2015 14:12:03 -0500

Some initial notes to help keep the call within time.

>      -- http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan
That link currently says:

Jun 	Support for xml-only draft submission
Jun 	ScheduledSession, meeting cutoffs, floorplan, and possibly document 
tags schema change
Jun 	Leveraging CDN for serving external static libs
Jul 	Liaison tool improvements
Jul 	Improvements to when and where the tracker sends email

There is also a moderate-sized maintenance release coming up that 
includes addressing
facelift issues, improving capturing IANA comments, handling some ART 
issues,  and adding
more meeting support for the secretariat.
>    - Submission tool automatically generates text from XML -- Robert
Henrik is working on this one - it will be the first of the releases above.
>    - Liaison Tool improvements -- Robert
On track. Ryan is finishing the new forms and workflow functionality the 
project required.
I'll be vetting the "default initial contacts" for each external group 
through the liaison oversight program soon.

>    - Review Tracking -- Robert
The document is in Jari's hands (AD Evaluation). Pete Resnick has agreed 
to shepherd and will
provide a shepherd writeup next week. I have minor comments from Jari 
and from Brian Carpenter
to incorporate.
>    - iCal for face-to-face and virtual interim meetings -- Robert
I am still thinking through building and serving these calendars 
directly from the tracker.
So far, it looks like it will be fairly straightforward.
>    - Automation for WG iCal creation and deletion -- Robert
Waiting to do this until we have more experience from the groups that 
are trying to use these calendars.
>    - Making email sending table driven -- Henrik and Robert
Nothing new to report - this is in the queue as shown at the top of this 
message.
>    - Upload PPT or PDF or both for meeting materials -- Robert
I'll follow up on this separately.
>    - Improve infrastructure for finding and fetching artifacts -- Robert
Nothing new to report on those two items.
>    - RFC Format-related SOWs -- Robert
There is a revision of the PublicationFormatter that takes the 
design-team's work on
draft-hoffman-rfcv3-preptool into account. Both of those need review please.
>    - IMAP access to the email archives -- Robert
This got a lot of time this cycle:
* We spent some time working out why the authorization system would 
frequently stop working.
It turned out to be a consequence of not having many users - connections 
to MySQL were timing out.

* We spent a lot of time repairing bad dates in the messages in several 
lists, and cleaning up some
critical messages that were parsed out of the mbox files incorrectly. 
We've identified a couple of classes
of other messages that need repair (affecting a significant part of the 
archive), but this is not blocking.

* I am recruiting the next round of testers and getting them started on 
testing. So far we've gotten
positive feedback from Cyrus.

>    - VM Architecture for Servers -- Robert
Nothing new to report.
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development