Subject: [TOOLS-DEVELOPMENT] Tools Call Agenda -- 14 April 2015 at 13:00 Eastern

From: Russ Housley <[email-masked]>
Date: Mon, 6 Apr 2015 11:56:14 -0400

Tools Call Agenda -- 14 April 2015 at 13:00 Eastern

1. Datatracker Projects
   - Expected Datatracker Releases -- Robert and Henrik
     -- http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan
   - Liaison Tool improvements -- Robert
   - Agenda Tool enhancements -- Robert
   - Performance improvements -- Henrik
   - Review Tracking -- Robert
   - Facelift -- Robert
   - Report on email handling in the datatracker -- Robert

2. Community & Other Projects
   - Present a directory view of active, archived, and unknown I-Ds	-- Robert
   - Can we turning off the FTP service? -- Robert
   - IETF Website Makeover -- Joe and Greg
   - IETF Meeting App -- Alexa

3. RFC Services Projects
   - xml2rfc bug fixes -- Alice and Henrik
   - DOI -- Alice and Heather
   - RFC Editor Website Makeover -- Alice and Heather
   - RFC Format-related SOWs -- Robert
   - Fonts for RFCs -- Heather
   - RSE's Design Teams -- Heather

4. Transition of Mission Critical Tools
   - Moving issue trackers and wikis for IETF WGs on ietf.org

5. Server Infrastructure
   - iCal servers -- AMS
   - IMAP access to the email archives -- Robert
   - VM Architecture for Servers -- Robert

6. IDIQ Contractors
   - RFP for more IDIQ contractors -- Ray

7. Parking Lot
   - Mentor Support Tool -- AMS
   - RFC Editor automatic stats and reporting RFP -- Heather
   - Author information for very old I-Ds in the datatracker -- Robert

8. AOB

---

From: Robert Sparks <[email-masked]>
Date: Fri, 10 Apr 2015 10:21:29 -0500

Some early notes to help keep the meeting on time.

>       -- http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan
I don't think we need to spend any time on this call talking about this 
item.
(We'll talk about facelift later in the agenda).
If anyone has questions about the other upcoming releases that aren't 
answered
in the comments below, please bring them up before we get to Tuesday.
>     - Liaison Tool improvements -- Robert
In progress - finishing the mapping to groups and building the list of 
default contacts.
>     - Agenda Tool enhancements -- Robert
In progress - nothing new to report since IETF92
>     - Review Tracking -- Robert
I hope to have a revised draft out mid-week next week.
>     - Facelift -- Robert
We expect this will have been deployed before the meeting - I'm sure 
we'll have a few things to discuss.
>     - Report on email handling in the datatracker -- Robert
We are working on the change to the ballot editing page that will let 
the ADs copy a working group (and will
copy a working group by default). We have a script to scrub working 
group lists out of the Notify field and
will be socializing that with the IESG and working group chairs early 
next week. It will run after the
first maintenance release after the facelift is deployed.

We are starting in on normalizing when and to who the tracker sends 
email (remember the large spreadsheet
from just before the Dallas meeting). We're looking into making that 
more data-driven (as opposed to hard-coded)
where it's feasible to do so.
>     - Present a directory view of active, archived, and unknown I-Ds	-- Robert
This has become "normalizing the way artifacts are stored and presented".
The draft Archive and the Repository are now exposed with http and rsync.
We have been classifying the contents of the filesystem, and moving 
cruft aside.
I expect we will complete the majority of restructuring where we are 
holding files
before the next tools call.
>     - Can we turning off the FTP service? -- Robert
I expect talking this down to take a noticeable fraction of our meeting 
time.
>     - RFC Format-related SOWs -- Robert
Nothing new to report here. We will cover the dependencies these are 
waiting on later in the call.
>     - IMAP access to the email archives -- Robert
We are testing with the full archive, adding testers slowly.
We are starting to get some load data, but the number of users is still 
too low to extrapolate from
(see http://devc.amsl.com/mrtg/)
The testers we have are finding some fun issues that were pre-existing 
in the archive, but IMAP made easier to find.
We are gathering information about how to configure clients at
http://trac.tools.ietf.org/group/tools/trac/wiki/ImapTesting
Alexey is making some tweaks to how the server responds to subscription 
requests to induce the better behavior out of clients as we learn more 
about them.

>     - VM Architecture for Servers -- Robert
In progress - the above topics on normalizing where artifacts are kept 
and analyzing how and when email is sent and received are the active 
efforts.
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Robert Sparks <[email-masked]>
Date: Mon, 13 Apr 2015 14:15:02 -0500

I'd also like to add a short conversation about the codesprint and the 
hackathon to the AoB section.

RjS

On 4/10/15 10:21 AM, Robert Sparks wrote:
> I don't think we need to spend any time on this call talking about 
> this item.
> I expect talking this down to take a noticeable fraction of our 
> meeting time.
> We are starting to get some load data, but the number of users is 
> still too low to extrapolate from
> Alexey is making some tweaks to how the server responds to 
> subscription requests to induce the better behavior out of clients as 
> we learn more about them.
>