Subject: Re: [TOOLS-DEVELOPMENT] DAViCal Command Line

From: Robert Sparks <[email-masked]>
Date: Tue, 14 Apr 2015 13:36:52 -0500

Thanks Matt -

Adding tool-development to continue the conversation from the call.

On 4/14/15 12:10 PM, Matt Larson wrote:
> Greetings!
>
> I do not remember if I sent this out before, so I am sending it out again.  Apologies if this is a duplicate.  Here are the commands needed to create an account and calendar in DAViCal from the command line.
>
> Setting up a user
>
> /a/www/www6s/DAViCal/cmdlnutl/davical-cmdlnutl --user <username> --create --fullname '<Fullname>' --email <email>
> 		 --dateformat 'I' --principaltype Person --password <password>
> 		 --locale en --defaultperm read
There's a small mismatch between what that implies and what we said on 
the call.
If I heard you correctly, the username above wouldn't be an individual's 
username, but would instead be something like "nvo3-chairs"?
What do the usernames created in the system so far look like?

>
> Setting up a calendar
>
> /a/www/www6s/DAViCal/cmdlnutl/davical-cmdlnutl --user <username> --create --collection '<calendarname>' --public
Is the username provided here the one that will be set up to have access 
to the newly created calendar?
(as opposed to some user that has permission to create new calendars - I 
assume that falls out from running this as root?)
>
> Matt
>
> -------------------------------------------
> Matthew Larson, Asst. IT Director
> Association Management Solutions
> Forum Management, Meeting and Event Planning
> 48377 Fremont Blvd., Suite 117, Fremont, CA  94538
> http://www.amsl.com
>

---

From: Matt Larson <[email-masked]>
Date: Tue, 14 Apr 2015 14:42:11 -0400

Hi Robert,

Comments inline.

> On Apr 14, 2015, at 2:36 PM, Robert Sparks <[email-masked]> wrote:
> 
> Thanks Matt -
> 
> There's a small mismatch between what that implies and what we said on the call.
> If I heard you correctly, the username above wouldn't be an individual's username, but would instead be something like "nvo3-chairs"?

The username is simply the WG acronym.  Since the username ends up in the subscription URLs, this produces nice, clean URLs.  For example, the 6MAN calendar account is "6MAN".

> Is the username provided here the one that will be set up to have access to the newly created calendar?
> (as opposed to some user that has permission to create new calendars - I assume that falls out from running this as root?)

The username here is the account the calendar belongs to.  So to create a calendar for 6MAN, the command was:

/a/www/www6s/DAViCal/cmdlnutl/davical-cmdlnutl --user 6MAN --create --collection 'calendar' --public

The suggested default is to use 'calendar' as the name for the user's primary calendar.  This also ends up being a component in the URL.

Matt

---

From: Russ Housley <[email-masked]>
Date: Tue, 14 Apr 2015 15:33:02 -0400

For consistency with the mail list conventions, we should probably use all lowercase for calendar names and usernames.

Russ

On Apr 14, 2015, at 2:42 PM, Matt Larson wrote:

> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development