Subject: [TOOLS-DEVELOPMENT] Question on the status of calendaring

From: Robert Sparks <[email-masked]>
Date: Tue, 10 Feb 2015 10:37:02 -0600

On the last tools call, Matt reported that the issue with 
editing/deleting events on calendars had been addressed, and we asked 
for a round of testing with Ray and the secretariat. Do we have any 
conclusions from that testing yet?

A few meetings before that, we identified that some work was needed to 
automate the creation and maintenance of the configuration before 
creating calendars for a large number of entities (such as for every 
working group). Has any progress been made on that?

RjS

---

From: Alexa Morris <[email-masked]>
Date: Tue, 10 Feb 2015 08:48:48 -0800

Robert,

I am not completely sure where things stand with Ray and the calendar testing — last I heard he was still experiencing issues. I can tell you that last Friday, Matt, Amy, Cindy and I spent some time testing the features out on three different versions of Calendar, and we discovered that there were some issues (with what CalDav does to the “default" calendar) in version 4.04. Other versions we tested worked well. It’s easy enough to upgrade Cindy and Amy (who were running 4.04) but it’s something that we need to keep in mind if/when we deploy this more widely.

What that also made us realize is that we need to expand our testing, and this week we plan to try this out in the Windows environment. If the CalDav software proves to be particularly fickle, we may need to reexamine whether it’s the right path forward. 

Alexa

On Feb 10, 2015, at 8:37 AM, Robert Sparks <[email-masked]> wrote:

> On the last tools call, Matt reported that the issue with editing/deleting events on calendars had been addressed, and we asked for a round of testing with Ray and the secretariat. Do we have any conclusions from that testing yet?
> 
> A few meetings before that, we identified that some work was needed to automate the creation and maintenance of the configuration before creating calendars for a large number of entities (such as for every working group). Has any progress been made on that?
> 
> RjS
> 
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development
> 

----------
Alexa Morris / Executive Director / IETF
48377 Fremont Blvd., Suite 117, Fremont, CA  94538
Phone: +1.510.492.4089 / Fax: +1.510.492.4001
Email: [email-masked]

Managed by Association Management Solutions (AMS)
Forum Management, Meeting and Event Planning
www.amsl.com <http://www.amsl.com/>

---

From: Matt Larson <[email-masked]>
Date: Tue, 10 Feb 2015 13:40:51 -0500

> On Feb 10, 2015, at 11:37 AM, Robert Sparks <[email-masked]> wrote:
> 

Hi Robert,

We are still testing.  My last report from Ray was that his last calendar item change attempt worked, which was a major step forward.  We are still working with Cindy and Amy to to further testing with the IAB and IESG calendars.  As that has progressed, we have discovered an issue with the version of Apple's iCal they are running (4.0.4).  That version, for some reason, assigns every .ics invitation they receive to the IAB calendar and will not allow them to change the calendar assignment.  Alexa and I, on later versions of Apple iCal, do not experience this issue.

As Alexa noted in her response, we are also going to be doing testing with other clients under Mac OS and other operating systems.  We want to make sure there is a reasonable selection of clients which will work with the server installation.

> A few meetings before that, we identified that some work was needed to automate the creation and maintenance of the configuration before creating calendars for a large number of entities (such as f…

I have not examined this in detail yet, as I want to make sure we have a viable server package in place first.  

Matt

-------------------------------------------
Matthew Larson, Asst. IT Director
Association Management Solutions
Forum Management, Meeting and Event Planning
48377 Fremont Blvd., Suite 117, Fremont, CA  94538
http://www.amsl.com

---

From: Russ Housley <[email-masked]>
Date: Wed, 11 Feb 2015 00:48:10 -0500

I'd really like to announce WG calendars before Dallas.  It seems to me that an issue with one version of one client is not a reason to delay deployment and announcement.

Russ

---

From: Matt Larson <[email-masked]>
Date: Wed, 11 Feb 2015 16:50:47 -0500

Hi all,

We are in the process of getting Amy and Cindy either upgraded, or set up with some alternative calendar client software, so that they can continue operational testing with the IAB and IESG calendars on the CAVDav server.

Meanwhile, I would like to suggest that we identify a couple of working groups that might be interested in using the calendar server to include as test groups, so that we can see how the server is going to do with a wider user base.  Can you suggest a few working groups whose chairs might be interested in testing this out for us with their groups?

In the meantime, I will be working on code for creating calendar accounts in bulk, so that our clerical staff doesn't have to create them all.  (I plan to look at the possibility of automatic integration with the Datatracker when I can spend some time with the Tools Team, hopefully at the Dallas meeting.)

I'll keep you all informed as to my progress over the next couple of days!

Matt

> On Feb 11, 2015, at 12:48 AM, Russ Housley <[email-masked]> wrote:
>

---

From: Lou Berger <[email-masked]>
Date: Wed, 11 Feb 2015 18:08:39 -0500

On 02/11/2015 04:50 PM, Matt Larson wrote:
> Meanwhile, I would like to suggest that we identify a couple of
> working groups that might be interested in using the calendar server
> to include as test groups, so that we can see how the server is going
> to do with a wider user base.  Can you suggest a few working groups
> whose chairs might be interested in testing this out for us with
> their groups?

Don't know if this has been covered before/discussed.  What about having
a calendar that shows all interims as a test case?

I also bet that Sue Hares <[email-masked]> would be interested/willing.

Lou

---

From: Bob Hinden <[email-masked]>
Date: Thu, 12 Feb 2015 07:39:45 +0800

Matt,

> On Feb 12, 2015, at 5:50 AM, Matt Larson <[email-masked]> wrote:
> 
> Hi all,
> 

What versions of iCal and MacOS work and don’t work.

> Meanwhile, I would like to suggest that we identify a couple of working groups that might be interested in using the calendar server to include as test groups, so that we can see how the server is…

I need to check with my co-chair, but I will volunteer 6MAN.

Thanks,
Bob

---

From: Russ Housley <[email-masked]>
Date: Wed, 11 Feb 2015 19:32:01 -0500

Robert Sparks and myself as STIR WG Chairs

Sean Turner as TLS WG and RTCWEB WG Chair

Heather Flanagan for RFC Editor-related calendars

---

From: Russ Housley <[email-masked]>
Date: Wed, 11 Feb 2015 20:54:22 -0500

Lou:

We are working on a system where each WG will have an iCal managed by the WG Chairs.

Russ

---

From: Lou Berger <[email-masked]>
Date: Wed, 11 Feb 2015 21:10:29 -0500

Russ,

I did get that I was suggesting something slightly off topic.  If you
start thinking through some of the user-side scaling issues, I think you
might reach the suggestion that I came up with.  (I.e., do I really
want/need a calendar for each of the ~7 WGs I track/participate in, no
but something that allows me to easily see across WGs, say their
interims, now that would be really helpful and replace something I'm
doing now manually...)

But feature creep is always a risk, so I accept that my suggestion is
out of scope.  It'll be interesting to see how / if the per -WG icals
work out....

Thanks,
Lou

---

From: Russ Housley <[email-masked]>
Date: Wed, 11 Feb 2015 21:16:18 -0500

I'd like to see this proceed, and get some experience with it.  We all have our crystal balls about the next steps ...

Russ

---

From: Ray Pelletier <[email-masked]>
Date: Thu, 12 Feb 2015 08:40:53 -0500

All
Wouldn't it be possible to roll up all the WG calendar entries into a Master WG Calendar?

Surely individuals could subscribe to any WG calendars they follow?

Ray

> On Feb 11, 2015, at 9:16 PM, Russ Housley <[email-masked]> wrote:
>