Subject: Re: [TOOLS-DEVELOPMENT] Tools Call Agenda -- 2 December 2014

From: Robert Sparks <[email-masked]>
Date: Mon, 01 Dec 2014 13:50:10 -0600

I'd like to add few bullets to this agenda, and have reports on some of 
the existing bullets below to help save time on the call.

On 11/30/14 9:46 AM, Russ Housley wrote:
> Tools Call Agenda -- 2 December 2014 at 13:00 Eastern
>
> 1. Datatracker Projects
>     - Expected Datatracker Releases -- Robert and Henrik
See <http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan>.
>     - IPR Tool improvements -- Robert
Close to ready to deploy. I've asked several people to spot-check 
disclosures - need to hear back from them.
(See ipr-test.rjsparks.edu)
>     - Liaison Tool improvements -- Robert
On hold until after the IPR tool is deployed, and Ryan has had a chance 
to finish a few other things, including
the work on the MailArchive tool called out later in this message.

And, I'd like to add bullets for short conversations about

- Additional Agenda tool enhancements
    * Allowing the graphical tool to work with leadership meetings, 
breaks, and breakout sessions
    * Initializing the timeslots and common items like breaks and 
registration for new meetings

- Datatracker optimization
    * It's time to invest in measuring the datatracker performance and 
looking for ways to improve it.

- Status on integrating a common review tracking tool into the datatracker

- Status on the facelift project
>
> 2. Community & Other Projects
>     - Present a directory view of active, archived, and unknown I-Ds	-- AMS
I think this one should show Henrik and me for reporting until it's done.
We spent time on it in Honolulu, and determined that we since we need to
change how files are organized on disk to get this done, we might as 
well clean
some things up in the process. Henrik is writing up a proposal for what 
the result
will look like.
>     - Mentor Support Tool -- AMS
>     - IETF Website Makeover -- Joe and Greg
>
> 3. RFC Services Projects
>     - xml2rfc bug fixes -- Alice and Henrik
>     - DOI RFP -- Ray
>     - RFC Editor Website Makeover RFP -- Ray
>     - Automatic stats and reporting RFP -- Ray
>     - rfclint SOW -- Robert
>     - text submission converter SOW -- Robert
These (and the other format related SoW) are essentially done, but
I need to combine three of them into one.

The presentation format converter SoW relies on the drafts coming
from the format design team, which are nearing completion, but are
still changing rapidly.

One of the SoW, probably the presentation format converter, needs 
additional
text pointing to a description of the processing that will be performed 
on a
v3 document before publication as an RFC (things like calculating 
section anchors
and including the expanded boilerplate). The description itself will 
likely land in
the framework document.
>     - RSE's Design Team -- Heather
>
> 4. Transition of Mission Critical Tools
>     - Moving mail aliases to ietf.org and link them to datatracker database
Mostly done. The aliases are working @ietf.org. Henrik is working on 
changing the
@tools.ietf.org to forward to @ietf.org.
>     - Moving issue trackers and wikis for IETF WGs on ietf.org
Directorate and area wikis are ready.
The next step in moving the WGs is working through moving the subversion 
repositories.
>
> 5. Server Infrastructure
>     - VM Architecture for Servers -- AMS
>     - iCal servers -- AMS
>     - IMAP access to the email archives -- Robert
The IMAP access project has started. Alexey and I met in Honolulu. We 
currently
expect most of the development effort to take place during December.

And, please add a bullet to talk about needed enhancements to the web-based
archive tool. Ryan and I discussed addressing a few points before 
starting on the
liaison tool work - these are captured as major priority items here:
<http://wiki.tools.ietf.org/tools/ietfdb/report/27>. For quick 
reference, these include:
   * Having the view that the archived-at URL resolves to show the 
context for the
      message within its list.
   * Keeping the current message selected when toggling in and out of 
thread view mode

>
> 6. IDIQ Contractors
>     - Status of RFP for more IDIQ contractors -- Ray
>
> 7. Parking Lot
>     - Test Coverage -- Henrik
>
> 8. AOB
>
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Robert Sparks <[email-masked]>
Date: Tue, 02 Dec 2014 11:23:49 -0600

I'm not finding webex info for this call?

RjS