Subject: Re: [TOOLS-DEVELOPMENT] Next steps on the rfc format related SoWs

From: Robert Sparks <[email-masked]>
Date: Mon, 24 Nov 2014 10:28:43 -0600

I haven't gotten any feedback on this message.

Should I combine idnits, rfclint, and svgcheck into one SoW, or leave 
them as separate things?

Pros: Might build a work bite large enough to be interesting to more bidders
Cons: Fatesharing separable problems

As below, I think we must keep the publication formatter, xmldiff, and 
the text submission converter as separate things.

Before I start in on combining any of the SoW, I'd like to hear that 
this group still thinks that's the right thing to do.

RjS

On 10/30/14 11:09 AM, Robert Sparks wrote:
> For reference - these are the documents in flight:
>     PublicationFormatter-02
>     TextSubmissionConverter-02
>     idnits-00
>     rfclint-04
>     svgcheck-02
>     xmlDiff-03
>
> The next burst of effort needs to focus on fleshing out 
> PublicationFormatter,
> and making sure the documents from the rfc-design team that it points 
> to are
> sufficiently clear to inform implementation.
>
> We've talked for some time about combining some of these near the end. 
> We're
> getting there, and I want to double check what we think should be 
> combined to
> reduce the number of SoWs.
>
> I can see combining idnits, rfclint, and svgcheck into one SoW (that 
> asks for three tools).
>
> I'm not sure we want to couple the fates of any of
> xmlDiff, TextSubmissionConverter, and PublicationFormatter.
>
> Is having four SoWs when we're done the right target?
>
> RjS
>

---

From: "Scott O. Bradner" <[email-masked]>
Date: Mon, 24 Nov 2014 11:37:01 -0500

fwiw - combining the smaller jobs seems reasonable to me

Scott

> On Nov 24, 2014, at 11:28 AM, Robert Sparks <[email-masked]> wrote:
> 
> Should I combine idnits, rfclint, and svgcheck into one SoW, or leave them as separate things?
> 
> As below, I think we must keep the publication formatter, xmldiff, and the text submission converter as separate things.
> 
> Before I start in on combining any of the SoW, I'd like to hear that this group still thinks that's the right thing to do.
> 
> RjS
> 
>> The next burst of effort needs to focus on fleshing out PublicationFormatter,
>> and making sure the documents from the rfc-design team that it points to are
>> We've talked for some time about combining some of these near the end. We're
>> getting there, and I want to double check what we think should be combined to
>> I can see combining idnits, rfclint, and svgcheck into one SoW (that asks for three tools).
>> 
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Tony Hansen <[email-masked]>
Date: Mon, 24 Nov 2014 12:25:52 -0500

An alternative to combining the SoWs, but slightly harder to manage up 
front, is to either 1) allow people to bid in lots, or 2) add a 
"combination SoW" that includes the ones you want to combine via reference.

     Tony