Subject: [TOOLS-DEVELOPMENT] Tools Call Agenda -- 9 September 2014

From: Russ Housley <[email-masked]>
Date: Tue, 9 Sep 2014 11:04:37 -0400

Tools Call Agenda -- 9 September 2014 at 13:00 Eastern

1. Datatracker Projects
  - Expected Datatracker Releases -- Robert and Henrik
  - Automated Javascript testing -- Robert
  - Test Coverage -- Henrik
  - IPR Tool improvements -- Robert
  - Liaison Tool improvements -- Robert
  - UI style decision needed -- Russ

2. Community & Other Projects
  - Present a directory view of active, archived, and unknown I-Ds	-- AMS
  - Setup directorate wikis to ietf.org
  - IETF Website Makeover
  - Consequences of mail list rename -- AMS
  - Mentor Support Tool -- AMS

3. RFC Services Projects
  - xml2rfc bug fixes -- Alice and Henrik
  - DOI SOW -- Robert
  - rfclint  SOW -- Robert
  - text submission converter SOW -- Robert
  - RSE's Design Team -- Heather

4. Transition of Mission Critical Tools
  - Moving mail aliases to ietf.org and link them to datatracker database
  - Moving issue trackers and wikis for IETF WGs on ietf.org
  - Moving xml2rfc to xml.ietf.org

5. Server Infrastructure
  - Automatic failover from Sunnyvale to Orlando -- AMS
  - Support from a Content Distribution Network -- AMS
  - iCal servers -- AMS
  - IMAP access to the email archives -- Robert

6. IDIQ Contractors
  - We have lost two, so we should get more -- Russ

7. Parking Lot

8. AOB

---

From: Robert Sparks <[email-masked]>
Date: Tue, 09 Sep 2014 10:22:26 -0500

I'll cover Henrik's items except for xml2rfc.

Some quick notes inline to help keep the call moving.

I'm not finding notes for the previous meetings easily - did we get any? 
Can we be sure to get some this time?

>    - Expected Datatracker Releases -- Robert and Henrik
The next release is probably mid to late next week, then a series
of releases are planned following that. See
<http://trac.tools.ietf.org/tools/ietfdb/wiki/MergePlan>
>    - Automated Javascript testing -- Robert
Framework deployed. Additional tests are prioritized behind other work, 
probably
until late Oct.
>    - Test Coverage -- Henrik
Still researching additional coverage tools.
>    - IPR Tool improvements -- Robert
On track. Current expectations are to begin testing with select 
community members in late September.
>    - Liaison Tool improvements -- Robert
Not on track - will be discussing next steps with the TMC later in the call.
>    - UI style decision needed -- Russ
I think we can talk this through, but I suspect we will want to schedule 
another call, focusing on this topic, next week.
>    - Present a directory view of active, archived, and unknown I-Ds	-- AMS
(chipping in what I know)

The directory structure is documented (for staff and developers) at
<http://trac.tools.ietf.org/tools/ietfdb/wiki/DraftRepositoryDirectories>

I am still working to expose the new repository over ftp and rsync. 
There are
some significant design decisions, and some research to be done into what
we can do with the ftp server. I expect the next significant bit of 
progress here
to happen in a couple of weeks.

Once we have ftp and rsync figured out, Alexa and I will work together to
build a short description of the archives for the community which will be
posted somewhere appropriate on www.ietf.org.

>    - Setup directorate wikis to ietf.org
See the general wiki and trac migration subject below.

>    - text submission converter SOW -- Robert
I don't think we need to spend time on these 3 - they are in community 
review.
>    - Moving mail aliases to ietf.org and link them to datatracker database
This is code complete. The next step is testing from Matt, final 
deployment, and announcement.
>    - Moving issue trackers and wikis for IETF WGs on ietf.org
Matt has set up one wiki, but he and Henrik need to work further on 
setting up a prototype (in the software architecture sense) instance 
that can be copied to instantiate each new directorate wiki on demand.
>    - Moving xml2rfc to xml.ietf.org
I think this is done, but the result is xml2rfc.ietf.org. Was there 
another change needed that I've forgotten about?
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development