Subject: [TOOLS-DEVELOPMENT] xmldiff-02

From: Robert Sparks <[email-masked]>
Date: Mon, 11 Aug 2014 14:30:40 -0500

I _think_ I've found a way to reflect this conversation, and to take 
Tony's point about significant whitespace into account.
The result is attached as -02.

RjS

On 7/18/14, 12:44 PM, Robert Sparks wrote:
>
> On 7/18/14, 12:40 PM, Julian Reschke wrote:
>> On 2014-07-18 17:35, Tony Hansen wrote:
>>> On 7/17/14, 3:56 PM, Julian Reschke wrote:
>>>> On 2014-07-17 21:41, Tony Hansen wrote:
>>>>> On 7/14/14, 2:45 PM, Robert Sparks wrote:
>>>>>> This reflects being able to run the application on a personal 
>>>>>> computer
>>>>>> as well as having it run as part of a web service.
>>>>>>
>>>>>> I _think_ that's all that we concluded on last weeks call. Please 
>>>>>> let
>>>>>> me know if I forgot something that we settled.
>>>>>
>>>>> One suggestion is that the xml2rfc grammar should support 
>>>>> diff=deleted
>>>>> and diff=added attributes on various elements. This way, a paragraph
>>>>> that has been deleted could be rendered as something like this:
>>>>>      <t diff='deleted'>This is the old text</t>
>>>>>      <t diff='added'>This is the new text</t>
>>>>> or
>>>>>      <t>This is the <spanx diff='deleted'>old</spanx><spanx
>>>>> diff='added'>new</spanx> text</t>
>>>>>
>>>>> This would then be rendered appropriately in the given output 
>>>>> formats.
>>>>
>>>> How do you handle added/removed section, title changes, etc?
>>>>
>>>> Note that rfc2629.xslt has support for this via the undocumented ed:
>>>> namespace, you can see it at work over here:
>>>> <http://greenbytes.de/tech/webdav/draft-reschke-rfc2231-in-http-12.html> 
>>>>
>>>>
>>>> (and no, the diffs were not autogenerated)
>>>
>>> Cool, running code.
>>>
>>> Ok, sections should have diff= as well. And titles work just fine 
>>> within
>>> the <titleelement> tag.
>>>
>>> Since you've put some previous thought into this, how would YOU suggest
>>> handling added/removed sections, title changes, etc?
>>>
>>> Can you describe more about the ed: namespace, since it's (as you say)
>>> undocumented?
>>
>> Oh, it's mainly a copy of HTML's <ins> and <del>, with some additions:
>>
>> - a <replace> container that can group an <ins> and a <del>
>>
>> - some hacks to deal with changes in attributes
>>
>> - some support to link edits to in-document issues (that's probably 
>> something we don't want to do)
>>
>>> To you, does it seem worth adding support for this to the v3 processor?
>>> Particularly given the desire we have for xmldiff. I could see it being
>>> done either as a direct set of elements/attributes, OR as a 
>>> reference to
>>> a >>documented<< ed namespace (like we make reference to the xi:include
>>> facility).
>>
>> I think I'd see it as something that can be done on top of the v3 
>> vocabulary. So define it as an extension vocabulary that imports the 
>> v3 vocab and modifies it.
>>
>> Yes, support in a v3 processor would be cool, but I'm a bit concerned 
>> about the scope...
> Agreed - I don't see this diff being something that needs to be valid 
> given the v3 grammar.
> I'm not even sure it should be an extension of the v3 grammar, though 
> it would clearly reuse chunks of that language.
> I could see container elements, for instance, holding both an old and 
> new chunk, or something similar.
>
>>
>> Best regards, Julian
>>
>> _______________________________________________
>> TOOLS-DEVELOPMENT mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/tools-development
>
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Tony Hansen <[email-masked]>
Date: Mon, 11 Aug 2014 15:53:56 -0400

> The result is attached as -02.

Thank you Robert. I like how this is progressing.

You might add ", possibly in a separate namespace," to the end of "to 
include markup for inserted and deleted blocks".

s/<code>/<sourcecode>/

     Tony