Subject: [TOOLS-DEVELOPMENT] Tools Call Tuesday 10 June at 1:00 PM ET

From: Ray Pelletier <[email-masked]>
Date: Tue, 3 Jun 2014 10:49:47 -0400

All;

A reminder of our monthly call Tuesday 10 June at 1:00 PM ET.  Webex details below.

Ray

Topic: Tools Cmte 
Date: Tuesday, June 10, 2014 
Time: 1:00 pm, Eastern Daylight Time (New York, GMT-04:00) 
Meeting Number: 968 353 303 
Meeting Password: Tools 

------------------------------------------------------- 
To join the online meeting (Now from mobile devices!) 
------------------------------------------------------- 
1. Go to https://workgreen.webex.com/workgreen/j.php?MTID=m2dd81f7f01ae37dbd510f392e97cc3e0 
2. If requested, enter your name and email address. 
3. If a password is required, enter the meeting password: Tools 
4. Click "Join". 

To view in other time zones or languages, please click the link: 
https://workgreen.webex.com/workgreen/j.php?MTID=m12ce998a6815187868019953cc33512e 

------------------------------------------------------- 
To join the audio conference only 
------------------------------------------------------- 
To receive a call back, provide your phone number when you join the meeting, or call the number below and enter the access code. 
Call-in toll-free number (US/Canada): 1-877-668-4490 
Call-in toll number (US/Canada): 1-408-792-6300 

Access code:968 353 303 
Global call-in numbers: https://workgreen.webex.com/workgreen/globalcallin.php?serviceType=MC&ED=275502062&tollFree=1 
Toll-free dialing restrictions: http://www.webex.com/pdf/tollfree_restrictions.pdf 

------------------------------------------------------- 
For assistance 
------------------------------------------------------- 
1. Go to https://workgreen.webex.com/workgreen/mc 
2. On the left navigation bar, click "Support". 

You can contact me at: 
[email-masked] 
1-703-652-9534 

Add this meeting to your calendar program: 
https://workgreen.webex.com/workgreen/j.php?MTID=m36cac92847239018fa298fb45235dd5a 

The playback of UCF (Universal Communications Format) rich media files requires appropriate players. To view this type of rich media files in the meeting, please check whether you have the players installed on your computer by going to https://workgreen.webex.com/workgreen/systemdiagnosis.php. 

Sign up for a free trial of WebEx 
http://www.webex.com/go/mcemfreetrial 

http://www.webex.com 

CCP:+14087926300x968353303# 

IMPORTANT NOTICE: This WebEx service includes a feature that allows audio and any documents and other materials exchanged or viewed during the session to be recorded. By joining this session, you automatically consent to such recordings. If you do not consent to the recording, discuss your concerns with the meeting host prior to the start of the recording or do not join the session. Please note that any such recordings may be subject to discovery in the event of litigation.

---

From: Russ Housley <[email-masked]>
Date: Tue, 3 Jun 2014 17:43:43 -0400

Tools Call Agenda -- 10 June 2014 at 13:00 Eastern

1. Datatracker Projects
   - Expected Datatracker Releases -- Robert and Henrik
   - Automated Javascript testing -- Henrik
   - Test Coverage -- Henrik
   - IPR Tool improvements -- Robert
   - Liaison Tool improvements -- Robert
   - Sandbox Datatracker for WG chairs -- Robert

2. Community & Other Projects
   - Present a directory view of active, archived, and unknown I-Ds	-- AMS
   - Setup directorate wikis to ietf.org
   - IETF Website Makeover

3. RFC Services Projects
   - xml2rfc bug fixes -- Alice and Henrik
   - RSE Design Team -- Heather

4. Transition of Mission Critical Tools
   - Moving mail aliases to ietf.org and link them to datatracker database
   - Moving issue trackers and wikis for IETF WGs on ietf.org

5. Server Infrastructure
   - Automatic failover from Sunnyvale to Orlando -- AMS
   - Support from a Content Distribution Network -- AMS
   - iCal servers -- AMS

6. Parking Lot
   - IMAP access to the email archives
   
7. AOB

---

From: Robert Sparks <[email-masked]>
Date: Tue, 03 Jun 2014 16:51:32 -0500

Some suggested tweaks:

>     - Automated Javascript testing -- Henrik
I think I have the ball on that instead of Henrik
>     - xml2rfc bug fixes -- Alice and Henrik
Can we make some time here for the DOI SoW?

If we have time, I'd also like to talk about the rfclint and text 
submission converter SoWs.
>     - IMAP access to the email archives
This should come out of the parking lot - I think the SoW that's 
circulating is ready to go.
(We may not need to spend meeting time on it unless someone says we need 
discussion).

>     
> 7. AOB
>
> _______________________________________________
> TOOLS-DEVELOPMENT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-development

---

From: Robert Sparks <[email-masked]>
Date: Fri, 06 Jun 2014 10:09:19 -0500

I also suggest adding a short report (from Alexa?) on tooling for the 
mentoring program to section 2.

---

From: Alexa Morris <[email-masked]>
Date: Fri, 6 Jun 2014 10:00:34 -0700

Sounds good (and, yes, I will provide the update).

Alexa

On Jun 6, 2014, at 8:09 AM, Robert Sparks <[email-masked]> wrote:

> I also suggest adding a short report (from Alexa?) on tooling for the mentoring program to section 2.
> 

----------
Alexa Morris / Executive Director / IETF
48377 Fremont Blvd., Suite 117, Fremont, CA  94538
Phone: +1.510.492.4089 / Fax: +1.510.492.4001
Email: [email-masked]

Managed by Association Management Solutions (AMS)
Forum Management, Meeting and Event Planning
www.amsl.com <http://www.amsl.com/>

---

From: Robert Sparks <[email-masked]>
Date: Mon, 09 Jun 2014 15:45:37 -0500

A summary for some of the items on Tuesday's call to help keep us within 
time:

The tools server crashes have taken up May's and early June's slack.

I've started several SoW documents - thanks for the feedback on them.
I expect to start about that many additional ones during June.

>     - Expected Datatracker Releases -- Robert and Henrik
IRTF RG functionality should be out imminently (possibly today) - this 
is a big new functionality release

We expect to have a team-focused release (starting with the edu-team) in 
June
      This adds the notion of uploading materials that are not specific 
to meetings.
      This already started driving updates and adds to Role and Group 
data (updating
      the edu-team chairs) and that will continue (adding the members, 
starting to
      define groups for teams that are not yet represented).

There will be a small release focused on schema changes in June
     ScheduledSession will get renamed
     Slug field will be extended to allow 16 characters

>     - Automated Javascript testing -- Henrik
I'm currently prototyping tests using Selenium and PhantomJS.
I expect to have the basic framework, and a couple of the primary tests 
ready
by the codesprint. It should be straightforward to add more tests to the 
framework
then.
>     - IPR Tool improvements -- Robert
We are at the end of verifying the models, and in the thick of building 
migrations.
Normalizing the legacy data is being difficult, but we expected that.
>     - Liaison Tool improvements -- Robert
Work starts today.
>     - Sandbox Datatracker for WG chairs -- Robert
We've thought through the design and have most of the implementation in 
place.
The remainder should get finished by 13Jun.

---

From: "Scott O. Bradner" <[email-masked]>
Date: Mon, 9 Jun 2014 17:15:42 -0400

I am going to miss this call - I got a day job meeting moved onto of this one and could
not get it moved

Scott